Desenvolvimento de scripts U-SQL usando as ferramentas do Data Lake para Visual Studio

O Azure Data Lake Analytics e as Ferramentas do Stream Analytics incluem a funcionalidade relacionada a dois serviços do Azure, Azure Data Lake Analytics e Azure Stream Analytics. Veja mais informações sobre os cenários do Azure Stream Analytics em ferramentas do Azure Stream Analytics para Visual Studio.

Este artigo descreve como usar o Visual Studio para criar contas do Azure Data Lake Analytics. Você pode definir trabalhos no U-SQL e enviar trabalhos ao serviço Data Lake Analytics. Para saber mais sobre a Análise Data Lake, consulte a Visão geral da Análise Data Lake do Azure.

Importante

Recomenda-se que você atualize para a versão 2.3.3000.4 ou posterior das Ferramentas do Azure Data Lake para Visual Studio. As versões anteriores não estão disponíveis para download e foram preteridas.

  1. Verifique se você estiver usando uma versão anterior ao 2.3.3000.4 do Azure Data Lake Tools para Visual Studio.

    Check tool version

  2. Se sua versão for uma versão anterior do 2.3.3000.4, atualize o Azure Data Lake Tools para Visual Studio visitando o Centro de download:

Pré-requisitos

Instale as Ferramentas do Azure Data Lake para Visual Studio

Este tutorial requer que Ferramentas do Data Lake Tools para Visual Studio esteja instalado. Para obter mais informações, consulte Instalar Ferramentas do Data Lake para Visual Studio.

Conecte-se com uma conta do Azure Data Lake Analytics

  1. Abra o Visual Studio.

  2. Abra o Data Lake Analytics Explorer: selecione Exibir>Data Lake Analytics Explorer.

  3. Clique com o botão direito do mouse em Azure e selecione Conectar à Assinatura do Microsoft Azure. Em Entre em sua conta, siga as instruções.

  4. No Gerenciador de servidores, selecione Azure>Data Lake Analytics. Você verá uma lista das suas contas do Data Lake Analytics.

Escreve seu primeiro script U-SQL

O texto a seguir é um script U-SQL simples. Ele define um pequeno conjunto de dados e grava o conjunto de dados no repositório padrão do Data Lake Store como um arquivo chamado /data.csv.

USE DATABASE master;
USE SCHEMA dbo;
@a  = 
    SELECT * FROM 
        (VALUES
            ("Contoso", 1500.0),
            ("Woodgrove", 2700.0)
        ) AS 
              D( customer, amount );
OUTPUT @a
    TO "/data.csv"
    USING Outputters.Csv();

Enviar um trabalho da Análise Data Lake

  1. No Visual Studio, selecione Arquivo>Novo>Projeto.

  2. Selecione o tipo Projeto de U-SQL e depois Avançar. Em Configurar seu novo projeto, selecione Criar.

    O Visual Studio cria uma solução que contém um arquivo Script.usql.

  3. Cole o script de Escreve seu primeiro script U-SQL na janela Script.usql.

  4. No Gerenciador de Soluções, clique com o botão direito do mouse em Script.usql e selecione Enviar Script.

  5. Em Enviar Trabalho, escolha sua conta do Data Lake Analytics e selecione Enviar.

    Submit U-SQL Visual Studio project

Após o envio do trabalho, a guia Exibição do trabalho é aberta para mostrar o andamento do trabalho.

  • Resumo do trabalho mostra o resumo do trabalho.
  • Grafo do Trabalho visualiza o andamento do trabalho.
  • Operações de metadados mostra todas as ações que foram executadas no catálogo de U-SQL.
  • Dados mostra todas as entradas e saídas.
  • Histórico de estado mostra os detalhes da linha do tempo e do estado.
  • Análise de AU mostra quantos AUs foram usados no trabalho e explora simulações de diferentes estratégias de alocação de AU.
  • Diagnósticos fornece uma análise avançada para otimização de desempenho e a execução do trabalho.

U-SQL Visual Studio Data Lake Analytics job performance graph

Para ver a versão mais recente do status do trabalho e atualizar a tela, selecione Atualizar.

Verificar o status do trabalho

  1. No Gerenciador de servidores, selecione Azure>Data Lake Analytics.

  2. Expanda o nome da conta do Data Lake Analytics.

  3. Clique duas vezes em Trabalhos.

  4. Selecione o trabalho enviado anteriormente.

Veja a saída do trabalho

  1. No Gerenciador de Servidores, navegue até o trabalho enviado.

  2. Clique na guia Dados.

  3. Na guia Saídas do trabalho, selecione o arquivo "/data.csv".

Próximas etapas