Problemas com servidores de região no Azure HDInsight

Este artigo descreve as etapas de solução de problemas e possíveis soluções para problemas durante a interação com clusters do Azure HDInsight.

Cenário: Regiões não atribuídas

Problema

Ao executar hbase hbck o comando, você verá uma mensagem de erro semelhante a:

multiple regions being unassigned or holes in the chain of regions

A partir da interface do usuário do Apache HBase Master você pode exibir o número de regiões desbalanceadas em todos os servidores da região. Depois, você pode executar o comando hbase hbck para ver os espaços na cadeia de regiões.

Causa

Os orifícios podem ser o resultado de regiões offline.

Resolução

Corrige as atribuições. Siga as etapas abaixo para exibir as regiões não atribuídas de volta no estado normal:

  1. Entre no cluster do HDInsight HBase usando SSH.

  2. Execute o comando hbase zkcli para conectar-se ao shell do ZooKeeper.

  3. Execute os comando rmr /hbase/regions-in-transition ou rmr /hbase-unsecure/regions-in-transition.

  4. Saia do shell do zookeeper usando exit o comando.

  5. Abra a interface do usuário do Apache Ambari e reinicie o serviço Active HBase Master.

  6. Execute o comando hbase hbck novamente (sem mais nenhuma opção). Verifique a saída e garanta a atribuição de todas as regiões.


Cenário: servidores de região inodados

Problema

Falha ao iniciar os servidores de região.

Causa

Vários diretórios WAL de divisão.

  1. Obter lista de WALs atuais: hadoop fs -ls -R /hbase/WALs/ > /tmp/wals.out.

  2. Inspecionar o wals.out arquivo. Se houver muitos diretórios de divisão (começando com a divisão de *), o servidor de região provavelmente falhará devido a esses diretórios.

Resolução

  1. Pare o HBase no portal do Ambari.

  2. Execute hadoop fs -ls -R /hbase/WALs/ > /tmp/wals.out para obter uma nova lista de WALs.

  3. Mova os diretórios *-splitting para uma pasta temporária, splitWAL e exclua os diretórios *-splitting.

  4. Execute o comando hbase zkcli para conectar-se ao shell do zookeeper.

  5. Execute rmr /hbase-unsecure/splitWAL.

  6. Reinicie o serviço HBase.

Próximas etapas

Se você não encontrou seu problema ou não conseguiu resolver seu problema, visite um dos seguintes canais para obter mais suporte:

  • Obtenha respostas de especialistas do Azure por meio do Suporte da Comunidade do Azure.

  • Conecte-se com @AzureSupport – a conta oficial do Microsoft Azure para aprimorar a experiência do cliente. Como se conectar à comunidade do Azure para os recursos certos: respostas, suporte e especialistas.

  • Se precisar de mais ajuda, poderá enviar uma solicitação de suporte do portal do Azure. Selecione Suporte na barra de menus ou abra o hub Ajuda + suporte. Para obter informações mais detalhadas, consulte Como criar uma solicitação de Suporte do Azure. O acesso ao Gerenciamento de assinaturas e ao suporte de cobrança está incluído na sua assinatura do Microsoft Azure, e o suporte técnico é fornecido por meio de um dos Planos de suporte do Azure.