Visão geral de Consultas no Power BI Desktop

Com o Power BI Desktop você pode se conectar ao mundo dos dados, criar relatórios atraentes e fundamentais e compartilhar seus esforços com outras pessoas — que poderão então se basear em seu trabalho e expandir seus esforços de business intelligence.

Exibições do Power BI Desktop

O Power BI Desktop tem três modos de exibição:

  • Exibição de Relatório – você pode usar as consultas que cria para elaborar visualizações atraentes, organizadas como você deseja que elas apareçam e com várias páginas, que você pode compartilhar com outras pessoas.
  • Exibição de tabela – Veja os dados em seu relatório no formato de modelo de dados, em que você pode adicionar medidas, criar novas colunas e gerenciar relações.
  • Exibição de Modelos – obtenha uma representação gráfica das relações que são estabelecidas no seu modelo de dados e gerencie-as ou modifique-as conforme necessário.

Acesse essas exibições selecionando um dos três ícones no lado esquerdo do Power BI Desktop. Na imagem a seguir, a exibição de Relatório está selecionada, indicada pela faixa amarela ao lado do ícone.

Captura de tela do Power BI Desktop mostrando a exibição de Relatório selecionada.

O Power BI Desktop também é fornecido com o Editor do Power Query. Use o Editor do Power Query para se conectar a uma ou várias fontes de dados, formatar e transformar os dados para atender às suas necessidades e, em seguida, carregar esse modelo no Power BI Desktop.

Este artigo fornece uma visão geral do trabalho com os dados no Editor do Power Query, mas há mais coisas para aprender. No final deste artigo, você encontrará links para diretrizes detalhadas sobre os tipos de dados compatíveis. Você também encontrará diretrizes sobre como se conectar a dados, formatar dados, criar relações e como começar a usar.

Mas, primeiro, vamos nos familiarizar com o Editor do Power Query.

Editor do Power Query

Power BI Desktop oferece duas experiências de Editor do Power Query:

  • Nova experiência do Power Query (Prévia): um editor reformulado com navegação simplificada, acessibilidade aprimorada e uma experiência consistente do Power Query no Power BI Desktop, na modelagem na Web e em outros produtos do Fabric.
  • Experiência herdada: a janela de Editor do Power Query original.

Em ambas as experiências, você usa Editor do Power Query para se conectar a uma ou muitas fontes de dados, formatar e transformar os dados para atender às suas necessidades e carregar o resultado em Power BI Desktop. Selecione a guia que corresponde à experiência que você está usando.

Para conhecer as limitações conhecidas, as soluções alternativas e um espaço para compartilhar feedback, consulte Limitações conhecidas e soluções alternativas da nova experiência do Power Query.

Note

A nova experiência de Power Query está em versão prévia.

Pré-requisitos

Power BI Desktop com o recurso de visualização New Power Query habilitado.

Para habilitar a nova experiência de Power Query:

  1. Inicie o Power BI Desktop.
  2. Vá para Arquivo>Opções e configurações>Opções.
  3. Selecione Preview features e, em seguida, marque a caixa de seleção New Power Query experience.
  4. Selecione OK.

A mesma funcionalidade de visualização prévia habilita tanto a nova experiência Obter Dados quanto o novo Editor do Power Query. Para retornar ao editor herdado, desmarque a caixa de seleção. Você não precisa reiniciar Power BI Desktop. Para obter mais informações sobre a nova experiência obter dados, consulte Obter dados no Power BI Desktop.

Abrir o Editor do Power Query

Para abrir Editor do Power Query, selecione Transformar dados na guia Página Inicial do Power BI Desktop.

Sem conexões de dados, o Editor do Power Query é exibido como um painel em branco, pronto para receber dados. Depois que uma consulta é carregada, o editor apresenta cinco componentes distintos. Os números na tabela a seguir correspondem às chamadas numeradas na captura de tela.

Captura de tela do novo Editor do Power Query no Power BI Desktop com cada componente descrito e numerado.

# Componente Description
1 Faixa de Opções A experiência de navegação na faixa de opções, que fornece várias guias para adicionar transformações, selecionar opções para sua consulta e acessar diferentes botões da faixa de opções para concluir várias tarefas.
2 Painel de Consultas Uma exibição de todas as suas consultas disponíveis.
3 Exibição atual Sua visualização principal de trabalho, que, por padrão, mostra uma visualização prévia dos dados da sua consulta. Você também pode habilitar o modo de exibição de diagrama junto com a visualização de dados. Você pode alternar entre a exibição de esquema e a visualização de dados, mantendo a exibição do diagrama.
4 Configurações de consulta Uma exibição da consulta selecionada no momento com informações relevantes, como nome da consulta, etapas de consulta e vários indicadores.
5 Barra de estado Uma barra mostrando informações importantes sobre sua consulta, como tempo de execução, total de colunas e linhas e status de processamento. Essa barra também contém botões para alterar o modo de exibição atual.

Cada um desses componentes é descrito nas seções a seguir. Para obter um passo a passo completo da interface do usuário Power Query, consulte Usar Power Query para transformar dados.

A faixa de opções

A faixa de opções é o componente em que você encontra a maioria das transformações e ações que pode executar no Editor do Power Query. Os comandos são agrupados nas guias Página Inicial, Transformação, Adicionar coluna, Exibição, Ferramentas e Ajuda . Cada guia fornece botões e opções específicos que proporcionam acesso fácil às transformações e ações que você pode precisar.

A guia Página Inicial contém as tarefas de consulta comuns, incluindo os comandos Obter dados que você usa para se conectar aos dados e iniciar o processo de criação da consulta. Para obter mais informações sobre as fontes de dados disponíveis, consulte Fontes de dados no Power BI Desktop. Para obter mais informações sobre como usar conectores, consulte Obter visão geral dos dados.

A guia Transformar fornece acesso a tarefas comuns de transformação de dados, como adicionar ou remover colunas, alterar tipos de dados e dividir colunas. A guia Adicionar coluna fornece mais tarefas associadas à adição de uma coluna, formatação de dados de coluna e adição de colunas personalizadas. A guia Exibir controla quais painéis e exibições são exibidos e abre o Editor Avançado.

A interface Power Query é responsiva e se ajusta à resolução da tela. Se você quiser uma versão compacta da faixa de opções, selecione o botão recolher no canto inferior direito da faixa de opções. Para retornar à faixa de opções padrão, selecione o ícone de expansão no mesmo canto.

Muitas das tarefas disponíveis na faixa de opções também podem ser acessadas ao clicar com o botão direito em uma coluna ou em outros dados na exibição atual. As transformações geralmente podem ser alcançadas de mais de um lugar, para que você possa usar a experiência que preferir.

Para obter mais informações sobre como transformar dados, incluindo exemplos, confira Tutorial: Formatar e combinar dados no Power BI Desktop.

O painel Consultas

O painel Consultas exibe todas as suas consultas disponíveis. Quando você seleciona uma consulta, seus dados são exibidos na exibição atual, onde você pode moldar e transformar os dados para atender às suas necessidades.

Selecione o ícone no canto superior direito do painel Consultas para recolher o painel e selecione-o novamente para expandi-lo. Ícones semelhantes em toda a interface permitem recolher ou expandir outras exibições e seções, para que você possa se concentrar na exibição mais importante para você.

Para obter mais informações, consulte o painel Consultas.

O modo de exibição atual

O modo de exibição atual é sua exibição de trabalho principal. Por padrão, ele mostra a visualização de dados para a consulta selecionada. Você realiza grande parte do trabalho de consulta nessa área. Selecione um cabeçalho de coluna ou clique com o botão direito do mouse nele para ver as transformações disponíveis para essa coluna. Muitos desses itens são iguais aos botões nas guias da faixa de opções.

Quando você seleciona uma transformação, a consulta aplica a etapa aos dados. Ele também salva a etapa como parte da própria consulta. O painel Configurações de Consulta registra as etapas em ordem sequencial, conforme descrito posteriormente neste artigo.

Você também pode habilitar as ferramentas de criação de perfil de dados para entender melhor seus dados, incluindo distribuição de valor e qualidade da coluna. Habilite e desabilite essas ferramentas na guia Exibir à sua conveniência. Para obter mais informações, consulte Usando as ferramentas de criação de perfil de dados.

Alternar entre exibições

Além de recolher painéis e seções, você também pode alternar quais exibições são exibidas. Vá para a guia Exibir na faixa de opções, em que você encontra os grupos Visualização e Layout que controlam a aparência da interface.

Captura de tela da guia Exibir no novo Editor do Power Query, mostrando os grupos Visualização e Layout.

O lado direito da barra de status também contém ícones para o diagrama, dados e exibições de esquema. Use esses ícones para alterar entre exibições ou para habilitar e desabilitar a exibição de sua escolha.

Experimente essas opções para encontrar a exibição e o layout com os quais você está mais confortável trabalhando.

Exibição de esquema

A exibição de esquema oferece uma maneira rápida e simples de interagir somente com os componentes do esquema para sua tabela, como os nomes de coluna e os tipos de dados. Use a exibição de esquema quando quiser executar ações relacionadas ao esquema, como remover colunas, renomear colunas, alterar tipos de dados de coluna, reordenar colunas ou duplicar colunas.

Captura de tela do modo de exibição de esquema no novo Editor do Power Query, mostrando as colunas Nome, Tipo e Chave para a consulta selecionada.

Quando o modo de exibição de esquema está ativo, a guia Ferramentas de esquema é exibida na faixa de opções com as ações que se aplicam às colunas.

Para obter mais informações, consulte Usando a exibição de Esquema.

Exibição de diagrama

A exibição de diagrama ajuda você a visualizar como a consulta é estruturada e como ela pode interagir com outras consultas em seu projeto. Cada etapa em sua consulta tem um ícone distinto para ajudá-lo a reconhecer a transformação que foi usada e as linhas conectam as etapas para ilustrar dependências.

Quando a visualização de dados e o modo de exibição de diagrama estão habilitados, o modo de exibição de diagrama aparece sobre a visualização de dados. Com o modo de exibição de diagrama habilitado, selecione o sinal de adição para procurar uma nova transformação a ser adicionada à consulta.

Captura de tela da exibição de diagrama mostrada acima da visualização de dados no novo Editor do Power Query.

Para obter mais informações, consulte exibição de Diagrama.

O painel Configurações de Consulta

O painel Configurações de Consulta mostra informações sobre a consulta selecionada no momento, como o nome da consulta, suas etapas e vários indicadores. Cada transformação aplicada à consulta é salva como uma etapa na seção Etapas aplicadas .

Se você precisar verificar como sua consulta é transformada de etapa em etapa, selecione uma etapa para visualizar como sua consulta é resolvida nesse ponto específico.

É importante saber que os dados subjacentes não são alterados. Em vez disso, o Editor do Power Query ajusta e forma a exibição dos dados.

Você pode renomear etapas, excluir etapas ou reordenar as etapas conforme quiser. Para fazer isso, clique com o botão direito do mouse na etapa na seção Etapas aplicadas e escolha no menu exibido. Selecione Propriedades para alterar o nome de uma etapa ou adicionar uma descrição a ela. Todas as etapas de consulta são executadas na ordem em que aparecem.

Para obter mais informações, consulte Usando a lista De Etapas Aplicadas.

A barra de status

A barra de status aparece na parte inferior do editor e mostra informações importantes sobre sua consulta, como tempo de execução, total de colunas e linhas e status de processamento. O lado direito da barra de status também contém ícones que você pode usar para alterar o modo de exibição atual.

Captura de tela da barra de status no novo Editor do Power Query, mostrando o status do processamento, as contagens de colunas e linhas e os ícones de exibição.

A barra de fórmulas

A barra de fórmulas mostra a expressão da linguagem de fórmula Power Query M para a etapa selecionada. Você pode editar a expressão diretamente na barra de fórmulas para ajustar uma única etapa ou usar o Editor Avançado para trabalhar com o script de consulta completo.

Obter ajuda

A guia Ajuda no Editor do Power Query fornece links para informações do Power BI. Você pode acessar as mesmas opções de ajuda selecionando Arquivo>.

Editor Avançado

O Editor Avançado permite que você veja o código que o Editor do Power Query está criando com cada etapa. Ele também permite que você crie seu próprio código na linguagem da fórmula do Power Query M. Para iniciar o editor avançado, selecione Exibição na faixa de opções, então selecione Editor Avançado. Uma janela é exibida, mostrando o código gerado para a consulta selecionada.
Captura de tela do Power BI Desktop mostrando a caixa de diálogo do Editor Avançado.

Você pode editar o código diretamente na janela Editor Avançado . Para fechar a janela, selecione o botão Concluído ou Cancelar .

O Editor Avançado está disponível tanto na nova experiência quanto na experiência antiga. A captura de tela anterior mostra a experiência herdada. Alguns controles do Editor avançado e opções de exibição são diferentes na nova experiência. Para obter mais informações, consulte limitações conhecidas e soluções alternativas da nova experiência do Power Query.

Salvando seu trabalho

Quando sua consulta estiver onde você deseja, selecione Fechar e Aplicar no menu Arquivo do Editor do Power Query. Essa ação aplica as alterações e fecha o editor.
Captura de tela do Power BI Desktop mostrando a opção Fechar e Aplicar na guia Arquivo.

À medida que o progresso é feito, o Power BI Desktop fornece uma caixa de diálogo para exibir seu status.
Captura de tela do Power BI Desktop mostrando a caixa de diálogo de confirmação de Alterações Aplicadas à Consulta.

Quando estiver pronto, o Power BI Desktop poderá salvar seu trabalho na forma de um arquivo .pbix.

Para salvar seu trabalho, selecione Arquivo>Salvar (ou Arquivo>Salvar como), conforme mostrado na imagem a seguir. Captura de tela de Power BI Desktop mostrando a guia Arquivo Editor do Power Query. As opções salvar e salvar como realçadas.

Há inúmeras coisas que você pode fazer com o Power BI Desktop. Para obter mais informações sobre seus recursos, consulte as seguintes fontes: