Solucionar problemas com a previsão
Este artigo ajuda você a solucionar problemas e resolve problemas relacionados à previsão no Microsoft Dynamics 365 Sales.
Problema 1 – Um erro é exibido quando você tenta criar uma previsão baseada em território
Sintomas
Quando você tenta criar uma previsão baseada em território, um erro é exibido. Além disso, os dados em uma previsão baseada em território podem não ser atualizados.
Motivo
Quando as atualizações do sistema são executadas, a hierarquia da entidade de território é desabilitada (embora você tenha habilitado anteriormente), o que causa esse erro.
Resolução
Para resolve esse problema, você deve habilitar a hierarquia na definição de relação territory_parent_territory de Relações. Siga estas etapas:
Vá para Configurações avançadas.
A página de configurações avançadas é aberta em uma guia.
Selecione Configurações>Personalizações de Personalização>.
A página de configurações do Power Apps é aberta.
SelecioneEntidades de Dados> e, em seguida, selecione Território.
Na página Território , selecione a guia Relações e selecione Pai.
Na caixa de diálogo Muitos para um, selecione a caixa de marcar Hierárquica e selecione Concluído.
Salve e feche a entidade.
Problema 2 – não é possível ocultar o campo de categoria de previsão em formulários de oportunidade
Motivo
Às vezes, o aplicativo exibe o campo de categoria Previsão em formulários de oportunidade, mesmo depois de ter sido configurado como invisível por padrão por meio de personalizações de formulário.
Resolução
Para resolve esse erro, você deve excluir o campo de categoria Previsão do formulário. Siga estas etapas:
No aplicativo, na barra de navegação, selecione o ícone Configurações e selecione Configurações Avançadas.
A página Configurações de Gerenciamento de Negócios é aberta em uma nova guia do navegador.
Na barra de navegação, selecione Configurações e, em Personalização, selecione Personalizações.
Selecione Personalizar o Sistema.
Em Componentes no gerenciador de soluções, expanda Entidades, expanda Oportunidade e selecione Formulários.
Abra o formulário Opportunity do tipo de formulário Main.
O formulário de oportunidade é aberto em uma nova janela.
Na seção Resumo , selecione o campo Categoria De previsão e selecione Remover.
Salve e publique a configuração.
Problema 3 – Não é possível exibir previsões
Motivo
Se você estivesse usando a versão anterior da previsão e atualizado para o mais recente, o mapa do site de previsão pode não ser atualizado. Isso pode ser causado pela presença de uma camada não gerenciada do aplicativo do Sales Hub, o que permitiria que o mapa do site de previsão abrisse a versão anterior da previsão.
A imagem a seguir é um exemplo da versão anterior da home page de previsão.
Resolução
Para resolve esse problema, atualize a entrada do mapa do site de previsão para a grade de entrada de previsão mais recente. Para obter mais informações, consulte Adicionar opções de grade de previsão e configuração no mapa do site.
Problema 4 – Não é possível carregar a grade de previsão e um erro é exibido
Motivo
O processo ForecastInstanceActions é desativado. O motivo pode ser que o proprietário de uma organização tenha sido alterado, o que está causando a falha ao carregar a grade de previsão. O erro mostrado na imagem a seguir é exibido.
A ação (ForecastInstanceActions) para buscar previsões foi desabilitada.
Resolução
Para resolve esse erro, ative o processo ForecastInstanceActions. Siga estas etapas:
Acesse Configurações avançadas e selecione Configurações>Processos do Centro> deProcessos.
Na caixa de pesquisa, insira ForecastInstanceActions. Você pode ver que o processo está no estado Rascunho .
Selecione o processo e selecione Ativar.
Na mensagem de confirmação, selecione Ativar.
Verifique se o estado do processo está ativado e feche Configurações.
Problema 5 – Não é possível exibir dados de detalhamento em uma grade de previsão
Motivo
Você não tem privilégios suficientes para a entidade Configuração de Previsão exibir dados de detalhamento na grade de previsão. O erro mostrado na imagem a seguir é exibido.
Algo deu errado.
Houve um erro ao recuperar os registros de previsão.
Recarregue a página do navegador novamente.
Resolução
Para resolve esse erro, o administrador deve fornecer privilégios de leitura na entidade Configuração de Previsão para sua função de segurança. Siga estas etapas:
Vá para Configurações avançadas e selecione Configurações>Funções de Segurança deSegurança>.
Selecione a função de segurança para a qual você deseja aplicar os privilégios.
Na página função de segurança, selecione Guia Entidades Personalizadas e vá para a linha Configuração de Previsão .
Selecione e forneça os privilégios de leitura.
Feche as configurações.
Problema 6 – Os campos de categoria de previsão não são atualizados
Motivo
Em uma previsão, depois de atualizar o campo de categoria de previsão para Won ou Lost, as oportunidades ainda aparecem no bucket de pipeline anterior. Esse erro ocorre porque o fluxo de trabalho do Processo de Mapeamento de Categoria de Previsão de Oportunidades está desabilitado em sua organização.
Resolução
Para resolve o erro, ative o fluxo de trabalho processo de mapeamento de categoria de previsão de oportunidade. Siga estas etapas:
Vá para Configurações avançadas e selecione ConfiguraçõesPersonalizações>>Personalizar o Sistema.
No sitemap, selecione Processos.
Selecione o fluxo de trabalho processo de mapeamento de categoria de previsão de oportunidade e selecione Ativar.
As categorias de previsão nas oportunidades serão atualizadas corretamente. As oportunidades que foram alteradas antes de ativar o fluxo de trabalho devem ser alteradas manualmente. Além disso, abra o fluxo de trabalho processo de mapeamento de categoria de previsão de oportunidade e verifique se as condições estão definidas corretamente para cada categoria de previsão.
Salve e feche as configurações.
Problema 7 – Não é possível ativar uma previsão que tenha uma coluna relacionada à hierarquia do tipo de pesquisa
Motivo
Esse problema ocorre porque o usuário "Dynamics 365 Sales Previsão" não tem a permissão de leitura para a entidade de pesquisa relacionada à hierarquia.
Resolução
Para resolver o problema, siga as etapas:
Vá para configurações avançadas e selecione Configurações>funções de Segurança do>Sistema>.
Abra a função Forecast AppUser e selecione a guia em que o tipo de entidade está presente.
Habilite a permissão De leitura no nível da organização para o tipo de entidade do campo de pesquisa.
Salve as alterações.
Problema 8 – Não é possível ativar uma previsão
Motivo
A ativação de previsão falha devido a vários motivos.
Resolução
Para resolver o problema, siga as etapas:
- Verifique se você fez todas as configurações obrigatórias para o modelo de previsão.
- Verifique se os filtros de hierarquia na configuração de previsão não filtram toda a hierarquia. Vá para a seção Visualização na etapa geral para garantir que a hierarquia exista. Para obter mais informações, consulte Adicionar filtros adicionais a uma previsão.
Problema 9 – Não é possível encontrar a opção de configuração de previsão nas Configurações do Aplicativo
Motivo
A opção de configuração de previsão pode não estar visível nas Configurações do Aplicativo do Hub de Vendas devido aos seguintes motivos:
- Você não tem a permissão de leitura para a entidade de configuração de previsão.
- O administrador não adicionou manualmente a grade de previsão e a configuração na seção Gerenciamento de Desempenho .
Resolução
Para resolver o problema, siga estas etapas:
- Atribua a função de segurança do Gerenciador de Previsões ao usuário que deve ser capaz de criar e gerenciar configurações de previsão.
- Em Configuração de previsão, os itens do painel de navegação de previsão devem ser adicionados em um aplicativo personalizado.
Problema 10 – Não é possível exibir previsões para a hierarquia de usuário
Motivo
Esse problema ocorre devido a permissões insuficientes para exibir a previsão.
Resolução
Para resolver o problema, verifique se:
Uma dessas condições é atendida:
Você é o proprietário da previsão. O campo Pesquisa do proprietário na etapa Permissões da configuração de previsão mostra quem é o proprietário.
Você faz parte das funções de segurança que têm a permissão de leitura, conforme configurado na etapa Permissões da configuração de previsão.
Alguém compartilhou a previsão com você. Para obter mais informações, consulte Habilitar ou desabilitar o compartilhamento de previsão.
O campo pesquisa proprietário na etapa Permissões da configuração de previsão não está definido como Nenhum. Se estiver definido como Nenhum, ninguém poderá exibir a previsão.
Problema 11 – Os valores de campo de previsão mostram zero ou em branco na grade de previsão
Motivo
As colunas associadas ao campo Seletor, Quantidade e Data podem ter a segurança no nível do campo habilitada.
Resolução
Para resolver o problema, você precisa conceder a permissão De leitura ao usuário #Dynamics 365 Sales Previsão nos perfis de segurança do campo. Caso contrário, a coluna mostrará 0 para todos os usuários. Siga estas etapas para configurar os perfis de segurança de campo:
- Acesse Configurações Perfis> desegurança de campo desegurança>de configurações> avançadas.
- Selecione o perfil de segurança de campo associado ao campo que mostra 0.
- Selecione Usuários>Adicionar.
- Pesquise o usuário # Dynamics 365 Sales Previsão, selecione a caixa de seleção no nome do usuário e selecione Selecionar Adicionar>.
- Selecione Permissões de Campo e conceda permissão de leitura ao campo.
- Salve e feche o perfil.
Recalcular a previsão e verificar se a coluna mostra valores apropriados.
Problema 12 – Não é possível recalcular manualmente a coluna de previsão na página Previsões
Motivo
A coluna de previsão na página Previsões não pode ser recalculada manualmente.
Resolução
A coluna de previsão na Previsão é recalculada automaticamente após cada sete dias e não dá suporte a recalculação manual. Isso ocorre porque as previsões são baseadas em modelos orientados por IA que analisam dados históricos e o pipeline de vendas abertas para prever o resultado futuro da receita. A coluna de previsão mostra a receita prevista para cada vendedor e gerente com base no campo Status de uma oportunidade. Para otimizar a precisão das previsões, verifique se os valores de Categoria de Previsão são mantidos em sincronização com o campo Status . Para a categoria de previsão fora da caixa, um fluxo de trabalho garante que quando uma oportunidade é fechada como Won ou Lost, a categoria de previsão é atualizada com o valor adequado.
Problema 13 – A previsão de exibição de grade subjacente é desabilitada (somente leitura) quando a página está carregando
Motivo
Um JavaScript personalizado configurado na configuração de previsão impede que a grade seja editável.
Resolução
Para resolver o problema, examine o código JavaScript personalizado e marcar se ele desabilitar a exibição de grade de registros subjacente.