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Cenário: O nó de cluster fica sem espaço em disco no Azure HDInsight

Este artigo descreve os passos de resolução de problemas e possíveis resoluções de problemas ao interagir com clusters do Azure HDInsight.

Problema

Uma tarefa pode falhar com uma mensagem de erro semelhante a: /usr/hdp/2.6.3.2-14/hadoop/libexec/hadoop-config.sh: fork: No space left on device.

Em alternativa, poderá receber um alerta do Apache Ambari semelhante a: local-dirs usable space is below configured utilization percentage.

Causa

A cache da aplicação Apache Yarn pode ter consumido todo o espaço em disco disponível. É provável que a aplicação Spark esteja a ser executada de forma ineficiente.

Resolução

  1. Utilize a IU do Ambari para determinar que nó está a ficar sem espaço em disco.

  2. Determinar que pasta no nó preocupante contribui para a maior parte do espaço em disco. Primeiro, aceda ao SSH no nó e, em seguida, execute df para listar a utilização do disco para todas as montagens. Normalmente, /mnt é um disco temporário utilizado pelo OSS. Pode introduzir numa pasta e, em seguida, escrever sudo du -hs para mostrar tamanhos de ficheiro resumidos numa pasta. Se vir uma pasta semelhante a /mnt/resource/hadoop/yarn/local/usercache/livy/appcache/application_1537280705629_0007, esta saída significa que a aplicação ainda está em execução. Este resultado pode dever-se à persistência do RDD ou aos ficheiros aleatórios intermédios.

  3. Para mitigar o problema, elimine a aplicação, o que libertará espaço em disco utilizado por essa aplicação.

  4. Se o problema ocorrer frequentemente nos nós de trabalho, pode otimizar as definições de cache local do YARN no cluster.

    Abra a IU do Ambari Navegue para YARN –> Configurações –> Avançadas.
    Adicione as duas propriedades seguintes à secção de yarn-site.xml personalizada e guarde:

    yarn.nodemanager.localizer.cache.target-size-mb=2048
    yarn.nodemanager.localizer.cache.cleanup.interval-ms=300000
    
  5. Se o acima não corrigir permanentemente o problema, otimize a sua aplicação.

Passos seguintes

Se não vir o problema ou não conseguir resolver o problema, visite um dos seguintes canais para obter mais suporte:

  • Obtenha respostas de especialistas do Azure através do Suporte da Comunidade do Azure.

  • Ligue-se ao @AzureSupport – a conta oficial do Microsoft Azure para melhorar a experiência do cliente. Ligar a comunidade do Azure aos recursos certos: respostas, suporte e especialistas.

  • Se precisar de mais ajuda, pode submeter um pedido de suporte do portal do Azure. Selecione Suporte na barra de menus ou abra o hub Ajuda + suporte . Para obter informações mais detalhadas, veja Como criar um pedido de suporte do Azure. O acesso à Gestão de Subscrições e ao suporte de faturação está incluído na sua subscrição do Microsoft Azure e o Suporte Técnico é fornecido através de um dos Planos de Suporte do Azure.