Поделиться через


Ошибка обновления надстройки в Copilot for Sales add-in for Microsoft Outlook

Эта статья поможет устранить неполадки и устранить сообщение об ошибке, которое неоднократно предлагает пользователям обновить надстройку Microsoft Copilot для продаж для Outlook.

Примечание.

Microsoft Sales Copilot перебран в качестве Microsoft Copilot для продаж в январе 2024 года. Снимки экрана в этой статье будут обновлены с новым именем в ближайшее время.

Кого затрагивает проблема?

Тип требования Description
Клиентское приложение Надстройка Copilot для продаж Outlook
Платформа Веб-клиенты и настольные клиенты
ОС Windows и Mac
Развертывание Под управлением пользователя и под управлением администратора
CRM Dynamics 365 и Salesforce
Пользователи Все пользователи

Симптомы

При открытии области "Copilot для продаж" в Microsoft Outlook отображается следующее сообщение об ошибке:

Ошибка надстройки: доступно обновление этой надстройки, требующее проверки и подтверждения для установки.

При выборе UPDATE поведение зависит от того, используете ли вы Outlook в Интернете или классическое приложение.

Снимок экрана: ошибка обновления надстройки и кнопка UPDATE.

  • Если вы используете Outlook в Интернете, запускается новое окно браузера, и вы перейдете на экран Copilot for Sales for Microsoft Outlook в всплывающем окне надстроек Для Outlook. Сообщение об ошибке по-прежнему отображается в новом окне браузера. Однако в исходном окне браузера можно временно использовать Copilot для продаж, пока страница не будет обновлена, и вы увидите исходное сообщение об ошибке.

  • Если вы используете классическое приложение Outlook, появится последующее сообщение об ошибке, указывающее, что надстройка в настоящее время обновляется. При закрытии области "Copilot для продаж" и повторном его открытии copilot для продаж временно не будет работать, пока вы не закройте или снова откроете Outlook, а ошибка повторится.

    Снимок экрана: предупреждение о надстройке в классическом приложении Outlook.

Причина

Изменения разрешений произошли в новой надстройке Copilot для продаж для Outlook.

Для некоторых изменений разрешений требуется явное согласие администратора или переустановка надстройки Copilot для продаж Outlook. Эти изменения разрешений всегда привязаны к недавнему обновлению надстройки Copilot для продаж Outlook. Вы можете проверить, когда к надстройке было применено последнее обновление, на соответствующей странице сведений об источнике приложения. Если вы видите недавнее обновление надстройки Copilot для продаж Outlook, эта ошибка, скорее всего, связана с соответствующими изменениями разрешений из-за обновления.

Решение

Первым шагом является определение того, является ли надстройка Copilot for Sales Outlook управляемой администратором или пользователем. От этого зависят шаги по устранению проблемы.

  1. Откройте Outlook (в Интернете или настольное приложение).

  2. Выберите Получить надстройки на вкладке Главная на ленте.

  3. В окне надстроек Outlook проверьте, указана ли надстройка Copilot для продаж Для Microsoft Outlook в разделе", управляемом администратором.

    Снимок экрана: раздел, управляемый администратором, где можно проверить, указана ли надстройка Copilot для продаж Для Microsoft Outlook.

  4. Если надстройка указана в разделе", управляемом администратором, попросите администратора клиента выполнить следующие действия:

    1. В центре администрирования Microsoft 365 выберите Параметры>Интегрированные приложения.

    2. На странице "Интегрированные приложения " выберите приложение Copilot для продаж .

      Откроется панель Microsoft Copilot для продаж .

    3. Если кнопка "Обновить" доступна, выберите ее и следуйте инструкциям по обновлению надстройки.

    4. Если кнопка "Обновить" недоступна, перейдите на вкладку "Конфигурация", выберите Copilot для продаж для Microsoft Outlook и нажмите кнопку "Удалить". После завершения переустановите надстройку Copilot для продаж для Microsoft Outlook. Дополнительные сведения см. в разделе "Установка Copilot для продаж".

  5. Если надстройка не указана в разделе Управляемые администратором, удалите надстройку из раздела Мои надстройки и переустановите ее.

Примечание.

Изменение может занять до 24 часов, чтобы изменения вступили в силу для конечных пользователей при развертывании через управляемый администратором поток.

Дополнительная информация

Если проблема по-прежнему не решена, перейдите в Copilot для продаж - Microsoft Community Hub для взаимодействия с нашими экспертами.