Предоставление общего доступа к проекту и присоединение к сеансу совместной работы в Visual Studio

Important

Visual Studio Live Share находится в режиме обслуживания без дополнительных функций.

Существующие возможности остаются доступными. Используйте эту документацию для текущих функциональных возможностей и операционных рекомендаций. Дополнительные сведения см. в разделе Режим обслуживания для Visual Studio Live Share.

После установки и входа в Visual Studio Live Share поделитесь проектом и запустите сеанс совместной работы с командой.

Предоставление общего доступа к проекту

Выполните следующие действия, чтобы начать сеанс совместной работы и пригласить коллегу работать с вами.

  1. Вход

    Теперь, когда вы вошли в систему, вы готовы начать собственный сеанс совместной работы. Не войдете? Дополнительные сведения см. в разделе Вход.

  2. Открытие решения, проекта или папки

    Используйте обычный рабочий процесс, чтобы открыть папку, проект или решение, поделиться с гостями.

  3. [Необязательно] Обновление скрытых или исключенных файлов

    По умолчанию Live Share скрывает от гостей все файлы и папки в вашем проекте, перечисленные в файлах .gitignore. Скрытие файла предотвращает его отображение в дереве файлов, исключая его, чтобы он не передавался даже во время операций, таких как отладка. Если вы хотите скрыть или исключить другие файлы, в проект можно добавить файл.vsls.json с помощью этих параметров. Дополнительные сведения см. в разделе управления доступом к файлам и видимостью .

  4. Запуск сеанса совместной работы

    Нажмите кнопку Live Share в правом верхнем углу, чтобы запустить сеанс Live Share. Ссылка на общий доступ к сеансу совместной работы автоматически копируется в буфер обмена.

    Screenshot с кнопкой Live Share при входе в Visual Studio.

    При первом запуске сеанса совместной работы вы увидите окно средства Live Share. Убедитесь, что вы закрепите это окно, чтобы оно отображалось при следующем запуске сеанса Live Share.

    Снимок экрана, на котором показано окно инструмента Live Share в Visual Studio.

    Note

    Вы можете попросить программное обеспечение брандмауэра для настольных компьютеров разрешить агенту Live Share открыть порт при первом совместном использовании. Принятие этого является совершенно необязательным, но позволяет безопасному прямому режиму повысить производительность, когда пользователь, с которым вы работаете, находится в той же сети, что и вы. Дополнительные сведения см. в разделе об изменении режима подключения .

  5. [Необязательно] Включение режима только для чтения

    После запуска сеанса совместной работы можно настроить сеанс только для чтения. Этот режим запрещает гостям вносить изменения в общий код.

    После того как вы поделитесь, вы получите уведомление о том, что ссылка-приглашение скопирована в буфер обмена. Затем можно выбрать параметр, чтобы сделать сеанс доступен только для чтения.

    Снимок экрана: параметр

  6. Отправить кому-то ссылку

    Отправьте ссылку по электронной почте, Teams, Slack, Skype или другому приложению связи любому пользователю, которому вы хотите пригласить. Учитывая уровень доступа к сеансам Live Share для гостей, вы должны предоставлять доступ только пользователям, которым вы доверяете. Внимательно подумайте о последствиях того, что вы предоставляете общий доступ.

    Tip

    Хотите понять последствия безопасности некоторых функций Live Share? Ознакомьтесь со статьей по безопасности .

    Если у приглашенного вами гостя есть вопросы, статья Краткое руководство: присоединение к первому сеансу содержит дополнительную информацию о том, как начать работу в качестве гостя.

  7. [Необязательно] Утверждение гостя

    Гости автоматически присоединяются к сеансу совместной работы по умолчанию, и вы получите уведомление, когда они готовы к работе с вами. Это уведомление позволяет удалить их из сеанса. Тем не менее, вы также можете требовать явного утверждения для всех, кто присоединяется.

    Перейдите в раздел Tools > Параметры > Live Share >, затем измените параметр Требовать утверждение гостя на True, чтобы включить эту функцию. После включения этого параметра уведомление предложит утвердить гостя, прежде чем они смогут присоединиться.

    Снимок экрана, на котором показан запрос на одобрение присоединения в Visual Studio.

    Дополнительные сведения о рекомендациях по обеспечению безопасности приглашений см. в приглашениях и доступе на присоединение.

  8. Управление сеансом Live Share

    После того как ваш гость откроет ссылку на общий сеанс в Visual Studio Code или Visual Studio, вы увидите их в списке участников в окне инструментов Live Share. Теперь вы можете видеть, в каком файле сейчас находится ваш гость, рядом с его именем.

    Снимок экрана, на котором показано окно инструмента Visual Studio Live Share, где отображается участник.

    Окно средства Live Share позволяет получить доступ ко всем ключевым функциям для управления сеансом в одном месте.

    Tip

    Не отображается окно инструмента Live Share больше во время сеансов? Вы всегда можете выбрать Совместный доступ > Просмотреть окно Live Share, чтобы открыть его!

Завершение сеанса совместной работы

Как организатор, вы можете полностью остановить общий доступ и завершить сеанс совместной работы, выбрав кнопку «Общий доступ» в правом верхнем углу, а затем выбрав «Завершить сеанс Live Share».

Снимок экрана, на котором показан выбор пункта «Совместное использование», а затем пункта «Завершить сеанс Live Share» в раскрывающемся меню.

Все гости уведомляются о завершении сеанса. После завершения сеанса гости больше не смогут получить доступ к содержимому, и все временные файлы автоматически очищаются.

Наличие проблем с общим доступом? Ознакомьтесь с устранением неполадок.

Присоединиться к сеансу совместной работы

После скачивания и установки Visual Studio Live Share гостям необходимо выполнить несколько шагов, чтобы присоединиться к размещенной сессии совместной работы. Существует два способа присоединения: через браузер или вручную.

Tip

Если вы присоединяетесь к сеансу совместной работы в качестве гостя, важно понимать, что организаторы могут ограничить ваш доступ к определённым файлам или возможностям. Хотите понять последствия безопасности некоторых функций и параметров Live Share? Дополнительные сведения см. в статье о безопасности .

Присоединение через браузер

Самый простой способ присоединиться к сеансу совместной работы — открыть ссылку приглашения в веб-браузере. Вот что вас ожидает, если вы будете следовать этому сценарию.

  1. Вход

    После установки расширения Live Share вы хотите войти в систему, чтобы сообщить другим сотрудникам, кто вы являетесь. Visual Studio использует учетную запись персонализации по умолчанию, поэтому этот шаг можно пропустить.

    Дополнительные сведения см. в разделе Вход.

  2. Щелкните ссылку приглашения или откройте приглашение в браузере

    Откройте или снова откройте ссылку приглашения в браузере.

    Note

    Если у вас еще не установлено расширение Live Share, вам будут предложены ссылки на Marketplace расширений. Установите расширение, перезапустите средство и повторите попытку.

    Вы получите уведомление о том, что браузер хочет запустить средство с поддержкой Live Share. Если вы позволите ему запустить выбранное средство, вы будете подключены к сеансу совместной работы после запуска.

    {Снимок экрана: страница присоединения в браузере.}

    Если хост не в сети, вместо этого на этом этапе вы получите уведомление. Вы можете связаться с организатором и попросить его снова открыть доступ.

    Note

    По-прежнему есть проблемы? Дополнительные сведения см. в разделе "Присоединение вручную".

  3. Сотрудничать

    Вот и все! Через несколько минут вы будете подключены, и вы можете начать совместную работу.

    Вы увидите кнопку Live Share для передачи состояния сеанса. Сведения о состоянии сеанса см. ниже, чтобы узнать, как выглядит кнопка.

    После завершения подключения вы автоматически перейдете к файлу, который в данный момент редактирует организатор.

Присоединение вручную

Вы можете вручную присоединиться без использования веб-браузера. Ручное присоединение полезно в ситуациях, когда средство, которое вы хотите использовать, уже запущено. Используйте ручное присоединение, если хотите использовать не тот инструмент, который обычно используете. Вы также можете использовать его, если у вас по какой-то причине не работают ссылки-приглашения.

  1. Вход

    После установки расширения Live Share вы хотите войти в систему, чтобы сообщить другим сотрудникам, кто вы являетесь. Visual Studio использует учетную запись персонализации по умолчанию, поэтому вы можете полностью пропустить этот шаг.

    Дополнительные сведения см. в разделе Вход.

  2. Использование команды join

    Перейдите в Файл > Присоединиться к сеансу Live Share.

    Снимок экрана, на котором показано меню «Файл» в Visual Studio с выбранным пунктом Join Live Share Session.

  3. Вставьте ссылку приглашения

    Вставьте URL-адрес приглашения и подтвердите его.

  4. Сотрудничать

    Вот и все! Вы должны быть подключены к сеансу совместной работы мгновенно.

    Вы увидите кнопку Live Share для передачи состояния сеанса. Дополнительные сведения о том, как выглядит кнопка, см. в разделе о состоянии сеанса.

    После подключения вы автоматически перейдёте туда, где организатор в данный момент редактирует.

Покинуть сеанс совместной работы

Как гость, вы можете покинуть сеанс совместной работы, не завершая его для остальных, просто закрыв инструмент.

Снимок экрана, показывающий меню Visual Studio Live Share при присоединении к сеансу совместной работы.

Или вы можете выйти из сеанса, нажав кнопку «Общий доступ» и выбрав «Покинуть сеанс Live Share».

Все временные файлы автоматически очищаются, поэтому дальнейшие действия не требуются.

Проблемы с присоединением? Ознакомьтесь с устранением неполадок.

Состояния сеанса

После начала или присоединения к сеансу совместной работы и доступа к общему содержимому кнопка Live Share в правом верхнем углу обновляет его внешний вид, чтобы отразить состояние активного сеанса совместной работы.

Ниже приведены состояния, которые обычно отображаются:

Государство Кнопка Description
Неактивное Снимок экрана: кнопка Live Share в неактивном состоянии сеанса. Нет активного сеанса совместной работы, и ничто не предоставлено в общий доступ.
Узел: общий доступ In-Progress Снимок экрана, на котором показана кнопка Live Share в состоянии активного сеанса совместного доступа. Сеанс совместной работы начинается, а общий доступ к содержимому начнется в ближайшее время.
Хост: общий доступ Снимок экрана: кнопка Live Share в состоянии активного сеанса общего доступа. Сеанс совместной работы активен и предоставляется общий доступ к содержимому.
Хост: общий доступ: только чтение Снимок экрана: кнопка Live Share в состоянии сеанса общего доступа только для чтения. Предоставление доступа к сеансу совместной работы в режиме только для чтения.
Гость: присоединение к сеансу Снимок экрана: кнопка Live Share в состоянии сеанса присоединения. Присоединение к существующему сеансу совместной работы.
Гость: Подключился Снимок экрана: кнопка Live Share в состоянии присоединенного сеанса. Присоединились к активному сеансу совместной работы, подключились и получают общий контент.
Гость: подключен, только для чтения Снимок экрана, на котором показана кнопка Live Share в присоединённом сеансе только для чтения. Вы присоединились и подключены к активному сеансу совместной работы в режиме только чтения.

Дальнейшие действия