Not
Åtkomst till den här sidan kräver auktorisering. Du kan prova att logga in eller ändra kataloger.
Åtkomst till den här sidan kräver auktorisering. Du kan prova att ändra kataloger.
I den här artikeln beskrivs hur du identifierar och löser felet "SubnetIsFull" som inträffar när du försöker uppgradera ett AKS-kluster (Azure Kubernetes Service).
Här är ett exempel på felmeddelandet:
Det gick inte att skala nodpoolens <AGENT-POOLNAMN> i Kubernetes-tjänsten "<NAME>". Fel: VMSSAgentPoolReconciler-återförsök misslyckades: Code='SubnetIsFull' Message='<SUBNET NAME>\ med adressprefix <PREFIX>\ har inte tillräckligt med kapacitet för IP-adresser.' Detaljer=[]
Förutsättningar
Den här artikeln kräver Azure CLI version 2.0.65 eller en senare version. Om du vill hitta versionsnumret kör du az --version. Om du måste installera eller uppgradera Azure CLI kan du läsa Installera Azure CLI.
Mer detaljerad information om uppgraderingsprocessen finns i avsnittet "Uppgradera ett AKS-kluster" i Uppgradera ett AKS-kluster (Azure Kubernetes Service).
Symptome
En AKS-klusteruppgradering misslyckas och du får felmeddelandet "SubnetIsFull".
Orsak
Det här felet uppstår om klustret inte har tillräckligt med IP-adresser för att skapa en ny nod.
När du planerar att utföra en uppgraderings- eller skalningsåtgärd bör du överväga antalet nödvändiga IP-adresser. Om IP-adressintervallet som du konfigurerade i klustret endast stöder ett fast antal noder misslyckas uppgraderings- eller skalningsåtgärden. Mer information finns i IP-adressplanering för dina AKS-kluster (Azure Kubernetes Service).
Lösning
Minska klusternoderna för att reservera IP-adresser för uppgraderingen.
Om nedskalning inte är ett alternativ och det virtuella nätverkets CIDR har tillräckligt med IP-adresser kan du försöka lägga till en nodpool som har ett unikt undernät:
- Lägg till en ny användarnodpool i det virtuella nätverket i ett större undernät.
- Växla den ursprungliga nodpoolen till en systemnodpoolstyp.
- Skala upp användarnodpoolen.
- Skala ned den ursprungliga nodpoolen.
Mer information
Kontakta oss för att få hjälp
Om du har frågor kan du ställa support för Azure-communityn. Du kan också lämna produktfeedback till Azure feedback-community.