Dela via


Felsöka felkoden "PublicIPCountLimitReached"

Den här artikeln beskriver hur du identifierar och löser felet "PublicIPCountLimitReached" som uppstår när du försöker uppgradera ett Azure Kubernetes Service -kluster (AKS).

Förutsättningar

Den här artikeln kräver Azure CLI version 2.0.65 eller en senare version. Kör för att hitta versionsnumret az --version. Om du måste installera eller uppgradera Azure CLI kan du läsa Så här installerar du Azure CLI.

Mer detaljerad information om uppgraderingsprocessen finns i avsnittet "Uppgradera ett AKS-kluster" i Uppgradera ett Azure Kubernetes Service -kluster (AKS).

Symptom

Uppgraderingen av AKS-klustret misslyckas och du får felmeddelandet "PublicIPCountLimitReached".

Orsak

Felet uppstår om du har nått det maximala antalet offentliga IP-adresser som tillåts för din prenumeration.

Lösning

Om du vill höja gränsen eller kvoten för din prenumeration går du till Azure Portal, skapar en supportbegäran om tjänst- och prenumerationsgränser (kvoter) och anger kvottypen till Nätverk.

När kvotändringen börjar gälla kan du försöka uppgradera klustret till samma version som du tidigare försökte uppgradera till. Den här processen utlöser en avstämning.

az aks upgrade --resource-group <ResourceGroupName> --name <AKSClusterName> --kubernetes-version <KUBERNETES_VERSION>

Kontakta oss för att få hjälp

Om du har frågor eller behöver hjälp skapar du en supportförfrågan eller frågar Azure community support. Du kan också skicka produktfeedback till Azure-feedbackcommunityn.