Felsöka felkoden "SubnetIsFull" under en uppgradering av AKS-klustret

Den här artikeln beskriver hur du identifierar och löser felet "SubnetIsFull" som inträffar när du försöker uppgradera ett Azure Kubernetes Service -kluster (AKS).

Här är ett exempel på felmeddelandet:

Det gick inte att skala nodpoolens <AGENTPOOLNAMN> i Kubernetes-tjänsten "<NAME>". Fel: VMSSAgentPoolReconciler-återförsök misslyckades: Code='SubnetIsFull' Message='<SUBNET NAME>\ with address prefix <PREFIX>\ har inte tillräckligt med kapacitet för IP-adresser. Details=[]

Förutsättningar

Den här artikeln kräver Azure CLI version 2.0.65 eller en senare version. Kör för att hitta versionsnumret az --version. Om du måste installera eller uppgradera Azure CLI kan du läsa Så här installerar du Azure CLI.

Mer detaljerad information om uppgraderingsprocessen finns i avsnittet "Uppgradera ett AKS-kluster" i Uppgradera ett Azure Kubernetes Service -kluster (AKS).

Symptom

Uppgraderingen av AKS-klustret misslyckas och du får felmeddelandet "SubnetIsFull".

Orsak

Det här felet uppstår om klustret inte har tillräckligt med IP-adresser för att skapa en ny nod.

När du planerar att utföra en uppgraderings- eller skalningsåtgärd bör du överväga antalet ip-adresser som krävs. Om IP-adressintervallet som du har konfigurerat i klustret endast stöder ett fast antal noder misslyckas uppgraderings- eller skalningsåtgärden. Mer information finns i avsnittet "Planera IP-adressering för klustret" i Konfigurera Azure CNI-nätverk i Azure Kubernetes Service (AKS).

Lösning

Minska klusternoderna för att reservera IP-adresser för uppgraderingen.

Om nedskalning inte är ett alternativ och det virtuella nätverkets CIDR har tillräckligt med IP-adresser kan du försöka lägga till en nodpool som har ett unikt undernät:

  1. Lägg till en ny användarnodpool i det virtuella nätverket i ett större undernät.
  2. Växla den ursprungliga nodpoolen till en typ av systemnodpool.
  3. Skala upp användarnodpoolen.
  4. Skala ned den ursprungliga nodpoolen.

Kontakta oss för att få hjälp

Om du har frågor eller behöver hjälp skapar du en supportförfrågan eller frågar Azure community support. Du kan också skicka produktfeedback till Azure-feedbackcommunityn.