Dela via


Windows visar ett blåskärmsfel vid start av en virtuell Azure-dator

Den här artikeln beskriver blåskärmsfel som kan uppstå när du startar en virtuell Windows-dator (VM) i Microsoft Azure. Den innehåller steg som hjälper dig att samla in data för ett supportärende.

Symptom

En virtuell Windows-dator startar inte. När du kontrollerar startskärmbilderna i Startdiagnostik visas något av följande felmeddelanden på en blå skärm:

Datorn stötte på ett problem och måste startas om. Vi samlar bara in felinformation och sedan kan du starta om.

Datorn stötte på ett problem och måste startas om.

Orsak

Det kan finnas många orsaker till att du får ett stoppfel. De vanligaste orsakerna är följande problem:

  • Problem i en drivrutin
  • Skadad systemfil eller -minne
  • Ett program som har åtkomst till en förbjuden del av minnet

Lösning

Tips

Om du har en säkerhetskopia av den virtuella datorn nyligen kan du försöka återställa den virtuella datorn från säkerhetskopian för att åtgärda startproblemet.

För att lösa det här problemet måste du först samla in en dumpfil för kraschen innan du kontaktar supporten. Följ dessa steg för att samla in dumpfilen:

Steg 1: Leta upp dumpfilen och skicka ett supportärende

Del 1: Koppla OS-disken till en virtuell återställningsdator
  1. Ta en ögonblicksbild av OS-disken för den berörda virtuella datorn för att skapa en säkerhetskopia. Mer information finns i Skapa en ögonblicksbild av en virtuell hårddisk.

  2. Koppla OS-disken till en virtuell återställningsdator.

  3. Använd RDP (Remote Desktop Protocol) för att fjärransluta till den virtuella återställningsdatorn.

  4. Om OS-disken för den berörda virtuella datorn är krypterad inaktiverar du krypteringen innan du går vidare till nästa steg. Mer information finns i Dekryptera den krypterade OS-disken.

Del 2: Leta upp dumpfilen och skicka ett supportärende
  1. På den virtuella återställningsdatorn går du till Windows-mappen på den anslutna OS-disken. Om enhetsbeteckningen som är tilldelad till den anslutna OS-disken till exempel är F går du till F:\Windows.

  2. Leta upp filen Memory.dmp och skicka sedan ett supportärende och bifoga dumpfilen.

Om du inte hittar dumpfilen går du till nästa steg för att aktivera dumploggen och seriekonsolen och återskapar sedan problemet.

Steg 2: Aktivera dumploggen och seriekonsolen

Viktigt

Det här avsnittet, metoden eller uppgiften innehåller steg som beskriver hur du ändrar registret. Det kan uppstå allvarliga problem om du gör detta felaktigt. Följ därför instruktionerna noga, För skydd säkerhetskopierar du registret innan du ändrar det så att du kan återställa det om ett problem uppstår. Mer information om hur du säkerhetskopierar och återställer registret finns i Hur du säkerhetskopierar och återställer registret i Windows.

Så här aktiverar du dumploggen och seriekonsolen:

  1. Öppna en upphöjd kommandotolksession som administratör.

  2. Kör följande BCDEdit-kommandon med alternativen /ems och /emssettings :

    Aktivera seriekonsolen:

    bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON
    bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
    
  3. Kontrollera att det lediga utrymmet på OS-disken är större än minnesstorleken (RAM) på den virtuella datorn.

    Om det inte finns tillräckligt med utrymme på OS-disken ändrar du platsen där minnesdumpfilen skapas och refererar till den platsen till alla datadiskar som är anslutna till den virtuella datorn som har tillräckligt med ledigt utrymme. Om du vill ändra platsen ersätter %SystemRoot% du med enhetsbeteckningen för datadisken, till exempel F:, i följande kommandon.

    Om du vill aktivera OS-dumpfilen kör du följande kommandon för att läsa in, lägga till och ta bort för att implementera den föreslagna konfigurationen med hjälp av reg-verktyget :

    Läs in registreringsdatafilen från den brutna OS-disken:

    reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
    

    Aktivera på ControlSet001:

    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

    Aktivera på ControlSet002:

    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

    Ta bort den trasiga OS-disken:

    reg unload HKLM\<broken-system>
    

Steg 3: Återskapa problemet

  1. Koppla från OS-disken och koppla sedan os-disken till den berörda virtuella datorn igen.

  2. Starta den virtuella datorn för att återskapa problemet så att en dumpfil genereras.

  3. Upprepa instruktionerna i avsnittet Steg 1: Leta upp dumpfilen och skicka ett supportärende .

Kontakta oss för att få hjälp

Om du har frågor eller behöver hjälp skapar du en supportförfrågan eller frågar Azure community support. Du kan också skicka produktfeedback till Azure-feedbackcommunityn.