Dela via


Lösningsinstallationen misslyckas på grund av beroenden som inte finns i en CDS-miljö

Den här artikeln innehåller en lösning på ett problem där lösningsinstallationen misslyckas på grund av beroenden som inte finns i en CDS-miljö.

Gäller för: Microsoft Dynamics 365
Ursprungligt KB-nummer: 4499731

Symptom

När du försöker importera en lösning i Dynamics 365 misslyckas importen på grund av saknade beroenden. Om du installerar lösningen från administrationscentret kanske du bara ser ett meddelande om att installationen misslyckades. Om du importerar en lösning från Dynamics 365 webbapp kan du se mer information, till exempel vilka beroenden som saknas.

Orsak

Det kan inträffa om lösningen kräver komponenter som inte finns i en Common Data Service-miljö (CDS). En cds-miljö innehåller inte alla entiteter och innehåller bara vissa standardentiteter. Om lösningen som du försöker installera beror på en entitet som inte finns i din miljö (t.ex. en entitet som bara finns i försäljningsappen) skulle lösningen inte kunna installeras.

Åtgärd

Försök endast att installera lösningen i en miljö som innehåller de komponenter som krävs. Det finns många lösningar i Administrationscenter och AppSource som bara kan installeras om du har vissa licenser, till exempel en licens som innehåller sales-appen.