Databricks IDE uzantısı kur

Bu makale, Databricks IDE uzantısının nasıl kurulup açılacağını, ardından uzantının kullanacağı bir projenin nasıl yapılandırılacağını anlatır. Bkz. Databricks IDE uzantısı.

Gereksinimler

Databricks IDE uzantısı kullanmak için:

  • Kullanılabilir en az bir Azure Databricks çalışma alanınız olmalı ve çalışma alanında en az bir Azure Databricks cluster bulunmalıdır. Eğer bir kümeniz yoksa, Databricks IDE uzantısı kurulumunun bir parçası olarak bir küme oluşturabilirsiniz.

    Not

    Databricks SQL ambarları bu uzantı tarafından desteklenmez.

  • Visual Studio Code sürüm 1.104.0 veya üzeri mutlaka kurulu olmalı. Yüklü sürümünüzü görüntülemek için, Linux veya macOS ana menüsünden Code > Hakkında öğesine ve Windows ana menüsünden Help > Hakkında öğesine tıklayın. Visual Studio Code’u indirmek, yüklemek ve yapılandırmak için Visual Studio Code’u Ayarlama bölümüne bakın.

  • Visual Studio Code, Python yorumlayıcının kullanılabilirliği de dahil olmak üzere Python kodlama için yapılandırılmalıdır. Ayrıntılar için bkz. VS Code'da Python ile Çalışmaya Başlama.

Uzantıyı yükleme ve açma

  1. Visual Studio Code'da Extensions görünümünü açın (ana menüden Görünüm > Extensions).

  2. Market'te Arama Uzantıları alanına Databricks yazın.

  3. Databricks uzantısına ve ardından Yükle'ye tıklayın.

    Not

    Databricks doğrulanmış sahipliği olan uzantıyı seçtiğinizden emin olun.

    Uzantıyı Uzantılar Marketi'nden yükleme

  4. Yükleme Gerekli düğmesine tıklayın veya Visual Studio Code'u yeniden başlatın.

  5. (İsteğe bağlı) Istendiğinde, kodlama ajanlarınızın Azure Databricks ile etkili çalışması için yapay zeka araçlarını kurun. Bkz: Yapay zeka araçlarını yükleme ve kullanma.

  6. Uzantıyı açmak için kenar çubuğunda Databricks simgesine tıklayın.

  7. Databricks IDE uzantısını Azure Databricks çalışma alanınıza bağlanacak şekilde yapılandırın. Databricks projenizi yapılandırma konusuna bakın.

Uzantının farklı bir sürümünü yükleme

Databricks IDE uzantısının belirli bir sürümünü, örneğin önceki bir sürümünü, yüklemek veya yayınlanan sürüme yükseltmek istiyorsanız, Visual Studio Code'da Extensions görünümünde (Görünüm > Uzantılar ana menüsünden):

  1. Databricks'e tıklayın, ardından Kaldır açılır ok simgesine tıklayın.

  2. Başka Bir Sürüm Yükle'ye tıklayın ve bir sürüm seçin.

    Uzantının başka bir sürümünü yükleme

    Alternatif olarak, yayın sürümüne yükseltmek için Yayın Sürümüne Geç'e tıklayın.

  3. Sürüm değişikliğini uygulamak için uzantılarını başlat'a tıklayın veya Visual Studio Code yeniden başlatın.

Daha fazla bilgi için Visual Studio Code uzantısı belgelerine bakın.

Uzantıyı kaldırma

Databricks IDE uzantısını kaldırmanız gerekiyorsa, Visual Studio Code'da ana menüden View > Extensions'a tıklayın, sonra:

  1. Uzantı listesinde Databricks uzantısını seçin.
  2. Kaldır'ı tıklatın.
  3. Yükleme Gerekli düğmesine tıklayın veya Visual Studio Code'u yeniden başlatın.