Visual Studio IDE turu

Visual Studio tümleşik geliştirme ortamına (IDE) bu girişte bazı pencereler, menüler ve diğer kullanıcı arabirimi özelliklerinde bir tura çıkarsınız.

Herhangi bir uygulama türü geliştirmek veya dil öğrenmek için Visual Studio Tümleşik Geliştirme Ortamı'nda (IDE) çalışırsınız. Visual Studio IDE, kod düzenlemenin ötesinde grafik tasarımcıları, derleyicileri, kod tamamlama araçlarını, kaynak denetimini, uzantıları ve daha birçok özelliği tek bir yerde bir araya getirir.

İndirme ve kurma

Başlamak için Visual Studio'yu indirin ve sisteminize yükleyin.

Visual Studio Yükleyicisi'nde, istediğiniz programlama dilleri veya platformlar için ihtiyacınız olan özellik grupları olan iş yüklerini seçer ve yüklersiniz. Bu makaleyi takip etmek için yükleme sırasında .NET masaüstü geliştirme iş yükünü seçtiğinizden emin olun.

Visual Studio Yükleyicisi'nde seçilen .NET masaüstü geliştirme iş yükünün ekran görüntüsü.

Visual Studio'nuz zaten varsa . .NET masaüstü geliştirme iş yükünü aşağıdaki gibi ekleyebilirsiniz:

  • Visual Studio Yükleyicisi'ni başlatın.
  • İstenirse yükleyicinin kendisini güncelleştirmesine izin verin.
  • Visual Studio için bir güncelleştirme varsa, bir Güncelleştir düğmesi gösterilir. Yüklemeyi değiştirmeden önce onu güncellemek için seçin.
  • Visual Studio yüklemenizi bulun ve Değiştir düğmesini seçin.
  • Henüz seçili değilse .NET masaüstü geliştirme iş yükünü seçin ve Değiştir düğmesini seçin. Aksi takdirde, diyalog penceresini kapatın.

Başlangıç penceresi

Visual Studio'yu açtıktan sonra göreceğiniz ilk şey başlangıç penceresidir. Kodu kopyalama veya kullanıma alma, var olan bir projeyi veya çözümü açma, yeni bir proje oluşturma veya yalnızca bazı kod dosyaları içeren bir klasör açma seçenekleri vardır.

Visual Studio'daki başlangıç penceresini gösteren açıklamalı ekran görüntüsü.

Visual Studio 2022'de başlangıç penceresini gösteren açıklamalı ekran görüntüsü.

Visual Studio'yu ilk kez kullanıyorsanız, son projeler listeniz boş olur.

Proje veya çözüm olmadan kod geliştirmek için Visual Studio'da kodunuzu açmak için Yerel klasör aç seçeneğini kullanın. Aksi takdirde, GitHub veya Azure DevOps gibi bir kaynak sağlayıcıdan yeni bir proje oluşturabilirsiniz veya bir depo kopyalayabilirsiniz.

Visual Studio geliştirme ortamını belirli bir proje veya kod yüklenmeden açmak için Kod olmadan devam et seçeneğini kullanın. Canlı Paylaşım oturumuna katılmak veya hata ayıklama işlemine eklemek için bu seçeneği belirleyebilirsiniz. Başlangıç penceresini kapatmak ve IDE'yi açmak için Esc tuşuna da basabilirsiniz.

Projenizi oluşturma

Visual Studio'nun özelliklerini keşfetmek için yeni bir proje oluşturalım.

  1. Visual Studio'yu başlatın ve Yeni proje oluştur'u seçin.

    Visual Studio'daki 'Yeni Proje Oluştur' penceresinin ekran görüntüsü.

    Yeni proje oluştur penceresi açılır ve birkaç proje şablonu gösterilir. Şablon, belirli bir proje türü için gereken temel dosyaları ve ayarları içerir.

    Burada bir proje şablonu arayabilir, filtreleyebilir ve seçebilirsiniz. Yeni proje oluştur penceresinde son kullanılan proje şablonlarınızın listesi de gösterilir.

  2. Yeni proje oluştur penceresinde, proje türleri listesini filtrelemek için arama kutusuna konsol yazın. Tüm diller açılan listesinden C# (veya seçtiğiniz başka bir dil) seçerek arama sonuçlarını daha da daraltın.

     İstediğiniz şablonu seçtiğiniz Visual Studio 'Yeni proje oluştur' penceresinin ekran görüntüsü.

  3. C# seçeneğini belirlediyseniz Konsol Uygulaması şablonunu ve ardından İleri'yi seçin. Farklı bir dil seçtiyseniz herhangi bir şablonu seçmeniz yeter.

  4. Yeni projenizi yapılandırın penceresinde varsayılan proje adını ve konumunu kabul edin ve İleri'yi seçin.

     Visual Studio'da yeni proje yapılandır penceresinin ekran görüntüsü; burada projenin adını ve proje konumunu girin.

  5. Ek bilgiler penceresinde, .NET 10.0Framework açılan menüsünde göründüğünden emin olun ve Create öğesini seçin.

     İstediğiniz .NET sürümünü seçtiğiniz Visual Studio Ek bilgi penceresinin ekran görüntüsü.

  6. Proje, Visual Studio'da oluşturulur ve yüklenir.

Visual Studio'nun özelliklerini keşfetmek için yeni bir proje oluşturalım.

  1. Visual Studio'yu başlatın ve Yeni proje oluştur'u seçin.

    Visual Studio 2022'de 'Yeni proje oluştur' penceresinin ekran görüntüsü.

    Yeni proje oluştur penceresi açılır ve birkaç proje şablonu gösterilir. Şablon, belirli bir proje türü için gereken temel dosyaları ve ayarları içerir.

    Burada bir proje şablonu arayabilir, filtreleyebilir ve seçebilirsiniz. Yeni proje oluştur penceresinde son kullanılan proje şablonlarınızın listesi de gösterilir.

  2. Yeni proje oluştur penceresinde, proje türleri listesini filtrelemek için arama kutusuna konsol yazın. Tüm diller açılan listesinden C# (veya seçtiğiniz başka bir dil) seçerek arama sonuçlarını daha da daraltın.

    Visual Studio 2022'de istediğiniz şablonu seçtiğiniz 'Yeni proje oluştur' penceresinin ekran görüntüsü.

  3. C# seçeneğini belirlediyseniz Konsol Uygulaması şablonunu ve ardından İleri'yi seçin. Farklı bir dil seçtiyseniz herhangi bir şablonu seçmeniz yeter.

  4. Yeni projenizi yapılandırın penceresinde varsayılan proje adını ve konumunu kabul edin ve İleri'yi seçin.

    Visual Studio 2022'de projenin adını ve proje konumunu girdiğiniz Yeni proje yapılandır penceresinin ekran görüntüsü.

  5. Ek bilgiler penceresinde Çerçeve açılan menüsünde.NET 8.0'ın göründüğünden emin olun ve oluştur'u seçin.

    Visual Studio 2022'de istediğiniz .NET sürümünü seçtiğiniz Ek bilgi penceresinin ekran görüntüsü.

  6. Proje, Visual Studio'da oluşturulur ve yüklenir.

Temel düzen

  • Projenizdeki, çözümünüzdeki veya kod klasörünüzdeki dosya ve klasör hiyerarşisinin grafik gösterimini gösteren Çözüm Gezgini'ni kullanarak projenizin içeriğine göz atın.

  • Hiyerarşiye göz atabilir ve dosyayı seçerek Düzenleyici'de açabilirsiniz. dosya Program.csDüzenleyici penceresinde açılır. Düzenleyici, dosyaların içeriğini gösterir ve visual studio'da kodlama çalışmanızın çoğunu yaptığınız yerdir.

    Visual Studio'daki Düzenleyicinin Ekran Görüntüsü.

  • Visual Studio'nun üst kısmındaki menü çubuğu komutları kategorilere ayırır. Örneğin, Proje menüsünde çalıştığınız projeyle ilgili komutlar bulunur. Araçlar menüsünde, Seçenekler'i seçerek Visual Studio'nın nasıl davranacağını özelleştirebilir veya Araçları ve Özellikleri Al'ı seçerek yüklemenize özellikler ekleyebilirsiniz. Kendi geliştirme stilinizi ve gereksinimlerinizi en iyi şekilde desteklemek için Visual Studio IDE ayarlarını çeşitli yollarla özelleştirebilirsiniz .

    Visual Studio'daki Menü çubuğunun ekran görüntüsü.

  • Bağlama duyarlı kod tamamlamaları, öneriler, kod açıklamaları ve daha fazlası ile doğrudan düzenleyicide GitHub Copilot ile yapay zeka yardımı alın. Örneğin, kodun ne yapmasını istediğinizi açıklayan doğal bir dil açıklaması yazarak veya sohbette kodlamayla ilgili sorular sorarak kod önerileri alabilirsiniz.

    Visual Studio 2022'deki GitHub Copilot uzantısının ekran görüntüsü.

    Visual Studio'da yapay zeka destekli geliştirme hakkında daha fazla bilgi edinin.

  • Fare imleci bir anahtar sözcüğün üzerindeyken veya bir anahtar sözcük seçtikten sonra F1 tuşuna basarak bağlamsal yardım alın. Örneğin konsolu seçin ve KonsolSınıfı'nda belgelere atlamak için F1 tuşuna basın.

  • Visual Studio'nun klavye erişilebilirliği mükemmeldir. Eylemleri hızlı bir şekilde gerçekleştirmek için bir dizi yerleşik klavye kısayolu destekler. Klavye kısayollarının listesini görmek için Yardım > Klavye Kısayolu Referansı kullanın.

  • Hata Listesi kodunuzun geçerli durumuyla ilgili hataları, uyarıları ve iletileri gösterir. Dosyanızda veya projenizde herhangi bir yerde hatalar (eksik ayraç veya noktalı virgül gibi) varsa, bunlar burada listelenir. Hata Listesi penceresini açmak için Görünüm menüsünü ve ardından Hata Listesi'ni seçin.

    Visual Studio'daki Hata Listesinin ekran görüntüsü.

  • En üstteki Arama kutusu, Visual Studio'da hemen hemen her şeyi bulmanın hızlı ve kolay bir yoludur. Özellik Arama 'yı (Ctrl + Shift + P, Ctrl + ,veya ) kullanarak özellikleri arayabilir veya Ctrl + QKod Arama 'yı (Ctrl + P) kullanarak dosya ve semboller gibi kod öğelerinizde arama yapabilirsiniz. Örneğin, bir Terminal penceresi açmak için bu pencereyi arayın ve arama sonuçlarından açın. Yerleşik terminal açılır ve komutlar için hazırdır.

    Visual Studio'daki Arama kutusunun ekran görüntüsü.

  • Visual Studio kullanırken herhangi bir sorunla karşılaşırsanız veya ürünü nasıl geliştirebileceğinize ilişkin önerileriniz varsa, IDE'nin sağ üst köşesindeki Geri Bildirim Gönder düğmesini seçerek bize bildirebilirsiniz.

    Visual Studio'daki Geri Bildirim Gönder düğmesinin ve menüsünün ekran görüntüsü.

  • Projenizdeki, çözümünüzdeki veya kod klasörünüzdeki dosya ve klasör hiyerarşisinin grafik gösterimini gösteren Çözüm Gezgini'ni kullanarak projenizin içeriğine göz atın.

  • Hiyerarşiye göz atabilir ve dosyayı seçerek Düzenleyici'de açabilirsiniz. dosya Program.csDüzenleyici penceresinde açılır. Düzenleyici, dosyaların içeriğini gösterir ve visual studio'da kodlama çalışmanızın çoğunu yaptığınız yerdir.

    Visual Studio 2022'de Düzenleyici'nin ekran görüntüsü.

  • Visual Studio'nun üst kısmındaki menü çubuğu komutları kategorilere ayırır. Örneğin, Proje menüsünde çalıştığınız projeyle ilgili komutlar bulunur. Araçlar menüsünde, Seçenekler'i seçerek Visual Studio'nın nasıl davranacağını özelleştirebilir veya Araçları ve Özellikleri Al'ı seçerek yüklemenize özellikler ekleyebilirsiniz. Kendi geliştirme stilinizi ve gereksinimlerinizi en iyi şekilde desteklemek için Visual Studio IDE ayarlarını çeşitli yollarla özelleştirebilirsiniz .

    Visual Studio 2022'de Menü çubuğunun ekran görüntüsü.

  • Bağlama duyarlı kod tamamlamaları, öneriler, kod açıklamaları ve daha fazlası ile doğrudan düzenleyicide GitHub Copilot ile yapay zeka yardımı alın. Örneğin, kodun ne yapmasını istediğinizi açıklayan doğal bir dil açıklaması yazarak veya sohbette kodlamayla ilgili sorular sorarak kod önerileri alabilirsiniz.

    Visual Studio 2022'deki GitHub Copilot uzantısının ekran görüntüsü.

    Visual Studio'da yapay zeka destekli geliştirme hakkında daha fazla bilgi edinin.

  • Fare imleci bir anahtar sözcüğün üzerindeyken veya bir anahtar sözcük seçtikten sonra F1 tuşuna basarak bağlamsal yardım alın. Örneğin konsolu seçin ve KonsolSınıfı'nda belgelere atlamak için F1 tuşuna basın.

  • Visual Studio'nun klavye erişilebilirliği mükemmeldir. Eylemleri hızlı bir şekilde gerçekleştirmek için bir dizi yerleşik klavye kısayolu destekler. Klavye kısayollarının listesini görmek için Yardım > Klavye Kısayolu Referansı kullanın.

  • Hata Listesi kodunuzun geçerli durumuyla ilgili hataları, uyarıları ve iletileri gösterir. Dosyanızda veya projenizde herhangi bir yerde hatalar (eksik ayraç veya noktalı virgül gibi) varsa, bunlar burada listelenir. Hata Listesi penceresini açmak için Görünüm menüsünü ve ardından Hata Listesi'ni seçin.

    Visual Studio 2022'deki Hata Listesi'nin ekran görüntüsü.

  • En üstteki Arama kutusu, Visual Studio'da hemen hemen her şeyi bulmanın hızlı ve kolay bir yoludur. Özellik Arama 'yı (Ctrl + Shift + PCtrl + ,veya ) kullanarak özellikleri arayabilir veya Ctrl + Qkod öğelerinizde (örneğin, dosya ve semboller) Kod Arama (Ctrl + P veya Ctrl + T) kullanarak arama yapabilirsiniz. Örneğin, bir Terminal penceresi açmak için bu pencereyi arayın ve arama sonuçlarından açın. Yerleşik terminal açılır ve komutlar için hazırdır.

    Visual Studio 2022'de Arama kutusunun ekran görüntüsü.

  • Visual Studio kullanırken herhangi bir sorunla karşılaşırsanız veya ürünü nasıl geliştirebileceğinize ilişkin önerileriniz varsa, IDE'nin sağ üst köşesindeki Geri Bildirim Gönder düğmesini seçerek bize bildirebilirsiniz.

    Visual Studio 2022'de Geri Bildirim Gönder düğmesinin ve menüsünün ekran görüntüsü.

Uygulamanızı oluşturma

Şimdi biraz derleme çıktısı görmek için projeyi derleyelim. Çıkış penceresi, projenizi oluşturma ve kaynak denetim sağlayıcınızdan gelen çıkış iletilerini gösterir.

Derlemenüsünden Çözüm Derle'yi seçin. Çıkış penceresi otomatik olarak odağı alır ve başarılı bir derleme iletisi gösterir.

 Projenizi oluştururken ve kaynak denetim sağlayıcınızdan gelen çıkış iletilerini gösteren Visual Studio Çıktı penceresinin ekran görüntüsü.

Visual Studio 2022'de projenizi oluştururken ve kaynak denetim sağlayıcınızdan gelen çıkış iletilerini gösteren Çıkış penceresinin ekran görüntüsü.

Uygulamanızı çalıştırma

  1. Araç çubuğunda Hata Ayıklamayı Başlat düğmesini (yeşil ok) seçin veya uygulamanızı çalıştırmak için F5 tuşuna basın.

    Hata ayıklama araç çubuğundaki Hata Ayıklamayı Başlat düğmesinin ekran görüntüsü.

    Visual Studio uygulamayı oluşturur ve Hello, World! iletisiyle bir konsol penceresi açılır. Artık çalışan bir uygulamanız var!

  2. Konsol penceresini kapatmak için herhangi bir tuşa basın.

Uygulamanızda hata ayıklama

Visual Studio'nun birçok yerleşik hata ayıklama özelliği vardır. Kodun yürütülmesini duraklatmak veya adım adım hata ayıklamak için kodun ilgilendiği herhangi bir noktada bir kesme noktası ayarlayın. Her aşamadaki değerleri inceleyerek kodun sorunlarını gidermek için Yerel Ayarlar, Otomatikler ve İzleme penceresine göz atın.

  1. Şimdi uygulamaya biraz daha kod ekleyelim. aşağıdaki C# kodunu yazan Console.WriteLine("Merhaba Dünya!");satırın önüne ekleyin:

    Console.WriteLine("\nWhat is your name?");
    var name = Console.ReadLine();
    

    Yazarken, kod önerilerini kabul etmek için de basabilirsiniz Tab .

  2. Uygulamanızı çalıştırmak için Visual Studio'da hata ayıklama araç çubuğunda Hata Ayıklamayı Başlat düğmesini (yeşil ok) seçin.

    Hata ayıklama araç çubuğundaki Hata Ayıklamayı Başlat düğmesinin ekran görüntüsü.

  3. Sorunları çözmek veya anında kodda değişiklik yapmak ve uygulamayı yeniden başlatmadan sonuçları görmek için Sık Erişimli Yeniden Yükleme'yi kullanın.

     Hata ayıklama araç çubuğundaki Çalışırken Yeniden Yükleme düğmesinin ekran görüntüsü.

  4. Araç çubuğundaki Durdur düğmesini seçerek uygulamayı istediğiniz zaman durdurabilirsiniz.

    Hata ayıklama araç çubuğundaki Durdur düğmesinin ekran görüntüsü.

Visual Studio'nun birçok yerleşik hata ayıklama özelliği vardır. Kodun yürütülmesini duraklatmak veya adım adım hata ayıklamak için kodun ilgilendiği herhangi bir noktada bir kesme noktası ayarlayın. Her aşamadaki değerleri inceleyerek kodun sorunlarını gidermek için Yerel Ayarlar, Otomatikler ve İzleme penceresine göz atın.

  1. Şimdi uygulamaya biraz daha kod ekleyelim. aşağıdaki C# kodunu yazan Console.WriteLine("Merhaba Dünya!");satırın önüne ekleyin:

    Console.WriteLine("\nWhat is your name?");
    var name = Console.ReadLine();
    

    Yazarken, kod önerilerini kabul etmek için de basabilirsiniz Tab .

  2. Uygulamanızı çalıştırmak için Visual Studio'da hata ayıklama araç çubuğunda Hata Ayıklamayı Başlat düğmesini (yeşil ok) seçin.

    Hata ayıklama araç çubuğundaki Hata Ayıklamayı Başlat düğmesinin ekran görüntüsü.

  3. Sorunları çözmek veya anında kodda değişiklik yapmak ve uygulamayı yeniden başlatmadan sonuçları görmek için Sık Erişimli Yeniden Yükleme'yi kullanın.

    Hata ayıklama araç çubuğundaki Anında Yeniden Yükleme düğmesinin ekran görüntüsü.

  4. Araç çubuğundaki Durdur düğmesini seçerek uygulamayı istediğiniz zaman durdurabilirsiniz.

    Hata ayıklama araç çubuğundaki Durdur düğmesinin ekran görüntüsü.

Kullanıcı arabirimini tanımak için Visual Studio'nun özelliklerinden yalnızca birkaçını incelediniz. Daha fazla keşfetmek için: