你当前正在访问 Microsoft Azure Global Edition 技术文档网站。 如果需要访问由世纪互联运营的 Microsoft Azure 中国技术文档网站,请访问 https://docs.azure.cn。
本文介绍在 Azure HDInsight 群集中使用交互式查询组件时出现的问题的故障排除步骤和可能的解决方案。
问题
Hive 视图不可访问,/var/log/hive
中的日志显示类似于以下内容的错误:
ERROR [Curator-Framework-0]: curator.ConnectionState (ConnectionState.java:checkTimeouts(200)) - Connection timed out for connection string (<zookeepername1>.contoso.com:2181,<zookeepername2>.contoso.com:2181,<zookeepername3>.contoso.com:2181) and timeout (15000) / elapsed (21852)
原因
Hive 可能无法建立与 Zookeeper 的连接,这会阻止 Hive 视图启动。
解决方法
检查 Zookeeper 服务是否正常运行。
检查 Zookeeper 服务是否具有 Hive Server2 的 ZNode 条目。 该值会缺失或不正确。
/usr/hdp/2.6.2.25-1/zookeeper/bin/zkCli.sh -server <zookeepername1> [zk: <zookeepername1>(CONNECTED) 0] ls /hiveserver2-hive2
若要重新建立连接,请重新启动 Zookeeper 节点,并重新启动 HiveServer2。
后续步骤
如果你的问题未在本文中列出,或者无法解决问题,请访问以下渠道之一获取更多支持:
通过 Azure 社区支持获取 Azure 专家的解答。
联系 @AzureSupport,这是用于改进客户体验的官方 Microsoft Azure 帐户。 它可以将 Azure 社区成员连接到适当的资源,为他们提供解答、支持和专家建议。
如果需要更多帮助,可以从 Azure 门户提交支持请求。 从菜单栏中选择“支持”,或打开“帮助 + 支持”中心。 有关更多详细信息,请参阅如何创建 Azure 支持请求。 Microsoft Azure 订阅中带有对订阅管理和计费支持的访问权限,技术支持通过 Azure 支持计划之一提供。