新 Microsoft Teams 客户端简介

重要

经典 Teams 客户端预计将在 2024 年 3 月 31 日弃用。

新的 Microsoft Teams 客户端 从头开始重新构思,并考虑了性能。 它更快、更简单、更智能、更灵活,可为应用和用户提供更好的体验。 新的 Teams 客户端支持除自适应卡片选项卡之外的所有现有 Teams 应用功能。 如果你有一个在经典 Teams 中运行的应用,该应用很可能在新 Teams 客户端中运行,不会出现任何问题。

以下是新 Teams 客户端的优点:

  • 新的 Teams 客户端使用 Microsoft Edge WebView2 的 Evergreen 版本来确保 Teams 客户端始终处于最新状态,其中包含 Microsoft Edge 和 Chromium 中提供的最新修补程序和改进。

  • 新的 Teams 客户端从头开始重新构建,考虑到性能,并包括负责启动应用和为其使用的 SDK API 提供支持的所有平台基础结构。

可以使用以下属性在新 Teams 或经典 Teams 客户端中标识应用使用情况:

注意

如果未定义 hostName,则假定应用在经典 Teams 客户端中运行。

经典 Teams 客户端使用 teams 字段表示,新的 Teams 客户端使用 teamsModern 字段表示。

时间线和推出

为确保平稳过渡,计划分阶段推出新平台,如下所示:

  • 经典 Teams 中所有平台功能的可用性:新 Teams 客户端中提供了所有应用。 除 已知问题 中列出的功能外,所有平台功能现在都可用。 新 Teams 客户端当前不支持已知问题下的平台功能。

已知问题

注意

  • Windows 和 Mac 客户端以及政府社区云 (GCC) 和 GCC-High 环境中支持新的 Teams 客户端。
  • 建议在从经典 Teams 客户端切换到新的 Teams 客户端后,在 Windows 和 Mac 客户端以及 GCC 和 GCC-High 环境中测试应用、选项卡、消息扩展、机器人和链接展开的功能。
  • 新的 Teams 客户端不支持自适应卡片选项卡。 经典 Teams 客户端预计将在 2024 年 3 月 31 日弃用。 如果应用使用自适应卡片选项卡,建议将选项卡重新生成为基于 Web 的选项卡。有关详细信息,请参阅 Teams 的生成选项卡

新 Teams 客户端当前不支持以下 Teams 功能:

  • 新的 Teams 客户端不支持位置和媒体 API。 建议使用 HTML5 地理位置和媒体。

  • 新的 Teams 客户端不支持 DevTools

  • 新的 Teams 客户端不支持应用缓存

  • window.alert新的 Teams 客户端不支持用于显示对话框的 、 window.confirmwindow.prompt API。 建议在自己的框架中呈现对话,例如,使用 Fluent V9 对话框或使用 Microsoft Teams JavaScript 客户端库 (TeamsJS) ,以使用自适应卡片或嵌套的 <iframe>显示 Teams 对话

有关新 Teams 客户端中的已知问题和差距的详细信息,请参阅 新的 Microsoft Teams

如果你的应用在经典 Teams 客户端中正常运行,但在新 Teams 中出现问题,则 在此页面上引发问题。 对于任何其他问题,请请求你提出 有关支持和反馈的问题。

另请参阅