Windows 停止错误 - 0x0000007E未处理系统线程异常

适用于:✔️ Windows VM

本文提供了解决来宾操作系统(来宾 OS)遇到问题并尝试重启 Azure 虚拟机(VM)的问题的步骤。 此外,你还会收到以下错误消息:

系统线程异常未处理。

现象

使用 启动诊断 查看 VM 输出的屏幕截图时,请注意,Windows 在返回“系统线程异常未处理”停止代码或“0x0000007E”错误代码后必须重新启动。

屏幕截图显示(你的电脑遇到问题,需要重启)。我们将为你重启消息,系统线程异常未处理停止代码。

原因

在分析内存转储文件之前,无法确定此问题的原因。 继续收集内存转储文件。

解决方案

提示

如果 VM 有最近的备份,可以尝试 从备份 还原 VM 以修复重启问题。

若要解决此问题,请收集事件的内存转储文件,并将该文件发送到Microsoft 支持部门。 若要收集转储文件,请按照后续部分中的说明进行操作。

第 1 部分:将 OS 磁盘附加到恢复 VM
  1. 创建受影响 VM 的 OS 磁盘的快照以创建备份。 有关详细信息,请参阅 创建虚拟硬盘的快照。

  2. 将 OS 磁盘附加到恢复 VM

  3. 使用远程桌面协议(RDP)远程连接到恢复 VM。

  4. 如果受影响的 VM 的 OS 磁盘已加密,请关闭加密,然后再转到下一步。 有关详细信息,请参阅 解密加密的 OS 磁盘

第 2 部分:找到转储文件并提交支持票证
  1. 在恢复 VM 上,转到 附加 OS 磁盘上的 Windows 文件夹。 例如,如果分配给附加 OS 磁盘的驱动器号为 F,请转到 F:\Windows

  2. 找到Memory.dmp文件,然后提交支持票证并附加转储文件。

注意

如果在查找 Memory.dmp 文件时遇到问题,可以尝试改用 串行控制台 中的不可屏蔽中断(NMI)调用。 可以使用 本指南通过 NMI 调用生成故障转储文件。

后续步骤

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