导入解决方案过程中缺少依赖项的错误

本文提供了有关在 Microsoft power Apps 中导入解决方案缺少依赖项的问题的解决方法。

适用于: Power Platform、Solutions

现象

尝试在 Power Apps 中导入解决方案时,会收到如下错误消息:

由于缺少依赖项,导入失败。

在解析缺少的依赖项之前,无法继续执行解决方案导入。

原因

该解决方案依赖于部署解决方案的源环境中存在的组件。 但是,在导入解决方案的目标环境中不存在该组件。

当通过 Microsoft 在源环境中进行计划维护,将应用程序升级到最新版本时,可能会出现此问题,但它们在目标环境中没有得到升级。

解决方法

重要

此处所述的体验可能尚不适用于所有区域的环境。

若要解决此问题,请执行以下步骤:

  1. 选择“显示依赖项”按钮,导航到“缺少的依赖项”页。

    此页面列出所有缺少的组件,并将其分类为 应用程序托管解决方案和非 托管组件

    提示

    查找组件依赖项的另一种方法是打开解决方案文件,将其解压缩,然后打开 solution.xml 文件。 在文件中,查找列出所有缺失的依赖项的<MissingDependencies>元素。

  2. 展开每个依赖项部分,并根据以下各节中所述的依赖项类型解决问题。 修复缺少的依赖项后,请重试导入。

来自 Dynamics 365 应用程序的缺失依赖项

当解决方案依赖于目标环境中缺少或过时的 Dynamics 365 应用程序中的组件时,会出现此问题。 可以在“缺少依赖项”页的“应用程序”部分找到这些依赖项。 每个条目提供以下格式的缺失应用程序的详细信息:

<solution_name>(<solution_version>)来自<application_name>

在应用程序名称旁边,你将找到一个 “安装 ”或 “更新 ”按钮,用于将你重定向到 Power Platform 管理中心。

显示“缺少依赖项”页的“应用程序”部分的屏幕截图。

若要解决此问题,请执行下列操作:

  • 如果未在目标环境中安装应用程序:

    • 系统管理员可以使用“ 安装 ”按钮,该按钮重定向到 Power Platform 管理中心中的 应用程序安装 页面。 选择并安装应用程序。
    • 非系统管理员可以使用 “复制安装链接 ”按钮复制应用程序安装链接,并请求其系统管理员安装该应用程序。 或者,系统管理员可以直接转到 应用程序安装 页,在 Power Platform 管理中心安装应用程序。
  • 如果应用程序已安装,但在目标环境中已过时:

    • 系统管理员可以使用 “更新 ”按钮在 Power Platform 管理中心打开应用程序更新页。
    • 非系统管理员可以使用 “复制更新链接 ”按钮复制应用程序更新链接,并请求其系统管理员更新应用程序。

缺少来自另一个托管解决方案的依赖项

当解决方案依赖于目标环境中缺少的另一个托管解决方案中的组件时,会出现此问题。 可以在“缺少依赖项”页的“托管解决方案”部分找到这些依赖项。 展开该部分可提供其他详细信息。

显示“缺少依赖项”页的“托管解决方案”部分的屏幕截图。

若要解决此问题,请将源环境中安装的相同解决方案版本导入到目标环境中。

缺少对“Active”解决方案的依赖项

当解决方案依赖于目标环境中缺少的源环境中的非托管自定义项时,会出现此问题。 可以在“缺少依赖项”页的“非托管组件”部分找到这些依赖项。 展开该部分可提供其他详细信息。

显示“缺少依赖项”页的“非托管组件”部分的屏幕截图。

若要解决此问题,请返回到源环境,包括缺少的组件,再次导出解决方案,然后将其导入目标环境。