本文提供了Power Automate 桌面版中多个登录相关问题的解决方法和解决方法。
通用登录或注销问题
Power Automate 桌面版使用名为 msalcache.bin3 的文件来获取令牌和对用户进行身份验证。
如果在登录或注销时遇到错误,请通过删除此文件删除所有存储的令牌。
若要删除该文件,请导航到 %localappdata%\Microsoft\Power Automate Desktop\Cache\MSI
MSI 安装或%localappdata%\Microsoft\Power Automate Desktop\Cache\Store
Microsoft应用商店安装。
注意
如果 AppData 文件夹在您的用户文件夹中不可见,请尝试显示隐藏文件。
删除 msalcache.bin3 文件后,关闭 Power Automate 控制台,从系统托盘退出 Power Automate 或重启 Power Automate 服务,然后重试登录。
Web 帐户管理器 (WAM) 错误
默认情况下,Power Automate 桌面版通过 Web 帐户管理器(WAM)对用户进行身份验证;这是操作系统附带的 Windows 组件,充当身份验证代理。
有关 WAM 和相关错误的详细信息,请参阅 将 MSAL.NET 与 Web 帐户管理器(WAM) 和 WAM 交互配合使用。
区域问题
在登录之前,请确保已从 “更改区域”选项中选择了正确的区域 。
浏览器阻止 Cookie
登录Power Automate 桌面版时,会收到以下错误消息:
我们无法登录。 浏览器当前设置为阻止 Cookie。 你需要允许 Cookie 使用此服务。
解决方法
转到控制面板>Internet 选项>安全>受信任的站点。
添加以下 URL:
login.microsoft.com
login.windows.net
login.microsoftonline.com
secure.aadcdn.microsoftonline-p.com
由于连接问题,无法登录
登录Power Automate 桌面版时,会收到以下错误消息:
登录期间出现问题。 请稍后重试或联系管理员。
验证问题
尝试登录到 Power Automate。 如果它按预期工作,则问题应与托管Power Automate 桌面版的计算机的本地网络配置相关。
解决方法
有关解决此问题的可能原因和步骤的详细信息,请参阅 无法创建、编辑、保存或查看桌面流。
登录窗口不断弹出
登录Power Automate 桌面版时,输入凭据时会弹出登录帐户窗口。 如果选择问号(?)图标以重置登录Microsoft帐户中的 帐户,则登录窗口将消失。
原因
另一个进程可能在同一台计算机上运行命名管道服务器。 此过程使用 localhost 终结点以提升的权限运行,并阻止其他应用程序使用此终结点。
若要确定另一个进程是否正在运行:
下载 Sysinternals 套件。
将 .zip 文件解压缩到文件夹中。
以管理员身份运行命令提示符。
导航到提取 Sysinternals Suite 的文件夹。
运行以下命令:
handle net.pipe
注意
运行此命令应会显示使用命名管道的进程列表以及它们侦听的地址。
使用以下链接确定是否有一个进程显示
EbmV0LnBpcGU6Ly8rLw==
字符串并解码进程:https://www.base64decode.org/
例如:
PAD.BrowserNativeMessageHost.exe pid: 21064 type: Section 464: \Sessions\1\BaseNamedObjects\net.pipe:EbmV0LnBpcGU6Ly8rL0JST1dTRVJOQVRJVkVIT1NULzE2NjIwLzEv Microsoft.Management.Services.IntuneWindowsAgent.exe pid: 26708 type: Section 6AC: \BaseNamedObjects\net.pipe:EbmV0LnBpcGU6Ly8rL0lOVFVORU1BTkFHRU1FTlRFWFRFTlNJT04vU1RBVFVTU0VSVklDRS8= PipesTest.Server.exe pid: 6540 type: Section 3AC: \BaseNamedObjects\net.pipe:EbmV0LnBpcGU6Ly8rLw==
解决方法
若要解决此问题,请停止在上一步中标识的进程,或者如果是内部进程,请使用更具体的终结点,例如 net.pipe://localhost/something
。
作为替代方法,请确保关闭Power Automate 桌面版(也从任务栏关闭),终止在前面的步骤中标识的进程,然后重试重启Power Automate 桌面版。
如果其他解决方案不可行,请指定Power Automate 桌面版可执行文件以管理员身份运行。 这种解决方法在某些情况下可能只解决了该问题,并且它会导致每次出现用户帐户控制(UAC)提示。