登录到 Salesforce CRM 时出现“传递给重定向 URL 失败”错误

本文可帮助你排查和解决Microsoft Power Platform 应用被Microsoft Copilot for Sales 中的管理员阻止时的登录问题。

谁受影响?

要求类型 Description
客户端应用 Copilot for Sales Outlook 加载项和 Teams 应用
平台 Web 和桌面客户端
操作系统 Windows 和 Mac
部署 用户管理和管理员管理
CRM Salesforce
用户 尝试对 Salesforce 实例进行身份验证的用户

现象

尝试从适用于 OutlookCopilot for Sales 外接程序登录到 Salesforce CRM 时,将显示以下错误消息:

传递给重定向 URL 的失败。 error=OAUTH_APP_BLOCKED error_description=此应用被管理员阻止

显示传递给重定向 URL 错误的失败的屏幕截图。

在 Salesforce CRM 中,Microsoft Power Platform 应用显示为“连接的应用 OAuth 使用情况”页上被阻止。

显示 Salesforce CRM 中阻止了Microsoft Power Platform 的屏幕截图。

原因

Salesforce CRM 中的 Microsoft Power Platform 应用被管理员阻止。

Copilot for Sales 通过 Microsoft Power Platform 连接的应用连接到 Salesforce CRM。 当管理员阻止Microsoft Power Platform 应用时,Salesforce 身份验证过程会失败并显示错误消息。

解决方法

确保 Salesforce CRM 中未阻止 Microsoft Power Platform 连接应用。

  1. 以管理员身份登录到 Salesforce CRM。

  2. 转到设置>平台工具>应用>连接的应用>连接的应用 OAuth 使用情况

  3. 对于 Microsoft Power Platform 应用,选择取消阻止

    Microsoft Power Platform 应用将从列表中消失,但已被取消阻止。

    使用 Copilot for Sales 从第一个用户成功登录后, Microsoft Power Platform 应用再次显示在列表中。

详细信息

如果你的问题仍未解决,请转到 Copilot for Sales - Microsoft社区中心 与我们的专家联系。

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