排查打印的已知问题

本文介绍打印过程中可能发生的新兴问题和常见问题,并为这些问题提供可能的解决方案。

当这些设备使用智能卡身份验证时,打印和扫描可能会失败

在环境中的域控制器上安装KB5004237后,使用智能卡(PIV)身份验证时,某些打印机、扫描仪和多功能设备可能不会打印。

解决方法

有关此问题的详细信息,请参阅 KB5005408 - 智能卡身份验证可能会导致打印和扫描失败

某些打印机无法通过 USB 打印

安装KB5003690或更高版本的更新(包括带外更新KB5004760和KB5004945),尝试打印到某些打印机时可能会遇到问题。 各种品牌和型号受到影响,主要是通过 USB 连接的收据或标签打印机。

解决方法

此问题由 已知问题回滚 (KIR)解决。 此问题与 CVE-2021-34527 或 CVE-2021-1675 无关。

Windows Print Spooler 远程代码执行漏洞

安装 2021 年 7 月 6 日 - KB5004945(OS 内部版本 19041.1083、19042.1083 和 19043.1083) 带 外更新和更高版本的 Windows 更新后,非管理员用户只能将打印驱动程序签名安装到打印服务器。 默认情况下,管理员可以将已签名和未签名的打印机驱动程序安装到打印服务器。 系统的受信任的根证书颁发机构中安装的根证书信任已签名的驱动程序。

解决方法

有关详细信息,请参阅 KB5005010:在应用 2021 年 7 月 6 日更新后限制新打印机驱动程序的安装。

连接到计算机的打印机无法打印

原因

物理打印机、打印驱动程序、打印服务器或尝试从中打印的应用程序中可能存在问题。

解决方法

请尝试以下步骤来识别并解决问题:

  • 验证物理打印机是否处于就绪状态,并设置正确的默认打印机。
  • 尝试打印测试页。
  • 尝试从命令行打印(仅在非 PostScript 打印机上)。 在命令提示符处键入 Dir > LPT1
  • 尝试从文本编辑器(如记事本)打印。 如果打印成功,这将确认打印机驱动程序正确,并且问题是由应用程序引起的。 如果无法从记事本打印,则问题由打印机驱动程序引起。
  • 检查系统驱动器上的可用磁盘空间。 如果没有足够的空间来后台处理作业,即使较小的作业没有,更大的作业也会失败。

连接到网络的打印机不打印

原因

物理打印机、客户端计算机上的逻辑打印机设置、尝试从网络协议或硬件打印的应用程序中可能存在问题。

解决方法

请尝试以下方法来隔离并解决问题:

  • 验证基本网络连接。 检查用户权限、协议、共享名称等,以确定你是否可以看到服务器。 尝试将文件复制到服务器。 如果无法访问服务器,则可能无法访问打印机。
  • 在“高级”选项卡上,确保打印机可用性时间正确。
  • 创建本地打印机,并将端口重定向到网络服务器。 使用“添加打印机向导”,选择“本地”,然后键入打印机的服务器和打印机名称(\\<servername>\<printername>)。 这决定了是否可以从打印服务器复制文件。
  • 检查打印服务器上的可用磁盘空间。 如果没有足够的空间来后台处理作业,即使较小的作业没有,更大的作业也会失败。

尝试在应用程序中配置打印机时拒绝访问消息

原因

您没有更改打印机配置的适当权限。

解决方法

必须具有“管理打印机”权限才能更改打印机设置。

文档不会完全打印或显示乱码

原因

打印机的驱动程序已损坏或不正确。

解决方法

在客户端计算机上验证或重新安装正确的打印机驱动程序。

硬盘问题发生,文档无法访问打印服务器

原因

硬盘可能没有足够的空间来后台处理文档。

解决方法

确保硬盘有足够的磁盘空间,或将后台处理程序文件夹重新定位到另一卷。

打印服务器上的文档不打印,无法删除

原因

打印后台处理程序可能会停止。

解决方法

在打印服务器上,尝试停止并重启打印后台处理程序服务。

未列出驱动程序

解决方法

Windows 打印机驱动程序是通过Microsoft与制造打印设备的独立硬件供应商合作开发的。 有关新的和更新的打印驱动程序,请参阅有关如何下载和安装最新打印机驱动程序Microsoft打印支持,并查看Windows 更新

必须安装从 Internet 下载的新打印驱动程序

原因

打印驱动程序未在 打印机的“添加打印机向导” 列表中列出,但已从 Internet 下载。

解决方法

  1. 将打印机驱动程序下载到空文件夹。
  2. 键入可执行文件的名称后跟 -d 开关展开文件。 例如,如果文件名Nt4prn.exe,请在命令提示符处键入以下命令: nt4prn -d
  3. 读取Readme.txtLicense.txt文件。
  4. 选择“开始”按钮,然后选择“设置>设备>打印机和扫描仪”。
  5. 在右侧的“相关设置”,选择“打印服务器属性”。
  6. “驱动程序 ”选项卡上,检查打印机是否已列出。 如果是,则全部设置。
  7. 如果未列出打印机,请选择“添加”,然后在“欢迎添加打印机驱动程序向导”中选择下一步”。
  8. “处理器选择 ”对话框中,选择设备的体系结构,然后选择“ 下一步”。
  9. “打印机驱动程序选择 ”对话框中,选择“ 具有磁盘”,然后选择“浏览” 按钮
  10. 指向在步骤 1 中下载驱动程序的文件夹,然后按照说明添加驱动程序。

即使启用了打印机位置跟踪,某些打印机也无法找到

原因

启用打印机位置跟踪后,默认行为是用户将仅查找其位置属性与命名约定匹配的打印机。

解决方法

再次为此打印机设置位置字符串。 若要了解如何执行此操作,请参阅 “启用打印机位置跟踪”。

命名方案必须更改,因为公司更改了其组织

解决方法

使用 Active Directory 站点和服务更新站点和子网。 然后,必须更新组织中受影响打印机的所有打印机位置字段。 可以创建 Active Directory 服务接口 (ADSI) 脚本来加快更新速度。

组织有一个没有任何子网的小型网络

解决方法

Active Directory 在目录树中找不到节点,而没有与之关联的子网。 如果组织足够小,则这种情况不是问题,因为用户可以在组织中搜索任何打印机。 但是,对于具有许多打印机的大型组织或组织,你仍可让用户浏览位置层次结构作为查找打印机的帮助。 为此,必须在 Active Directory 中创建对应于要创建的层次结构的人工子网。

数据收集

如果需要Microsoft支持方面的帮助,建议按照使用 TSS 收集信息中的 步骤收集用户体验问题来收集信息。