Poznámka:
Přístup k této stránce vyžaduje autorizaci. Můžete se zkusit přihlásit nebo změnit adresáře.
Přístup k této stránce vyžaduje autorizaci. Můžete zkusit změnit adresáře.
Důležité
Tato funkce je ve fázi veřejné verze Preview.
Ovladač Databricks pro SQLTools umožňuje pomocí rozšíření SQLTools pro Visual Studio Code procházet objekty SQL a spouštět dotazy SQL ve vzdálených pracovních prostorech Azure Databricks.
Requirements
Než budete moct použít ovladač Databricks pro SQLTools, váš pracovní prostor Azure Databricks a místní vývojový počítač musí splňovat následující požadavky.
Požadavky na pracovní prostor
Musíte mít k dispozici alespoň jeden pracovní prostor Azure Databricks a pracovní prostor musí splňovat následující požadavky:
Pracovní prostor musí obsahovat alespoň jeden Databricks SQL Warehouse.
Poznámka
Azure Databricks clustery nejsou podporovány ovladačem Databricks pro SQLTools.
U pracovních prostorů, které jsou povolené pro katalogu Unity, musí pracovní prostor obsahovat alespoň jeden katalog s alespoň jedním schématem (formálně označovaným jako databáze) v rámci daného katalogu.
U pracovních prostorů, které nejsou povolené pro katalog Unity, musí pracovní prostor obsahovat alespoň jedno schéma (dříve označované jako databáze).
Požadavky místního vývojového počítače
Na místním počítači pro vývoj musíte mít následující:
- Visual Studio Code verze 1.70 nebo vyšší Pokud chcete zobrazit nainstalovanou verzi, klikněte v hlavní nabídce v Linuxu nebo macOS na Code > O aplikaci Visual Studio Code a ve Windows na Nápověda > O aplikaci. Pokud chcete stáhnout, nainstalovat a nakonfigurovat Visual Studio Code, přečtěte si téma Nastavení editoru Visual Studio Code.
- Rozšíření SQLTools pro Visual Studio Code
- Rozšíření Databricks Driver for SQLTools pro Visual Studio Code.
Chcete-li nainstalovat rozšíření SQLTools, přejděte do nástroje SQLTools a klepněte na tlačítko Nainstalovat, nebo:
V editoru Visual Studio Code klikněte v hlavní nabídce na Zobrazení > Rozšíření.
Do pole Hledat rozšíření na Marketplace zadejte
SQLTools.Klikněte na položku SQLTools od Matheuse Teixeiry.
Poznámka
Může se zobrazit několik položek SQLTools . Nezapomeňte kliknout na položku od Matheus Teixeira.
Klikněte na Install.
Chcete-li nainstalovat rozšíření Databricks Driver for SQLTools, přejděte do Databricks Driver for SQLTools a klikněte na tlačítko Nainstalovat, nebo:
- V editoru Visual Studio Code klikněte v hlavní nabídce na Zobrazit > Rozšíření.
-
Do pole Hledat rozšíření na Marketplace zadejte
Databricks Driver for SQLTools. - Klikněte na položku Ovladač Databricks pro SQLTools.
- Klikněte na Install.
Ověřování
Pro ovladač Databricks pro SQLTools musíte nastavit ověřování následujícím způsobem.
Ovladač Databricks pro SQLTools podporuje následující typy ověřování Azure Databricks:
- Ověřování tokenu PAT služby Azure Databricks
- Ověřování azure Databricks OAuth typu machine-to-machine (M2M)
- Ověřování OAuth Azure Databricks uživatel–stroj (U2M)
- Ověřování přes Azure CLI
Poznámka
Ovladač Databricks pro SQLTools nepodporuje tokeny Microsoft Entra ID.
Ověřování osobního přístupového tokenu Azure Databricks
Chcete-li použít ovladač Databricks pro SQLTools s ověřováním pomocí osobního přístupového tokenu Azure Databricks, musíte mít osobní přístupový token Azure Databricks. Chcete-li vytvořit osobní token pro přístup, postupujte podle pokynů v tématu Vytváření osobních tokenů pro uživatele pracovního prostoru.
Ověřování azure Databricks OAuth typu machine-to-machine (M2M)
K ověření pomocí ovladače Databricks pro SQLTools můžete použít ověřování Azure Databricks OAuth typu machine-to-machine (M2M), a to následujícím způsobem:
Poznámka
Ověřování Azure Databricks OAuth M2M je k dispozici v ovladači Databricks pro SQLTools verze 0.4.2 a vyšší.
- Dokončete kroky konfigurace pro ověřování OAuth M2M. Viz ověřování typu OAuth machine-to-machine (M2M).
- Vytvořte konfigurační profil Azure Databricks s nastavením konfigurace ověřování OAuth M2M. Viz sekci „Config“ v článku ověřování OAuth machine-to-machine (M2M).
- Nainstalujte a otevřete rozšíření Databricks pro Visual Studio Code na místním vývojovém počítači.
- V rozšíření Databricks IDE klikněte na tlačítko Configure v panelu Konfigurace . Pokud se tlačítko Konfigurovat nezobrazí, klikněte místo toho na ikonu ozubeného kola (Konfigurovat pracovní prostor).
- V Paletě příkazů pro Hostitel Databricks zadejte adresu URL Azure Databricks pro jednotlivé pracovní prostory, například
https://adb-1234567890123456.7.azuredatabricks.net, a potom stiskněte Enter. - Vyberte položku konfiguračního profilu, která odpovídá položce, kterou jste vytvořili v kroku 2.
- Postupujte podle pokynů na obrazovce ve webovém prohlížeči a dokončete ověřování pomocí účtu Azure Databricks.
Ověřování OAuth uživatel–počítač (U2M) v Azure Databricks
K ověření pomocí ovladače Databricks pro SQLTools můžete použít Azure Databricks ověřování OAuth uživatele k počítači (U2M), a to následujícím způsobem:
Poznámka
Ověřování Azure Databricks OAuth U2M je k dispozici v ovladači Databricks pro SQLTools verze 0.4.2 a vyšší.
- Nainstalujte a otevřete rozšíření Databricks pro Visual Studio Code na místním vývojovém počítači.
- V rozšíření Databricks IDE klikněte na tlačítko Configure v panelu Konfigurace . Pokud se tlačítko Konfigurovat nezobrazí, klikněte místo toho na ikonu ozubeného kola (Konfigurovat pracovní prostor).
- V Paletě příkazů do pole Databricks Host zadejte URL pro jednotlivý pracovní prostor služby Azure Databricks, například . Pak stiskněte klávesu Enter.
- Vyberte OAuth (uživatel do počítače).
- Postupujte podle pokynů na obrazovce ve webovém prohlížeči a dokončete ověřování pomocí účtu Azure Databricks. Pokud se zobrazí výzva, povolte
all-apispřístup.
Ověřování Azure CLI
Azure CLI můžete použít k ověření pomocí ovladače Databricks Driver for SQLTools, a to následujícím způsobem:
Poznámka
Ověřování pomocí Azure CLI je ve stavu Experimentální. Tato funkce je dostupná v ovladači Databricks pro SQLTools verze 0.4.2 a vyšší.
- Pokud jste to ještě neudělali, nainstalujte azure CLI na místní vývojový počítač.
- Nainstalujte a otevřete rozšíření Databricks pro Visual Studio Code na místním vývojovém počítači.
- V rozšíření Databricks IDE klikněte na tlačítko Configure v panelu Konfigurace . Pokud se tlačítko Konfigurovat nezobrazí, klikněte místo toho na ikonu ozubeného kola (Konfigurovat pracovní prostor).
- V Příkazové paletě do pole Databricks Host zadejte adresu URL pro pracovní prostor služby Azure Databricks, například . Pak stiskněte klávesu Enter.
- Vyberte Azure CLI.
- Postupujte podle pokynů na obrazovce a dokončete ověřování pomocí Azure CLI.
Připojení ke schématu
V editoru Visual Studio Code na bočním panelu klikněte na ikonu SQLTools.
V zobrazení SQLTools, pokud rozšíření SQLTools používáte poprvé, klikněte v podokně Připojení na Přidat nové připojení. V opačném případě klikněte na ikonu Přidat nové připojení v záhlaví podokna.
Na kartě nastavení SQLTools v kroku Vyberte ovladač databáze klikněte na ikonu Databricks.
V kroku Nastavení připojení zadejte následující informace o vašem skladu, katalogu a schématu:
- Jako Název připojení zadejte jedinečný název tohoto připojení.
- (Volitelné) Do Skupina připojení zadejte název existující skupiny připojení pro přidání nového připojení k této skupině. Nebo zadejte jedinečný název pro vytvoření nové skupiny připojení s novým připojením. Skupiny připojení usnadňují hledání připojení v rozšíření.
- Pro připojení pomocí vyberte jednu z následujících možností:
- Pokud chcete pro ověřování použít osobní přístupový token Azure Databricks, vyberte název hostitele a token.
- Pokud chcete pro ovladač Databricks pro SQLTools verze 0.4.2 a vyšší použít ověřování OAuth U2M nebo M2M nebo Azure CLI, vyberte rozšíření VS Code (beta).
Pokud jste pro připojení pomocí vybrali název hostitele a token, zadejte pro Host nastavení serverového názvu hostitele skladu. Pro získání nastavení hostname serveru datového skladu, viz Získání podrobností o připojení pro výpočetní prostředek Azure Databricks.
Pro cesta zadejte nastavení HTTP cesty pro sklad nebo cluster. Chcete-li získat nastavení cesty HTTP skladu, podívejte se na Získání podrobností o připojení pro výpočetní prostředek Azure Databricks.
Pokud jste pro Připojit pomocí vybrali Název hostitele a token, zadejte hodnotu osobního přístupového tokenu Azure Databricks do pole Token.
Do katalogzadejte název katalogu.
Poznámka
U pracovních prostorů, které nejsou povoleny pro katalog Unity, můžete ponechat Katalog prázdné, pokud chcete použít výchozí hodnotu
hive_metastore.Pro schéma zadejte název svého schématu.
(Volitelné) Pro možnost Nastavit výchozí limit záznamů, ponechte výchozí hodnotu
50k zobrazení pouze prvních 50 řádků pro každý dotaz nebo zadejte jiný limit.
Klikněte na Otestovat připojení.
Pokud test připojení proběhne úspěšně, klikněte na uložit připojení.
Změna nastavení připojení
Tento postup předpokládá, že jste se úspěšně připojili k alespoň jednomu skladu.
- Pokud zobrazení SQLTools není viditelné, klikněte v nástroji Visual Studio Code na bočním panelu na ikonu SQLTools.
- V podokně Připojení rozbalte skupinu připojení, pokud pro cílové připojení existuje.
- Klikněte pravým tlačítkem myši na připojení a klikněte na Upravit připojení.
- Změňte nastavení cíle.
- Klikněte na Test připojení.
- Pokud test připojení proběhne úspěšně, klikněte na uložit připojení.
Procházení objektů schématu
- V podokně Připojení rozbalte skupinu připojení, pokud pro cílové připojení existuje.
- Dvakrát klikněte nebo rozbalte cílové připojení pro váš sklad.
- Rozbalte cílovou databázi (schéma), pokud existuje pro vaše připojení.
- Rozbalte tabulky nebo zobrazení, pokud pro databázi (schéma) existuje jedna nebo více tabulek nebo zobrazení.
- Rozbalením libovolné cílové tabulky nebo zobrazení zobrazíte sloupce tabulky nebo zobrazení.
Zobrazit řádky nebo schéma pro tabulku nebo databázové zobrazení.
Když rozbalíte tabulky nebo zobrazení v podokně Připojení, proveďte jednu z následujících akcí:
- Pokud chcete zobrazit řádky tabulky nebo zobrazení, klikněte pravým tlačítkem myši na tabulku nebo zobrazení a klikněte na Zobrazit záznamy tabulky nebo Zobrazit záznamy.
- Pokud chcete zobrazit schéma tabulky nebo zobrazení, klikněte pravým tlačítkem myši na tabulku nebo zobrazení a klikněte na popis tabulky nebo zobrazení.
Vygenerujte příkaz INSERT pro tabulku
- Umístěte kurzor do existujícího editoru na místo, kam chcete vložit dotaz.
- Když jsou Tabulky rozbaleny v podokně Připojení, klikněte pravým tlačítkem na tabulku a zvolte možnost Vygenerovat dotaz na vložení. Definice dotazu pro vložení se přidá na místo vložení kurzoru.
Vytvoření a spuštění dotazu
Tento postup předpokládá, že jste se úspěšně připojili k alespoň jednomu skladu.
- V podokně Připojení rozbalte skupinu připojení, pokud pro cílové připojení existuje.
- Dvakrát klikněte nebo rozbalte cílové připojení pro váš sklad.
- Pokud je vybrané připojení, klikněte na Nový soubor SQL v záhlaví podokna Připojení . Zobrazí se nová karta editoru.
- Zadejte dotaz SQL v novém editoru.
- Pokud chcete spustit dotaz SQL, klikněte v editoru na Spustit v aktivním připojení. Výsledky dotazu se zobrazí na nové kartě editoru.
Spustit existující dotaz
Tento postup předpokládá, že jste se úspěšně připojili k alespoň jednomu skladu.
- V podokně Připojení rozbalte skupinu připojení, pokud pro cílové připojení existuje.
- Poklepejte nebo rozbalte cílové připojení pro váš sklad.
- Při vybraném připojení otevřete libovolný soubor s příponou
.sqlnebo vyberte libovolnou skupinu průběžných příkazů SQL v libovolném editoru, který byl dříve otevřen. - Pokud chcete spustit dotaz SQL z otevřeného
.sqlsouboru s obsahem souboru.sqlzobrazeným v editoru, klikněte v editoru na Spustit při aktivním připojení v editoru. Výsledky dotazu se zobrazí na nové kartě editoru. - Chcete-li spustit vybranou skupinu nepřetržitých příkazů SQL v editoru, který byl dříve otevřen, klikněte pravým tlačítkem myši na výběr a potom klikněte na příkaz Spustit vybraný dotaz. Výsledky dotazu se zobrazí na nové kartě editoru.
Odeslat protokoly využití do Databricks
Pokud při používání ovladače Databricks pro SQLTools narazíte na problémy, můžete odeslat protokoly využití a související informace podpoře Databricks následujícím způsobem:
- Nainstalujte rozšíření Databricks pro Visual Studio Code do svého místního vývojového počítače.
- Zapněte logování tím, že zkontrolujete nastavení Logs: Enabled nebo nastavíte
databricks.logs.enablednatrue, jak je popsáno v Nastavení pro rozšíření Databricks IDE. Po zapnutí logování nezapomeňte restartovat Visual Studio Code. - Pokuste se reprodukovat váš problém.
- Z Palety příkazů (Zobrazit > Paleta příkazů z hlavní nabídky) spusťte příkaz Databricks: Open full logs.
- Odešlete soubory
Databricks Logs.log,databricks-cli-logs.jsonasdk-and-extension-logs.json, které se zobrazí, podpoře Databricks. - Zkopírujte také obsah terminálu (Zobrazení > Terminál) v souvislosti s daným problémem a odešlete tento obsah podpoře Databricks.
Zobrazení výstupu (Zobrazení > Výstup, protokoly Databricks) zobrazují zkrácené informace, pokud protokoly: Je zaškrtnuté povolené nebo je databricks.logs.enabled nastavena na true. Pro více informací změňte následující nastavení, jak je popsáno v Nastavení pro rozšíření Databricks IDE:
-
Protokoly: Pole: maximální délka nebo
databricks.logs.maxArrayLength -
Protokoly: Maximální délka pole nebo
databricks.logs.maxFieldLength -
Protokoly: Hloubka zkrácení nebo
databricks.logs.truncationDepth