Rychlý start: Vytvoření prvního toku dat pro získání a transformaci dat

Datové toky jsou samoobslužná cloudová technologie pro přípravu dat. V tomto článku vytvoříte první tok dat, získáte data pro tok dat a pak data transformujete a publikujete tok dat.

Požadavky

Před spuštěním jsou vyžadovány následující požadavky:

Vytvoření toku dat

V této části vytváříte svůj první tok dat.

Poznámka:

Od dubna 2026 se všechny nové položky Dataflow Gen2 vytvářejí s podporou integrace CI/CD a Gitu ve výchozím nastavení. Možnost vytvářet položky Toku dat Gen2 bez podpory CI/CD už není dostupná. Stávající toky dat bez CI/CD nadále fungují.

  1. Přejděte do pracovního prostoru Microsoft Fabric tak, že přejdete na portál Microsoft Fabric, v levém navigačním podokně vyberte Workspaces a pak v seznamu vyberte pracovní prostor.

  2. Vyberte +Nová položka a pak vyberte Dataflow Gen2.

    Snímek obrazovky se zvýrazněným výběrem Dataflow Gen2

Získat data

Pojďme získat nějaká data. V tomto příkladu získáváte data ze služby OData. K získání dat do toku dat použijte následující postup.

  1. V editoru toku dat vyberte Získat data a pak vyberte Další.

    Snímek obrazovky s vybranou možností Získat data a zvýrazněnou možností Další v rozevíracím seznamu

  2. Ve výběru zdroje dat vyberte Zobrazit více.

    Snímek obrazovky s možností Získat zdroj dat se zvýrazněným zobrazením

  3. V Novém zdroji vyberte Jiný>OData jako zdroj dat.

    Snímek obrazovky s kategorií Ostatní a zvýrazněným konektorem OData u možnosti Získat zdroj dat.

  4. Zadejte adresu URL https://services.odata.org/v4/northwind/northwind.svc/a pak vyberte Další.

    Snímek obrazovky se zdrojem dat OData, kde zadáte adresu URL dat

  5. Vyberte tabulky Objednávky a Zákazníci a pak vyberte Vytvořit.

    Snímek obrazovky navigátoru Power Query s tabulkami Zákazníci a Objednávky zvýrazněnými.

Další informace o zkušenostech a funkcionalitě získávání dat najdete v přehledu získávání dat.

Použijte transformace a publikujte

Do prvního toku dat jste načetli svá data. Blahopřejeme! Teď je čas použít několik transformací, které přenesou tato data do obrazce, který potřebujeme.

Transformujete data v editoru Power Query. Podrobný přehled editoru Power Query najdete v části Uživatelské rozhraní Power Query, ale tato sekce vás provede základními kroky:

  1. Ujistěte se, že jsou zapnuté nástroje pro profilaci dat . Přejděte na Home>Options>Global Options, a pak vyberte všechny možnosti v Profil sloupce.

    Snímek obrazovky s globálními možnostmi se zvýrazněnými možnostmi profilu sloupce

    Nezapomeňte také povolit zobrazení diagram pomocí konfigurací rozložení pod kartou View na pásu karet editoru Power Query nebo výběrem ikony zobrazení diagramu v pravém dolním rohu okna Power Query.

    Screenshot celkového vzhledu zobrazení diagramu Power Query.

  2. V tabulce Objednávky vypočítejte celkový počet objednávek na zákazníka: Vyberte sloupec CustomerID (ID zákazníka) v náhledu dat a pak na pásu karet ve kartě Transform vyberte možnost Group By (Seskupit podle).

    Snímek obrazovky znázorňující vybranou tabulku Objednávky a možnost Seskupení podle, zvýrazněnou na kartě Transformace.

  3. V rámci skupina podle provedete agregaci, která spočívá ve sčítání řádků. Další informace o možnostech Seskupit podle najdete v tématu Seskupování nebo shrnutí řádků.

    Snímek obrazovky s vybranou operací Seskupování podle a vybranou operací Počet řádků

  4. Po seskupení dat v tabulce Objednávky získáme tabulku se dvěma sloupci s ID zákazníka a Počet jako sloupce.

    Snímek obrazovky se dvěma sloupci tabulky

  5. Dále zkombinujte data z tabulky "Zákazníci" s počtem objednávek na jednoho zákazníka: Vyberte dotaz "Zákazníci" v zobrazení diagramu a pomocí nabídky "⋮" otevřete transformaci Sloučit dotazy jako novou.

    Snímek obrazovky s editorem toku dat se svislou elipsou v tabulce Customers (Zákazníci) a se zvýrazněnou funkcí sloučení dotazů jako nových

  6. Nakonfigurujte operaci sloučení tak, že jako odpovídající sloupec v obou tabulkách vyberete CUSTOMERID . Potom vyberte OK.

    Snímek obrazovky okna Sloučit

    Snímek obrazovky s oknem Sloučit, kde je levá tabulka pro sloučení nastavena na tabulku Zákazníci (Customers) a pravá tabulka je nastavena na tabulku Objednávky (Orders). Sloupec CustomerID (ID zákazníka) je vybraný pro tabulky Customers (Zákazníci) i Orders (Objednávky). Typ spojení je také nastaven na levý vnější. Všechny ostatní výběry jsou nastavené na výchozí hodnotu.

  7. Teď je nový dotaz se všemi sloupci z tabulky Zákazníci a jedním sloupcem s vnořenými daty z tabulky Objednávky.

    Snímek obrazovky s editorem toku dat s novým dotazem sloučení přidaným napravo od tabulek Zákazníci a Objednávky

  8. Pojďme se zaměřit na několik sloupců z tabulky Zákazníci. Pokud to chcete udělat, zapněte zobrazení schématu výběrem tlačítka zobrazení schématu v pravém dolním rohu editoru toku dat.

    Snímek obrazovky editoru toku dat se zvýrazněným tlačítkem zobrazení schématu v pravém dolním rohu

  9. V zobrazení schématu uvidíte všechny sloupce v tabulce. Vyberte CustomerID, CompanyName a Orders (2). Pak přejděte na kartu Nástroje schématu , vyberte Odebrat sloupce a zvolte Odebrat další sloupce. Tím se zachová jenom požadované sloupce.

    Snímek obrazovky se zobrazením schématu zobrazující všechny dostupné názvy sloupců se zvýrazněnými sloupci CustomerID, CompanyName a Orders (2).

    Snímek obrazovky nabídky Nástrojů schématu se zvýrazněnou možností Odstranit ostatní sloupce

  10. Sloupec Objednávky (2) obsahuje další podrobnosti z kroku sloučení. Chcete-li zobrazit a použít tato data, vyberte tlačítko Zobrazit zobrazení dat v pravém dolním rohu vedle zobrazení schématu. Potom v záhlaví sloupce Objednávky (2) vyberte ikonu Rozbalit sloupec a vyberte sloupec Počet . Tím se do tabulky přidá počet objednávek pro každého zákazníka.

    Snímek obrazovky pro použití zobrazení dat

  11. Teď seřadím zákazníky podle počtu objednávek, které udělali. Vyberte sloupec Počet, poté přejděte na kartu Přidat sloupec a vyberte sloupec Pořadí. Tím se přidá nový sloupec zobrazující pořadí jednotlivých zákazníků na základě jejich počtu objednávek.

    Snímek obrazovky s editorem toku dat s vybraným sloupcem Počet

  12. Ponechte výchozí nastavení ve sloupci pořadí. Potom tuto transformaci použijte výběrem tlačítka OK .

    Snímek obrazovky okna Pořadí se zobrazenými všemi výchozími nastaveními

  13. Teď přejmenujte výsledný dotaz jako Ohodnocení zákazníci pomocí Podokno nastavení dotazu na pravé straně obrazovky.

    Snímek obrazovky s editorem toku dat, se zvýrazněným názvem

  14. Jste připraveni nastavit, kam se vaše data budou odesílána. V podokně Nastavení dotazu se posuňte dolů a vyberte Vybrat cíl dat.

    Snímek obrazovky s editorem toku dat se zvýrazněným umístěním výběru cíle dat

  15. Pokud nějaký máte, můžete výsledky odeslat do jezera nebo tento krok přeskočit, pokud ne. Tady můžete vybrat, které jezero a tabulku použít pro vaše data, a zvolit, jestli chcete přidat nová data (připojit) nebo nahradit obsah (Nahradit).

    Snímek obrazovky s oknem Připojení k cíli dat a vybranou možností Lakehouse

    Snímek obrazovky s oknem Zvolit nastavení cíle

  16. Váš tok dat je teď připravený k publikování. Zkontrolujte dotazy v zobrazení diagramu a pak vyberte Publikovat.

    Snímek obrazovky editoru toku dat se zvýrazněným tlačítkem Publikovat na pravé dolní straně

    Výběrem možnosti Publikovat v pravém dolním rohu tok dat uložte. Vrátíte se do pracovního prostoru, kde se vedle názvu vašeho toku dat zobrazuje rotační ikona, která ukazuje, že probíhá publikování. Když ukazatel načítání zmizí, je tok dat připraven k aktualizaci.

    Důležité

    Při prvním vytvoření toku dat Gen2 v pracovním prostoru Fabric nastaví některé položky na pozadí (Lakehouse a Warehouse), které vám pomůžou spustit tok dat. Tyto položky sdílí všechny toky dat v pracovním prostoru a neměli byste je odstraňovat. Nejsou určené k přímému použití a obvykle nejsou ve vašem pracovním prostoru viditelné, ale můžete je vidět na jiných místech, jako jsou poznámkové bloky nebo analýzy SQL. Hledejte jména, která začínají na DataflowStaging, aby je našli.

  17. V pracovním prostoru vyberte ikonu Naplánovat aktualizaci .

    Snímek obrazovky pracovního prostoru se zvýrazněnou ikonou aktualizace plánu

  18. Zapněte plánovanou aktualizaci, vyberte Přidat jiný čas a nakonfigurujte aktualizaci, jak je znázorněno na následujícím snímku obrazovky.

    Snímek obrazovky znázorňující, jak vybrat jiný čas

    Snímek obrazovky s možnostmi plánované aktualizace se zapnutou plánovanou aktualizací, frekvencí aktualizace nastavenou na Denní, časovým pásmem nastaveným na koordinovaný univerzální čas a časem nastaveným na 4:00 Tlačítko Zapnout, Přidat další výběr času, vlastník datového toku a tlačítko Použít jsou zvýrazněny.

Uvolnění prostředků

Pokud nebudete tento tok dat dál používat, odstraňte tok dat pomocí následujícího postupu:

  1. Přejděte do svého pracovního prostoru Microsoft Fabric.

  2. Vyberte svislé tři tečky vedle názvu toku dat a pak vyberte Odstranit.

    Snímek obrazovky se třemi svislými tečkami a možností odstranění v rozevírací nabídce zvýrazněnou

  3. Výběrem možnosti Odstranit potvrďte odstranění toku dat.

    Snímek obrazovky s oknem Odstranit tok dat se zvýrazněným tlačítkem Odstranit

Tok dat v této ukázce ukazuje, jak načíst a transformovat data v toku dat Gen2. Naučili jste se:

  • Vytvořte tok dat Gen2.
  • Transformujte data.
  • Nakonfigurujte nastavení cíle pro transformovaná data.
  • Spusť a naplánovat datový tok.

V dalším článku se dozvíte, jak vytvořit první kanál.