Transformace dat pomocí Power Query

S Power Query se můžete připojit k mnoha různým zdrojům dat a transformovat je na požadovaný obrazec.

V tomto článku se dozvíte, jak vytvářet dotazy pomocí Power Query zjišťováním:

  • Jak funguje funkce Získat data v Power Query
  • Jak používat a využívat Power Query uživatelské rozhraní.
  • Jak provádět běžné transformace, jako je seskupení a slučování dat.

Pokud jste v Power Query noví, můžete se přihlásit k bezplatné zkušební verzi Power BI před zahájením. K vyzkoušení funkcí Power Query Online popsaných v tomto článku můžete použít datové toky Power BI.

Můžete také stáhnout Power BI Desktop zdarma.

Příklady v tomto článku se připojují k informačnímu kanálu OData Northwind a používají.

Připojení k datovému kanálu OData

Poznámka

Další informace o tom, kde získat data z jednotlivých produktů Microsoft, které obsahují Power Query, najdete v části Kdy získat data.

Nejprve vyhledejte konektor informačního kanálu OData v prostředí Získat data. V panelu hledání v pravém horním rohu můžete vyhledat OData.

Snímek obrazovky se stránkou Vybrat zdroj dat v okně Získat data se zvýrazněným konektorem OData

Po výběru tohoto konektoru se na obrazovce zobrazí nastavení připojení a přihlašovací údaje.

  • Jako adresu URL zadejte adresu URL datového kanálu OData Northwind: https://services.odata.org/V4/Northwind/Northwind.svc/.
  • Pro místní bránu datponechte jako žádnou.
  • Pro druh ověřováníponechte anonymně.

Vyberte tlačítko Další.

Otevře se Navigátor, kde vyberete tabulky, ke které se chcete připojit ze zdroje dat. Výběrem tabulky Zákazníci načtěte náhled dat a pak vyberte Transformovat data.

Screenshot stránky Power Query Navigator se zvýrazněnou tabulkou Customers (Zákazníci).

Dialogové okno pak načte data z tabulky Zákazníci do editoru Power Query.

Zkušenost připojení k vašim datům, určení metody ověřování a výběr konkrétního objektu nebo tabulky pro připojení se nazývá zkušenost získávání dat. Toto zkušenost je zdokumentována s podrobnostmi v článku Přehled získávání dat.

Poznámka

Další informace o konektoru OData najdete v datovém kanálu OData.

Součásti editoru Power Query

Návod

Pokud chcete najít editor Power Query v Power BI, v části Dotazy vyberte Transform data.

Snímek obrazovky domovské lišty v Power BI se zvýrazněným tlačítkem Transformovat data.

Editor Power Query představuje uživatelské rozhraní Power Query. V tomto uživatelském rozhraní můžete přidávat nebo upravovat dotazy, spravovat dotazy seskupením nebo přidáním popisů kroků dotazu nebo vizualizací dotazů a jejich struktury s různými zobrazeními. Uživatelské rozhraní Power Query má pět různých komponent. Čísla v následující tabulce odpovídají očíslovaným popiskům na snímku obrazovky.

Screenshot uživatelského rozhraní Power Query s jednotlivými komponentami označenými a číslovanými.

# Součást Description
1 Stuha Navigační prostředí pásu karet, které nabízí více karet pro přidání transformací, výběr možností dotazu a přístup k různým tlačítkům pásu karet pro dokončení různých úkolů.
2 Podokno dotazů Zobrazení všech dostupných dotazů
3 Aktuální zobrazení Hlavní pracovní zobrazení, které ve výchozím nastavení zobrazuje náhled dat pro váš dotaz. Můžete také povolit zobrazení diagramu spolu se zobrazením náhledu dat. Při údržbě zobrazení diagramu můžete také přepínat mezi zobrazením schématu a zobrazením náhledu dat.
4 Nastavení dotazů Zobrazení aktuálně vybraného dotazu s relevantními informacemi, jako je název dotazu, kroky dotazu a různé indikátory.
5 Stavový řádek Pruh zobrazující relevantní důležité informace o dotazu, jako je doba provádění, celkový počet sloupců a řádků a stav zpracování Tento panel obsahuje také tlačítka pro změnu aktuálního zobrazení.

Poznámka

Schéma a zobrazení diagramu jsou aktuálně k dispozici pouze v Power Query Online.

Před transformací dat v editoru Power Query vám pomůže zjistit, jak rozbalit nebo sbalit podokna uživatelského rozhraní a přepínat mezi zobrazeními. Výběr příslušných podoken vám umožní zaměřit se na zobrazení, které je pro vás nejdůležitější. Následující části zahrnují podokna a zobrazení dostupná v uživatelském rozhraní Power Query.

Pás karet v editoru Power Query

Pás karet je komponenta, ve které najdete většinu transformací a akcí, které lze v editoru Power Query provádět. Má několik karet, jejichž hodnoty závisí na integraci produktu. Každá karta nabízí konkrétní tlačítka a možnosti, z nichž některé můžou být v celém prostředí Power Query redundantní. Tato tlačítka a možnosti poskytují snadný přístup k transformacím a akcím, které možná budete potřebovat.

Snímek obrazovky standardního zobrazení pásu karet na kartě Domů uživatelského rozhraní Power Query.

Rozhraní Power Query je responzivní a snaží se upravit rozlišení obrazovky, aby vám ukázalo nejlepší prostředí. Ve scénářích, ve kterých chcete použít kompaktní verzi pásu karet, je v pravém dolním rohu pásu karet také tlačítko sbalit, které vám pomůže přepnout na kompaktní pás karet.

Screenshot kompaktního zobrazení pásu karet na Power Query kartě Domů uživatelského rozhraní.

Na standardní zobrazení pásu karet můžete přepnout tím, že vyberete ikonu rozšíření v pravém dolním rohu pásu karet.

Rozbalit a sbalit panely Power Query

Možná si všimnete, že v uživatelském rozhraní Power Query jsou ikony, které vám pomůžou sbalit nebo rozbalit určitá zobrazení nebo oddíly. V pravém horním rohu podokna Dotazy je například ikona, která po výběru sbalí toto podokno a při opětovném výběru ho rozbalí.

snímek obrazovky s zvýrazněním ikony v podokně Dotazy, které slouží ke sbalení a rozbalení podokna dotazů

Přepínání mezi zobrazeními Power Query

Kromě možnosti sbalit určitá podokna a oddíly v uživatelském rozhraní Power Query můžete také přepínat zobrazení. Pokud chcete přepnout zobrazení, přejděte na kartu View na pásu karet, kde najdete skupiny Preview a Layout, které řídí vzhled uživatelského rozhraní Power Query.

Doporučujeme vyzkoušet všechny tyto možnosti, abyste našli zobrazení a rozložení, se kterým budete pracovat nejlépe. Jako příklad vyberte zobrazení schématu na pásu karet.

Snímek obrazovky zdůrazňující tlačítko zobrazení schématu, které se nachází na kartě Zobrazení ve stuze Power Query.

Pravá strana stavového řádku obsahuje také ikony pro zobrazení diagramu, dat a schématu. Tyto ikony můžete použít ke změně mezi zobrazeními. Tyto ikony můžete také použít k povolení nebo zakázání zobrazení podle vašeho výběru.

snímek obrazovky se sbaleným podoknem dotazů a aktuálním zobrazením přepnutým na zobrazení schématu se zvýrazněnou ikonou zobrazení schématu.

Co je zobrazení schématu v Power Query

Zobrazení schématu nabízí rychlý a jednoduchý způsob interakce pouze s komponentami schématu pro vaši tabulku, jako jsou názvy sloupců a datové typy. Zobrazení schématu doporučujeme, když chcete provádět akce související se schématem. Tyto akce můžou odebírat sloupce, přejmenovávat sloupce, měnit datové typy sloupců, měnit pořadí sloupců nebo duplikovat sloupce.

Poznámka

Další informace o zobrazení schématu najdete v tématu Použití zobrazení schématu.

Například v zobrazení schématu zaškrtněte políčko vedle Objednávky a CustomerDemographics, a na pásu karet vyberte akci Odebrat sloupce. Tento výběr použije transformaci pro odebrání těchto sloupců z vašich dat.

snímek obrazovky s vybranými sloupci Objednávky a DemografieZákazníků a zvýrazněnou možností odebrat sloupce

Co je zobrazení diagramu v Power Query

Teď můžete přepnout zpět do zobrazení náhledu dat a povolit zobrazení diagramu, aby používalo více vizuální perspektivy dat a dotazů.

Snímek obrazovky s zvýrazněním ikon zobrazení diagramu a zobrazení náhledu dat

Zobrazení diagramu vám pomůže vizualizovat strukturu dotazu a způsob interakce s dalšími dotazy v projektu. Každý krok v dotazu má jedinečnou ikonu, která vám pomůže rozpoznat použitou transformaci. Řádky propojují kroky pro ilustraci závislostí. Vzhledem k tomu, že je povolené zobrazení náhledu dat i zobrazení diagramu, zobrazí se zobrazení diagramu nad náhledem dat.

Screenshot pracovního prostoru Power Query zobrazující zobrazení diagramu s náhledem dat.

Poznámka

Další informace o zobrazení diagramu najdete v části Diagram view.

Seskupení zákazníků podle země nebo oblasti v zobrazení diagramu

Chcete-li spočítat zákazníky podle země/oblasti, přidejte transformaci Seskupit podle. Pokud je zobrazení diagramu povolené, vyberte znaménko plus. Můžete vyhledat novou transformaci, kterou chcete přidat do dotazu. Vyhledejte Seskupování podle a vyberte transformaci.

Snímek obrazovky s hledáním skupiny podle zobrazení diagramu

Objeví se dialogové okno Skupina podle. Operaci Seskupit podle můžete nastavit tak, aby seskupila podle země/oblasti a spočítala počet řádků zákazníků pro každou zemi/oblast.

  1. Ponechte přepínač Basic vybraný.
  2. Vyberte Zemi nebo oblast , podle které chcete seskupit.
  3. Jako název nového sloupce zadejte Customers a jako operaci vyberte Count rows.

Snímek obrazovky se základním dialogem Skupina se zadanými daty zákazníků

Chcete-li provést operaci, vyberte OK. Náhled dat se aktualizuje, aby zobrazoval celkový počet zákazníků podle země nebo oblasti.

Alternativní způsob, jak spustit dialogové okno Seskupit podle , je použít tlačítko Seskupit podle na pásu karet nebo vybrat a podržet (pravým tlačítkem myši) sloupec Země/oblast .

Snímek obrazovky s zvýrazněním tlačítka Seskupit podle na pásu karet a možností Seskupit podle v nabídce sloupce země/oblasti

Pro pohodlí lze k transformacím v Power Query často přistupovat z několika míst, takže si uživatelé mohou vybrat prostředí, které preferují.

Přidání nového dotazu

Teď, když máte dotaz, který poskytuje počet zákazníků na zemi nebo oblast, můžete k datům přidat kontext vyhledáním celkového počtu dodavatelů pro každou zemi nebo oblast.

Nejprve je potřeba přidat data Suppliers. Vyberte Získat data. V Zvolte zdroj dat, vyhledejte OData. Pak vyberte konektor OData.

Snímek obrazovky se stránkou Zvolit zdroj dat se zvýrazněným konektorem OData

Znovu se zobrazí prostředí připojení OData. Zadejte nastavení připojení, jak je popsáno v Připojit k datovému kanálu OData pro připojení k datovému kanálu OData Northwind. V navigátoru vyhledejte tabulku Dodavatelé a vyberte ji.

Návigátor Power Query s vybranými dodavateli Northwind OData.

Vyberte Create a přidejte nový dotaz do editoru Power Query. Rozbalte podokno Dotazy , které teď zobrazuje dotaz Zákazníci i Dodavatelé .

snímek obrazovky s podoknem Dotazy s důrazem na dotazy zákazníků i dodavatelů

Znovu otevřete dialogové okno Seskupovat podle, tentokrát výběrem tlačítka Seskupovat podle na pásu karet pod kartou Transformace .

Snímek obrazovky s částí pásu karet Karty Transformace se zvýrazněnou možností Seskupování

V dialogovém okně Seskupit podle nastavte operaci Seskupit podle země/oblasti a spočítejte počet řádků dodavatele na zemi/oblast.

  1. Ponechte přepínač Basic vybraný.
  2. Vyberte Zemi nebo oblast , podle které chcete seskupit.
  3. Vložte Suppliers do Název nového sloupce a v Operationvyberte Count rows.

Snímek obrazovky s dialogovým oknem Základní skupina se zadanými údaji dodavatelů

Poznámka

Další informace o transformaci skupiny pomocí najdete v tématu Skupinové nebo souhrnné řádky .

Referenční dotazy

Když odkazujete na dotaz, vytvoříte nový dotaz, který odkazuje na výstup existujícího dotazu. Teď, když máte dotaz pro zákazníky a dotaz na dodavatele, je vaším dalším cílem zkombinovat je do jednoho. K dosažení tohoto cíle můžete použít mnoho metod, včetně možnosti Sloučit v tabulce Zákazníci , duplikování dotazu nebo odkazování na dotaz. V tomto příkladu vytvořte odkaz tak, že vyberete a podržíte (kliknete pravým tlačítkem) na tabulku Zákazníci a vyberete Odkaz. Tato akce vytvoří nový dotaz, který odkazuje na dotaz Zákazníci .

Snímek obrazovky nabídky Zákazníci se zvýrazněnou možností Reference

Po vytvoření tohoto nového dotazu změňte název dotazu na Analýzu země/oblasti a zakažte načtení tabulky Zákazníci zrušením zaškrtnutí políčka Povolit načtení z dotazu Dodavatelé .

snímek obrazovky, kde se název třetího dotazu změnil na Country Analysis (Analýza země) a možnost načtení dodavatelů není zaškrtnuta a je zvýrazněná.

Sloučit dotazy

Operace slučování dotazů spojuje dvě existující tabulky v rámci podle odpovídajících hodnot z jednoho nebo více sloupců. V tomto příkladu je cílem spojit tabulky Customers a Suppliers do jedné tabulky pouze pro země/oblasti, které mají jak Zákazníci, tak i Dodavatelé.

V dotazu Analýza země/oblasti vyberte na kartě Domů na pásu karet možnost Sloučit dotazy.

Snímek obrazovky pracovního prostoru Power Query s vybraným dotazem pro analýzu země/oblasti a zvýrazněnou možností Sloučit dotazy na kartě Domů

Zobrazí se nové dialogové okno pro operaci sloučení. Pak můžete vybrat dotaz, který chcete sloučit s aktuálním dotazem. V pravé tabulce pro sloučení vyberte dotaz Dodavatelé a pak v obou dotazech vyberte pole Země/oblast . Nakonec vyberte typ připojení Inner, protože pro tuto analýzu chcete jenom země/oblasti, ve kterých máte zákazníky a dodavatele .

Snímek obrazovky s dialogovým oknem Sloučit dotazy se sloupcem země/oblasti vybraným v dotazech a vybraném typu Vnitřní spojení

Po výběru tlačítka OK se do dotazu Analýza země/oblasti přidá nový sloupec, který obsahuje data z dotazu Dodavatelé . Vyberte ikonu vedle pole Dodavatelé , která zobrazuje nabídku, ve které můžete vybrat pole, která chcete rozbalit. Vyberte pouze pole Dodavatelé a pak vyberte tlačítko OK.

Snímek obrazovky se sloupcem Dodavatelé, kde je otevřena nabídka a vybraná pouze možnost Dodavatelé

Výsledkem této operace rozbalení je tabulka s pouze 12 řádky. Přejmenujte pole Suppliers.1 na Suppliers tak, že dvakrát kliknete na název pole a zadáte nový název.

Snímek obrazovky s přejmenovaným sloupcem Dodavatelé

Poznámka

Další informace o funkci Sloučení dotazů najdete v přehledu Sloučení dotazů.

Použitý postup

Každá transformace použitá pro váš dotaz se uloží jako krok v Použitý postup části podokna nastavení dotazu. Pokud někdy potřebujete zkontrolovat, jak je váš dotaz transformován z kroku na krok, můžete vybrat krok a zobrazit náhled toho, jak se váš dotaz v daném okamžiku vyřeší.

Můžete také vybrat a podržet dotaz (kliknout pravým tlačítkem) a vybrat možnost Vlastnosti změnit název dotazu nebo přidat popis dotazu. Vyberte například krok Sloučit dotazy z dotazu Analýza země/oblasti, podržte ho (klikněte pravým tlačítkem myši) a změňte název dotazu na Sloučení s dodavateli a jeho popis na Načítání dat z dotazu Dodavatelé pro Dodavatele podle země/oblasti.

Snímek obrazovky s dialogovým oknem Vlastnosti kroku se změněným názvem a vyplněným popisem

Po této změně můžete najet myší na ikonu sloučit dotaz v zobrazení diagramu nebo najet myší na novou ikonu vedle kroku v podokně Použitý postup a přečíst si jeho popis.

Snímek obrazovky znázorňující, kam najet myší pro zobrazení vlastností kroku.

Poznámka

Další informace o Použitých krocíchnaleznete v části Použití seznamu použitých kroků.

Než přidáte nový sloupec, zakažte zobrazení diagramu tak, aby používalo jenom náhled dat.

Přidání nového sloupce

Můžete přidat nový sloupec počítaný z existujících sloupců. S daty pro zákazníky a dodavatele v jedné tabulce teď můžete vypočítat poměr zákazníků k dodavateli pro každou zemi/oblast. Vyberte poslední krok dotazu Analýza země/oblasti a pak vyberte sloupce Zákazníci i Dodavatelé . Na kartě Přidat sloupec na pásu karet a ve skupině Z čísla vyberte v rozevíracím seznamu možnost Standardní a potom Dělit (celé číslo).

Screenshot pracovního prostoru Power Query s kartou Přidat sloupec a vybranou možností Standard a zvýrazněnou možností Dělit (celé číslo).

Tato změna vytvoří nový sloupec s názvem Celočíselné dělení, který můžete přejmenovat na Poměr. Tato změna je posledním krokem dotazu a poskytuje poměr zákazníků k dodavatelům pro země/oblasti, ve kterých data mají zákazníky a dodavatele.

Profilace dat

Profilace dat je funkce Power Query, která vám pomůže lépe porozumět vašim datům. Povolením funkcí profilace dat získáte zpětnou vazbu k datům v polích dotazu, jako je distribuce hodnot, kvalita sloupců a další.

Tuto funkci můžete použít při vývoji dotazů. Tuto funkci můžete povolit a zakázat podle svých možností. Následující obrázek ukazuje všechny nástroje pro profilaci dat povolené pro dotaz analýzy země/oblasti .

Snímek obrazovky s informacemi o profilaci dat s podrobnostmi pro sloupec Poměr v dolní části

Poznámka

Další informace o profilaci datnajdete v tématu Použití nástrojů pro profilaci dat.

Rozšířený editor

Pokud chcete sledovat kód, který editor Power Query vytváří s každým krokem, nebo chcete vytvořit vlastní tvarovací kód, můžete použít rozšířený editor. Pokud chcete otevřít advanced editor, vyberte na pásu karet kartu View a pak vyberte Rozšířený editor. Zobrazí se okno s existujícím kódem dotazu.

snímek obrazovky s rozšířeným editorem, který obsahuje kód bez chyb syntaxe

Kód můžete přímo upravit v okně Rozšířený editor. Editor indikuje, jestli váš kód nemá chyby syntaxe. Okno zavřete tak, že vyberete tlačítko Hotovo nebo Zrušit.

Nápověda k Power Query Accessu

V aplikacích Microsoft, které používají Power Query, jsou k dispozici různé úrovně nápovědy. Tato část popisuje tyto úrovně nápovědy.

Nápověda pro Power Query v Excelu

Existuje několik způsobů, jak získat přístup k informacím nápovědy Power Query, které se konkrétně týkají Power Query v Excel. Jedním ze způsobů, jak získat přístup k dokumentaci k online Excel Power Query, je vybrat Soubor>Help>Help v editoru Power Query.

Pokud chcete získat přístup k informacím nápovědy Power Query vestavěné funkce v Excelu, vyberte na pásu karet Excel kartu Help a do vyhledávacího textového pole zadejte Power Query.

nápověda k Power Query v desktopové verzi Power BI

V editoru Power Query, který běží na Power BI Desktopu, je karta Help, ale v tuto chvíli všechny možnosti přejdou na umístění, která poskytují informace o Power BI. Tyto stejné informace nápovědy Power BI v editoru Power Query v Power BI Desktopu můžete také otevřít tak, že vyberete Soubor>, a pak vyberete některou z dostupných možností nápovědy.

Nápověda k Power Query v služba Power BI, Power Apps, Dynamics 365 Customer Insights a v Azure Data Factory

Karta Power Query Help v služba Power BI, Power Apps, Dynamics 365 Customer Insights a Azure Data Factory obsahuje odkazy na důležité zdroje informací o Power Query.

Screenshot karty nápovědy s dokumentací Power Query a se zobrazenými možnostmi nápovědy, komunity a zpětné vazby.

Mezi možnosti na kartě nápovědy patří odkazy na:

  • Power Query dokumentaci: Odkazy na dokumentaci k Power Query
  • Klávesové zkratky: Odkazy na článek klávesové zkratky v dokumentaci Power Query.
  • Support: Odkazuje na web podpory produktu Microsoft, ve kterém je aktuálně spuštěný Power Query.
  • Webové stránky Power Query: Odkazy na webové stránky Power Query.
  • Power Query blog: Odkazy na Power Query blog
  • Power Query komunita: Odkazy na komunitu Power Query.
  • Předložte nápad: Odkazuje na webovou stránku idejí produktu Microsoft, ve kterém právě běží Power Query.
  • Send feedback: Otevře se okno v Power Query. Okno vás vyzve k hodnocení vašich zkušeností s Power Query a poskytnutí dalších informací, které chcete poskytnout.

Poznámka

V současné době Azure Analysis Services neobsahuje žádné vložené odkazy na nápovědu Power Query. Můžete ale získat nápovědu pro funkce Power Query M. Další informace najdete v další části.

Nápověda k funkcím Power Query M

Kromě funkcí nápovědy Power Query uvedených v předchozích částech můžete také získat nápovědu pro jednotlivé funkce jazyka M v editoru Power Query. Postup se mírně liší v závislosti na používané verzi: Power Query Desktop (integrované do aplikací, jako je Power BI Desktop) nebo Power Query Online (integrované do služeb, jako jsou služba Power BI a toky dat). Následující kroky popisují, jak se k této vložené nápovědě dostat.

  1. V otevřeném editoru Power Query vyberte tlačítko vložení kroku ().
  2. Do řádku vzorců zadejte název funkce, kterou chcete zkontrolovat.
    1. Pokud používáte Power Query Desktop, zadejte rovnítko, mezeru a název funkce.
    2. Pokud používáte Power Query Online, zadejte název funkce.
  3. Vyberte vlastnosti funkce.
    1. Pokud používáte Power Query Desktop, v podokně Nastavení dotazu v části Properties vyberte Všechny vlastnosti.
    2. Pokud používáte Power Query Online, v podokně Nastavení dotazu vyberte Properties.

Tyto kroky otevřou vložené informace nápovědy pro vybranou funkci a umožňují zadat jednotlivé vlastnosti používané funkcí.

snímek obrazovky s popisem a syntaxí funkce Date.AddDays M a vstupními body pro každý z parametrů funkce

Shrnutí

V tomto článku jste vytvořili řadu dotazů s Power Query, které poskytují analýzu poměru mezi zákazníky na úrovni země/oblasti pro společnost Northwind.

Seznámili jste se s komponentami uživatelského rozhraní Power Query, jak vytvářet nové dotazy v editoru dotazů, odkazovat dotazy, sloučit dotazy, porozumět části Použitý postup a přidat nové sloupce. Dozvěděli jste se také, jak pomocí nástrojů pro profilaci dat lépe porozumět datům.

Power Query je výkonný nástroj, který slouží k připojení k mnoha různým zdrojům dat a transformaci dat do požadovaného tvaru. Scénáře popsané v tomto článku jsou příklady, které vám ukážou, jak můžete pomocí Power Query transformovat nezpracovaná data do důležitých obchodních přehledů.