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Gilt für: ✔️ Windows-VMs
Dieser Artikel enthält Schritte zum Beheben von Problemen, bei denen der Windows-Start-Manager das Starten eines virtuellen Azure-Computers (VM) verhindert.
Symptom
Der virtuelle Computer wartet auf eine Benutzereingabeaufforderung und wird erst gestartet, wenn er manuell dazu angewiesen wird.
Wenn Sie Startdiagnose verwenden, um den Screenshot der VM anzuzeigen, sehen Sie, dass im Screenshot der Windows-Start-Manager mit der Meldung Wählen Sie ein Betriebssystem aus, um zu starten, oder drücken Sie die TAB-TASTE, um ein Tool auszuwählen angezeigt wird.
Ursache
Der Fehler ist auf das BCD-Flag displaybootmenu im Windows-Start-Manager zurückzuführen. Wenn das Flag aktiviert ist, wird der Benutzer während des Startvorgangs vom Windows-Start-Manager aufgefordert, das auszuführende Ladeprogramm auszuwählen, was zu einer Startverzögerung führt. In Azure kann dieses Feature die Startzeit eines virtuellen Computers verlängern.
Lösung
Tipp
Wenn Sie über eine aktuelle Sicherung der VM verfügen, können Sie versuchen, die VM aus der Sicherung wiederherzustellen, um das Startproblem zu beheben.
Prozessübersicht:
- Konfigurieren Sie mithilfe der seriellen Konsole eine kürzere Startzeit.
- Erstellen Sie eine Reparatur-VM, und greifen Sie darauf zu.
- Konfigurieren Sie eine kürzere Startzeit auf einer Reparatur-VM.
- Empfohlen: Aktivieren der seriellen Konsole und der Speicherabbildsammlung vor der Neuerstellung der VM.
- Erstellen Sie den virtuellen Computer neu.
Konfigurieren Sie mithilfe der seriellen Konsole eine kürzere Startzeit.
Wenn Sie Zugriff auf die serielle Konsole haben, gibt es zwei Möglichkeiten, kürzere Startzeiten zu erzielen. Verringern Sie entweder die displaybootmenu-Wartezeit, oder entfernen Sie das Flag vollständig.
Befolgen Sie die Anweisungen für den Zugriff auf die serielle Azure-Konsole für Windows, um Zugriff auf die textbasierte Konsole zu erhalten.
Notiz
Wenn Sie nicht auf die serielle Konsole zugreifen können, fahren Sie mit Erstellen einer Reparatur-VM und Zugriff darauf fort.
Option A: Verkürzen der Wartezeit
a. Die Wartezeit ist standardmäßig auf 30 Sekunden festgelegt, kann jedoch verkürzt werden (z. B. auf 5 Sekunden).
b. Verwenden Sie den folgenden Befehl in der seriellen Konsole, um den Timeoutwert anzupassen:
bcdedit /set {bootmgr} timeout 5
Option B: Entfernen des BCD-Flags
a. Geben Sie den folgenden Befehl ein, um zu verhindern, dass die Aufforderung „Startmenü anzeigen“ angezeigt wird:
bcdedit /deletevalue {bootmgr} displaybootmenu
Notiz
Wenn Sie die serielle Konsole nicht verwenden konnten, um in den obigen Schritten eine kürzere Startzeit zu konfigurieren, können Sie stattdessen mit den folgenden Schritten fortfahren. Sie führen die Problembehandlung nun im Offlinemodus durch, um dieses Problem zu beheben.
Erstellen und Aufrufen einer Reparatur-VM
- Führen Sie die Schritte 1-3 der VM-Reparaturbefehle aus, um eine Reparatur-VM vorzubereiten.
- Stellen Sie über eine Remotedesktopverbindung eine Verbindung mit der Reparatur-VM her.
Konfigurieren einer kürzeren Startzeit auf einer Reparatur-VM
Öffnen Sie eine Eingabeaufforderung mit erhöhten Rechten.
Geben Sie Folgendes ein, um DisplayBootMenu zu aktivieren:
Verwenden Sie diesen Befehl für VMs der Generation 1:
bcdedit /store <VOLUME LETTER WHERE THE BCD FOLDER IS>:\boot\bcd /set {bootmgr} displaybootmenu yes
Verwenden Sie diesen Befehl für VMs der Generation 2:
bcdedit /store <VOLUME LETTER OF EFI SYSTEM PARTITION>:EFI\Microsoft\boot\bcd /set {bootmgr} displaybootmenu yes
Ersetzen Sie die Symbole „Größer als“ oder „Kleiner als“ und den darin enthaltenen Text, z. B. „< Text hier >“, durch die entsprechenden Angaben.
Legen Sie den Timeoutwert auf 5 Sekunden fest:
Verwenden Sie diesen Befehl für VMs der Generation 1:
bcdedit /store <VOLUME LETTER WHERE THE BCD FOLDER IS>:\boot\bcd /set {bootmgr} timeout 5
Verwenden Sie diesen Befehl für VMs der Generation 2:
bcdedit /store <VOLUME LETTER OF EFI SYSTEM PARTITION>:EFI\Microsoft\boot\bcd /set {bootmgr} timeout 5
Ersetzen Sie die Symbole „Größer als“ oder „Kleiner als“ und den darin enthaltenen Text, z. B. „< Text hier >“, durch die entsprechenden Angaben.
Empfohlen: Aktivieren der seriellen Konsole und der Speicherabbildsammlung vor der Neuerstellung der VM
Führen Sie die folgenden Schritte aus, um die Speicherabbildsammlung und die serielle Konsole zu aktivieren:
Öffnen Sie eine Eingabeaufforderungssitzung als Administrator.
Führen Sie die folgenden BCDEdit-Befehle mit den Optionen /ems und /emssettings aus:
Aktivieren Sie die serielle Konsole:
bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
Überprüfen Sie, ob der freie Speicherplatz auf dem Betriebssystemdatenträger größer als die Größe des Arbeitsspeichers (RAM) auf der VM ist.
Wenn nicht genügend Speicherplatz auf dem Betriebssystemdatenträger vorhanden ist, ändern Sie den Speicherort, an dem die Speicherabbilddatei erstellt wird, und verweisen Sie auf einen beliebigen Datenträger, der an die VM angeschlossen ist und über ausreichend freien Speicherplatz verfügt. Um den Speicherort zu ändern, ersetzen Sie in den folgenden Befehlen
%SystemRoot%
durch den Laufwerksbuchstaben des Datenträgers, beispielsweiseF:
.Um die Speicherabbilddatei des Betriebssystems zu aktivieren, führen Sie die folgenden Befehle load, add und unload aus, um die vorgeschlagene Konfiguration mithilfe des Tools reg zu implementieren:
Laden der Registrierungsstruktur vom beschädigten Betriebssystem-Datenträger:
reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
Aktivieren für „ControlSet001“:
reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Aktivieren für „ControlSet002“:
reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Entladen des beschädigten Betriebssystemdatenträgers:
reg unload HKLM\<broken-system>
Neuerstellen der ursprünglichen VM
Führen Sie Schritt 5 der VM-Reparaturbefehle aus, um die VM zu reassemblieren.
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