Hinweis
Für den Zugriff auf diese Seite ist eine Autorisierung erforderlich. Sie können versuchen, sich anzumelden oder das Verzeichnis zu wechseln.
Für den Zugriff auf diese Seite ist eine Autorisierung erforderlich. Sie können versuchen, das Verzeichnis zu wechseln.
Gilt für: ✔️ Windows-VMs
Dieser Artikel enthält Schritte zur Behebung von Problemen, bei denen virtuelle Computer unter Windows Server 2008 mit einer Fehlermeldung abstürzen, in der auf einen Hardwarefehler hingewiesen wird.
Symptome
Wenn Sie mithilfe der Startdiagnose den Screenshot des virtuellen Computers anzeigen, sehen Sie einen Bluescreen mit folgender Meldung:
*** Fehlfunktion der Hardware
Call your vendor for support
*** Das System hat angehalten ***
Bluescreen
Serielle Konsole
Ursache
Dieser Bildschirm wird angezeigt, wenn das Gastbetriebssystem nicht ordnungsgemäß eingerichtet ist und ein nicht maskierbarer Interrupt (NMI) gesendet wurde. In der Fehlermeldung wird darauf hingewiesen, dass durch ein Kernelmodusprogramm eine Ausnahme generiert wurde, die der Handler nicht abgefangen hat. Die generierte Ausnahme kann durch Erfassen eines Speicherabbilds ermittelt werden.
Lösung
Prozessübersicht
Tipp
Wenn Sie über eine aktuelle Sicherung der VM verfügen, können Sie versuchen, die VM aus der Sicherung wiederherzustellen, um das Startproblem zu beheben.
- Einrichten des Registrierungsschlüssels für den nicht maskierbaren Interrupt (NMI)
- Erstellen und Aufrufen einer Reparatur-VM
- Aktivieren der seriellen Konsole und der Speicherabbilderfassung
- Neuerstellen der VM
Einrichten des Registrierungsschlüssels für den nicht maskierbaren Interrupt (NMI)
Starten Sie den virtuellen Computer über das Azure-Portal neu, damit das Gastbetriebssystem normal startet.
Wenn Sie wieder auf den virtuellen Computer zugreifen können, öffnen Sie eine Eingabeaufforderung mit erhöhten Rechten („Als Administrator ausführen“).
Richten Sie mithilfe des folgenden Befehls den NMI-Registrierungsschlüssel ein:
REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Weitere Informationen zum Befehl „REG ADD“ finden Sie hier.
(Optional) Richten Sie die Speicherabbilderfassung ein:
REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
(Optional) Richten Sie den Zugriff auf die serielle Konsole ein:
BCDEDIT /ems {current} on, or bcdedit /ems '{current}' on if you are using PowerShell BCDEDIT /emssettings EMSPORT:1 EMSBAUDRATE:115200
Weitere Informationen zum Befehl „BCDEDIT“ finden Sie hier.
Starten Sie den virtuellen Computer mithilfe des folgenden Befehls neu:
SHUTDOWN /r /t 0 /f
Weitere Informationen zum Befehl „SHUTDOWN“ finden Sie hier.
Wichtig
Damit sollte das Problem behoben sein.
Notiz
Testen Sie Ihren virtuellen Computer nach dem Neustart, um sich zu vergewissern, dass er normal funktioniert. Sollten weiterhin Probleme auftreten, erhalten Sie im nächsten Abschnitt weitere Informationen.
Tipp
Es empfiehlt sich, im obigen Abschnitt den Registrierungsschlüssel für den nicht maskierbaren Interrupt (NMI) einzurichten. Falls Ihr virtueller Computer im Anschluss jedoch nicht normal gestartet wurde, wurde die Registrierung des Gastbetriebssystems unter Umständen nicht wie beabsichtigt geändert. In diesem Fall können Sie wie im Anschluss beschrieben vorgehen, um die Registrierungseinstellungen manuell hinzuzufügen.
Erstellen und Aufrufen einer Reparatur-VM
- Führen Sie die Schritte 1-3 der VM-Reparaturbefehle aus, um eine Reparatur-VM vorzubereiten.
- Stellen Sie über eine Remotedesktopverbindung eine Verbindung mit der Reparatur-VM her.
Aktivieren der seriellen Konsole und der Speicherabbilderfassung
Vor der Neuerstellung des virtuellen Computers empfiehlt es sich, die Speicherabbilderfassung und die serielle Konsole zu aktivieren. Gehen Sie dazu wie folgt vor:
Öffnen Sie eine Eingabeaufforderungssitzung als Administrator.
Führen Sie die folgenden BCDEdit-Befehle mit den Optionen /ems und /emssettings aus:
Aktivieren Sie die serielle Konsole:
bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
Überprüfen Sie, ob der freie Speicherplatz auf dem Betriebssystemdatenträger größer als die Größe des Arbeitsspeichers (RAM) auf der VM ist.
Wenn nicht genügend Speicherplatz auf dem Betriebssystemdatenträger vorhanden ist, ändern Sie den Speicherort, an dem die Speicherabbilddatei erstellt wird, und verweisen Sie auf einen beliebigen Datenträger, der an die VM angeschlossen ist und über ausreichend freien Speicherplatz verfügt. Um den Speicherort zu ändern, ersetzen Sie in den folgenden Befehlen
%SystemRoot%
durch den Laufwerksbuchstaben des Datenträgers, beispielsweiseF:
.Um die Speicherabbilddatei des Betriebssystems zu aktivieren, führen Sie die folgenden Befehle load, add und unload aus, um die vorgeschlagene Konfiguration mithilfe des Tools reg zu implementieren:
Laden der Registrierungsstruktur vom beschädigten Betriebssystem-Datenträger:
reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
Aktivieren für „ControlSet001“:
reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Aktivieren für „ControlSet002“:
reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Entladen des beschädigten Betriebssystemdatenträgers:
reg unload HKLM\<broken-system>
Neuerstellung des virtuellen Computers
- Verwenden Sie Schritt 5 der VM-Reparaturbefehle, um die VM neu zu erstellen.
Nächste Schritte
Kontaktieren Sie uns für Hilfe
Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.