SQL Server 2019 - Windows 11

Luís Assunção 111 Reputation points
2021-09-06T08:55:26.087+00:00

Hi guys... So, I installed Windows 11 available to the Insiders program, but unfortunately, I'm having a problem that was already caused in other versions of SQL/Windows. I already tried all the solutions related to this issue but none worked. So, I'm going to leave the details: ![129499-image.png][1] [1]: /api/attachments/129499-image.png?platform=QnA Overall summary: Final result: Failed: see details below Exit code (Decimal): -2061893606 Start time: 2021-09-06 09:39:22 End time: 2021-09-06 09:43:17 Requested action: Install Setup completed with required actions for features. Troubleshooting information for those features: Next step for SQLEngine: Use the following information to resolve the error, uninstall this feature, and then run the setup process again. Machine Properties: Machine name: LEXUS Machine processor count: 16 OS version: Microsoft Windows 11 Pro (10.0.22000) OS service pack: OS region: United States OS language: English (United States) OS architecture: x64 Process architecture: 64 Bit OS clustered: No Product features discovered: Product Instance Instance ID Feature Language Edition Version Clustered Configured Package properties: Description: Microsoft SQL Server 2019 ProductName: SQL Server 2019 Type: RTM Version: 15 SPLevel: 0 Installation location: C:\SQL2019\Developer_ENU\x64\setup\ Installation edition: Developer Product Update Status: None discovered. User Input Settings: ACTION: Install ADDCURRENTUSERASSQLADMIN: false AGTSVCACCOUNT: NT AUTHORITY\SYSTEM AGTSVCPASSWORD: ***** AGTSVCSTARTUPTYPE: Manual ASBACKUPDIR: Backup ASCOLLATION: Latin1_General_CI_AS ASCONFIGDIR: Config ASDATADIR: Data ASLOGDIR: Log ASPROVIDERMSOLAP: 1 ASSERVERMODE: TABULAR ASSVCACCOUNT: <empty> ASSVCPASSWORD: <empty> ASSVCSTARTUPTYPE: Automatic ASSYSADMINACCOUNTS: <empty> ASTELSVCACCT: <empty> ASTELSVCPASSWORD: <empty> ASTELSVCSTARTUPTYPE: 0 ASTEMPDIR: Temp BROWSERSVCSTARTUPTYPE: Disabled CLTCTLRNAME: <empty> CLTRESULTDIR: <empty> CLTSTARTUPTYPE: 0 CLTSVCACCOUNT: <empty> CLTSVCPASSWORD: <empty> CLTWORKINGDIR: <empty> COMMFABRICENCRYPTION: 0 COMMFABRICNETWORKLEVEL: 0 COMMFABRICPORT: 0 CONFIGURATIONFILE: C:\Program Files\Microsoft SQL Server\150\Setup Bootstrap\Log\20210906_093909\ConfigurationFile.ini CTLRSTARTUPTYPE: 0 CTLRSVCACCOUNT: <empty> CTLRSVCPASSWORD: <empty> CTLRUSERS: <empty> ENABLERANU: false ENU: true EXTSVCACCOUNT: <empty> EXTSVCPASSWORD: <empty> FEATURES: SQLENGINE FILESTREAMLEVEL: 0 FILESTREAMSHARENAME: <empty> FTSVCACCOUNT: <empty> FTSVCPASSWORD: <empty> HELP: false IACCEPTPYTHONLICENSETERMS: false IACCEPTROPENLICENSETERMS: false IACKNOWLEDGEENTCALLIMITS: false INDICATEPROGRESS: false INSTALLSHAREDDIR: C:\Program Files\Microsoft SQL Server\ INSTALLSHAREDWOWDIR: C:\Program Files (x86)\Microsoft SQL Server\ INSTALLSQLDATADIR: <empty> INSTANCEDIR: C:\Program Files\Microsoft SQL Server\ INSTANCEID: MSSQLSERVER INSTANCENAME: MSSQLSERVER ISMASTERSVCACCOUNT: NT AUTHORITY\Network Service ISMASTERSVCPASSWORD: <empty> ISMASTERSVCPORT: 8391 ISMASTERSVCSSLCERTCN: <empty> ISMASTERSVCSTARTUPTYPE: Automatic ISMASTERSVCTHUMBPRINT: <empty> ISSVCACCOUNT: NT AUTHORITY\Network Service ISSVCPASSWORD: <empty> ISSVCSTARTUPTYPE: Automatic ISTELSVCACCT: <empty> ISTELSVCPASSWORD: <empty> ISTELSVCSTARTUPTYPE: 0 ISWORKERSVCACCOUNT: NT AUTHORITY\Network Service ISWORKERSVCCERT: <empty> ISWORKERSVCMASTER: <empty> ISWORKERSVCPASSWORD: <empty> ISWORKERSVCSTARTUPTYPE: Automatic MATRIXCMBRICKCOMMPORT: 0 MATRIXCMSERVERNAME: <empty> MATRIXNAME: <empty> MRCACHEDIRECTORY: NPENABLED: 0 PBDMSSVCACCOUNT: <empty> PBDMSSVCPASSWORD: <empty> PBDMSSVCSTARTUPTYPE: 0 PBENGSVCACCOUNT: <empty> PBENGSVCPASSWORD: <empty> PBENGSVCSTARTUPTYPE: 0 PBPORTRANGE: <empty> PBSCALEOUT: false PID: ***** QUIET: false QUIETSIMPLE: false ROLE: RSINSTALLMODE: DefaultNativeMode RSSVCACCOUNT: <empty> RSSVCPASSWORD: <empty> RSSVCSTARTUPTYPE: Automatic SAPWD: ***** SECURITYMODE: SQL SQLBACKUPDIR: <empty> SQLCOLLATION: SQL_Latin1_General_CP1_CI_AS SQLJAVADIR: <empty> SQLMAXDOP: 8 SQLMAXMEMORY: 2147483647 SQLMINMEMORY: 0 SQLSVCACCOUNT: NT AUTHORITY\SYSTEM SQLSVCINSTANTFILEINIT: false SQLSVCPASSWORD: ***** SQLSVCSTARTUPTYPE: Automatic SQLSYSADMINACCOUNTS: LEXUS\despo SQLTELSVCACCT: NT Service\SQLTELEMETRY SQLTELSVCPASSWORD: <empty> SQLTELSVCSTARTUPTYPE: Automatic SQLTEMPDBDIR: <empty> SQLTEMPDBFILECOUNT: 8 SQLTEMPDBFILEGROWTH: 64 SQLTEMPDBFILESIZE: 8 SQLTEMPDBLOGDIR: <empty> SQLTEMPDBLOGFILEGROWTH: 64 SQLTEMPDBLOGFILESIZE: 8 SQLUSERDBDIR: <empty> SQLUSERDBLOGDIR: <empty> SUPPRESSPAIDEDITIONNOTICE: false SUPPRESSPRIVACYSTATEMENTNOTICE: false TCPENABLED: 0 UIMODE: Normal UpdateEnabled: true UpdateSource: MU USEMICROSOFTUPDATE: false USESQLRECOMMENDEDMEMORYLIMITS: false X86: false Configuration file: C:\Program Files\Microsoft SQL Server\150\Setup Bootstrap\Log\20210906_093909\ConfigurationFile.ini Detailed results: Feature: Database Engine Services Status: Failed Reason for failure: An error occurred during the setup process of the feature. Next Step: Use the following information to resolve the error, uninstall this feature, and then run the setup process again. Component name: SQL Server Database Engine Services Instance Features Component error code: 0x851A001A Error description: Wait on the Database Engine recovery handle failed. Check the SQL Server error log for potential causes. Error help link: https://go.microsoft.com/fwlink?LinkId=20476&ProdName=Microsoft+SQL+Server&EvtSrc=setup.rll&EvtID=50000&ProdVer=15.0.4013.40&EvtType=0xD15B4EB2%400x4BDAF9BA%401306%4026&EvtType=0xD15B4EB2%400x4BDAF9BA%401306%4026 Feature: SQL Browser Status: Passed Feature: SQL Writer Status: Passed Feature: SQL Client Connectivity SDK Status: Passed Feature: SQL Client Connectivity Status: Passed Rules with failures or warnings: Global rules: Warning IsFirewallEnabled The Windows Firewall is enabled. Make sure the appropriate ports are open to enable remote access. See the rules documentation at https://go.microsoft.com/fwlink/?linkid=2094702 for information about ports to open for each feature. Rules report file: C:\Program Files\Microsoft SQL Server\150\Setup Bootstrap\Log\20210906_093909\SystemConfigurationCheck_Report.htm

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,640 questions
{count} votes

Accepted answer
  1. Leon Laude 85,701 Reputation points
    2021-09-06T10:28:07.433+00:00

    Hi anonymous user,

    SQL Server 2019 is not yet officially supported on Windows 11, because Windows 11 has not been officially released yet.
    This however doesn't necessarily mean that it won't work, but it has not been tested/verified by Microsoft so any issue may occur.

    SQL Server 2019: Hardware and software requirements - Operating system support
    https://learn.microsoft.com/en-us/sql/sql-server/install/hardware-and-software-requirements-for-installing-sql-server-ver15?view=sql-server-ver15#operating-system-support

    ----------

    If the reply was helpful please don't forget to upvote and/or accept as answer, thank you!

    Best regards,
    Leon

    2 people found this answer helpful.

27 additional answers

Sort by: Most helpful
  1. Anil Ekmekci 21 Reputation points
    2021-10-08T16:35:33.523+00:00

    Hi,
    Now Windows 11 has released but i have the same issue with same error. I can't resolve it.

    4 people found this answer helpful.

  2. Tim Elliston 56 Reputation points
    2021-11-08T13:02:34.537+00:00

    Does any one from Microsoft read these posts?

    4 people found this answer helpful.

  3. Jonathan Potts 36 Reputation points
    2021-11-15T00:06:36.767+00:00

    So I am having this same issue and I think I narrowed down the cause. I am using a Samsung 980 SSD which seems to have issues with Windows 11.

    On Windows 11, with my Samsung 980 SSD, I am getting the following:

    C:\Windows\system32>fsutil fsinfo sectorinfo c:
    LogicalBytesPerSector :                                 512
    PhysicalBytesPerSectorForAtomicity :                    16384
    PhysicalBytesPerSectorForPerformance :                  16384
    FileSystemEffectivePhysicalBytesPerSectorForAtomicity : 4096
    Device Alignment :                                      Aligned (0x000)
    Partition alignment on device :                         Aligned (0x000)
    No Seek Penalty
    Trim Supported
    Not DAX capable
    Not Thinly-Provisioned
    

    When on Windows 10, PhysicalBytesPerSectorForAtomicity and PhysicalBytesPerSectorForPerformance were 4096 which is what the correct value should be I believe.

    4 people found this answer helpful.

  4. David Cearini 21 Reputation points
    2021-10-12T20:25:31.093+00:00

    Same issue here, but If it could help I have 2 different Notebook, only one have the issue with Sql Server 2019.
    The installation on a Microsoft Surface with exactly the same software configuration perfectly run.

    I have done various test:

    • Installed a fresh windows 11 copy
    • Installed SQL server on Window 10, doing an update to Windows 11 after the installation
    • Installed SQL Server as first software before the updates, and after all the windows updates

    Nothing change! Every time it works on the microsoft Surface and crash on the other notebook, so there is something in the hardware configutation that generate this problem.

    UPDATE: I have created a Virtual Machine on my phisical Windows 11 machine using the same Windows 11 ISO and the same SQL Server installer and everything run!
    I think that this confirm the Hardware compatibility problem! I'm using SQL Server on my virtual machine at this moment

    2 people found this answer helpful.