SQL Server 2019 - Windows 11

Luís Assunção 111 Reputation points
2021-09-06T08:55:26.087+00:00

Hi guys... So, I installed Windows 11 available to the Insiders program, but unfortunately, I'm having a problem that was already caused in other versions of SQL/Windows. I already tried all the solutions related to this issue but none worked. So, I'm going to leave the details: ![129499-image.png][1] [1]: /api/attachments/129499-image.png?platform=QnA Overall summary: Final result: Failed: see details below Exit code (Decimal): -2061893606 Start time: 2021-09-06 09:39:22 End time: 2021-09-06 09:43:17 Requested action: Install Setup completed with required actions for features. Troubleshooting information for those features: Next step for SQLEngine: Use the following information to resolve the error, uninstall this feature, and then run the setup process again. Machine Properties: Machine name: LEXUS Machine processor count: 16 OS version: Microsoft Windows 11 Pro (10.0.22000) OS service pack: OS region: United States OS language: English (United States) OS architecture: x64 Process architecture: 64 Bit OS clustered: No Product features discovered: Product Instance Instance ID Feature Language Edition Version Clustered Configured Package properties: Description: Microsoft SQL Server 2019 ProductName: SQL Server 2019 Type: RTM Version: 15 SPLevel: 0 Installation location: C:\SQL2019\Developer_ENU\x64\setup\ Installation edition: Developer Product Update Status: None discovered. User Input Settings: ACTION: Install ADDCURRENTUSERASSQLADMIN: false AGTSVCACCOUNT: NT AUTHORITY\SYSTEM AGTSVCPASSWORD: ***** AGTSVCSTARTUPTYPE: Manual ASBACKUPDIR: Backup ASCOLLATION: Latin1_General_CI_AS ASCONFIGDIR: Config ASDATADIR: Data ASLOGDIR: Log ASPROVIDERMSOLAP: 1 ASSERVERMODE: TABULAR ASSVCACCOUNT: <empty> ASSVCPASSWORD: <empty> ASSVCSTARTUPTYPE: Automatic ASSYSADMINACCOUNTS: <empty> ASTELSVCACCT: <empty> ASTELSVCPASSWORD: <empty> ASTELSVCSTARTUPTYPE: 0 ASTEMPDIR: Temp BROWSERSVCSTARTUPTYPE: Disabled CLTCTLRNAME: <empty> CLTRESULTDIR: <empty> CLTSTARTUPTYPE: 0 CLTSVCACCOUNT: <empty> CLTSVCPASSWORD: <empty> CLTWORKINGDIR: <empty> COMMFABRICENCRYPTION: 0 COMMFABRICNETWORKLEVEL: 0 COMMFABRICPORT: 0 CONFIGURATIONFILE: C:\Program Files\Microsoft SQL Server\150\Setup Bootstrap\Log\20210906_093909\ConfigurationFile.ini CTLRSTARTUPTYPE: 0 CTLRSVCACCOUNT: <empty> CTLRSVCPASSWORD: <empty> CTLRUSERS: <empty> ENABLERANU: false ENU: true EXTSVCACCOUNT: <empty> EXTSVCPASSWORD: <empty> FEATURES: SQLENGINE FILESTREAMLEVEL: 0 FILESTREAMSHARENAME: <empty> FTSVCACCOUNT: <empty> FTSVCPASSWORD: <empty> HELP: false IACCEPTPYTHONLICENSETERMS: false IACCEPTROPENLICENSETERMS: false IACKNOWLEDGEENTCALLIMITS: false INDICATEPROGRESS: false INSTALLSHAREDDIR: C:\Program Files\Microsoft SQL Server\ INSTALLSHAREDWOWDIR: C:\Program Files (x86)\Microsoft SQL Server\ INSTALLSQLDATADIR: <empty> INSTANCEDIR: C:\Program Files\Microsoft SQL Server\ INSTANCEID: MSSQLSERVER INSTANCENAME: MSSQLSERVER ISMASTERSVCACCOUNT: NT AUTHORITY\Network Service ISMASTERSVCPASSWORD: <empty> ISMASTERSVCPORT: 8391 ISMASTERSVCSSLCERTCN: <empty> ISMASTERSVCSTARTUPTYPE: Automatic ISMASTERSVCTHUMBPRINT: <empty> ISSVCACCOUNT: NT AUTHORITY\Network Service ISSVCPASSWORD: <empty> ISSVCSTARTUPTYPE: Automatic ISTELSVCACCT: <empty> ISTELSVCPASSWORD: <empty> ISTELSVCSTARTUPTYPE: 0 ISWORKERSVCACCOUNT: NT AUTHORITY\Network Service ISWORKERSVCCERT: <empty> ISWORKERSVCMASTER: <empty> ISWORKERSVCPASSWORD: <empty> ISWORKERSVCSTARTUPTYPE: Automatic MATRIXCMBRICKCOMMPORT: 0 MATRIXCMSERVERNAME: <empty> MATRIXNAME: <empty> MRCACHEDIRECTORY: NPENABLED: 0 PBDMSSVCACCOUNT: <empty> PBDMSSVCPASSWORD: <empty> PBDMSSVCSTARTUPTYPE: 0 PBENGSVCACCOUNT: <empty> PBENGSVCPASSWORD: <empty> PBENGSVCSTARTUPTYPE: 0 PBPORTRANGE: <empty> PBSCALEOUT: false PID: ***** QUIET: false QUIETSIMPLE: false ROLE: RSINSTALLMODE: DefaultNativeMode RSSVCACCOUNT: <empty> RSSVCPASSWORD: <empty> RSSVCSTARTUPTYPE: Automatic SAPWD: ***** SECURITYMODE: SQL SQLBACKUPDIR: <empty> SQLCOLLATION: SQL_Latin1_General_CP1_CI_AS SQLJAVADIR: <empty> SQLMAXDOP: 8 SQLMAXMEMORY: 2147483647 SQLMINMEMORY: 0 SQLSVCACCOUNT: NT AUTHORITY\SYSTEM SQLSVCINSTANTFILEINIT: false SQLSVCPASSWORD: ***** SQLSVCSTARTUPTYPE: Automatic SQLSYSADMINACCOUNTS: LEXUS\despo SQLTELSVCACCT: NT Service\SQLTELEMETRY SQLTELSVCPASSWORD: <empty> SQLTELSVCSTARTUPTYPE: Automatic SQLTEMPDBDIR: <empty> SQLTEMPDBFILECOUNT: 8 SQLTEMPDBFILEGROWTH: 64 SQLTEMPDBFILESIZE: 8 SQLTEMPDBLOGDIR: <empty> SQLTEMPDBLOGFILEGROWTH: 64 SQLTEMPDBLOGFILESIZE: 8 SQLUSERDBDIR: <empty> SQLUSERDBLOGDIR: <empty> SUPPRESSPAIDEDITIONNOTICE: false SUPPRESSPRIVACYSTATEMENTNOTICE: false TCPENABLED: 0 UIMODE: Normal UpdateEnabled: true UpdateSource: MU USEMICROSOFTUPDATE: false USESQLRECOMMENDEDMEMORYLIMITS: false X86: false Configuration file: C:\Program Files\Microsoft SQL Server\150\Setup Bootstrap\Log\20210906_093909\ConfigurationFile.ini Detailed results: Feature: Database Engine Services Status: Failed Reason for failure: An error occurred during the setup process of the feature. Next Step: Use the following information to resolve the error, uninstall this feature, and then run the setup process again. Component name: SQL Server Database Engine Services Instance Features Component error code: 0x851A001A Error description: Wait on the Database Engine recovery handle failed. Check the SQL Server error log for potential causes. Error help link: https://go.microsoft.com/fwlink?LinkId=20476&ProdName=Microsoft+SQL+Server&EvtSrc=setup.rll&EvtID=50000&ProdVer=15.0.4013.40&EvtType=0xD15B4EB2%400x4BDAF9BA%401306%4026&EvtType=0xD15B4EB2%400x4BDAF9BA%401306%4026 Feature: SQL Browser Status: Passed Feature: SQL Writer Status: Passed Feature: SQL Client Connectivity SDK Status: Passed Feature: SQL Client Connectivity Status: Passed Rules with failures or warnings: Global rules: Warning IsFirewallEnabled The Windows Firewall is enabled. Make sure the appropriate ports are open to enable remote access. See the rules documentation at https://go.microsoft.com/fwlink/?linkid=2094702 for information about ports to open for each feature. Rules report file: C:\Program Files\Microsoft SQL Server\150\Setup Bootstrap\Log\20210906_093909\SystemConfigurationCheck_Report.htm

Windows for business | Windows Client for IT Pros | User experience | Other

Answer accepted by question author
Leon Laude 86,206 Reputation points
2021-09-06T10:28:07.433+00:00

Hi anonymous user,

SQL Server 2019 is not yet officially supported on Windows 11, because Windows 11 has not been officially released yet.
This however doesn't necessarily mean that it won't work, but it has not been tested/verified by Microsoft so any issue may occur.

SQL Server 2019: Hardware and software requirements - Operating system support
https://learn.microsoft.com/en-us/sql/sql-server/install/hardware-and-software-requirements-for-installing-sql-server-ver15?view=sql-server-ver15#operating-system-support

----------

If the reply was helpful please don't forget to upvote and/or accept as answer, thank you!

Best regards,
Leon

Was this answer helpful?

2 people found this answer helpful.

28 additional answers

Sort by: Most helpful
  1. devon jerothe 6 Reputation points
    2021-10-12T14:47:31.247+00:00

    Jumping on to mention I'm having the exact same issue.

    Event viewer shows issues with ntdll.dll and sqllang.dll

    This was on a fresh install on a formatted drive.

    Faulting application name: sqlservr.exe, version: 2019.150.2000.5, time stamp: 0x5d8a9215
    Faulting module name: ntdll.dll, version: 10.0.22000.120, time stamp: 0x50702a8c
    Exception code: 0xc0000005
    Fault offset: 0x00000000000357ae
    Faulting process id: 0x1124
    Faulting application start time: 0x01d7bf67449d262c
    Faulting application path: C:\Program Files\Microsoft SQL Server\MSSQL15.MSSQLSERVER\MSSQL\Binn\sqlservr.exe
    Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
    Report Id: 8a318979-1413-46d7-8bbe-e0165f19cce8
    Faulting package full name: 
    Faulting package-relative application ID: 
    

    Was this answer helpful?

    1 person found this answer helpful.
    0 comments No comments

  2. 文通 邓 6 Reputation points
    2021-10-12T11:25:48.06+00:00

    I also met the same problem and searched GOOGLE and BaiDu. Ran out of options!! First windows10, upgrade windows11 after the database service can not start, such as the official version out, installed the official version of windows11, the problem is still the same. Let's hope Microsoft supports SQL installation on windows11 soon.

    Was this answer helpful?

    1 person found this answer helpful.

  3. Cyber Sinh 6 Reputation points
    2021-10-11T13:10:15.79+00:00

    Same issue for me.
    As workaround, I installed SQL Server 2019 in a linux container (docker) under WSL2.
    It's still crazy that a major Microsoft software works better on Linux than on Windows.

    Was this answer helpful?

    1 person found this answer helpful.

  4. Robert Castles 31 Reputation points
    2021-10-08T18:14:09.937+00:00

    Same here, and there are no good details in ERRORLOG, no errors indicated. I tried to even run install/run SQL services as my own ID, and it refuses to start. I did find something in event viewer.

    This was on a machine which was upgraded from Windows 10 where SQL Server 2019 Developer was running fine.

    I also tried a clean install, new instance, no success.

    Here's my ERRORLOG

    2021-10-05 23:42:46.91 Server Microsoft SQL Server 2019 (RTM) - 15.0.2000.5 (X64)
    Sep 24 2019 13:48:23
    Copyright (C) 2019 Microsoft Corporation
    Developer Edition (64-bit) on Windows 10 Pro 10.0 <X64> (Build 22000: )

    2021-10-05 23:42:46.91 Server UTC adjustment: -4:00
    2021-10-05 23:42:46.91 Server (c) Microsoft Corporation.
    2021-10-05 23:42:46.91 Server All rights reserved.
    2021-10-05 23:42:46.93 Server Server process ID is 12236.
    2021-10-05 23:42:46.93 Server System Manufacturer: 'Gigabyte Technology Co., Ltd.', System Model: 'B550 AORUS ELITE V2'.
    2021-10-05 23:42:46.93 Server Authentication mode is WINDOWS-ONLY.
    2021-10-05 23:42:46.93 Server Logging SQL Server messages in file 'C:\Program Files\Microsoft SQL Server\MSSQL15.MSSQLSERVER3\MSSQL\Log\ERRORLOG'.
    2021-10-05 23:42:46.93 Server The service account is 'WORKGROUP\TRON$'. This is an informational message; no user action is required.
    2021-10-05 23:42:46.93 Server Registry startup parameters:
    -d C:\Program Files\Microsoft SQL Server\MSSQL15.MSSQLSERVER3\MSSQL\DATA\master.mdf
    -e C:\Program Files\Microsoft SQL Server\MSSQL15.MSSQLSERVER3\MSSQL\Log\ERRORLOG
    -l C:\Program Files\Microsoft SQL Server\MSSQL15.MSSQLSERVER3\MSSQL\DATA\mastlog.ldf
    2021-10-05 23:42:46.93 Server Command Line Startup Parameters:
    -s "MSSQLSERVER3"
    2021-10-05 23:42:46.93 Server SQL Server detected 1 sockets with 8 cores per socket and 16 logical processors per socket, 16 total logical processors; using 16 logical processors based on SQL Server licensing. This is an informational message; no user action is required.
    2021-10-05 23:42:46.93 Server SQL Server is starting at normal priority base (=7). This is an informational message only. No user action is required.
    2021-10-05 23:42:46.93 Server Detected 49057 MB of RAM. This is an informational message; no user action is required.
    2021-10-05 23:42:46.93 Server Using conventional memory in the memory manager.
    2021-10-05 23:42:46.93 Server Page exclusion bitmap is enabled.
    2021-10-05 23:42:47.06 Server Buffer Pool: Allocating 8388608 bytes for 7209225 hashPages.
    2021-10-05 23:42:47.06 Server Default collation: SQL_Latin1_General_CP1_CI_AS (us_english 1033)
    2021-10-05 23:42:47.07 Server Buffer pool extension is already disabled. No action is necessary.
    2021-10-05 23:42:47.09 Server Query Store settings initialized with enabled = 1,
    2021-10-05 23:42:47.09 Server The maximum number of dedicated administrator connections for this instance is '1'
    2021-10-05 23:42:47.10 Server This instance of SQL Server last reported using a process ID of 17804 at 10/5/2021 11:42:41 PM (local) 10/6/2021 3:42:41 AM (UTC). This is an informational message only; no user action is required.
    2021-10-05 23:42:47.10 Server Node configuration: node 0: CPU mask: 0x000000000000ffff:0 Active CPU mask: 0x000000000000ffff:0. This message provides a description of the NUMA configuration for this computer. This is an informational message only. No user action is required.
    2021-10-05 23:42:47.11 Server Using dynamic lock allocation. Initial allocation of 2500 Lock blocks and 5000 Lock Owner blocks per node. This is an informational message only. No user action is required.
    2021-10-05 23:42:47.11 Server Lock partitioning is enabled. This is an informational message only. No user action is required.
    2021-10-05 23:42:47.11 Server In-Memory OLTP initialized on standard machine.
    2021-10-05 23:42:47.11 Server [INFO] Created Extended Events session 'hkenginexesession'

    2021-10-05 23:42:47.11 Server Database Instant File Initialization: disabled. For security and performance considerations see the topic 'Database Instant File Initialization' in SQL Server Books Online. This is an informational message only. No user action is required.
    2021-10-05 23:42:47.12 Server Total Log Writer threads: 2. This is an informational message; no user action is required.
    2021-10-05 23:42:47.13 Server clwb is selected for pmem flush operation.
    2021-10-05 23:42:47.13 Server Software Usage Metrics is disabled.
    2021-10-05 23:42:47.13 spid9s Starting up database 'master'.
    2021-10-05 23:42:47.14 spid9s There have been 256 misaligned log IOs which required falling back to synchronous IO. The current IO is on file C:\Program Files\Microsoft SQL Server\MSSQL15.MSSQLSERVER3\MSSQL\DATA\master.mdf.
    2021-10-05 23:42:47.21 Server CLR version v4.0.30319 loaded.
    2021-10-05 23:42:47.24 Server Common language runtime (CLR) functionality initialized using CLR version v4.0.30319 from C:\Windows\Microsoft.NET\Framework64\v4.0.30319.

    Event viewer

    Faulting application name: sqlservr.exe, version: 2019.150.2080.9, time stamp: 0x5fa6009b
    Faulting module name: ntdll.dll, version: 10.0.22000.120, time stamp: 0x50702a8c
    Exception code: 0xc0000005
    Fault offset: 0x00000000000a7279
    Faulting process id: 0x2ad4
    Faulting application start time: 0x01d7bb349d6efc9a
    Faulting application path: C:\Program Files\Microsoft SQL Server\MSSQL15.MSSQLSERVER\MSSQL\Binn\sqlservr.exe
    Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
    Report Id: f5ece71b-a28b-479f-bbd4-c616102e9427
    Faulting package full name:
    Faulting package-relative application ID:

    Was this answer helpful?

    1 person found this answer helpful.

Your answer

Answers can be marked as 'Accepted' by the question author and 'Recommended' by moderators, which helps users know the answer solved the author's problem.