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Résoudre les problèmes liés aux exceptions de seuil de recyclage de rôle de service cloud (classique)

Importante

Services cloud (classique) est désormais déconseillé pour les nouveaux clients et sera mis hors service le 31 août 2024 pour tous les clients. Les nouveaux déploiements doivent utiliser le nouveau modèle de déploiement basé sur azure Resource Manager, Azure Services cloud (support étendu).

Cet article vous aide à résoudre les problèmes liés aux exceptions UpdateDeploymentRoleRecycleThresholdReached qui se produisent pendant le déploiement des services cloud.

Symptôme

Vos instances de rôle de service ont été recyclées en continu lors d’une mise à jour ou d’une mise à niveau. La mise à jour ou la mise à niveau avec vos paramètres de configuration ont empêché l’exécution des instances de rôle.

Le message suivant s’affiche :

Vos instances de rôle ont recyclé un certain nombre de fois au cours d’une opération de mise à jour ou de mise à niveau. Cela indique que la nouvelle version de votre service ou les paramètres de configuration que vous avez fournis lors de la configuration du service empêchent l’exécution des instances de rôle. Vérifiez que votre code ne lève pas d’exceptions non gérées et que vos paramètres de configuration sont corrects, puis démarrez une autre opération de mise à jour ou de mise à niveau.

Cause

Une exception UpdateDeploymentRoleRecycleThresholdReached signifie que les instances de rôle du service cloud ont été recyclées pendant un certain temps pendant une mise à jour.

Pour plus d’informations sur les exceptions de rôle non gérées, consultez Problèmes courants qui entraînent le recyclage des rôles Azure Cloud Service (classique).

Solution

Pour résoudre ce problème, effectuez l’une des actions suivantes :

  • Supprimez l’emplacement de déploiement à partir duquel les rôles sont recyclés. Ensuite, effectuez un nouveau déploiement sur un emplacement vide.

  • Créez un nouveau service cloud instance, déployez-le et mettez à jour le nom canonique du service (CName).

Que se passe-t-il si vous ne souhaitez pas perdre l’adresse IP associée à votre emplacement de déploiement existant ? Suivez ensuite ces étapes pour réserver et libérer l’adresse. Pour plus d’informations, consultez Adresses IP réservées pour Services cloud & Machines Virtuelles.

  1. Réservez l’adresse IP de l’emplacement de déploiement existant.

  2. Libérez l’adresse IP réservée associée.

  3. Supprimez l’emplacement de déploiement.

  4. Effectuez un nouveau déploiement sur cet emplacement.

  5. Associez l’adresse IP réservée requise à cet emplacement de service cloud.

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