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Azure Data Box Disk でのデータ コピーに関する問題のトラブルシューティング

この記事は Microsoft Azure Data Box Disk に適用され、ディスクにデータをコピーするときに発生する問題のトラブルシューティング方法について説明します。 この記事では、分割コピー ツールを使用するときの問題についても説明します。

Linux システム使用時のデータ コピーの問題

このセクションでは、Linux クライアントを使用してディスクにデータをコピーするときに発生する一部の問題について詳しく説明します。

問題: ドライブが読み取り専用としてマウントされる

原因

クリーンでないファイル システムでは、ドライブが読み取り専用としてマウントされる可能性があります。

ドライブを読み取り/書き込みとして再マウントしても、Data Box ディスクでは機能しません。 このシナリオは、dislocker によって暗号化解除されたドライブではサポートされていません。 次のコマンドを使用して、デバイスを正常に再マウントできます。

# mount -o remount, rw /mnt/DataBoxDisk/mountVol1

再マウントは成功しましたが、データは保持されません。

解決策

Linux システムで次の手順を実行します。

  1. ntfsfix ユーティリティの ntfsprogs パッケージをインストールします。

  2. ロック解除ツールによってドライブに提供されたマウント ポイントのマウントを解除します。 マウント ポイントの数はドライブによって異なります。

    unmount /mnt/DataBoxDisk/mountVol1
    
  3. 対応するパスで ntfsfix を実行します。 強調表示されている番号は、手順 2 と同じである必要があります。

    ntfsfix /mnt/DataBoxDisk/bitlockerVol1/dislocker-file
    
  4. 次のコマンドを実行して、マウントの問題の原因となる可能性がある休止状態メタデータを削除します。

    ntfs-3g -o remove_hiberfile /mnt/DataBoxDisk/bitlockerVol1/dislocker-file /mnt/DataBoxDisk/mountVol1
    
  5. クリーンなマウント解除を行います。

    ./DataBoxDiskUnlock_x86_64 /unmount
    
  6. クリーンなロック解除とマウントを行います。

  7. ファイルを書き込み、マウント ポイントをテストします。

  8. マウントを解除して再マウントし、ファイルの永続化を検証します。

  9. データ コピーを続行します。

問題: コピー後にデータが保持されないというエラー

原因

マウント後にコピーしたデータがドライブに含まれていない場合は、読み取り専用としてマウントした後に読み取り/書き込みとして再マウントされた可能性があります。

解決策

その場合は、 ドライブが読み取り専用としてマウントされる場合の解決策を参照してください。

そうではなかった場合は、Data Box Disk Unlock ツールがインストールされているフォルダーからログをコピーし、 Microsoft サポートにお問い合わせください

Data Box Disk Split Copy ツールのエラー

分割コピー ツールを使用して複数のディスクにデータを分割するときに発生する問題を次の表にまとめます。

エラー メッセージ/警告 推奨事項
[情報] ボリューム m の BitLocker パスワードを取得中
[エラー]ボリューム m の BitLocker キーの取得中にキャッチされた例外:
シーケンスに要素が含まれていません。
このエラーは、コピー先の Data Box ディスクがオフラインの場合に発生します。
diskmgmt.msc ツールを使用してディスクをオンラインにします。
[エラー] 例外が発生しました: WMI 操作が失敗しました。
メソッド=数値パスワードで解除, ReturnValue=2150694965,
Win32Message=指定された回復パスワードの形式が無効です。
BitLocker 回復パスワードは 48 桁です。
回復パスワードが正しい形式であることを確認してから、もう一度やり直してください。
Data Box Disk Unlock ツールを使用して、最初にディスクのロックを解除し、コマンドを再試行します。 詳細については、以下を参照してください。
  • Data Box Disk のロックを解除します
  • ディスクのロック解除
  • [エラー]例外が発生しました:ターゲット ドライブに DriveManifest.xml ファイルが存在します。
    これは、ターゲット ドライブが別のジャーナル ファイルで準備されている可能性があることを示します。
    同じドライブにさらにデータを追加するには、前のジャーナル ファイルを使用します。 既存のデータを削除し、新しいインポート ジョブのターゲット ドライブを再利用するには、ドライブ上の DriveManifest.xml を削除します。 新しいジャーナル ファイルを使用して、このコマンドを再実行します。
    このエラーは、複数のインポート セッションで同じドライブ セットを使用しようとすると発生します。
    1 つの分割セッションとコピー セッションに対してのみ、1 つのドライブ セットを使用します。
    [エラー]例外がスローされました:CopySessionId importdata-sept-test-1 は以前のコピー セッションを参照し、新しいコピー セッションには再利用できません。 このエラーは、以前に正常に完了したジョブと同じジョブ名を新しいジョブに使用しようとすると報告されます。
    新しいジョブに一意の名前を割り当てます。
    [情報]宛先ファイルまたはディレクトリ名が NTFS の長さの制限を超えています。 このメッセージは、長いファイル パスのために宛先ファイルの名前が変更されたときに報告されます。
    この動作を制御するには、 config.json ファイルの処理オプションを変更します。
    [エラー]例外が発生しました: JSON エスケープ シーケンスが正しくありません。 このメッセージは、config.json に無効な形式がある場合に報告されます。
    ファイルを保存する前に、JSONlint を使用してconfig.jsonを検証します。

    次のステップ