Teams Android デバイスの条件付きアクセス関連の問題を修正する
現象
条件付きアクセスは、企業リソースにアクセスするデバイスが正しく管理され、セキュリティで保護されていることを確認するのに役立つMicrosoft Entra機能です。 条件付きアクセス ポリシーが Teams サービスに適用されている場合、Teams にアクセスする Android デバイス (Teams の電話、Teams のディスプレイ、Teams パネル、および Android のMicrosoft Teams Roomsを含む) は、ポリシーに準拠している必要があります。 それ以外の場合、条件付きアクセスでは、ユーザーがデバイス上の Teams アプリにサインインしたり、使用したりできなくなります。
これらのポリシーが適用されている場合は、準拠していないデバイスで次の 1 つ以上の問題が発生する可能性があります。
- デバイスは Teams にサインインできないか、サインイン ループでスタックします。
- デバイスは Teams からランダムに自動的にサインアウトします。
- Microsoft Teams がフリーズまたはクラッシュする。
原因
これらの問題は、次の理由で発生する可能性があります。
サポートされていない条件付きアクセス ポリシーまたはIntuneデバイス コンプライアンス ポリシー設定
デバイスが非準拠としてマークされている場合、Microsoft Entra トークン発行サービスは、デバイス オブジェクトのトークンの更新を停止するか、トークンを取り消します。 この場合、デバイスは更新された認証トークンを取得できないため、強制的にサインアウトされます。
デバイスのコンプライアンス状態をチェックするには、Intuneデバイス コンプライアンス ダッシュボードを使用します。
サインイン頻度の設定
この設定により、定期的な再認証が強制されます。 これにより、さまざまなサインイン頻度が設定されている条件付きアクセス ポリシーの数によっては、デバイスがランダムにサインアウトする可能性があります。 再認証が行われると、トークンは取り消され、ユーザー アカウントの下に新しいデバイス オブジェクトが作成されます。 デバイス オブジェクトの数がデバイスの制限Microsoft Entra超えている場合、またはデバイスの制限Intune場合、ユーザーはデバイスにサインインできません。
使用条件 (ToU) ポリシーと MFA 条件付きアクセス ポリシー (両方が使用されている場合)
詳細については、「 Teams 電話に関する既知の問題」を参照してください。
問題が条件付きアクセス ポリシーによって引き起こされるかどうかをチェックするには、次の手順に従います。
Azure portalのサインイン ログに移動します。
[ ユーザー サインイン (非対話型)] タブを選択します。
[ フィルターの追加] を選択して、次のフィルターを追加します。
- 状態: [ 失敗] を選択し、[ 適用] を選択します。
- アプリケーション: 「Teams」と入力し、[ 適用] を選択します。
次の アプリケーション 値を持つ影響を受けるユーザー名の項目を探します。
- Microsoft Teams
- Microsoft Teams サービス
- Microsoft Teams – デバイス 管理 エージェント
失敗したサインインに関する詳細を表示するには、各項目を選択します。 通常、[ 基本情報 ] タブの次のフィールドから詳細情報を取得できます。
- サインイン エラー コード
- エラーの理由
- その他の詳細
サインイン エラー コードがコンプライアンスに関連していると思われる場合は、[ 条件付きアクセス ] タブを選択し、 エラー の結果を示すポリシーを探します。
ポリシーの詳細を確認します。
解決方法
特定の条件付きアクセス ポリシーによって発生する問題を解決するには、 デバイス フィルター を使用して、これらのポリシーからデバイスを除外します。 一般的に使用されるデバイス プロパティは、 製造元 と モデルです。 一般的に使用される演算子は 、Contains、 StartsWith、および In です。
注:
- デバイス フィルターは、ユーザー アカウントではなくデバイス オブジェクトにのみ適用されます。
- モデルや製造元などの一部の属性は、デバイスがIntuneに登録されている場合にのみ設定できます。 デバイスがIntuneに登録されていない場合は、拡張機能属性を使用します。
- 条件付きアクセスを構成し、コンプライアンス ポリシーをIntuneするために必要なアクセス権がない場合は、アクセス権を持つユーザーと協力してください。 Teams デバイスでサポートされていない設定がないか、各ポリシー設定を確認します。
次のスクリーンショットは、デバイス フィルターの例を示しています。
関連情報
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