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メールに関する問題のトラブルシューティング

この記事は、Dynamics 365 Salesのメールに関連する問題のトラブルシューティングと解決に役立ちます。

問題 1: Email エディターに、コンテキストの電子メール ポップアップ ウィンドウに正しくないタイトルが表示される

Dynamics 365 2020 リリースウェーブ 2 にアップグレードした後、電子メール エディターは、コンテキスト 電子メール ポップアップ ウィンドウに正しくないタイトルを表示します。

原因

既定の電子メール フォームでは、 イベントと onchange イベントがトリガーされ、onloadコンテキストの電子メール ポップアップで電子メール タイトルやその他の属性を更新するのに役立ちます。 カスタム電子メール フォームまたはアンマネージド レイヤー フォームがある場合、 onload イベントと onchange イベントは使用できません。 そのため、メール タイトルが正しく表示されません。

解決方法

この問題を解決するには、 イベントと onchange イベントをonloadカスタム電子メール フォームに追加する必要があります。

  1. 新しいソリューションを作成します

  2. 新しく作成したソリューションにカスタム電子メール フォームを追加します。

  3. ソリューションをエクスポートします

  4. フォームの XML に次のコードを追加します。

    <events>
        <event name="onload" application="true" active="true">
            <InternalHandlers>
                <Handler functionName="Activities.Email.formOnload" libraryName="Activities/SystemLibraries/Email_main_system_library.js" handlerUniqueId="ecdfe4d8-d6d3-4d21-ab68-8ea75bb30a79" enabled="true" parameters="" passExecutionContext="true" />
                <Handler functionName="Activities.Email.NotifyPanelSubjectChange" libraryName="Activities/SystemLibraries/Email_main_system_library.js" handlerUniqueId="{706607A8-4424-4C9A-847A-602FC8035B48}" enabled="true" parameters="" passExecutionContext="true" solutionaction="Added"/>
            </InternalHandlers>
        </event>
        <event name="onchange" application="true" active="true" attribute="subject" solutionaction="Added">
            <Handlers>
                <Handler functionName="Activities.Email.NotifyPanelSubjectChange" libraryName="Activities/SystemLibraries/Email_main_system_library.js" handlerUniqueId="{706607A8-4424-4C9A-847A-602FC8035B48}" enabled="true" parameters="" passExecutionContext="true"/>
            </Handlers>
        </event>
    </events>
    <clientresources>
        <internalresources>
            <clientincludes>
                <internaljscriptfile src="$webresource:Activities/SystemLibraries/Email_main_system_library.js" />
            </clientincludes>
        </internalresources>
    </clientresources>
    
  5. ソリューションをインポートします

問題 2: 追跡されていないメールと会議を自動キャプチャで表示できない

自動キャプチャでは、organization内の一部またはすべてのユーザーの追跡されていないメールや会議は表示されません。

原因

バージョン 9.2.24031.00102 以降では、Dynamics 365 Salesは最小特権アクセスの原則に従います。これにより、テナントで条件付きアクセス ポリシーを持つユーザーが追跡されていないメールや会議にアクセスできなくなります。

追跡されていないメールや会議がユーザーに表示されない場合は、次の手順を実行して、問題が条件付きアクセス ポリシーによって発生しているかどうかを確認します。

  1. 少なくとも条件付きアクセス管理者としてMicrosoft Entra 管理センターにサインインします。

  2. [Identity>Monitoring & 正常性>サインイン ログ] に移動します

  3. [ ユーザー サインイン (非対話型)] タブに切り替え、次のフィルターを追加します。

    • アプリケーションDataverse が含まれている
    • リソースMicrosoft Graph が含まれている
    • 状態[失敗] と等しい

    影響を受けるユーザーに対して一部の結果が返される場合、問題は条件付きアクセス ポリシーが原因です。

回避策

この問題は想定される動作であるため、解決できません。 別の方法として、ユーザーは Outlook で Microsoft Copilot for Sales を使用して個々のアクティビティを記録したり、 サーバー側同期 を使用してすべてのメールや会議を自動的に追跡したりできます。