Power Query gebruiken om gegevens te transformeren

Met Power Query kunt u verbinding maken met veel verschillende gegevensbronnen en de gegevens transformeren in de gewenste vorm.

In dit artikel leert u hoe u query's maakt met Power Query door het volgende te ontdekken:

  • Hoe de ervaring Gegevens ophalen werkt in Power Query.
  • Hoe u de Power Query-gebruikersinterface kunt gebruiken en ervan kunt profiteren.
  • Algemene transformaties uitvoeren, zoals het groeperen en samenvoegen van gegevens.

Als u geen toegang hebt tot Power Query, kunt u zich aanmelden voor een gratis proefversie van Power BI voordat u begint. U kunt Power BI gegevensstromen gebruiken om de Power Query Online-ervaringen uit te proberen die in dit artikel worden beschreven.

U kunt ook Power BI Desktop gratis downloaden.

Voorbeelden in dit artikel maken verbinding met en gebruiken de OData-feed van Northwind.

Verbinding maken met een OData-feed

Notitie

Ga naar Where to get data voor meer informatie over waar u gegevens kunt ophalen uit elk van de Microsoft producten die Power Query bevatten.

Zoek eerst de OData-feedconnector vanuit de get data-ervaring. U kunt zoeken naar OData- in de zoekbalk in de rechterbovenhoek.

Schermopname van de pagina Gegevensbron kiezen van de ervaring Gegevens ophalen met de nadruk op de OData-connector.

Nadat u deze connector hebt geselecteerd, worden in het scherm de verbindingsinstellingen en referenties weergegeven.

  • Voer voor URL de URL van de OData-feed Northwind in: https://services.odata.org/V4/Northwind/Northwind.svc/.
  • Laat voor On-premises gegevensgatewayals geen instellen.
  • Laat verificatietypeanoniem.

Selecteer de knop Volgende.

De Navigator opent nu, waar u de tabellen selecteert waarmee u vanuit de gegevensbron verbinding wilt maken. Selecteer de tabel Klanten om een voorbeeld van de gegevens te laden en selecteer vervolgens Gegevens transformeren.

Schermopname van de pagina Power Query Navigator met de nadruk op de tabel Klanten.

Het dialoogvenster laadt vervolgens de gegevens uit de tabel Klanten in de Power Query-editor.

De ervaring van het verbinden met uw gegevens, het opgeven van de authenticatiemethode en het selecteren van het specifieke object of de specifieke tabel waarmee u verbinding wilt maken, heet de gegevens ophalen-ervaring. Deze ervaring wordt beschreven met meer informatie in het artikel Gegevensoverzicht ophalen .

Notitie

Ga naar OData-feedfeed voor meer informatie over de OData-feedconnector.

Onderdelen van de Power Query-editor

Aanbeveling

Als u de Power Query-editor in Power BI wilt zoeken, selecteert u onder Query's Transform-gegevens.

Schermopname van de balk Start in Power BI met de knop Gegevens transformeren gemarkeerd.

De Power Query-editor vertegenwoordigt de Power Query gebruikersinterface. In deze gebruikersinterface kunt u query's toevoegen of wijzigen, query's beheren door beschrijvingen te groeperen of toe te voegen aan querystappen, of uw query's en hun structuur visualiseren met verschillende weergaven. De Power Query gebruikersinterface heeft vijf afzonderlijke onderdelen. De nummers in de volgende tabel komen overeen met de genummerde aanduidingen in de schermafbeelding.

Schermopname van de gebruikersinterface van Power Query, waarbij elk onderdeel wordt beschreven en genummerd.

# Onderdeel Description
1 Ribbon De lintnavigatie, met meerdere tabbladen om transformaties toe te voegen, opties voor uw query te selecteren en verschillende knoppen op het lint te gebruiken voor het uitvoeren van verschillende taken.
2 Deelvenster Query's Een weergave van al uw beschikbare query's.
3 Huidige weergave Uw belangrijkste werkweergave, die standaard een voorbeeld van de gegevens voor uw query weergeeft. U kunt ook de diagramweergave inschakelen samen met de voorbeeldweergave van de gegevens. U kunt ook schakelen tussen de schemaweergave en de voorbeeldweergave van de gegevens terwijl u de diagramweergave behoudt.
4 Query-instellingen Een weergave van de momenteel geselecteerde query met relevante informatie, zoals querynaam, querystappen en verschillende indicatoren.
5 Statusbalk Een balk met relevante belangrijke informatie over uw query, zoals uitvoeringstijd, totale kolommen en rijen en verwerkingsstatus. Deze balk bevat ook knoppen om uw huidige weergave te wijzigen.

Notitie

De schema- en diagramweergave zijn momenteel alleen beschikbaar in Power Query Online.

Voordat u gegevens in de Power Query-editor transformeert, kunt u weten hoe u de deelvensters van de gebruikersinterface kunt uitvouwen of samenvouwen en kunt schakelen tussen weergaven. Als u de juiste deelvensters selecteert, kunt u zich richten op de weergave die het belangrijkst voor u is. In de volgende secties worden de deelvensters en weergaven beschreven die beschikbaar zijn in de Power Query gebruikersinterface.

Het lint van de Power Query-editor

Het lint is het onderdeel waarin u de meeste transformaties en acties vindt die u kunt uitvoeren in de Power Query-editor. Het heeft meerdere tabbladen, waarvan de waarden afhankelijk zijn van de productintegratie. Elk van de tabbladen biedt specifieke knoppen en opties, waarvan sommige mogelijk overbodig zijn in de hele Power Query ervaring. Deze knoppen en opties bieden u eenvoudig toegang tot de transformaties en acties die u mogelijk nodig hebt.

Schermopname van de standaardlintweergave op het tabblad Start van de Power Query gebruikersinterface.

De Power Query-interface reageert en probeert uw schermresolutie aan te passen om u de beste ervaring te laten zien. In scenario's waarin u een compacte versie van het lint wilt gebruiken, is er ook een knop samenvouwen in de rechterbenedenhoek van het lint om u te helpen over te schakelen naar het compacte lint.

Schermopname van de compacte lintweergave op het tabblad Start van de Power Query gebruikersinterface.

U kunt teruggaan naar de standaardlintweergave door het uitvouwpictogram in de rechterbenedenhoek van het lint te selecteren.

Power Query-deelvensters uitvouwen en samenvouwen

Mogelijk merkt u dat er in de Power Query gebruikersinterface pictogrammen zijn waarmee u bepaalde weergaven of secties kunt samenvouwen of uitvouwen. Er bevindt zich bijvoorbeeld een pictogram in de rechterbovenhoek van het deelvenster Query's waarmee het queryvenster wordt samengevouwen wanneer dit is geselecteerd en het deelvenster wordt uitgevouwen wanneer het opnieuw is geselecteerd.

Schermopname waarin het pictogram in het deelvenster Query's wordt benadrukt dat wordt gebruikt om het deelvenster Query's samen te vouwen en uit te vouwen.

Schakelen tussen Power Query weergaven

Naast het samenvouwen van bepaalde deelvensters en secties in de gebruikersinterface van Power Query, kunt u ook schakelen welke weergaven worden weergegeven. Als u wilt schakelen tussen weergaven, gaat u naar het tabblad Weergave op het lint waar u de Preview en Layout-groepen vindt, die bepalen hoe de Power Query gebruikersinterface eruitziet.

U wordt aangeraden al deze opties uit te proberen om de weergave en indeling te vinden waarmee u het prettigst kunt werken. Selecteer als voorbeeld Schemaweergave op de menubalk.

Schermopname met de nadruk op de knop Schemaweergave op het tabblad Beeld op het lint Power Query.

De rechterkant van de statusbalk bevat ook pictogrammen voor de diagram-, gegevens- en schemaweergaven. U kunt deze pictogrammen gebruiken om te schakelen tussen weergaven. U kunt deze pictogrammen ook gebruiken om de weergave van uw keuze in of uit te schakelen.

Schermopname met het deelvenster Query's samengevouwen en de huidige weergave is overgeschakeld naar de schemaweergave en het pictogram van de schemaweergave benadrukt.

Wat is de schemaweergave in Power Query

De schemaweergave biedt u een snelle en eenvoudige manier om alleen te communiceren met de onderdelen van het schema voor uw tabel, zoals de kolomnamen en gegevenstypen. U wordt aangeraden de schemaweergave uit te voeren wanneer u schemagerelateerde acties wilt uitvoeren. Deze acties kunnen bestaan uit het verwijderen van kolommen, het wijzigen van de naam van kolommen, het wijzigen van kolomgegevenstypen, het opnieuw ordenen van kolommen of het dupliceren van kolommen.

Notitie

Ga naar Schemaweergave gebruikenom meer te leren over de schemaweergave.

Selecteer in de schemaweergave bijvoorbeeld het vinkje naast de kolommen Orders en CustomerDemographics en selecteer op het lint de actie Kolommen verwijderen. Met deze selectie wordt een transformatie toegepast om deze kolommen uit uw gegevens te verwijderen.

Schermopname van de geselecteerde kolommen Orders en CustomerDemographics en de optie Kolommen verwijderen benadrukt.

Wat is de diagramweergave in Power Query

U kunt nu teruggaan naar de voorbeeldweergave van gegevens en de diagramweergave inschakelen om een visueel perspectief van uw gegevens en query's te gebruiken.

Schermopname waarin de pictogrammen van de diagramweergave en de voorbeeldweergave van gegevens worden benadrukt.

In de diagramweergave kunt u visualiseren hoe uw query is gestructureerd en hoe deze kan communiceren met andere query's in uw project. Elke stap in uw query heeft een uniek pictogram waarmee u de transformatie kunt herkennen die is gebruikt. Lijnen verbinden stappen om afhankelijkheden te illustreren. Omdat zowel de voorbeeldweergave van de gegevens als de diagramweergave zijn ingeschakeld, wordt de diagramweergave boven aan het gegevensvoorbeeld weergegeven.

Schermafbeelding van de Power Query werkruimte met de diagramweergave met gegevensvoorbeeld.

Notitie

Ga naar diagramweergavevoor meer informatie over de diagramweergave.

Klanten groeperen op land/regio in de diagramweergave

Om klanten per land/regio te tellen, voegt u een transformatie Groeperen op toe. Als de diagramweergave is ingeschakeld, selecteert u het plusteken. U kunt zoeken naar een nieuwe transformatie die u aan uw query kunt toevoegen. Zoek naar , groepeer op en selecteer de omzetting.

Schermopname met een zoekopdracht naar een

Het dialoogvenster groeperen op wordt vervolgens weergegeven. U kunt de bewerking Groeperen op instellen om te groeperen op land/regio en het aantal klantrijen per land/regio te tellen.

  1. Laat het keuzerondje Basic aangevinkt.
  2. Selecteer Land/regio om op te groeperen.
  3. Voer Klanten in als de nieuwe kolomnaam en selecteer Rijen tellen als de bewerking.

Schermopname van het dialoogvenster Basisgroep met de gegevens van de klanten ingevoerd.

Selecteer OK- om de bewerking uit te voeren. Uw voorbeeld van gegevens wordt vernieuwd om het totale aantal klanten per land/regio weer te geven.

Een andere manier om het dialoogvenster Groeperen op te starten, is door de knop Groeperen op te gebruiken op het lint of om de kolom Land/regio te selecteren en vast te houden (klik erop met de rechtermuisknop).

Schermopname waarin de knop Groeperen op op het lint en de optie Groeperen op in het kolommenu van land/regio worden benadrukt.

Voor het gemak kunnen transformaties in Power Query vaak worden geopend vanaf meerdere locaties, zodat gebruikers ervoor kunnen kiezen om de gewenste ervaring te gebruiken.

Een nieuwe query toevoegen

Nu u een query hebt die het aantal klanten per land/regio biedt, kunt u context toevoegen aan deze gegevens door het totale aantal leveranciers voor elk land/elke regio te zoeken.

Eerst moet u de Leveranciers gegevens toevoegen. Selecteer Gegevens ophalen. Zoek in Kies Gegevensbronnaar OData. Selecteer vervolgens de OData-connector.

Schermopname van de pagina Gegevensbron kiezen met de nadruk op de OData-connector.

De OData-verbindingservaring wordt opnieuw weergegeven. Voer de verbindingsinstellingen in zoals beschreven in Verbinding maken met een OData-feed om verbinding te maken met de OData-feed Northwind. In de Navigator, zoek naar en selecteer de tabel Leveranciers.

Schermopname van de Power Query navigator met de Northwind OData-leveranciers geselecteerd.

Selecteer Create om de nieuwe query toe te voegen aan de Power Query-editor. Vouw het deelvenster Query's uit, waarin nu zowel de klanten als de query Leveranciers worden weergegeven.

Schermopname van het deelvenster Query's waarin zowel de query's van klanten als leveranciers worden benadrukt.

Open het dialoogvenster Groeperen op opnieuw door de knop Groeperen op te selecteren op het lint onder het tabblad Transformeren.

Schermopname van een deel van het lint op het tabblad Transformeren, met de nadruk op Groeperen.

Stel in het dialoogvenster Groeperen de bewerking Groeperen in op groeperen op land/regio en tel het aantal leveranciersrijen per land/regio.

  1. Laat het keuzerondje Basic aangevinkt.
  2. Selecteer Land/regio om op te groeperen.
  3. Voer Leveranciers in in Nieuwe kolomnaam en selecteer Rijen tellen in Bewerking.

Schermopname van het dialoogvenster Basisgroep met de gegevens van de leveranciers ingevoerd.

Notitie

Voor meer informatie over de transformatie Groeperen op, gaat u naar groeperen of samenvatten van rijen.

Referentiequery's

Wanneer u naar een query verwijst, maakt u een nieuwe query die verwijst naar de uitvoer van een bestaande query. Nu u een query voor klanten en een query voor leveranciers hebt, is het uw volgende doel om ze te combineren in één. U kunt veel methoden gebruiken om dit doel te bereiken, inclusief de optie Samenvoegen in de tabel Klanten , het dupliceren van een query of het verwijzen naar een query. In dit voorbeeld maakt u een verwijzing door de tabel Klanten te selecteren en vast te houden (met de rechtermuisknop te klikken) en Verwijzing te selecteren. Met deze actie maakt u een nieuwe query die verwijst naar de query Klanten .

Schermopname van het menu Klanten met de optie Verwijzing benadrukt.

Nadat u deze nieuwe query hebt gemaakt, wijzigt u de naam van de query in Land/regioanalyse en schakelt u de belasting van de tabel Klanten uit door de optie Laden inschakelen uit de query Leveranciers uit te schakelen.

Schermopname van de derde querynaam, gewijzigd naar Landanalyse, en de optie Leveranciers laden inschakelen niet gemarkeerd en benadrukt.

Zoekopdrachten samenvoegen

Met een samenvoegquery wordt een bewerking twee bestaande tabellen samengevoegd op basis van overeenkomende waarden uit één of meerdere kolommen. In dit voorbeeld is het doel om zowel de tabellen Klanten als Leveranciers samen te voegen in één tabel voor de landen/regio's met zowel Klanten als Leveranciers.

Selecteer in de query Analyse van land/regio de optie Query's samenvoegen op het tabblad Start op het lint.

Schermopname van de werkruimte Power Query waarin de query voor land-/regioanalyse is geselecteerd en de optie Query's samenvoegen op het tabblad Start benadrukt.

Er wordt een nieuw dialoogvenster voor de samenvoegbewerking weergegeven. Vervolgens kunt u de query selecteren die u wilt samenvoegen met uw huidige query. Selecteer in de tabel Rechts voor samenvoegen de query Leveranciers en selecteer vervolgens het veld Land/regio in beide query's. Selecteer ten slotte het type inner join, omdat u alleen de landen/regio's wilt waarin u klanten en leveranciers heeft voor deze analyse.

Schermopname van het dialoogvenster 'Query's samenvoegen' waarbij in beide query's de kolom Land/regio is geselecteerd en het type Binnenste join is geselecteerd.

Nadat u de knop OK hebt geselecteerd, wordt er een nieuwe kolom toegevoegd aan de query Land/regioanalyse die de gegevens uit de query Leveranciers bevat. Selecteer het pictogram naast het veld Leveranciers , waarin een menu wordt weergegeven waarin u kunt selecteren welke velden u wilt uitvouwen. Selecteer alleen het veld Leveranciers en selecteer vervolgens de knop OK.

Schermopname van de kolom Leveranciers met het menu Leveranciers geopend en alleen Leveranciers geselecteerd.

Het resultaat van deze uitvouwen bewerking is een tabel met slechts 12 rijen. Wijzig de naam van het veld Leveranciers.1 in Leveranciers door te dubbelklikken op de veldnaam en de nieuwe naam in te voeren.

Schermopname van de hernoemde kolom Leveranciers.

Notitie

Voor meer informatie over de functie Queries samenvoegen, kunt u naar Overzicht van Queries samenvoegengaan.

Toegepaste stappen

Elke transformatie die op uw query wordt toegepast, wordt opgeslagen als een stap in de Toegepaste stappen sectie van het deelvenster Queryinstellingen. Als u ooit wilt controleren hoe uw query wordt getransformeerd van stap tot stap, kunt u een stap selecteren en een voorbeeld bekijken van hoe uw query op dat specifieke punt wordt omgezet.

U kunt ook een query selecteren en vasthouden (met de rechtermuisknop klikken) en de optie Eigenschappen selecteren om de naam van de query te wijzigen of een beschrijving voor de query toe te voegen. Selecteer bijvoorbeeld de stap Query's samenvoegen in de query Analyse van land/regio en houd deze ingedrukt (klik er met de rechtermuisknop op). Wijzig vervolgens de naam van de query in Samenvoegen met leveranciers en de beschrijving in Gegevens ophalen uit de query Leveranciers voor Leveranciers op land/regio.

Schermopname van het dialoogvenster Eigenschappen van stap met de gewijzigde naam en beschrijving ingevuld.

Na deze wijziging kunt u de muisaanwijzer boven het pictogram voor de samenvoegquery in de diagramweergave houden of boven het nieuwe pictogram naast de stap in het deelvenster Toegepaste stappen houden om de beschrijving te lezen.

Schermopname die laat zien waar u kunt hoveren om de eigenschappen van de stap in te zien.

Notitie

Als u meer wilt weten over toegepaste stappen, gaat u naar Met de lijst Toegepaste stappen.

Voordat u een nieuwe kolom toevoegt, schakelt u de diagramweergave uit om alleen de voorbeeldweergave gegevens te gebruiken.

Een nieuwe kolom toevoegen

U kunt een nieuwe kolom toevoegen die wordt berekend op basis van bestaande kolommen. Met de gegevens voor klanten en leveranciers in één tabel kunt u nu de verhouding tussen klanten en leveranciers voor elk land/elke regio berekenen. Selecteer de laatste stap van de query Analyse van land/regio en selecteer vervolgens de kolommen Klanten en Leveranciers . Op het tabblad Kolom toevoegen in het lint en in de groep Van getal selecteert u Standaard en vervolgens Delen (geheel getal) in de vervolgkeuzelijst.

Schermopname van de werkruimte Power Query met het tabblad Kolom toevoegen en Standaard geselecteerd en de optie Delen (geheel getal) benadrukt.

Met deze wijziging maakt u een nieuwe kolom met de naam gehele getallen deling die u kunt hernoemen naar verhouding. Deze wijziging is de laatste stap van uw query en biedt de verhouding van de klant tot leverancier voor de landen/regio's waar de gegevens klanten en leveranciers hebben.

Gegevensprofilering

Gegevensprofilering is een Power Query functie waarmee u uw gegevens beter kunt begrijpen. Door de functies voor gegevensprofilering in te schakelen, krijgt u feedback over de gegevens in uw queryvelden, zoals waardedistributie, kolomkwaliteit en meer.

Gebruik deze functie tijdens de ontwikkeling van uw query's. U kunt de functie op uw gemak in- en uitschakelen. In de volgende afbeelding ziet u alle hulpprogramma's voor gegevensprofilering die zijn ingeschakeld voor uw query voor land-/regioanalyse .

Schermopname van de gegevensprofileringsgegevens met details voor de kolom Verhouding onderaan.

Notitie

Voor meer informatie over gegevensprofileringgaat u naar Met de hulpprogramma's voor gegevensprofilering.

De geavanceerde editor

Als u de code wilt observeren die door de Power Query editor wordt gemaakt met elke stap of als u uw eigen vormgevingscode wilt maken, kunt u de geavanceerde editor gebruiken. Als u de advanced editor wilt openen, selecteert u het tabblad Weergave op het lint en selecteert u vervolgens Geavanceerde editor. Er wordt een venster weergegeven met de bestaande querycode.

Schermopname van de geavanceerde editor, die code bevat zonder syntaxisfouten.

U kunt de code rechtstreeks bewerken in het venster Geavanceerde editor. De editor geeft aan of uw code vrij is van syntaxisfouten. Als u het venster wilt sluiten, selecteert u de knop Gereed of Annuleren.

Help voor Power Query openen

Er zijn verschillende helpniveaus die kunnen worden geopend in de Microsoft-apps die gebruikmaken van Power Query. In deze sectie worden deze Help-niveaus beschreven.

Power Query-hulp in Excel

Er zijn een aantal manieren om toegang te krijgen tot Power Query Help-informatie die specifiek van toepassing is op Power Query in Excel. Een manier om toegang te krijgen tot de online Excel Power Query documentatie is door File>Help>Help te selecteren in de Power Query-editor.

Als u de help-informatie in de inline Power Query in Excel wilt openen, selecteert u het tabblad Help op het Excel lint en voert u Power Query in het zoektekstvak in.

Power Query-hulp in Power BI Desktop

Er is een tabblad Help in de Power Query-editor die wordt uitgevoerd op Power BI Desktop, maar op dit moment gaan alle opties naar locaties die Power BI informatie leveren. U kunt dezelfde Power BI Help informatie ook bereiken in de Power Query-editor in Power BI Desktop door Bestand>Help te selecteren en vervolgens een van de Help-opties te selecteren.

Power Query hulp bij Power BI-service, Power Apps, Dynamics 365 Customer Insights en Azure Data Factory

Het tabblad Power Query Help in Power BI-service, Power Apps, Dynamics 365 Customer Insights en Azure Data Factory bevat koppelingen naar belangrijke informatiebronnen over Power Query.

Schermopname van het tabblad Help met de Power Query documentatie met alle help-, community- en feedbackopties weergegeven.

De opties op het tabblad Help bevatten koppelingen naar:

  • Power Query documentatie: Koppelingen naar de Power Query-documentatie
  • Toetsenbordsneltoetsen: Koppelingen naar het artikel met sneltoetsen in de documentatie van Power Query.
  • Support: Koppelingen naar de ondersteuningswebsite van het Microsoft product waarin Power Query momenteel wordt uitgevoerd.
  • Power Query website: Koppelingen naar de Power Query website.
  • Power Query blog: Koppelingen naar het Power Query blog
  • Power Query community: Koppelingen naar de Power Query-community.
  • Submit an idea: Koppelingen naar de ideeënwebsite van het Microsoft product waarin Power Query momenteel wordt uitgevoerd.
  • Feedback versturen: Hiermee opent u een venster in Power Query. In het venster wordt u gevraagd om uw ervaring te beoordelen met Power Query en om eventuele aanvullende informatie op te geven die u wilt leveren.

Notitie

Op dit moment bevat Azure Analysis Services geen inline Power Query Help-koppelingen. U kunt echter hulp krijgen voor Power Query M-functies. Meer informatie vindt u in de volgende sectie.

Help voor Power Query M-functies

Naast de Power Query Help-functies die in de vorige secties worden vermeld, kunt u ook hulp krijgen voor afzonderlijke M-functies vanuit de Power Query-editor. De stappen verschillen enigszins, afhankelijk van de versie die u gebruikt: Power Query Desktop (geïntegreerd in apps zoals Power BI Desktop) of Power Query Online (geïntegreerd in services zoals Power BI-service en gegevensstromen). In de volgende stappen wordt beschreven hoe u toegang krijgt tot deze inline-help.

  1. Met de Power Query-editor geopend, selecteer de knop Invoegen ().
  2. Voer in de formulebalk de naam in van een functie die u wilt controleren.
    1. Als u Power Query Desktop gebruikt, voert u een gelijkteken, een spatie en de naam van een functie in.
    2. Als u Power Query Online gebruikt, voert u de naam van een functie in.
  3. Selecteer de eigenschappen van de functie.
    1. Als u Power Query Desktop gebruikt, selecteert u in het deelvenster Query-instellingen onder PropertiesAlle eigenschappen.
    2. Als u Power Query Online gebruikt, selecteert u in het deelvenster Query SettingsProperties.

Met deze stappen opent u de help-informatie inline voor de geselecteerde functie en kunt u afzonderlijke eigenschappen invoeren die door de functie worden gebruikt.

Schermopname van de beschrijving en syntaxis van de functie Date.AddDays M, samen met toegangspunten voor elk van de parameters van de functie.

Samenvatting

In dit artikel hebt u een reeks query's gemaakt met Power Query die een verhoudingsanalyse van klanten tot leveranciers biedt op land/regio-niveau voor de Northwind Corporation.

U hebt de onderdelen van de Power Query gebruikersinterface geleerd, hoe u nieuwe query's maakt in de queryeditor, referentiequery's, samenvoegquery's, inzicht krijgt in de sectie toegepaste stappen en nieuwe kolommen toevoegt. U hebt ook geleerd hoe u de hulpprogramma's voor gegevensprofilering gebruikt om uw gegevens beter te begrijpen.

Power Query is een krachtig hulpprogramma dat wordt gebruikt om verbinding te maken met veel verschillende gegevensbronnen en de gegevens te transformeren in de gewenste vorm. De scenario's die in dit artikel worden beschreven, zijn voorbeelden om te laten zien hoe u Power Query kunt gebruiken om onbewerkte gegevens te transformeren in belangrijke bruikbare zakelijke inzichten.