Funkcje edytora kodu

Dotyczy:yes Visual Studio Visual Studio nodla komputerów Mac noVisual Studio Code

Edytor programu Visual Studio udostępnia wiele funkcji, które ułatwiają pisanie kodu i tekstu oraz zarządzanie nim. Możesz rozwinąć i zwinąć różne bloki kodu przy użyciu konspektowania. Aby dowiedzieć się więcej o kodzie, użyj funkcji IntelliSense, przeglądarki obiektów i hierarchii wywołań. Kod można znaleźć przy użyciu funkcji, takich jak Przejdź do, Przejdź do definicji i Znajdź wszystkie odwołania. Możesz wstawić bloki kodu z fragmentami kodu i wygenerować kod przy użyciu funkcji, takich jak Generowanie z użycia. Jeśli wcześniej nie używasz edytora programu Visual Studio, zobacz Learn to use the code editor (Dowiedz się, jak używać edytora kodu).

Uwaga

Ten temat dotyczy programu Visual Studio w systemie Windows. W przypadku programu Visual Studio dla komputerów Mac zobacz Edytor źródła (Visual Studio dla komputerów Mac).

Kod można wyświetlić na wiele różnych sposobów. Domyślnie Eksplorator rozwiązań wyświetla kod uporządkowany według plików. Możesz kliknąć kartę Widok klas w dolnej części okna, aby wyświetlić kod zorganizowany według klas.

Tekst można przeszukiwać i zastępować w jednym lub wielu plikach. Aby uzyskać więcej informacji, zobacz Znajdowanie i zastępowanie tekstu. Do znajdowania i zamieniania tekstu można użyć wyrażeń regularnych. Aby uzyskać więcej informacji, zobacz Używanie wyrażeń regularnych w programie Visual Studio.

Różne języki programu Visual Studio oferują różne zestawy funkcji, a w niektórych przypadkach funkcje zachowują się inaczej w różnych językach. Wiele z tych różnic jest określonych w opisach funkcji, ale aby uzyskać więcej informacji, można zobaczyć sekcje dotyczące określonych języków programu Visual Studio.

Funkcje edytora

Cecha Opis
Kolorowanie składni Niektóre elementy składniowe plików kodu i znaczników są kolorowane inaczej, aby je odróżnić. Na przykład słowa kluczowe (takie jak using w języku C# i Imports Visual Basic) są jednym kolorem, ale typy (takie jak Console i Uri) są innym kolorem. Inne elementy składni są również kolorowane, takie jak literały ciągów i komentarze. Język C++ używa koloru, aby rozróżniać między innymi typy, wyliczenia i makra.

Możesz zobaczyć domyślny kolor dla każdego typu i można zmienić kolor dla dowolnego określonego elementu składni w oknie dialogowym Czcionki i kolory, Środowisko, Opcje, które można otworzyć z menu Narzędzia .
Znaczniki błędów i ostrzeżeń Podczas dodawania kodu i kompilowania rozwiązania mogą być widoczne (a) różne kolorowe faliste podkreślenia (znane jako zygzaki) lub (b) żarówki pojawiające się w kodzie. Czerwone zygzaki oznaczają błędy składni, niebieski oznacza błędy kompilatora, zielony oznacza ostrzeżenia i fioletowy oznacza inne typy błędów. Szybkie akcje sugerują poprawki problemów i ułatwiają stosowanie poprawki.

Domyślny kolor każdego błędu i przełącznika ostrzegawczego można zobaczyć w oknie dialogowym Narzędzia>Opcje>czcionki środowiska> i kolory. Poszukaj błędu składni, błędu kompilatora, ostrzeżenia i innego błędu.
Dopasowywanie nawiasów klamrowych Gdy punkt wstawiania jest umieszczany na otwartym nawiasie klamrowym w pliku kodu, wyróżnione są zarówno nawiasy klamrowe, jak i zamykające. Ta funkcja zapewnia natychmiastową opinię na temat zagubionych lub brakujących nawiasów klamrowych. Można włączyć lub wyłączyć dopasowywanie nawiasów klamrowych przy użyciu ustawienia automatycznego wyróżniania ogranicznika (Narzędzia>Opcje>Edytor tekstu). Kolor wyróżnienia można zmienić w ustawieniu Czcionki i kolory (Środowisko opcji> narzędzi>). Wyszukaj dopasowywanie nawiasów klamrowych (wyróżnienie) lub dopasowywanie nawiasów klamrowych (prostokąt).
Wizualizator struktury Linie kropkowane łączą pasujące nawiasy klamrowe w plikach kodu, co ułatwia otwieranie i zamykanie par nawiasów klamrowych. Może to pomóc w szybkim znalezieniu kodu w bazie kodu. Te wiersze można włączać lub wyłączać za pomocą wytycznych dotyczących wyświetlania struktury w sekcji Wyświetlanie na stronieOgólneedytora> tekstuOpcje>narzędzi>.
Numery wierszy Numery wierszy można wyświetlić na lewym marginesie okna kodu. Nie są one domyślnie wyświetlane. Tę opcję można włączyć w ustawieniach Edytor tekstu Wszystkie języki (Narzędzia>Opcje>Edytor> tekstuWszystkie języki). Numery wierszy dla poszczególnych języków programowania można wyświetlić, zmieniając ustawienia dla tych języków (Narzędzia>Opcje>języka> edytora<>tekstów). W przypadku numerów wierszy do wydrukowania należy wybrać pozycję Uwzględnij numery wierszy w oknie dialogowym Drukowanie .
Śledzenie zmian Kolor lewego marginesu umożliwia śledzenie zmian wprowadzonych w pliku. Zmiany wprowadzone od momentu otwarcia pliku, ale nie zostały zapisane, są oznaczone żółtym paskiem na lewym marginesie (nazywanym marginesem zaznaczenia). Po zapisaniu zmian (ale przed zamknięciem pliku) pasek zmieni kolor na zielony. Jeśli cofniesz zmianę po zapisaniu pliku, pasek zmieni kolor na pomarańczowy. Aby wyłączyć tę funkcję i włączyć, zmień opcję Śledź zmiany w ustawieniach edytora tekstu (Narzędzia>Opcje>Edytor tekstu).
Wybieranie kodu i tekstu Możesz zaznaczyć tekst w standardowym trybie ciągłego strumienia lub w trybie skrzynkowym, w którym zamiast zestawu wierszy wybiera się prostokątną część tekstu. Aby zaznaczyć zaznaczenie w trybie pola, naciśnij klawisze Alt podczas przeciągania myszy nad zaznaczeniem (lub naciśnijklawisz> strzałki Alt<+Shift+). Zaznaczenie zawiera wszystkie znaki w prostokącie zdefiniowanym przez pierwszy znak i ostatni znak w zaznaczeniu. Wszystkie wpisane lub wklejone do wybranego obszaru są wstawiane w tym samym punkcie w każdym wierszu.
Zoom Możesz powiększyć lub powiększyć dowolne okno kodu, naciskając i trzymając naciśnięty klawisz Ctrl i przesuwając kółko przewijania myszy (lub Ctrl+Shift+. w celu zwiększenia i naciśnięcia klawisza Ctrl+Shift+w celu zmniejszenia). Możesz również użyć pola Powiększenie w lewym dolnym rogu okna kodu, aby ustawić określony procent powiększenia . Funkcja powiększenia nie działa w oknach narzędzi.
Przestrzeń wirtualna Domyślnie wiersze w edytorach programu Visual Studio kończą się po ostatnim znaku, dzięki czemu klawisz Strzałka w prawo na końcu wiersza przenosi kursor na początek następnego wiersza. W niektórych innych edytorach wiersz nie kończy się po ostatnim znaku i można umieścić kursor w dowolnym miejscu w wierszu. Możesz włączyć przestrzeń wirtualną w edytorze w ustawieniach Narzędzia>Opcje>Edytor> tekstuWszystkie języki. Należy pamiętać, że możesz włączyć przestrzeń wirtualną lub zawijanie wyrazów, ale nie obie te elementy.
Drukowanie Opcje w oknie dialogowym Drukowanie umożliwiają dołączenie numerów wierszy lub ukrycie zwiniętych regionów kodu podczas drukowania pliku. W oknie dialogowym Ustawienia strony możesz również wydrukować pełną ścieżkę i nazwę pliku, wybierając pozycję Nagłówek strony.

Opcje drukowania kolorów można ustawić w oknie dialogowym Narzędzia>Opcje> Czcionkiśrodowiskowe>i kolory. Wybierz pozycję Drukarka na liście Pokaż ustawienia, aby dostosować drukowanie kolorów. Można określić różne kolory drukowania pliku niż do edycji pliku.
Cofnij globalne i wykonaj ponownie Polecenia Cofnij ostatnią akcję globalną i Wykonaj ponownie ostatnią akcję globalną w menu Edycja cofnij lub wykonaj ponownie akcje globalne, które mają wpływ na wiele plików. Akcje globalne obejmują zmianę nazwy klasy lub przestrzeni nazw, wykonywanie operacji znajdowania i zastępowania w rozwiązaniu, refaktoryzowanie bazy danych lub dowolną inną akcję, która zmienia wiele plików. Polecenia cofania globalnego i ponownego wykonania można zastosować do akcji w bieżącej sesji programu Visual Studio, nawet po zamknięciu rozwiązania, w którym zastosowano akcję.

Zaawansowane funkcje edycji

Na pasku narzędzi można znaleźć wiele funkcji zaawansowanych w menu Edytuj>zaawansowane . Nie wszystkie te funkcje są dostępne dla wszystkich typów plików kodu.

Cecha Opis
Formatuj dokument Ustawia odpowiednie wcięcie wierszy kodu i przenosi nawiasy klamrowe do oddzielnych wierszy w dokumencie.
Formatowanie zaznaczenia Ustawia odpowiednie wcięcie wierszy kodu i przenosi nawiasy klamrowe do oddzielnych wierszy w zaznaczeniu.
Tabify Selected Lines Zmiany prowadzące spacje do kart tam, gdzie jest to konieczne.
Wyrejeowywanie zaznaczonych wierszy Zmienia wiodące karty na spacje. Jeśli chcesz przekonwertować wszystkie spacje w pliku na karty (lub wszystkie karty do spacji), możesz użyć Edit.ConvertSpacesToTabs poleceń i Edit.ConvertTabsToSpaces . Te polecenia nie są wyświetlane w menu programu Visual Studio, ale można je wywołać w oknie Szybki dostęp lub w oknie polecenia.
Utwórz wielkie litery Zmienia wszystkie znaki w zaznaczeniu na wielkie litery lub jeśli nie ma zaznaczenia, zmienia znak w punkcie wstawiania na wielkie litery. Skrót: Ctrl+Shift+U.
Ustaw małe litery Zmienia wszystkie znaki w zaznaczeniu na małe litery lub jeśli nie ma zaznaczenia, zmienia znak w punkcie wstawiania na małe litery. Skrót: Ctrl+U.
Przenieś zaznaczone linie w górę Przenosi zaznaczoną linię w górę o jeden wiersz. Skrót: Alt+Strzałka w górę.
Przenieś zaznaczone linie w dół Przenosi zaznaczoną linię w dół o jeden wiersz. Skrót: Alt+Strzałka w dół.
Usuń poziome białe znaki Usuwa karty lub spacje na końcu bieżącego wiersza. Skrót: Ctrl+K, Ctrl+\
Wyświetl białe znaki Wyświetla spacje jako podniesione kropki i karty jako strzałki. Koniec pliku jest wyświetlany jako prostokątny glif. Jeśli wybrano opcje Narzędzia>Edytor>>tekstuWszystkie języki>Word Zawijanie>widoczne glyphs dla zawijania wyrazów jest również wyświetlane.
Zawijanie wierszy Powoduje, że wszystkie wiersze w dokumencie będą widoczne w oknie kodu. Możesz wyłączyć zawijanie wyrazów i włączyć w edytorze tekstów Wszystkie ustawienia języków (Narzędzia>Opcje>Edytor> tekstuWszystkie języki).
Wybór komentarza Dodaje znaki komentarza do zaznaczenia lub bieżącego wiersza. Skrót: Ctrl+K, Ctrl+C
Usuń znaczniki komentarza Usuwa znaki komentarza z zaznaczenia lub bieżącego wiersza. Skrót: Ctrl+K, Ctrl+U
Zwiększ wcięcie wiersza Dodaje kartę (lub równoważne spacje) do wybranych wierszy lub bieżącego wiersza.
Zmniejsz wcięcie wiersza Usuwa kartę (lub równoważne spacje) z wybranych wierszy lub bieżącego wiersza.
Wybierz tag W dokumencie zawierającym tagi (na przykład XML lub HTML) wybiera tag.
Wybieranie zawartości tagu W dokumencie zawierającym tagi (na przykład XML lub HTML) wybiera zawartość.

Możesz poruszać się w edytorze kodu na kilka różnych sposobów, w tym przechodzenie do tyłu i do przodu do poprzednich punktów wstawiania, wyświetlanie definicji typu lub elementu członkowskiego i przechodzenie do określonej metody przy użyciu paska nawigacyjnego. Aby uzyskać więcej informacji, zobacz Nawigowanie po kodzie.

Znajdowanie odwołań w bazie kodu

Aby dowiedzieć się, gdzie znajdują się odwołania do określonych elementów kodu w bazie kodu, możesz użyć polecenia Znajdź wszystkie odwołania lub naciśnij klawisz Shift+F12. Ponadto po kliknięciu typu lub elementu członkowskiego funkcja wyróżniania odwołania automatycznie wyróżnia wszystkie odwołania do tego typu lub elementu członkowskiego. Aby uzyskać więcej informacji, zobacz Znajdowanie odwołań w kodzie.

Generowanie, naprawianie lub refaktoryzacja kodu

Istnieje wiele sposobów, na które program Visual Studio może pomóc w generowaniu, naprawianiu i refaktoryzacji kodu.

  • Możesz użyć fragmentów kodu , aby wstawić szablon, taki jak blok przełącznika lub deklaracja wyliczenia .

  • Możesz użyć szybkich akcji , aby wygenerować kod, taki jak klasy i właściwości, lub wprowadzić zmienną lokalną. Możesz również użyć szybkich akcji, aby ulepszyć kod, na przykład w celu usunięcia niepotrzebnych rzutów i nieużywanych zmiennych lub dodania kontroli wartości null przed uzyskaniem dostępu do zmiennych.

  • Możesz refaktoryzować kod , aby zmienić nazwę zmiennej, zmienić kolejność parametrów metody lub zsynchronizować typ z jego nazwą, aby wymienić kilka.

Dopasowywanie edytora

Ustawienia programu Visual Studio możesz udostępnić innym deweloperom, ustawienia są zgodne ze standardem lub powrócić do ustawień domyślnych programu Visual Studio przy użyciu kreatora importu i eksportu ustawień w menu Narzędzia . W Kreatorze ustawień importu i eksportu można zmienić wybrane ustawienia ogólne lub język i ustawienia specyficzne dla projektu.

Aby zdefiniować nowe klucze dostępu lub ponownie zdefiniować istniejące klucze dostępu, przejdź do pozycji Narzędzia>Opcje>Klawiatura środowiskowa>. Aby uzyskać więcej informacji na temat klawiszy dostępu, zobacz Domyślne skróty klawiaturowe.

Aby uzyskać informacje o opcjach edytora specyficznych dla języka JavaScript, zobacz Opcje edytora Języka JavaScript.

Zobacz też