Verileri dönüştürmek için Power Query'yi kullanma

Power Query ile birçok farklı veri kaynağına bağlanabilir ve verileri istediğiniz şekle dönüştürebilirsiniz.

Bu makalede şunları keşfederek Power Query ile sorgu oluşturmayı öğreneceksiniz:

  • Power Query'de Veri al deneyiminin nasıl çalıştığı.
  • Power Query kullanıcı arabirimini kullanma ve bu arabirimden yararlanma.
  • Verileri gruplandırma ve birleştirme gibi yaygın dönüştürmeleri gerçekleştirme.

Power Query yeniyseniz başlamadan önce ücretsiz Power BI deneme sürümüne kaydolabilirsiniz. Bu makalede açıklanan Power Query Online deneyimlerini denemek için Power BI veri akışlarını kullanabilirsiniz.

Ayrıca Power BI Desktop'u ücretsiz olarak indirebilirsiniz.

Bu makaledeki örnekler Northwind OData akışına bağlanıpkullanır.

OData akışına bağlanma

Not

Power Query içeren Microsoft ürünlerinin her birinden veri alma konusunda daha fazla bilgi edinmek için Veri nereden alınır sayfasına gidin.

Başlamak için Veri al deneyiminde OData akış bağlayıcısını bulun. Sağ üst köşedeki arama çubuğunda OData arayabilirsiniz.

OData bağlayıcısının vurgulanmış olduğu Veri alma deneyiminin Veri kaynağı seçin sayfasının ekran görüntüsü.

Bu bağlayıcıyı seçtikten sonra ekranda bağlantı ayarları ve kimlik bilgileri gösterilir.

  • URL için Northwind OData akışı URL'sini girin: https://services.odata.org/V4/Northwind/Northwind.svc/.
  • Şirket içi veri ağ geçidiiçin, ayarları "yok" olarak bırakın.
  • Kimlik Doğrulaması türüiçin anonim olarak ayarlayın.

İleri düğmesini seçin.

Gezgini açılır ve burada veri kaynağından bağlanmak istediğiniz tabloları seçersiniz. Müşteriler tablosunu seçerek verilerin önizlemesini yükleyin ve ardından Verileri dönüştürseçin.

Müşteriler tablosunun vurgulanmış olduğu Power Query Gezgini sayfasının ekran görüntüsü.

Daha sonra, iletişim kutusu Müşteriler tablosundaki verileri Power Query düzenleyicisine yükler.

Verilerinize bağlanma, kimlik doğrulama yöntemini belirtme ve bağlanılacak nesne veya tabloyu seçme deneyimi,veri alma deneyimi olarak adlandırılır. Bu deneyim, Veri almaya genel bakış makalesinde daha ayrıntılı olarak belgelenmiştir.

Not

OData akışı bağlayıcısı hakkında daha fazla bilgi edinmek için OData Akışı'na gidin.

Power Query düzenleyicisinin bileşenleri

Tip

Power BI'da Power Query düzenleyicisini bulmak için Sorgular altında Transform data öğesini seçin.

 Power BI Giriş çubuğunun Ekran görüntüsü ve Verileri dönüştür düğmesi vurgulanmış.

Power Query düzenleyicisi Power Query kullanıcı arabirimini temsil eder. Bu kullanıcı arabiriminde sorguları ekleyebilir veya değiştirebilir, sorgu adımlarını gruplandırarak veya açıklama ekleyerek sorguları yönetebilir ya da sorgularınızı ve bunların yapısını farklı görünümlerle görselleştirebilirsiniz. Power Query kullanıcı arabiriminin beş ayrı bileşeni vardır. Aşağıdaki tablodaki numaralar, ekran görüntüsündeki numaralı açıklamalara karşılık gelir.

Power Query kullanıcı arabirimi ekran görüntüsü, her bileşeni ana hatlarıyla ve numaralandırılmış olarak gösterilmiştir.

# Bileşen Description
1 Şerit Dönüştürmeler eklemek, sorgunuz için seçenekler belirlemek ve çeşitli görevleri tamamlamak üzere farklı şerit düğmelerine erişmek için birden çok sekme sunan şerit gezinme deneyimi.
2 Sorgular bölmesi Tüm kullanılabilir sorgularınızın görünümü.
3 Geçerli görünüm Varsayılan olarak sorgunuz için verilerin önizlemesini gösteren ana çalışma görünümünüz. Veri önizleme görünümüyle birlikte diyagram görünümünü de etkinleştirebilirsiniz. Diyagram görünümünü korurken şema görünümü ile veri önizleme görünümü arasında da geçiş yapabilirsiniz.
4 Sorgu ayarları Sorgu adı, sorgu adımları ve çeşitli göstergeler gibi ilgili bilgilerle seçili durumdaki sorgunun görünümü.
5 Durum çubuğu Yürütme süresi, toplam sütun ve satırlar ve işleme durumu gibi sorgunuzla ilgili önemli bilgileri gösteren çubuk. Bu çubuk, geçerli görünümünüzü değiştirmek için düğmeler de içerir.

Not

Şema ve diyagram görünümü şu anda yalnızca Power Query Online'da kullanılabilir.

Power Query düzenleyicisinde verileri dönüştürmeden önce, kullanıcı arabirimi bölmelerini genişletmeyi veya daraltmayı ve görünümler arasında geçiş yapmayı bilmenize yardımcı olur. Uygun bölmeleri seçtiğinizde sizin için en önemli görünüme odaklanabilirsiniz. Aşağıdaki bölümlerde, Power Query kullanıcı arabiriminde kullanılabilen bölmeler ve görünümler ele alınmaktadır.

Power Query düzenleyicisi şeridi

Şerit, Power Query düzenleyicisinde yapabileceğiniz dönüşümlerin ve eylemlerin çoğunu bulabileceğiniz bileşendir. Değerleri ürün tümleştirmesine bağlı olan birden çok sekmesi vardır. Sekmelerin her biri belirli düğmeler ve seçenekler sağlar ve bunların bazıları tüm Power Query deneyiminde yedekli olabilir. Bu düğmeler ve seçenekler, ihtiyaç duyabileceğiniz dönüşümlere ve eylemlere kolay erişim sağlar.

 Power Query kullanıcı arabiriminin Giriş sekmesindeki standart şerit görünümünün ekran görüntüsü.

Power Query arabirimi yanıt verir ve size en iyi deneyimi göstermek için ekran çözünürlüğünüzü ayarlamaya çalışır. Şeridin kompakt bir sürümünü kullanmak istediğiniz senaryolarda, şeridin sağ alt köşesinde sıkıştırılmış şeride geçmenize yardımcı olacak bir daralt düğmesi de vardır.

 Power Query kullanıcı arabiriminin Giriş sekmesindeki sıkıştırılmış şerit görünümünün ekran görüntüsü.

Şeridin sağ alt köşesindeki genişlet simgesini seçerek standart şerit görünümüne geri dönebilirsiniz.

Power Query bölmelerini genişletme ve daraltma

Power Query kullanıcı arabiriminde belirli görünümleri veya bölümleri daraltmanıza veya genişletmenize yardımcı olan simgeler olduğunu fark edebilirsiniz. Örneğin, Sorgular bölmesinin sağ üst köşesinde, seçildiğinde sorgular bölmesini daraltan ve yeniden seçildiğinde bölmeyi genişleten bir simge vardır.

Sorgular bölmesini daraltmak ve genişletmek için kullanılan Sorgular bölmesindeki simgeyi vurgulayan ekran görüntüsü.

Power Query görünümleri arasında geçiş yapma

Power Query kullanıcı arabiriminde belirli bölmeleri ve bölümleri daraltabilmenin dışında, hangi görünümlerin görüntüleneceğini de değiştirebilirsiniz. Görünümler arasında geçiş yapmak için şeritteki View sekmesine gidin ve Preview ve Layout gruplarını bulun. Bu sekme, Power Query kullanıcı arabiriminin nasıl görüneceğini denetler.

En rahat çalıştığınız görünümü ve düzeni bulmak için bu seçeneklerin tümünü denemeniz tavsiye edilir. Örnek olarak, şeritten Şema görünümü seçin.

Screenshot, Power Query şeridindeki Görünüm sekmesinde bulunan Şema görünümü düğmesini vurgular.

Durum çubuğunun sağ tarafında diyagram, veriler ve şema görünümleri için simgeler de bulunur. Görünümler arasında değişiklik yapmak için bu simgeleri kullanabilirsiniz. Bu simgeleri, tercih ettiğiniz görünümü etkinleştirmek veya devre dışı bırakmak için de kullanabilirsiniz.

Sorgular bölmesinin daraltıldığı ve geçerli görünümün şema görünümüne geçtiği ve şema görünümü simgesinin vurgulandığı ekran görüntüsü.

Power Query şema görünümü nedir?

Şema görünümü, yalnızca tablonuzun sütun adları ve veri türleri gibi şema bileşenleriyle etkileşim kurmanız için hızlı ve kolay bir yol sunar. Şemayla ilgili eylemleri gerçekleştirmek istediğinizde şema görünümünü öneririz. Bu eylemler sütunları kaldırmak, sütunları yeniden adlandırmak, sütun veri türlerini değiştirmek, sütunları yeniden sıralamak veya sütunları çoğaltmak olabilir.

Not

Şema görünümü hakkında daha fazla bilgi edinmek için Şema görünümünü kullanmabölümüne gidin.

Örneğin, şema görünümünde, Siparişler ve CustomerDemographics sütunlarının yanındaki onay işaretlerini seçin ve şeritten Sütunları kaldır eylemini seçin. Bu seçim, bu sütunları verilerinizden kaldırmak için bir dönüştürme uygular.

Orders ve CustomerDemographics sütunlarının seçili olduğu ekran görüntüsü ve Sütunları kaldır seçeneği vurgulanmış.

Power Query diyagram görünümü nedir?

Artık veri önizleme görünümüne geri dönebilir ve diyagram görünümünü etkinleştirerek verilerinizin ve sorgunuzun daha görsel bir bakış açısını kullanabilirsiniz.

Diyagram görünümü ve veri önizleme görünümü simgelerini vurgulayan ekran görüntüsü.

Diyagram görünümü, sorgunuzun nasıl yapılandırıldığını ve projenizdeki diğer sorgularla nasıl etkileşim kurabileceğini görselleştirmenize yardımcı olur. Sorgunuzdaki her adımın, kullanılan dönüşümü tanımanıza yardımcı olacak ayrı bir simgesi vardır. Satırlar bağımlılıkları göstermek için adımları birbirine bağlar. Hem veri önizleme görünümü hem de diyagram görünümü etkinleştirildiğinden, veri önizlemesinin üzerinde diyagram görünümü görüntülenir.

Power Query çalışma alanında, veri önizlemesi ile birlikte diyagram görünümünü gösteren ekran görüntüsü.

Not

Diyagram görünümü hakkında daha fazla bilgi edinmek içinDiyagram görünümü'ne gidin.

Diyagram görünümünde müşterileri ülkeye/bölgeye göre gruplandırma

Ülke/bölge başına müşterileri saymak için Dönüşüme göre gruplandırma ekleyin. Diyagram görünümü etkinken artı işaretini seçin. Sorgunuza eklemek için yeni bir dönüşüm arayabilirsiniz. 'ye göre Grubu ara ve dönüşümü seç.

Diyagram görünümünde grup araması içeren ekran görüntüsü.

Ardından Grupla iletişim kutusu görüntülenir. Gruplandırma ölçütü işlemini ülkeye/bölgeye göre gruplandıracak şekilde ayarlayabilir ve ülke/bölge başına müşteri satırlarının sayısını sayabilirsiniz.

  1. Temel radyo düğmesini seçili tutun.
  2. Gruplandırmak için Ülke/bölge'yi seçin.
  3. Yeni sütun adı olarak Müşteriler girin ve işlem olarak Satırları Say seçin.

Müşterilerin verilerinin girilmiş olduğu temel Grup iletişim kutusunun ekran görüntüsü.

Tamam seçeneğini işlemi gerçekleştirmek için seçin. Veri önizlemeniz, ülkeye/bölgeye göre toplam müşteri sayısını gösterecek şekilde yenilenir.

Gruplandır iletişim kutusunu başlatmanın alternatif bir yolu, şeritteki Gruplandırma ölçütü düğmesini kullanmak veya Ülke/bölge sütununu seçmek ve basılı tutmaktır (sağ tıklayın).

Şeritteki Gruplandır düğmesini ve ülke/bölge sütun menüsünde gruplandır seçeneğini vurgulayan ekran görüntüsü.

Kolaylık sağlamak için, Power Query dönüşümlere genellikle birden çok yerden erişilebilir, böylece kullanıcılar tercih ettikleri deneyimi kullanmayı tercih edebilir.

Yeni sorgu ekleme

Ülke/bölge başına müşteri sayısını sağlayan bir sorgunuz olduğuna göre, her ülke/bölge için toplam tedarikçi sayısını bularak bu verilere bağlam ekleyebilirsiniz.

İlk olarak, Sağlayıcılar verilerini eklemeniz gerekir. Veri al'ı seçin. Veri kaynağı seçinbölümünde ODataiçin arama yapın. Ardından OData bağlayıcısını seçin.

OData bağlayıcısının vurgulanmış olduğu Veri kaynağı seçin sayfasının ekran görüntüsü.

OData bağlantı deneyimi yeniden görünür. Northwind OData akışına bağlanmak için OData akışına bağlanma bölümünde açıklandığı gibi bağlantı ayarlarını girin. Navigator deneyiminde Sağlayıcılar tablosunu arayın ve seçin.

 Northwind OData sağlayıcılarının seçili olduğu Power Query gezgininin ekran görüntüsü.

Yeni sorguyu Power Query düzenleyicisine eklemek için Create öğesini seçin. Şimdi hem Müşteriler hem de Sağlayıcılar sorgusunu gösteren Sorgular bölmesini genişletin.

Hem müşteriler hem de sağlayıcı sorgularını vurgulayan Sorgular bölmesinin ekran görüntüsü.

göre gruplandır iletişim kutusunu yeniden açın, bu kez Dönüştür sekmesinin altındaki şeritteki Gruplandır düğmesini seçerek.

Gruplandırma vurgulanmış olarak Dönüştür sekmesi şeridinin bir bölümünün ekran görüntüsü.

Gruplandırma ölçütü iletişim kutusunda Gruplandırma ölçütü işlemini ülkeye/bölgeye göre gruplandıracak şekilde ayarlayın ve ülke/bölge başına tedarikçi satır sayısını sayın.

  1. Temel radyo düğmesini seçili tutun.
  2. Gruplandırmak için Ülke/bölge'yi seçin.
  3. Yeni sütun adı içine Sağlayıcılar girin ve İşlemiçinde satırları say seçin.

Tedarikçi verilerinin girilmiş olduğu temel Grup iletişim kutusunun ekran görüntüsü.

Not

Grubunu dönüşümüyle ilgili daha fazla bilgi edinmek için, satırları gruplandırma veya özetlemebölümüne gidin.

Referans sorguları

Bir sorguya başvurduğunuz zaman, var olan bir sorgunun çıkışını gösteren yeni bir sorgu oluşturursunuz. Müşteriler için bir sorgunuz ve tedarikçiler için bir sorgunuz olduğuna göre, bir sonraki hedefiniz bunları tek bir sorguda birleştirmektir. Müşteriler tablosundaki Birleştir seçeneği, bir sorguyu yineleme veya sorguya başvurma dahil olmak üzere bu hedefe ulaşmak için birçok yöntem kullanabilirsiniz. Bu örnek için, Customers tablosunu seçip basılı tutarak (sağ tıklayarak) ve Reference seçeneğini belirleyerek bir referans oluşturun. Bu eylem , Müşteriler sorgusuna başvuran yeni bir sorgu oluşturur.

Başvuru seçeneğinin vurgulanmış olduğu Müşteriler menüsünün ekran görüntüsü.

Bu yeni sorguyu oluşturduktan sonra, Sağlayıcılar sorgusundaki Yüklemeyi etkinleştir seçeneğini temizleyerek sorgunun adını Ülke/bölge Analizi olarak değiştirin ve Müşteriler tablosunun yükünü devre dışı bırakın.

Ülke Analizi olarak değiştirilen üçüncü sorgu adının ekran görüntüsü ve Sağlayıcılar Yüklemeyi etkinleştir seçeneği işaretlenmemiş ve vurgulanmış.

Sorguları birleştirme

birleştirme sorguları işlemi, bir veya birden çok sütundaki eşleşen değerlere göre iki mevcut tabloyu birleştirir. Bu örnekte amaç, hem Müşterileri hem de Sağlayıcılar tablolarını yalnızca hem Müşterileri hem de Sağlayıcılarolan ülkeler/bölgeler için tek bir tabloda birleştirmektir.

Ülke/bölge Analizi sorgusunun içinde, şeritteki Giriş sekmesinde Sorguları birleştir seçeneğini belirleyin.

Ülke/bölge Çözümleme sorgusunun seçili olduğu ve Giriş sekmesinde sorguları birleştir seçeneğinin vurgulanmış olduğu Power Query çalışma alanının ekran görüntüsü.

Birleştirme işlemi için yeni bir iletişim kutusu görüntülenir. Ardından, geçerli sorgunuzla birleştirmek için sorguyu seçebilirsiniz. Birleştirme için Sağ tablodaSağlayıcılar sorgusunu seçin ve ardından her iki sorgudan da Ülke/bölge alanını seçin. Son olarak, bu analiz için yalnızca Müşteriler ve Sağlayıcılar bulunduğunuz ülkeleri/bölgeleri seçmek amacıyla İç birleştirme türünü seçin.

Hem sorgularda ülke/bölge sütununun hem de İç birleşim türünün seçili olduğu Sorguları birleştir iletişim kutusunun ekran görüntüsü.

Tamam düğmesini seçtikten sonra, Ülke/bölge Analizi sorgunuza Sağlayıcılar sorgusundaki verileri içeren yeni bir sütun eklenir. Hangi alanları genişletmek istediğinizi seçebileceğiniz bir menüyü gösteren Sağlayıcılar alanının yanındaki simgeyi seçin. Yalnızca Sağlayıcılar alanını seçin ve Tamam düğmesini seçin.

Sağlayıcılar menüsünün açık ve yalnızca Sağlayıcılar'ın seçili olduğu Sağlayıcılar sütununun ekran görüntüsü.

Bu genişletme işleminin sonucu, yalnızca 12 satırı olan bir tablodur. Alan adına çift tıklayıp yeni adı girerek Suppliers.1 alanını yalnızca Suppliers olarak yeniden adlandırın.

Yeniden adlandırılan Sağlayıcılar sütununun ekran görüntüsü.

Not

Sorguları Birleştirme özelliği hakkında daha fazla bilgi edinmek için Sorguları Birleştirme Genel Bakışbölümüne gidin.

Uygulanan adımlar

Sorgunuza uygulanan her dönüştürme, sorgu ayarları bölmesinin Uygulanan adımlar bölümüne bir adım olarak kaydedilir. Sorgunuzun adım adım nasıl dönüştürüldüğünü denetlemeniz gerekirse, bir adım seçebilir ve sorgunuzun bu noktada nasıl çözümlendiğinin önizlemesini görüntüleyebilirsiniz.

Ayrıca bir sorguyu seçip tutabilir (sağ tıklayabilir) ve Özellikler seçeneğini belirleyerek sorgunun adını değiştirebilir veya sorgu için bir açıklama ekleyebilirsiniz. Örneğin, Ülke/bölge Analizi sorgusundan Sorguları birleştir adımını seçip basılı tutun (sağ tıklayın) ve sorgunun adını Sağlayıcılarla Birleştir olarak, açıklamayı da Ülkeye/bölgeye göre Sağlayıcılar sorgusu için Sağlayıcılar sorgusundan veri alma olarak değiştirin.

Değiştirilen ad ve açıklamanın doldurulduğu Adım özellikleri iletişim kutusunun ekran görüntüsü.

Bu değişiklik sonrasında, diyagram görünümünde birleştirme sorgusu simgesinin üzerine gelebilir veya açıklamasını okumak için Uygulanan adımlar bölmesindeki adımınızın yanındaki yeni simgenin üzerine gelebilirsiniz.

Adım özelliklerini görüntülemek için üzerine gelinecek yeri gösteren ekran görüntüsü.

Not

Uygulanan adımlar hakkında daha fazla bilgi edinmek içinUygulanan Adımlar listesini kullanma bölümüne gidin.

Yeni sütun eklemeden önce Yalnızca Veri önizlemesini kullanmak için Diyagram görünümünü devre dışı bırakın.

Yeni sütun ekleme

Mevcut sütunlardan hesaplanan yeni bir sütun ekleyebilirsiniz. Müşteriler ve tedarikçilerin verileri tek bir tabloda yer alırsa, artık her ülke/bölge için müşteriden tedarikçiye oranı hesaplayabilirsiniz. Ülke/bölge Analizi sorgusunun son adımını seçin ve ardından hem Müşteriler hem de Sağlayıcılar sütunlarını seçin. Şeritteki Sütun ekle sekmesinde, Sayıdan grubunda Standart'ı seçin ve ardından açılan listeden Böl (Tamsayı) seçeneğini belirleyin.

Sütun ekle sekmesi ve Standart'ın seçili olduğu Power Query çalışma alanının ekran görüntüsü ve Böl (Tamsayı) seçeneği vurgulanmış.

Bu değişiklik, Tamsayı bölme adlı, Oranolarak yeniden adlandırabileceğiniz yeni bir sütun oluşturur. Bu değişiklik sorgunuzun son adımıdır ve verilerin müşterileri ve tedarikçilerinin bulunduğu ülkeler/bölgeler için müşteriden tedarikçiye oranı sağlar.

Veri profili oluşturma

Veri profili oluşturma, verilerinizi daha iyi anlamanıza yardımcı olan Power Query bir özelliktir. Veri profili oluşturma özelliklerini etkinleştirerek, değer dağıtımı, sütun kalitesi ve daha fazlası gibi sorgu alanlarınızın içindeki veriler hakkında geri bildirim alırsınız.

Sorgularınızın geliştirilmesi boyunca bu özelliği kullanın. Özelliği istediğiniz zaman etkinleştirebilir ve devre dışı bırakabilirsiniz. Aşağıdaki görüntüde Ülke/bölge Analizi sorgunuz için etkinleştirilen tüm veri profili oluşturma araçları gösterilmektedir.

En alttaki Oran sütununun ayrıntılarını içeren veri profili oluşturma bilgilerinin ekran görüntüsü.

Not

Veri profili oluşturmahakkında daha fazla bilgi edinmek için veri profili oluşturma araçlarını kullanma bölümüne gidin.

Gelişmiş düzenleyici

Power Query düzenleyicisinin her adımda oluşturduğu kodu gözlemlemek veya kendi şekillendirme kodunuzu oluşturmak istiyorsanız, gelişmiş düzenleyiciyi kullanabilirsiniz. advanced editor açmak için şeritteki View sekmesini ve ardından Gelişmiş Düzenleyici seçin. Var olan sorgu kodunu gösteren bir pencere görüntülenir.

Söz dizimi hatası olmayan kod içeren gelişmiş düzenleyicinin ekran görüntüsü.

Kodu doğrudan Gelişmiş Düzenleyici penceresinde düzenleyebilirsiniz. Düzenleyici, kodunuzun söz dizimi hatası içermediğini belirtir. Pencereyi kapatmak için Tamam veya İptal düğmesini seçin.

Power Query yardımına erişin

Power Query kullanan Microsoft uygulamalarında erişilebilen çeşitli yardım düzeyleri vardır. Bu bölümde bu yardım düzeyleri açıklanmaktadır.

Excel'de Power Query yardımı

Excel'daki Power Query için özel olarak geçerli olan Power Query yardım bilgilerine erişmenin birkaç yolu vardır. Çevrimiçi Excel Power Query belgelerine erişmenin bir yolu, Power Query düzenleyicisinde File>Help>Help seçmektir.

Excel'da satır içi Power Query yardım bilgilerine erişmek için, Excel şeridinde Help sekmesini seçin ve arama metin kutusuna Power Query girin.

Power BI Desktop'ta Power Query yardımı

Power BI Desktop'ta çalışan Power Query düzenleyicisinde Help sekmesi vardır, ancak şu anda tüm seçenekler Power BI bilgileri sağlayan konumlara gider. Ayrıca Power BI Desktop'taki Power Query düzenleyicisinde Dosya, ardından Yardım seçeneklerini seçerek bu Power BI Yardım bilgilerine erişebilirsiniz.

Power BI hizmeti, Power Apps, Dynamics 365 Customer Insights ve Azure Data Factory'de Power Query yardımı

Power BI hizmeti, Power Apps, Dynamics 365 Customer Insights ve Azure Data Factory'daki Power Query Help sekmesi, Power Query hakkında önemli bilgi kaynaklarının bağlantılarını içerir.

 Tüm yardım, topluluk ve geri bildirim seçeneklerinin görüntülendiği Power Query belgeleriyle birlikte yardım sekmesinin ekran görüntüsü.

Yardım sekmesindeki seçenekler şunlara bağlantılar içerir:

  • Power Query belgeleri: Power Query belgelerine bağlantılar
  • Keyboard kısayolları: Power Query belgelerindeki klavye kısayolları makalesinin bağlantıları.
  • Support: Power Query çalışmakta olan Microsoft ürünün destek web sitesine bağlantılar.
  • Power Query web sitesi: Power Query web sitesine bağlantılar.
  • Power Query blog: Power Query blogunun bağlantıları
  • Power Query community: Power Query topluluğuna bağlantılar.
  • Submit an idea: Power Query'in çalıştığı Microsoft ürününün fikirler web sitesine bağlantı.
  • Geri bildirim gönder: Power Query'da bir pencere açar. Pencere, Power Query deneyiminizi derecelendirmenizi ve sağlamak istediğiniz ek bilgileri sağlamanızı ister.

Not

Şu anda Azure Analysis Services satır içi Power Query yardım bağlantısı içermez. Ancak Power Query M işlevleri için yardım alabilirsiniz. Sonraki bölümde daha fazla bilgi yer alır.

Power Query M işlevleri için yardım

Önceki bölümlerde listelenen Power Query yardım işlevlerine ek olarak, Power Query düzenleyicisinin içinden tek tek M işlevleri için de yardım alabilirsiniz. Adımlar, kullandığınız sürüme göre biraz farklılık gösterir: Power Query Desktop (Power BI Desktop gibi uygulamalarla tümleşik) veya Power Query Online (Power BI hizmeti ve Veri Akışları gibi hizmetlerle tümleşik). Aşağıdaki adımlarda bu satır içi yardıma nasıl ulaşıldığı açıklanmaktadır.

  1. Power Query düzenleyicisi açıkken ekle adımını ( ) düğmesini seçin.
  2. Formül çubuğuna denetlemek istediğiniz işlevin adını girin.
    1. Power Query Desktop kullanıyorsanız, bir eşittir işareti, boşluk ve işlevin adını girin.
    2. Power Query Online kullanıyorsanız işlevin adını girin.
  3. İşlevin özelliklerini seçin.
    1. Power Query Desktop kullanıyorsanız, Query Ayarları bölmesinde, Properties altında Tüm özellikler'yi seçin.
    2. Power Query Online kullanıyorsanız, Query Ayarları bölmesinde Properties öğesini seçin.

Bu adımlar, seçtiğiniz işlevin satır içi yardım bilgilerini açar ve işlev tarafından kullanılan tek tek özellikleri girmenizi sağlar.

Date.AddDays M işlevi açıklamasının ve söz diziminin ekran görüntüsü ile işlevin parametrelerinin her biri için giriş noktaları.

Özet

Bu makalede, Northwind şirketi için ülke/bölge düzeyinde müşteriden tedarikçiye oran analizi sağlayan Power Query içeren bir dizi sorgu oluşturdunuz.

Power Query kullanıcı arabiriminin bileşenlerini, sorgu düzenleyicisinde yeni sorgular oluşturmayı, sorgulara başvurmayı, sorguları birleştirmeyi, uygulanan adımlar bölümünü anlamayı ve yeni sütunlar eklemeyi öğrendinsiniz. Ayrıca verilerinizi daha iyi anlamak için veri profili oluşturma araçlarını kullanmayı da öğrendinsiniz.

Power Query, birçok farklı veri kaynağına bağlanmak ve verileri istediğiniz şekle dönüştürmek için kullanılan güçlü bir araçtır. Bu makalede özetlenen senaryolar, ham verileri önemli eyleme dönüştürülebilir iş içgörülerine dönüştürmek için Power Query nasıl kullanabileceğinizi gösteren örneklerdir.