Hinweis
Für den Zugriff auf diese Seite ist eine Autorisierung erforderlich. Sie können versuchen, sich anzumelden oder das Verzeichnis zu wechseln.
Für den Zugriff auf diese Seite ist eine Autorisierung erforderlich. Sie können versuchen, das Verzeichnis zu wechseln.
Gilt für: ✔️ Windows-VMs
Dieser Artikel enthält Schritte zur Behebung von Problemen, bei denen der Datenträger in einem virtuellen Azure-Computer (VM) nicht gelesen werden kann.
Symptome
Wenn Sie Startdiagnose um den Screenshot der virtuellen Maschine (VM) zu betrachten, werden Sie feststellen, dass der Screenshot eine Aufforderung anzeigt, welche die Meldung „Ein Fehler beim Lesen des Datenträgers ist aufgetreten. Drücken Sie Strg+Alt+Entf, um neu zu starten." enthält.
Ursache
Diese Fehlermeldung gibt an, dass die Datenträgerstruktur beschädigt und nicht mehr lesbar ist. Wenn Sie einen virtuellen Computer der Generation 1 verwenden, ist es auch möglich, dass die Datenträgerpartition, die die Startkonfigurationsdaten enthält, nicht auf Active festgelegt ist.
Lösung
Übersicht über den Prozess
Tipp
Wenn Sie über eine aktuelle Sicherung der VM verfügen, können Sie versuchen, die VM aus der Sicherung wiederherzustellen, um das Startproblem zu beheben.
- Erstellen Sie eine Reparatur-VM, und greifen Sie darauf zu.
- Wählen Sie eine Lösung aus:
- Aktivieren Sie die serielle Konsole und die Speicherabbilderfassung.
- Erstellen Sie den virtuellen Computer neu.
Notiz
Wenn dieser Startfehler auftritt, ist das Gastbetriebssystem nicht funktionsfähig. Sie müssen die Problembehandlung im Offlinemodus durchführen, um dieses Problem zu beheben.
Erstellen und Aufrufen einer Reparatur-VM
- Führen Sie die Schritte 1-3 der VM-Reparaturbefehle aus, um eine Reparatur-VM vorzubereiten.
- Stellen Sie über eine Remotedesktopverbindung eine Verbindung mit der Reparatur-VM her.
Festlegen des Partitionsstatus auf „Active“
Notiz
Diese Entschärfung gilt nur für VMs der Generation 1. VMs der Generation 2 (mit UEFI) verwenden keine aktive Partition.
Fügen Sie den Systemdatenträger an einen virtuellen Wiederherstellungscomputer an.
Stellen Sie eine Remotedesktopverbindung mit dem virtuellen Wiederherstellungscomputer her.
Öffnen Sie Computerverwaltung>Datenträgerverwaltung. Stellen Sie sicher, dass der Datenträger in der Datenträgerverwaltungskonsole als Online gekennzeichnet ist. Achten Sie auf den Laufwerkbuchstaben, der dem angefügten Systemdatenträger zugewiesen ist.
Identifizieren Sie die Startpartition und die Windows-Partition. Wenn nur eine Partition auf dem Betriebssystemdatenträger vorhanden ist, ist diese Partition sowohl Startpartition als auch Windows-Partition.
Wenn der Betriebssystemdatenträger mehrere Partitionen enthält, können Sie die Partitionen identifizieren, indem Sie die Ordner darin anzeigen:
Die Windows-Partition enthält einen Ordner mit dem Namen Windows, und diese Partition ist größer als die anderen.
Die Startpartition enthält einen Ordner mit dem Namen "Start". Dieser Ordner ist standardmäßig ausgeblendet. Um den Ordner sichtbar zu machen, müssen Sie die ausgeblendeten Dateien und Ordner einblenden und die Option Geschützte Systemdateien ausblenden (empfohlen) deaktivieren. Die Startpartition hat in der Regel eine Größe von etwa 300 MB bis 500 MB.
Führen Sie den folgenden Befehl als Administrator aus, um einen Startdatensatz zu erstellen:
bcdboot <Windows partition>:\Windows /S <windows partition>:
Verwenden Sie das DISKPART-Tool, um zu überprüfen, ob die Windows-Partition aktiv ist:
Öffnen Sie eine Eingabeaufforderung mit erhöhten Rechten, und öffnen Sie das DISKPART-Tool.
diskpart
Listen Sie die Datenträger auf dem System auf, und suchen Sie nach hinzugefügten Datenträgern, und fahren Sie mit der Auswahl des neuen Datenträgers fort. In diesem Beispiel ist der neue Datenträger Datenträger 1.
list disk sel disk 1
Listet alle Partitionen auf diesem Datenträger auf, und fahren Sie dann mit der Auswahl der Partition fort, die Sie überprüfen möchten. In der Regel sind vom System verwaltete Partitionen kleiner und ca. 350 MB groß. In der folgenden Abbildung ist diese Partition Partition 1.
list partition sel partition 1
Überprüfen Sie den Status der Partition. In unserem Beispiel ist Partition 1 nicht aktiv.
detail partition
Wenn die Partition nicht aktiv ist, ändern Sie das Aktive Flag, und überprüfen Sie dann erneut, ob die Änderung ordnungsgemäß durchgeführt wurde.
active detail partition
Beenden Sie das DISKPART-Tool.
exit
Korrigieren der Datenträgerpartition
Öffnen Sie eine Eingabeaufforderung mit erhöhten Rechten (cmd.exe).
Verwenden Sie den folgenden Befehl, um CHKDSK für die Datenträger auszuführen und Fehler zu beheben:
chkdsk <DRIVE LETTER>: /f
Durch das Hinzufügen der Befehlsoption /f werden alle Fehler auf dem Datenträger behoben. Sie müssen dabei < LAUFWERKSBUCHSTABE > durch den Buchstaben der angefügten Betriebssystem-VHD ersetzen.
Aktivieren der seriellen Konsole und der Speicherabbilderfassung
Wichtig
Dieser Abschnitt, diese Methode bzw. diese Aufgabe enthält eine Beschreibung der Schritte zum Bearbeiten der Registrierung. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher müssen Sie sicherstellen, dass Sie diese Schritte sorgfältig ausführen. Erstellen Sie eine Sicherungskopie der Registrierung, bevor Sie Änderungen vornehmen, damit Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie unter: Sichern und Wiederherstellen der Registrierung Windows.
Empfohlen: Bevor Sie die VM neu erstellen, aktivieren Sie die serielle Konsole und die Speicherabbilderfassung, indem Sie diese Schritte ausführen:
Öffnen Sie eine Eingabeaufforderungssitzung als Administrator.
Führen Sie die folgenden BCDEdit-Befehle mit den Optionen /ems und /emssettings aus:
Aktivieren Sie die serielle Konsole:
bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
Überprüfen Sie, ob der freie Speicherplatz auf dem Betriebssystemdatenträger größer als die Größe des Arbeitsspeichers (RAM) auf der VM ist.
Wenn nicht genügend Speicherplatz auf dem Betriebssystemdatenträger vorhanden ist, ändern Sie den Speicherort, an dem die Speicherabbilddatei erstellt wird, und verweisen Sie auf einen beliebigen Datenträger, der an die VM angeschlossen ist und über ausreichend freien Speicherplatz verfügt. Um den Speicherort zu ändern, ersetzen Sie in den folgenden Befehlen
%SystemRoot%
durch den Laufwerksbuchstaben des Datenträgers, beispielsweiseF:
.Um die Speicherabbilddatei des Betriebssystems zu aktivieren, führen Sie die folgenden Befehle load, add und unload aus, um die vorgeschlagene Konfiguration mithilfe des Tools reg zu implementieren:
Laden der Registrierungsstruktur vom beschädigten Betriebssystem-Datenträger:
reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
Aktivieren für „ControlSet001“:
reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Aktivieren für „ControlSet002“:
reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Entladen des beschädigten Betriebssystemdatenträgers:
reg unload HKLM\<broken-system>
Neuerstellen der VM
Verwenden Sie Schritt 5 der VM-Reparaturbefehle, um die VM neu zu erstellen.
Kontaktieren Sie uns für Hilfe
Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.