Freigeben über


Windows-Stoppfehler 0xC0000102 Statusdatei beschädigt

Gilt für: ✔️ Windows-VMs

Dieser Artikel enthält Schritte zum Beheben von Problemen, bei denen das Windows-Betriebssystem (Os) den Stoppfehler 0xC0000102 auftritt, wodurch ein virtueller Azure-Computer (VM) nicht gestartet wird.

Symptome

Wenn Sie die Startdiagnose verwenden, um den Screenshot des virtuellen Computers anzuzeigen, zeigt der Screenshot die Meldung an, dass der Betriebssystemfehlercode während des Starts 0xC0000102.

Der Screenshot zeigt die detaillierten Informationen zu Fehler 0xC0000102.

Fehler 0xC0000102 auf einem CMD-Bildschirm.

Ursache

Fehler 0xC0000102 ist ein STATUS_FILE_CORRUPT_ERROR, was bedeutet, dass eine beschädigte Datei verhindert, dass Ihre VM ordnungsgemäß gestartet wird. Für diesen Fehlercode gibt es zwei mögliche Ursachen:

  • Die in der Fehlermeldung angezeigte Datei ist beschädigt.
  • Die Datenträgerstruktur ist beschädigt und unlesbar geworden.

Lösung

Versuchen Sie die VM aus einem Backup wiederherzustellen.

Wenn Sie über eine kürzliche Sicherung der VM verfügen, versuchen Sie möglicherweise, den virtuellen Computer aus der Sicherung wiederherzustellen, um das Startproblem zu beheben. Wenn das Wiederherstellen des virtuellen Computers aus der Sicherung nicht möglich ist, führen Sie die folgenden Schritte aus:

  1. Erstellen und Aufrufen einer Reparatur-VM
  2. Reparieren oder Ersetzen der beschädigten Datei
  3. Aktivieren der seriellen Konsole und der Speicherabbilderfassung
  4. Neuerstellen der VM

Notiz

Wenn dieser Fehler auftritt, ist das Gastbetriebssystem nicht funktionsfähig. Sie müssen die Problembehandlung im Offlinemodus durchführen, um dieses Problem zu beheben.

Schritt 1: Erstellen und Aufrufen einer Reparatur-VM

  1. Führen Sie die Schritte 1-3 des Vm-Reparaturprozesses aus , um eine Reparatur-VM vorzubereiten.
  2. Stellen Sie über eine Remotedesktopverbindung eine Verbindung mit der Reparatur-VM her.

Schritt 2: Reparieren oder Ersetzen der beschädigten Datei

Reparieren oder ersetzen Sie die beschädigte binärdatei (.sys), indem Sie die folgenden Schritte ausführen:

Reparieren der beschädigten Binärdatei

Öffnen Sie eine CMD-Eingabeaufforderung mit erhöhten Rechten, und führen Sie "chkdsk" auf dem Datenträger aus:

chkdsk <drive-letter>: /F

Ersetzen der beschädigten Binärdatei

  1. Suchen Sie auf dem angehängten Datenträger nach dem Speicherort der Binärdatei, die in der Fehlermeldung angezeigt wird.

  2. Benennen Sie die Datei von binärname>.sys in< binärname.sys.old um>.<

  3. Navigieren Sie auf dem angefügten Datenträger zum Ordner \Windows\WinSxS . Suchen Sie dann nach der Binärdatei, die in der Fehlermeldung angezeigt wird. Verwenden Sie dazu den folgenden Befehl in einer Eingabeaufforderung:

    dir <binary-name> /s
    

    Der Befehl listet alle verschiedenen Versionen der Binärdatei zusammen mit dem Erstellungsdatum auf. Kopieren Sie die neueste Version der Binärdatei in den Ordner \Windows\System32\Drivers , indem Sie den folgenden Befehl ausführen:

    copy <drive>:\Windows\WinSxS\<directory-where-file-is>\<binary-name>.sys <drive>:\Windows\System32\Drivers\
    

    Sehen Sie sich zum Beispiel die folgende Konsolenausgabe an:

    E:\Windows\WinSxS>dir ACPI.sys /s 
     Volume in drive E has no label. 
     Volume Serial Number is A0B1-C2D3 
    
     Directory of E:\Windows\WinSxS\amd64_acpi.inf_0123456789abcdef_6.3.9600.16384_none_cdef0123456789ab 
    
    11/21/2014  07:48 PM            94,989 acpi.sys 
                   1 File(s)         94,989 bytes 
    
     Directory of E:\Windows\WinSxS\amd64_acpi.inf_0123456789abcdef_6.3.9600.16384_none_89abcdef01234567 
    
    11/21/2014  07:48 PM           119,547 acpi.sys 
                   1 File(s)        119,547 bytes 
    
     Directory of E:\Windows\WinSxS\amd64_acpi.inf_0123456789abcdef_6.3.9600.16384_none_456789abcdef0123 
    
    11/21/2014  04:06 PM           533,824 acpi.sys 
                   1 File(s)        533,824 bytes 
    
         Total Files Listed: 
                   3 File(s)        748,360 bytes 
                   0 Dir(s)  123,967,512,576 bytes free 
    
    E:\Windows\WinSxS>copy E:\Windows\WinSxS\amd64_acpi.inf_0123456789abcdef_6.3.9600.16384_none_cdef0123456789ab\acpi.sys E:\Windows\System32\Drivers\ 
            1 file(s) copied. 
    
    E:\Windows\WinSxS> 
    

    Notiz

    • Wenn die System-Binärdatei nicht umbenannt werden kann, übernehmen Sie den Besitz der Datei. Mit dieser Aktion erhalten Sie vollzugriff auf diese Datei.

    • Die Beispielkonsolenausgabe zeigt die Lautstärke E als Beispiel an. Der tatsächliche Buchstabe sollte dem fehlerhaften Laufwerk entsprechen (das Betriebssystemlaufwerk, das als Datenlaufwerk mit der VM zur Problembehandlung verbunden ist).

    • Wenn die neueste Binärdatei nicht funktioniert, können Sie die vorherige Dateiversion ausprobieren, um eine frühere Systemaktualisierungsstufe für diese Komponente zu erhalten.

    • Wenn die einzige Binärdatei, die in diesem Schritt zurückgegeben wird, mit der Datei übereinstimmt, die Sie auf der betroffenen VM ersetzen möchten, und wenn beide Dateien dieselbe Größe und denselben Zeitstempel haben, können Sie die beschädigte Datei ersetzen, indem Sie sie von einer anderen funktionierenden VM mit demselben Betriebssystem und, wenn möglich, derselben Systemaktualisierungsstufe kopieren.

  4. Trennen Sie den reparierten Datenträger von der VM, auf der Sie die Problembehandlung ausführen. Erstellen Sie dann einen virtuellen Computer vom Betriebssystemdatenträger.

Schritt 3: Aktivieren der seriellen Konsole und der Speicherabbildsammlung

Vor der Neuerstellung des virtuellen Computers empfiehlt es sich, die Speicherabbilderfassung und die serielle Konsole zu aktivieren. Führen Sie dazu die folgenden Schritte aus:

  1. Öffnen Sie eine Eingabeaufforderungssitzung als Administrator.

  2. Führen Sie die folgenden BCDEdit-Befehle mit den Optionen /ems und /emssettings aus:

    Aktivieren Sie die serielle Konsole:

    bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON
    bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
    
  3. Überprüfen Sie, ob der freie Speicherplatz auf dem Betriebssystemdatenträger größer als die Größe des Arbeitsspeichers (RAM) auf der VM ist.

    Wenn nicht genügend Speicherplatz auf dem Betriebssystemdatenträger vorhanden ist, ändern Sie den Speicherort, an dem die Speicherabbilddatei erstellt wird, und verweisen Sie auf einen beliebigen Datenträger, der an die VM angeschlossen ist und über ausreichend freien Speicherplatz verfügt. Um den Speicherort zu ändern, ersetzen Sie in den folgenden Befehlen %SystemRoot% durch den Laufwerksbuchstaben des Datenträgers, beispielsweise F:.

    Um die Speicherabbilddatei des Betriebssystems zu aktivieren, führen Sie die folgenden Befehle load, add und unload aus, um die vorgeschlagene Konfiguration mithilfe des Tools reg zu implementieren:

    Laden der Registrierungsstruktur vom beschädigten Betriebssystem-Datenträger:

    reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
    

    Aktivieren für „ControlSet001“:

    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

    Aktivieren für „ControlSet002“:

    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

    Entladen des beschädigten Betriebssystemdatenträgers:

    reg unload HKLM\<broken-system>
    

Schritt 4: Neuerstellen der VM

Verwenden Sie Schritt 5 der VM-Reparaturbefehle, um die VM neu zu erstellen.

Kontaktieren Sie uns für Hilfe

Wenn Sie Fragen haben oder Hilfe mit Ihren Azure-Gutschriften benötigen, dann erstellen Sie beim Azure-Support eine Support-Anforderung oder fragen Sie den Azure Community-Support. Sie können auch Produktfeedback an die Azure Feedback Community senden.