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Gilt für: ✔️ Windows-VMs
In diesem Artikel finden Sie Schritte zum Beheben von Problemen, bei denen ein kritischer Prozess während des Starts auf einem virtuellen Azure-Computer abstürzt.
Symptom
Wenn Sie die Startdiagnose verwenden, um den Screenshot des virtuellen Computers anzuzeigen, wird im Screenshot der Fehler #0x000000EF mit der Meldung Critical Process Died angezeigt.
Ursache
Dies ist in der Regel darauf zurückzuführen, dass während des Starts ein kritischer Systemprozess fehlschlägt. Weitere Informationen zu Problemen in Bezug auf kritische Prozesse finden Sie unter „Fehlerprüfung 0xEF: CRITICAL_PROCESS_DIED“.
Lösung
Prozessübersicht
Tipp
Wenn Sie über eine aktuelle Sicherung der VM verfügen, können Sie versuchen, die VM aus der Sicherung wiederherzustellen, um das Startproblem zu beheben.
- Erstellen Sie eine Reparatur-VM, und greifen Sie darauf zu.
- Beheben Sie Beschädigungen des Betriebssystems.
- Empfohlen: Aktivieren der seriellen Konsole und der Speicherabbildsammlung vor der Neuerstellung der VM.
- Erstellen Sie den virtuellen Computer neu.
Notiz
Wenn dieser Startfehler auftritt, ist das Gastbetriebssystem nicht funktionsfähig. Sie müssen die Problembehandlung im Offlinemodus durchführen, um dieses Problem zu beheben.
Erstellen und Aufrufen einer Reparatur-VM
- Führen Sie die Schritte 1-3 der VM-Reparaturbefehle aus, um eine Reparatur-VM vorzubereiten.
- Stellen Sie über eine Remotedesktopverbindung eine Verbindung mit der Reparatur-VM her.
Beheben aller Beschädigungen des Betriebssystems
Öffnen Sie eine Eingabeaufforderung mit erhöhten Rechten.
Führen Sie den folgenden SFC-Befehl (System File Checker) aus:
sfc /scannow /offbootdir=<BOOT DISK DRIVE>:\ /offwindir=<BROKEN DISK DRIVE>:\windows
- Hierbei ist
<BOOT DISK DRIVE>
die Startpartition der defekten VM und<BROKEN DISK DRIVE>
die Betriebssystempartition der defekten VM. Ersetzen Sie die Symbole „Größer als“/„Kleiner als“ sowie den darin enthaltenen Text (z. B. „<Text hier>“) durch den entsprechenden Buchstaben.
- Hierbei ist
Führen Sie als Nächstes Schritt 5 der VM-Reparaturbefehle aus, um die VM zu reassemblieren und zu überprüfen, ob sie startet.
Wenn die VM dennoch nicht startet, erfassen Sie die Speicherabbilddatei.
Erfassen der Speicherabbilddatei
Wenn das Problem nach dem Ausführen von SFC weiterhin besteht, muss die Speicherabbilddatei analysiert werden, um die Ursache des Problems zu ermitteln. Führen Sie die folgenden Schritte aus, um die Speicherabbilddatei zu erfassen:
Schritt 1: Suchen der Speicherabbilddatei und Erstellen eines Supporttickets
Teil 1: Anfügen des Betriebssystemdatenträgers an eine VM für die Wiederherstellung
Erstellen Sie eine Momentaufnahme des Betriebssystemdatenträgers der betroffenen VM, um ein Backup zu erstellen. Weitere Informationen finden Sie unter Erstellen einer Momentaufnahme eines virtuellen Datenträgers.
Fügen Sie den Betriebssystemdatenträger an einen virtuellen Computer für die Wiederherstellung an.
Verwenden Sie das Remotedesktopprotokoll (RDP), um eine Remoteverbindung zur Wiederherstellungs-VM herzustellen.
Wenn der Betriebssystemdatenträger der betroffenen VM verschlüsselt ist, deaktivieren Sie die Verschlüsselung, bevor Sie mit dem nächsten Schritt fortfahren. Weitere Informationen finden Sie unter Entschlüsseln des verschlüsselten Betriebssystemdatenträgers.
Teil 2: Suchen nach der Speicherabbilddatei und Senden eines Supporttickets
Wechseln Sie auf der Wiederherstellungs-VM in den Ordner Windows auf dem angeschlossenen Betriebssystemdatenträger. Lautet der Laufwerksbuchstabe des angeschlossenen Betriebssystemdatenträgers beispielsweise F, wechseln Sie zu F:\Windows.
Suchen Sie die Datei Memory.dmp, erstellen Sie ein Supportticket und hängen Sie die Speicherabbilddatei an.
Wenn Sie die Speicherabbilddatei nicht finden können, fahren Sie mit den nächsten Schritten fort, um das Abbildprotokoll und die serielle Konsole zu aktivieren, und reproduzieren Sie dann das Problem.
Schritt 2: Aktivieren des Abbildprotokolls und der seriellen Konsole
Wichtig
Dieser Abschnitt, diese Methode bzw. diese Aufgabe enthält eine Beschreibung der Schritte zum Bearbeiten der Registrierung. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher müssen Sie sicherstellen, dass Sie diese Schritte sorgfältig ausführen. Erstellen Sie eine Sicherungskopie der Registrierung, bevor Sie Änderungen vornehmen, damit Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie unter: Sichern und Wiederherstellen der Registrierung Windows.
Führen Sie die folgenden Schritte aus, um das Abbildprotokoll und die serielle Konsole zu aktivieren:
Öffnen Sie eine Eingabeaufforderungssitzung als Administrator.
Führen Sie die folgenden BCDEdit-Befehle mit den Optionen /ems und /emssettings aus:
Aktivieren Sie die serielle Konsole:
bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
Überprüfen Sie, ob der freie Speicherplatz auf dem Betriebssystemdatenträger größer als die Größe des Arbeitsspeichers (RAM) auf der VM ist.
Wenn nicht genügend Speicherplatz auf dem Betriebssystemdatenträger vorhanden ist, ändern Sie den Speicherort, an dem die Speicherabbilddatei erstellt wird, und verweisen Sie auf einen beliebigen Datenträger, der an die VM angeschlossen ist und über ausreichend freien Speicherplatz verfügt. Um den Speicherort zu ändern, ersetzen Sie in den folgenden Befehlen
%SystemRoot%
durch den Laufwerksbuchstaben des Datenträgers, beispielsweiseF:
.Um die Speicherabbilddatei des Betriebssystems zu aktivieren, führen Sie die folgenden Befehle load, add und unload aus, um die vorgeschlagene Konfiguration mithilfe des Tools reg zu implementieren:
Laden der Registrierungsstruktur vom beschädigten Betriebssystem-Datenträger:
reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
Aktivieren für „ControlSet001“:
reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Aktivieren für „ControlSet002“:
reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Entladen des beschädigten Betriebssystemdatenträgers:
reg unload HKLM\<broken-system>
Empfohlen: Bevor Sie den virtuellen Computer neu erstellen, aktivieren Sie die serielle Konsole und die Speicherabbildsammlung.
Führen Sie die folgenden Schritte aus, um die serielle Konsole und die Speicherabbildsammlung zu aktivieren:
Öffnen Sie eine Eingabeaufforderungssitzung als Administrator.
Führen Sie die folgenden BCDEdit-Befehle mit den Optionen /ems und /emssettings aus:
Aktivieren Sie die serielle Konsole:
bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
Überprüfen Sie, ob der freie Speicherplatz auf dem Betriebssystemdatenträger größer als die Größe des Arbeitsspeichers (RAM) auf der VM ist.
Wenn nicht genügend Speicherplatz auf dem Betriebssystemdatenträger vorhanden ist, ändern Sie den Speicherort, an dem die Speicherabbilddatei erstellt wird, und verweisen Sie auf einen beliebigen Datenträger, der an die VM angeschlossen ist und über ausreichend freien Speicherplatz verfügt. Um den Speicherort zu ändern, ersetzen Sie in den folgenden Befehlen
%SystemRoot%
durch den Laufwerksbuchstaben des Datenträgers, beispielsweiseF:
.Um die Speicherabbilddatei des Betriebssystems zu aktivieren, führen Sie die folgenden Befehle load, add und unload aus, um die vorgeschlagene Konfiguration mithilfe des Tools reg zu implementieren:
Laden der Registrierungsstruktur vom beschädigten Betriebssystem-Datenträger:
reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
Aktivieren für „ControlSet001“:
reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Aktivieren für „ControlSet002“:
reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Entladen des beschädigten Betriebssystemdatenträgers:
reg unload HKLM\<broken-system>
Neuerstellen der ursprünglichen VM
Führen Sie Schritt 5 der VM-Reparaturbefehle aus, um die VM zu reassemblieren.
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