Error code :80180006

Chadi Boustani 200 Reputation points
2024-01-11T08:44:32.21+00:00

Hello Everyone. Trying to enroll devices with microsoft intune using company portal. When trying to sign in receiving error code :80180006 Server message: Unknown error code 0x80180006 Environment is WIN 10 pro 22H2: build 19045. Any advice on how to fix? Thanks

Microsoft Intune
Microsoft Intune
A Microsoft cloud-based management solution that offers mobile device management, mobile application management, and PC management capabilities.
4,609 questions
{count} votes

22 answers

Sort by: Most helpful
  1. rbish 81 Reputation points
    2024-01-19T23:52:02.19+00:00

    We submitted ticket to MS for this issue and we were told that we need to totally turn off WIP, leaving only MDM on within Entra.

    Go to your entra home page, and open the "Mobility..." Service by searching for it in the top - should show up as "Mobility (MDM and WIP)"
    Or you can just open this direct shortcut to that spot: https://entra.microsoft.com/#view/Microsoft_AAD_IAM/MdmList.ReactView Now open "Microsoft Intune", and ensure the top "MDM" function is set to "ALL" and that the bottom section for "WIP" is set to "None".
    We are still trying to verify if this actually fixes the issue for everybody without breaking anything for anybody else, but that is what MS suport told us to do.

    14 people found this answer helpful.

  2. Matthew Grant 60 Reputation points
    2024-01-12T22:59:52.4933333+00:00

    Found an odd workaround for the moment to this issue.

    1. under search> Manage your account>access work or school> Enroll only in device management. Then add accounts as normal. Restart
    2. Then under company portal register user as normal, however uncheck "allow company to manage your device" . Where it normally throws the 80006 error it will complete as normal. Then I was able to use bitlocker, save the key to azure and intune admin showed device registered
    9 people found this answer helpful.

  3. Koushik Barua 45 Reputation points
    2024-01-19T11:50:18.2666667+00:00

    Found a solution that effectively addressed the issue in our environment. The key was adjusting the MAM user scope settings. Initially, the MAM user scope was set to 'All users,' which usually gives priority to the Company Portal enrolment MAM over the MDM. By changing this setting to 'None,' I was able to resolve the conflict.

    https://learn.microsoft.com/en-us/windows/client-management/mdm-diagnose-enrollment
    User's image

    8 people found this answer helpful.

  4. Anonymous
    2024-01-23T04:49:21.38+00:00

    This is beyond a joke. I’m having a total meltdown over this grotesque issue. No comms from Support or solutions that actually work. Has rendered devices beyond the initial one that had issues without access to apps and files.

    5 people found this answer helpful.

  5. Graham Smith 20 Reputation points
    2024-01-15T13:58:31.2433333+00:00

    I had exactly the same error message with Windows 11. I can't get a screenshot anymore however what worked for me was NOT registering by supplying an email address to the text box that is initially presented, but rather by clicking a link towards the bottom of the dialog box that was something like "connect to Microsoft Entra" (not exact words but similar). All working fine after registering via that link.

    4 people found this answer helpful.