Partager via


Dépannez vos flux de travail automatisés Business Central

Lorsque vous vous connectez Business Central avec Power Automate pour créer des flux de travail automatisés, des messages d’erreur peuvent apparaitre. Cet article fournit des suggestions de solution aux problèmes récurrents.

Le flux ne s’exécute pas sur tous les enregistrements créés ou modifiés

Problème

Si un événement crée ou modifie de nombreux enregistrements, le flux ne s’exécute pas sur certains ou sur tous les enregistrements.

Cause possible

Actuellement, le nombre d’enregistrements traités par un flux est limité. Si plus de 1000 enregistrements sont créés ou modifiés en 30 secondes, le flux n’est pas déclenché.

Remarque

Pour les développeurs, le déclenchement du flux se fait par les notifications webhook et cette limitation est due à la façon dont le connecteur Business Central gère les notifications collection. En savoir plus sur Utilisation des webhooks dans Dynamics 365 Business Central dans l’aide pour les développeurs et les administrateurs.

Erreur « La réponse du service Business Central est trop volumineuse »

Problème

Lorsque vous utilisez une action qui interagit avec des enregistrements (comme Créer un enregistrement (V3) et Obtenir un enregistrement (V3)), Power Automate une erreur similaire à celle-ci peut s’afficher :

The response from the Business Central service is too large

Cause possible

Même si Business Central n’a pas défini de limite sur la taille des enregistrements renvoyés par les API, le connecteur Dynamics 365 Business Central pour Power Automate ne peut gérer que les enregistrements jusqu’à 8 Mo.

Toutes les API Business Central fournies par Microsoft renvoient des enregistrements inférieurs à cette limite, mais les API fournies par des partenaires peuvent ne pas le faire. Si vous voyez une erreur « La réponse du service Business Central est trop volumineuse », contactez le partenaire qui a créé l’API que vous utilisez.

Erreur « Ensemble d’entités introuvable »

Problème

Lorsque vous créez un flux Power Automate en utilisant un déclencheur d’approbation Business Central, comme Lorsque l’approbation d’un document achat est exigée, un message d’erreur identique au suivant peut apparaitre :

Entity set not found: \<name\>

L’espace réservé \<name\> correspond au nom du service Web manquant, comme workflowWebhookSubscriptions ou workflowPurchaseDocumentLines.

Cause possible

L’utilisation de Power Automate pour les approbations nécessite que certains objets de page et de codeunit soient publiés en tant que services Web. Par défaut, la plupart des objets requis sont publiés en tant que services Web pour vous. Mais dans certains cas, votre environnement a peut-être été personnalisé pour que ces objets ne soient plus publiés.

Corriger

Allez à la page Services Web et assurez-vous que les objets suivants sont publiés en tant que services Web. Il devrait y avoir une entrée dans la liste pour chaque objet, avec la case Publié cochée.

Type d’objet ID d’objet Nom de l’objet Nom du service
Codeunit 1544 WorkflowWebhookSubscription WorkflowActionResponse
Page 6408 workflowCustomers workflowCustomers
Page 6406 workflowGenJournalBatches workflowGenJournalBatches
Page 6407 workflowGenJournalLines workflowGenJournalLines
Page 6409 workflowItems workflowItems
Page 6405 Entité de ligne document achat workflowPurchaseDocumentLines
Page 6404 workflowPurchaseDocuments workflowPurchaseDocuments
Page 6403 Entité de ligne document vente workflowSalesDocumentLines
Page 6402 workflowSalesDocuments workflowSalesDocuments
Page 6410 workflowVendors workflowVendors
Page 831 workflowWebhookSubscriptions workflowWebhookSubscriptions

Noter

La valeur Nom du service doit être exactement comme indiqué dans le tableau. Ne modifiez ni ne traduisez le nom du service.

Pour plus d’informations sur la publication des services Web, voir Publier un service Web.

Voir aussi

Utiliser Power Automate Flux dans Business Central
Flux de travail
Configurer des flux de travail automatisés
Activer les flux instantanés
Gérer les flux Power Automate

Retrouvez ici des modules d’apprentissage en ligne gratuits pour Business Central