Important
Microsoft Agent 365 の早期アクセスを利用するには、フロンティア プレビュープログラムに参加する必要があります。 フロンティアは、Microsoft の最新の AI イノベーションと直接接続します。 Frontier のプレビューは、お客様の契約書に記載されている既存のプレビュー利用規約に従います。 これらの機能は現在開発中であるため、提供状況や機能は今後変更される可能性があります。
a365 publish コマンドを使用してエージェントをパッケージ化し、パッケージを Microsoft 365 管理センターにアップロードします。 発行後、組織内にエージェント インスタンスを作成し、エージェントを管理できます。
[前提条件]
始める前に、以下のアイテムを必ず用意してください。
必要なアカウントとアクセス許可
次のいずれかの役割を持つ Microsoft 365 テナント (管理センターのアップロード手順に必要)。
- グローバル管理者
- エージェントID管理者
必要なツール
- A365 CLI インストール済み (Agent 365 CLI)
必要なセットアップ手順
発行する前に、次の手順を実行します。
- エージェントブループリントを作成 - 設定ステップ に従ってエージェントブループリントを作成してください。
- エージェントをローカルでテスト する - Agents Playground を使用してエージェントが正しく動作することを確認します (「 エージェントをローカルでテストする」を参照)。
-
構成ファイルを準備 する -
a365.config.jsonとa365.generated.config.jsonが最新であることを確認します。
公開コマンド
a365 publishコマンドを実行してください:
a365 publish
注
a365 publish -hを実行すると、このコマンドでサポートされているすべてのオプションが表示されます。
このコマンドの効果:
-
マニフェストの更新 - エージェントブループリント ID を使用して
manifest.jsonを更新します -
パッケージの作成 -
manifest.jsonとアイコンをパッケージ化するmanifest.zip - 印刷手順 - Microsoft 365 管理センターを介してアップロードするための詳細な手順が表示されます
管理センターへのアップロード
a365 publishが完了したら、印刷された手順に従ってエージェントをアップロードします。
- Microsoft 365管理センターに移動します。
- [エージェント>すべてのエージェント] に移動します。
- [ カスタム エージェントのアップロード] を選択します。
- プロジェクトの
manifest.zipフォルダーからmanifestファイルをアップロードします。
詳細については、「 Microsoft 365 管理センターにエージェントをアップロードする」を参照してください。
成功した公開の確認
以下のチェックリストを使って、エージェントが正常にデプロイされていることを確認します:
✅
CLI の発行が成功する
✅
manifest
manifest.jsonで作成されたフォルダーmanifest.zip
✅
Microsoft 管理センターにエージェントが表示される
CLI出力
発行コマンドが成功すると、次の出力メッセージが表示されます。
✅ Manifest updated successfully
✅ manifest.zip created successfully
✅ ステップ バイ ステップのアップロード手順が印刷されました
コマンドが失敗した場合は、エラー メッセージを確認し、ブループリントのセットアップが完了していることを確認します。
起こりうる誤り:
| エラー | 解決への一歩 |
|---|---|
Agent blueprint ID not found |
a365 setupを実行してブループリントのセットアップを完了します。 |
Permissions missing |
a365 setup permissionsコマンドでセットアップを再実行します。 |
出版が失敗した場合は 、以下のステップ に従ってください。
マニフェスト ファイル
Test-Path PowerShell コマンドを使用して、 manifest フォルダー内 の次の ファイルをテストできます。
# Check manifest folder and contents exists
Test-Path <deploymentProjectPath>/manifest/
Test-Path <deploymentProjectPath>/manifest/manifest.json
Test-Path <deploymentProjectPath>/manifest/manifest.zip
# All should return: True
注
これらのファイルが見当たらない場合は、もう一度 a365 publish コマンド を実行してみてください。
エージェントが管理センターに現れる
注
アップロード後、エージェントが管理センターと Teams に表示されるまでに 5 ~ 10 分 かかる場合があります。 この遅延は正常です。
次の手順を使用して、エージェントが存在することを確認します。
- Microsoft 365管理センターに移動します。
- [エージェント>すべてのエージェント] に移動します。
- エージェントが一覧に表示されます。
以下の表は、どのような詳細が見つかるかを示しています。
| フィールド | チェックすべきこと |
|---|---|
| 名前 | あなたのエージェント名 (manifest.jsonから) |
| バージョン | バージョン番号 (例: 1.0.0) |
| 発行者 | あなたの組織名 |
| 可用性 | 利用可能/全ユーザー |
こちらも参照ください
次のステップ
エージェントを公開した後、テナント内で設定・使用できるインスタンスを作成してください。
トラブルシューティング
Microsoft 365 管理センターにエージェントを発行するときの一般的な問題。
ヒント
Agent 365トラブルシューティングガイドには、Agent 365 の開発ライフサイクルの各段階に対応した高レベルのトラブルシューティング推奨事項、ベストプラクティス、トラブルシューティングコンテンツへのリンクが含まれています。
Publishコマンドが失敗します
症状:
-
a365 publish中にエラー -
manifest.zipが作成されない
根本原因:
- セットアップはまだ完了していません
- マニフェスト検証エラー
- アクセス許可が不十分です
Solution:
セットアップが完了しているか確認してください。
a365 config display -g # Check for: agentBlueprintIdpublishコマンドを実行し、プロンプトに従ってください。
管理センターでのアップロードが失敗する
症状:
- Microsoft 365 管理センターで
manifest.zipをアップロードするときのエラー - アップロード後にエージェントが表示されない
根本原因:
- 管理センターのアクセス許可が不十分
- 無効または古い
manifest.zip
Solution:
- グローバル管理者またはエージェント ID 管理者ロールがあることを確認します。
-
a365 publishをもう一度実行して、新しいmanifest.zipを生成します。 - アップロード手順に従って、もう一度 アップロードしてみてください。
詳細については、「 Microsoft 365 管理センターにエージェントをアップロードする」を参照してください。