ใช้ Power Query เพื่อแปลงข้อมูล

ด้วย Power Query คุณสามารถเชื่อมต่อกับแหล่งข้อมูลต่างๆ มากมาย และแปลงข้อมูลเป็นรูปร่างที่คุณต้องการ

ในบทความนี้ คุณจะได้เรียนรู้วิธีสร้างคิวรีด้วย Power Query โดยการค้นหา:

  • ประสบการณ์การรับข้อมูลทํางานอย่างไรใน Power Query
  • วิธีใช้และใช้ประโยชน์จากส่วนติดต่อผู้ใช้ Power Query
  • วิธีการดําเนินการแปลงทั่วไป เช่น การจัดกลุ่มและการผสานข้อมูล

หากคุณเพิ่งเริ่มใช้ Power Query คุณสามารถ ลงทะเบียนเพื่อทดลองใช้ฟรี Power BI ก่อนเริ่ม คุณสามารถใช้กระแสข้อมูล Power BI เพื่อลองใช้งาน Power Query Online ที่อธิบายไว้ในบทความนี้

คุณยังสามารถ ดาวน์โหลด Power BI Desktop ได้ฟรี

ตัวอย่างในบทความนี้เชื่อมต่อกับ และใช้ตัวดึงข้อมูล Northwind OData

เชื่อมต่อกับตัวดึงข้อมูล OData

โน้ต

หากต้องการดูข้อมูลเพิ่มเติมเกี่ยวกับตําแหน่งที่จะรับข้อมูลจากผลิตภัณฑ์ Microsoft แต่ละรายการที่มี Power Query ให้ไปที่ จะรับข้อมูลได้ที่ไหน

เมื่อต้องการเริ่มต้น ค้นหาตัวเชื่อมต่อตัวดึงข้อมูล OData จากประสบการณ์การรับข้อมูล คุณสามารถค้นหา OData ในแถบค้นหาที่มุมบนขวา

สกรีนช็อตของหน้า เลือกแหล่งข้อมูล ของเน้น รับประสบการณ์ข้อมูลด้วยตัวเชื่อมต่อ OData

หลังจากที่คุณเลือกตัวเชื่อมต่อนี้ หน้าจอจะแสดงการตั้งค่าการเชื่อมต่อและข้อมูลประจําตัว

  • สําหรับ URL ให้ใส่ URL ของตัวดึงข้อมูล Northwind OData: https://services.odata.org/V4/Northwind/Northwind.svc/
  • สําหรับ เกตเวย์ข้อมูลภายในองค์กร ให้ปล่อยไว้เป็น ไม่มี
  • สําหรับ ชนิดการรับรองความถูกต้องปล่อยให้เป็นแบบไม่ระบุชื่อ

เลือกปุ่ม ถัดไป

ตัวนําทาง จะเปิดขึ้นซึ่งคุณเลือกตารางที่คุณต้องการเชื่อมต่อจากแหล่งข้อมูล เลือกตาราง Customers เพื่อโหลดตัวอย่างของข้อมูล จากนั้นเลือก แปลงข้อมูล

สกรีนช็อตของหน้า Power Query Navigator ที่เน้นตารางลูกค้า

จากนั้นกล่องโต้ตอบจะโหลดข้อมูลจากตาราง ลูกค้า ลงในตัวแก้ไข Power Query

ประสบการณ์การเชื่อมต่อกับข้อมูลของคุณ การระบุวิธีการรับรองความถูกต้อง และเลือกวัตถุหรือตารางเฉพาะที่จะเชื่อมต่อจะเรียกว่า รับประสบการณ์การใช้งานข้อมูล ประสบการณ์นี้ได้รับการบันทึกไว้พร้อมรายละเอียดเพิ่มเติมในบทความ ภาพรวมการรับข้อมูล

โน้ต

เมื่อต้องการเรียนรู้เพิ่มเติมเกี่ยวกับตัวเชื่อมต่อตัวดึงข้อมูล OData ไปที่ ตัวดึงข้อมูล OData

คอมโพเนนต์ของตัวแก้ไข Power Query

เคล็ดลับ

เมื่อต้องการค้นหาตัวแก้ไข Power Query ใน Power BI ภายใต้ คิวรี ให้เลือก แปลงข้อมูล

สกรีนช็อตของแถบหน้าแรกใน Power BI ที่มีปุ่มแปลงข้อมูลถูกไฮไลต์

ตัวแก้ไข Power Query แสดงถึงส่วนติดต่อผู้ใช้ Power Query ในอินเทอร์เฟซผู้ใช้นี้ คุณสามารถเพิ่มหรือปรับเปลี่ยนคิวรี จัดการคิวรีโดยการจัดกลุ่มหรือเพิ่มคําอธิบายไปยังขั้นตอนคิวรี หรือแสดงภาพคิวรีของคุณและโครงสร้างของคิวรีเหล่านั้นด้วยมุมมองที่แตกต่างกัน ส่วนติดต่อผู้ใช้ Power Query มีส่วนประกอบที่แตกต่างกันห้าส่วน ตัวเลขในตารางต่อไปนี้สอดคล้องกับคําบรรยายภาพที่มีหมายเลขในสกรีนช็อต

ภาพหน้าจอของส่วนต่อประสานผู้ใช้ Power Query ที่มีแต่ละส่วนประกอบที่ระบุไว้และกําหนดหมายเลข

# คอมโพเนนต์ คำอธิบาย
1 ริบบิ้น ประสบการณ์การนําทางริบบิ้น ซึ่งมีหลายแท็บเพื่อเพิ่มการแปลง เลือกตัวเลือกสําหรับคิวรีของคุณ และเข้าถึงปุ่มริบบิ้นที่แตกต่างกันเพื่อทํางานต่าง ๆ ให้เสร็จสมบูรณ์
2 บานหน้าต่างคิวรี มุมมองของคิวรีที่พร้อมใช้งานทั้งหมดของคุณ
3 มุมมองปัจจุบัน มุมมองการทํางานหลักของคุณซึ่งตามค่าเริ่มต้นจะแสดงตัวอย่างของข้อมูลสําหรับคิวรีของคุณ คุณยังสามารถเปิดใช้งาน มุมมองไดอะแกรม พร้อมกับมุมมองการแสดงตัวอย่างข้อมูล คุณยังสามารถสลับไปมาระหว่างมุมมอง schema ของ และมุมมองการแสดงตัวอย่างข้อมูลในขณะที่รักษามุมมองไดอะแกรมไว้
4 การตั้งค่าคิวรี มุมมองของคิวรีที่เลือกในปัจจุบันที่มีข้อมูลที่เกี่ยวข้อง เช่น ชื่อคิวรี ขั้นตอนคิวรี และตัวบ่งชี้ต่างๆ
5 แถบสถานะ แถบแสดงข้อมูลที่สําคัญที่เกี่ยวข้องเกี่ยวกับคิวรีของคุณ เช่น เวลาดําเนินการ คอลัมน์รวมและแถว และสถานะการประมวลผล แถบนี้ยังมีปุ่มสําหรับเปลี่ยนมุมมองปัจจุบันของคุณ

โน้ต

ขณะนี้มุมมอง Schema และไดอะแกรมพร้อมใช้งานใน Power Query Online เท่านั้น

ก่อนที่คุณจะแปลงข้อมูลในตัวแก้ไข Power Query การทราบวิธีการขยายหรือยุบบานหน้าต่าง UI และสลับระหว่างมุมมอง การเลือกบานหน้าต่างที่เหมาะสมช่วยให้คุณมุ่งเน้นไปที่มุมมองที่สําคัญที่สุดสําหรับคุณ ส่วนต่อไปนี้ครอบคลุมบานหน้าต่างและมุมมองที่พร้อมใช้งานในส่วนติดต่อผู้ใช้ Power Query

ริบบอนตัวแก้ไข Power Query

Ribbon เป็นส่วนประกอบที่คุณค้นหาการแปลงและการดําเนินการส่วนใหญ่ที่คุณสามารถทําได้ในตัวแก้ไข Power Query ซึ่งมีหลายแท็บซึ่งค่าขึ้นอยู่กับการรวมผลิตภัณฑ์ แต่ละแท็บมีปุ่มและตัวเลือกเฉพาะ ซึ่งบางแท็บอาจซ้ําซ้อนในประสบการณ์ Power Query ทั้งหมด ปุ่มและตัวเลือกเหล่านี้ช่วยให้คุณเข้าถึงการแปลงและการดําเนินการที่คุณอาจต้องการได้อย่างง่ายดาย

สกรีนช็อตของมุมมองริบบิ้นมาตรฐานบนแท็บ หน้าแรก ของส่วนติดต่อผู้ใช้ Power Query

อินเทอร์เฟซ Power Query ตอบสนองและพยายามปรับความละเอียดหน้าจอของคุณเพื่อแสดงประสบการณ์ที่ดีที่สุด ในสถานการณ์ที่คุณต้องการใช้ริบบิ้นขนาดกะทัดรัด ยังมีปุ่มยุบที่มุมขวาล่างของริบบอนเพื่อช่วยให้คุณสลับไปยังริบบิ้นขนาดกะทัดรัด

สกรีนช็อตของมุมมองริบบิ้นขนาดกะทัดรัดบนแท็บ หน้าแรก ของส่วนติดต่อผู้ใช้ Power Query

คุณสามารถสลับกลับไปยังมุมมอง ribbon มาตรฐาน โดยการเลือกไอคอนขยายที่มุมขวาล่างของริบบอนได้

ขยายและยุบบานหน้าต่าง Power Query

คุณอาจสังเกตเห็นว่าตลอดทั้งส่วนติดต่อผู้ใช้ Power Query มีไอคอนที่ช่วยคุณยุบหรือขยายมุมมองหรือส่วนบางอย่าง ตัวอย่างเช่น มีไอคอนอยู่ที่มุมบนขวาของบานหน้าต่าง คิวรี ที่ยุบบานหน้าต่างคิวรีเมื่อเลือกและขยายบานหน้าต่างเมื่อเลือกอีกครั้ง

สกรีนช็อตที่เน้นไอคอนบนบานหน้าต่างคิวรีที่ใช้ในการยุบและขยายบานหน้าต่างคิวรี

สลับไปมาระหว่างมุมมอง Power Query

นอกเหนือจากความสามารถในการยุบบานหน้าต่างและส่วนต่างๆ ในส่วนติดต่อผู้ใช้ Power Query แล้ว คุณยังสามารถสลับมุมมองที่แสดงได้อีกด้วย เมื่อต้องการสลับมุมมอง ให้ไปที่แท็บ View ใน Ribbon ที่คุณพบกลุ่ม Preview และ Layout ซึ่งควบคุมลักษณะของส่วนติดต่อผู้ใช้ Power Query

คุณควรลองใช้ตัวเลือกเหล่านี้เพื่อค้นหามุมมองและเค้าโครงที่คุณรู้สึกว่าทํางานสะดวกสบายที่สุด ตัวอย่างเช่น เลือกมุมมอง schema จาก ribbon

ภาพหน้าจอที่เน้นปุ่มมุมมองสคีมาที่พบภายในแท็บมุมมองในริบบิ้น Power Query

ด้านขวาของแถบสถานะยังประกอบด้วยไอคอนสําหรับไดอะแกรม ข้อมูล และมุมมองเค้าร่าง คุณสามารถใช้ไอคอนเหล่านี้เพื่อเปลี่ยนแปลงระหว่างมุมมองได้ คุณยังสามารถใช้ไอคอนเหล่านี้เพื่อเปิดหรือปิดการใช้งานมุมมองที่คุณเลือกได้

สกรีนช็อตที่มีบานหน้าต่างคิวรีที่ยุบและมุมมองปัจจุบันได้สลับไปยังมุมมอง Schema และไอคอนมุมมอง Schema ที่เน้น

มุมมอง Schema ใน Power Query คืออะไร

มุมมอง Schema ให้วิธีการที่ง่ายและรวดเร็วในการโต้ตอบกับคอมโพเนนต์ของ Schema สําหรับตารางของคุณเท่านั้น เช่น ชื่อคอลัมน์และชนิดข้อมูล เราขอแนะนําให้ใช้มุมมอง Schema เมื่อคุณต้องการทําการดําเนินการที่เกี่ยวข้องกับ schema การดําเนินการเหล่านี้สามารถเอาคอลัมน์ออก เปลี่ยนชื่อคอลัมน์ เปลี่ยนชนิดข้อมูลของคอลัมน์ เรียงลําดับคอลัมน์ใหม่ หรือทําซ้ําคอลัมน์ได้

โน้ต

เมื่อต้องการเรียนรู้เพิ่มเติมเกี่ยวกับมุมมอง Schema ไปที่ โดยใช้มุมมอง Schema

ตัวอย่างเช่น ในมุมมอง Schema เลือกเครื่องหมายถูกถัดจาก Orders และ คอลัมน์ CustomerDemographics และจากริบบอน ให้เลือกการดําเนินการ ลบคอลัมน์ การเลือกนี้จะนําการแปลงไปใช้เพื่อเอาคอลัมน์เหล่านี้ออกจากข้อมูลของคุณ

สกรีนช็อตของคอลัมน์คําสั่งซื้อและลูกค้าประชากรที่เลือก และตัวเลือกลบคอลัมน์ถูกเน้น

มุมมองไดอะแกรมใน Power Query คืออะไร

ในตอนนี้คุณสามารถสลับกลับไปยังมุมมองแสดงตัวอย่างข้อมูล และเปิดใช้งานมุมมองไดอะแกรมเพื่อใช้มุมมองวิชวลของข้อมูลและคิวรีของคุณได้มากขึ้น

สกรีนช็อตที่เน้นมุมมองไดอะแกรมและไอคอนมุมมองตัวอย่างข้อมูล

มุมมองไดอะแกรมช่วยให้คุณเห็นภาพวิธีการจัดโครงสร้างคิวรีของคุณ และวิธีการที่คิวรีนั้นอาจโต้ตอบกับคิวรีอื่นๆ ในโครงการของคุณ แต่ละขั้นตอนในคิวรีของคุณมีไอคอนที่แตกต่างกันเพื่อช่วยให้คุณจดจําการแปลงที่ใช้ บรรทัดขั้นตอนการเชื่อมต่อเพื่อแสดงให้เห็นการขึ้นต่อกัน เนื่องจากมุมมองการแสดงตัวอย่างข้อมูลและมุมมองไดอะแกรมเปิดใช้งานอยู่ มุมมองไดอะแกรมจะปรากฏที่ด้านบนของการแสดงตัวอย่างข้อมูล

สกรีนช็อตของพื้นที่ทํางาน Power Query ที่แสดงมุมมองไดอะแกรมพร้อมการแสดงตัวอย่างข้อมูล

โน้ต

เมื่อต้องการเรียนรู้เพิ่มเติมเกี่ยวกับมุมมองไดอะแกรม ให้ไปที่ มุมมองไดอะแกรม

จัดกลุ่มลูกค้าตามประเทศ/ภูมิภาคในมุมมองไดอะแกรม

หากต้องการนับจํานวนลูกค้าต่อประเทศ/ภูมิภาค ให้เพิ่ม กลุ่มตาม การแปลง เมื่อเปิดใช้งานมุมมองไดอะแกรมให้เลือกเครื่องหมายบวก คุณสามารถค้นหาการแปลงใหม่เพื่อเพิ่มไปยังคิวรีของคุณได้ ค้นหา จัดกลุ่มตาม และเลือกการแปลง

สกรีนช็อตพร้อมการค้นหากลุ่มตามในมุมมองไดอะแกรม

กล่องโต้ตอบ จัดกลุ่มตาม จะปรากฏขึ้น คุณสามารถตั้งค่า จัดกลุ่มตาม การดําเนินการเพื่อจัดกลุ่มตามประเทศ/ภูมิภาค และนับจํานวนแถวลูกค้าสําหรับแต่ละประเทศ/ภูมิภาคได้

  1. เลือกปุ่มตัวเลือก Basic ไว้
  2. เลือก ประเทศ/ภูมิภาค เพื่อจัดกลุ่มตาม
  3. ใส่ Customers เป็นชื่อคอลัมน์ใหม่ และเลือก นับจํานวนแถว เป็นการดําเนินการ

สกรีนช็อตของกล่องโต้ตอบกลุ่มพื้นฐานที่มีข้อมูลของลูกค้าที่ป้อน

เลือก ตกลง เพื่อดําเนินการ การแสดงตัวอย่างข้อมูลของคุณจะรีเฟรชเพื่อแสดงจํานวนลูกค้าทั้งหมดตามประเทศ/ภูมิภาค

วิธีอื่นในการเปิดใช้งานกล่องโต้ตอบ จัดกลุ่มตาม คือการใช้ปุ่ม จัดกลุ่มตาม ใน ribbon หรือเลือกค้างไว้ (คลิกขวา) คอลัมน์ ประเทศ/ภูมิภาค

สกรีนช็อตที่เน้นปุ่มจัดกลุ่มตามในริบบอนและตัวเลือกจัดกลุ่มตามในเมนูคอลัมน์ประเทศ/ภูมิภาค

เพื่อความสะดวก การแปลงใน Power Query มักจะสามารถเข้าถึงได้จากหลายที่ ดังนั้นผู้ใช้จึงสามารถเลือกใช้ประสบการณ์ที่พวกเขาต้องการได้

เพิ่มคิวรีใหม่

ตอนนี้คุณมีคิวรีที่ให้จํานวนลูกค้าต่อประเทศ/ภูมิภาคแล้ว คุณสามารถเพิ่มบริบทลงในข้อมูลนี้โดยการค้นหาจํานวนซัพพลายเออร์ทั้งหมดสําหรับแต่ละประเทศ/ภูมิภาค

ก่อนอื่น คุณต้องเพิ่มข้อมูล ซัพพลายเออร์ เลือก รับข้อมูล ใน เลือกแหล่งข้อมูลให้ค้นหา OData จากนั้นเลือกตัวเชื่อมต่อ OData

สกรีนช็อตของหน้าเลือกแหล่งข้อมูลที่เน้นตัวเชื่อมต่อ OData

ประสบการณ์การเชื่อมต่อ OData จะปรากฏขึ้นอีกครั้ง ใส่การตั้งค่าการเชื่อมต่อตามที่อธิบายไว้ใน เชื่อมต่อไปยังตัวดึงข้อมูล OData เพื่อเชื่อมต่อกับตัวดึงข้อมูล Northwind OData ในประสบการณ์ ตัวนําทาง ให้ค้นหาและเลือกตาราง ผู้จัดหาสินค้า ซัพพลายเออร์

ภาพหน้าจอของเครื่องนําทาง Power Query ที่เลือกซัพพลายเออร์ Northwind OData

เลือก Create เพื่อเพิ่มคิวรีใหม่ไปยังตัวแก้ไข Power Query ขยายบานหน้าต่างคิวรี ซึ่งตอนนี้แสดงทั้งคิวรี Customers และ Suppliers

สกรีนช็อตของบานหน้าต่างคิวรีที่เน้นทั้งคิวรีของลูกค้าและซัพพลายเออร์

เปิดกล่องโต้ตอบ จัดกลุ่ม ตาม อีกครั้ง โดยการเลือกปุ่ม Group ตาม บนริบบอน ภายใต้แท็บ แปลง

สกรีนช็อตของส่วนหนึ่งของริบบิ้นแท็บแปลงโดยเน้น จัดกลุ่มตาม

ในกล่องโต้ตอบ จัดกลุ่มตาม ให้ตั้งค่าการดําเนินการ จัดกลุ่มตาม เพื่อจัดกลุ่มตามประเทศ/ภูมิภาค และนับจํานวนแถวซัพพลายเออร์สําหรับแต่ละประเทศ/ภูมิภาค

  1. เลือกปุ่มตัวเลือก Basic ไว้
  2. เลือก ประเทศ/ภูมิภาค เพื่อจัดกลุ่มตาม
  3. ป้อน ซัพพลายเออร์ใน ชื่อคอลัมน์ใหม่ และเลือก นับจํานวนแถว ในการดําเนินการ

สกรีนช็อตของกล่องโต้ตอบกลุ่มพื้นฐานที่มีข้อมูลของซัพพลายเออร์ที่ป้อน

โน้ต

เมื่อต้องการเรียนรู้เพิ่มเติมเกี่ยวกับ จัดกลุ่มตาม แปลง ไปที่ การจัดกลุ่ม หรือการสรุปแถว

คิวรีอ้างอิง

เมื่อคุณอ้างอิงคิวรี คุณสร้างคิวรีใหม่ที่ชี้ไปยังผลลัพธ์ของคิวรีที่มีอยู่ ตอนนี้คุณมีการสอบถามสําหรับลูกค้าและการสอบถามสําหรับซัพพลายเออร์แล้ว เป้าหมายถัดไปของคุณคือการรวมเข้าด้วยกันเป็นรายการเดียว คุณสามารถใช้วิธีการมากมายเพื่อทําให้บรรลุเป้าหมายนี้ รวมถึงตัวเลือก ผสาน ในตาราง ลูกค้า ทําซ้ําคิวรี หรืออ้างอิงคิวรี สําหรับตัวอย่างนี้ สร้างการอ้างอิงโดยการเลือกตาราง ลูกค้า ค้างไว้ (คลิกขวา) การดําเนินการนี้จะเป็นการสร้างคิวรีใหม่ที่อ้างอิงถึงคิวรี Customers

สกรีนช็อตของเมนูลูกค้าที่เน้นตัวเลือกการอ้างอิง

หลังจากสร้างคิวรีใหม่นี้แล้ว ให้เปลี่ยนชื่อคิวรีเป็น การวิเคราะห์ประเทศ/ภูมิภาค และปิดใช้งานการโหลดตาราง ลูกค้า โดยการล้างตัวเลือก เปิดใช้งานโหลด จากคิวรี ซัพพลายเออร์

สกรีนช็อตของชื่อคิวรีที่สามถูกเปลี่ยนเป็น การวิเคราะห์ประเทศ และผู้จัดหาเปิดใช้งานตัวเลือกโหลดที่ยังไม่ได้ทําเครื่องหมายและเน้น

ผสานคิวรี

ผสานคิวรี การดําเนินการรวมตารางที่มีอยู่สองตารางเข้าด้วยกันโดยยึดตามค่าที่ตรงกันจากหนึ่งหรือหลายคอลัมน์ ในตัวอย่างนี้ เป้าหมายคือการรวมทั้งตาราง Customers และผู้จําหน่าย ลงในตารางเดียวสําหรับประเทศ/ภูมิภาคที่มีทั้งตาราง ลูกค้า และผู้จําหน่าย เท่านั้น

ภายในคิวรี การวิเคราะห์ประเทศ/ภูมิภาค ให้เลือกตัวเลือก ผสานคิวรี จากแท็บ หน้าแรก ในริบบอน

สกรีนช็อตของพื้นที่ทํางาน Power Query ที่มีคิวรีการวิเคราะห์ประเทศ/ภูมิภาคที่เลือกไว้ และตัวเลือกคิวรีแบบผสานในแท็บหน้าแรกที่เน้น

กล่องโต้ตอบใหม่สําหรับการดําเนินการผสานจะปรากฏขึ้น จากนั้นคุณสามารถเลือกคิวรีเพื่อผสานกับคิวรีปัจจุบันของคุณได้ ในตารางด้านขวาสําหรับการผสาน ให้เลือกคิวรีซัพพลายเออร์ จากนั้นเลือกเขตข้อมูลประเทศ/ภูมิภาคจากทั้งสองคิวรี สุดท้ายให้เลือกประเภทการเข้าร่วม ภายในของ เนื่องจากคุณต้องการเฉพาะประเทศ/ภูมิภาคที่คุณมี ลูกค้า และ ซัพพลายเออร์ สําหรับการวิเคราะห์นี้

ภาพหน้าจอของกล่องโต้ตอบผสานคิวรี่ที่มีคอลัมน์ประเทศ/ภูมิภาคที่เลือกในทั้งสองคิวรีและชนิดการรวมภายในที่เลือก

หลังจากที่คุณเลือกปุ่ม ตกลง คอลัมน์ใหม่จะถูกเพิ่มลงในคิวรีการวิเคราะห์ประเทศ/ภูมิภาคของคุณที่ประกอบด้วยข้อมูลจากคิวรีซัพพลายเออร์ เลือกไอคอนที่อยู่ถัดจากเขตข้อมูล ซัพพลายเออร์ ซึ่งแสดงเมนูที่คุณสามารถเลือกเขตข้อมูลที่คุณต้องการขยายได้ เลือกเฉพาะเขตข้อมูล ซัพพลายเออร์ จากนั้นเลือกปุ่ม ตกลง

สกรีนช็อตของคอลัมน์ ซัพพลายเออร์ ที่มีเมนู ซัพพลายเออร์ เปิดอยู่ และเลือกเฉพาะซัพพลายเออร์เท่านั้น

ผลลัพธ์ของ ขยาย คือตารางที่มีเพียง 12 แถวเท่านั้น เปลี่ยนชื่อเขตข้อมูล Suppliers.1 เป็น ผู้จัดหา โดยการดับเบิลคลิกที่ชื่อเขตข้อมูลและป้อนชื่อใหม่

สกรีนช็อตของคอลัมน์ ซัพพลายเออร์ ที่เปลี่ยนชื่อ

โน้ต

เมื่อต้องการเรียนรู้เพิ่มเติมเกี่ยวกับ ผสานคิวรี คุณลักษณะ ไปที่ ผสานคิวรี

ขั้นตอนที่กําหนดใช้

การแปลงข้อมูลทั้งหมดที่นําไปใช้กับคิวรีของคุณจะถูกบันทึกเป็นขั้นตอนในส่วน ขั้นตอนที่กําหนดใช้ ของบานหน้าต่างการตั้งค่าคิวรี หากคุณต้องการตรวจสอบว่าคิวรีของคุณมีการเปลี่ยนแปลงอย่างไรจากขั้นตอนหนึ่งไปอีกขั้น คุณสามารถเลือกขั้นตอนและแสดงตัวอย่างว่าคิวรีของคุณแก้ไขอย่างไรในจุดนั้น

คุณยังสามารถเลือกคิวรีค้างไว้ (คลิกขวา) และเลือกตัวเลือก คุณสมบัติ เพื่อเปลี่ยนชื่อของคิวรีหรือเพิ่มคําอธิบายสําหรับคิวรี ตัวอย่างเช่น เลือกและกดค้าง (คลิกขวา) ขั้นตอนการผสานคิวรีจากคิวรี การวิเคราะห์ประเทศ/ภูมิภาค และเปลี่ยนชื่อของคิวรีเป็น ผสานกับซัพพลายเออร์ และคําอธิบายเพื่อรับข้อมูลจากคิวรีซัพพลายเออร์สําหรับซัพพลายเออร์ตามประเทศ/ภูมิภาค

สกรีนช็อตของกล่องโต้ตอบคุณสมบัติขั้นตอนที่มีการกรอกชื่อและคําอธิบายที่เปลี่ยนไป

หลังจากการเปลี่ยนแปลงนี้ คุณสามารถวางเมาส์เหนือไอคอนผสานคิวรีในมุมมองไดอะแกรมหรือวางเมาส์เหนือไอคอนใหม่ถัดจากขั้นตอนของคุณในบานหน้าต่าง ขั้นตอนที่ใช้ เพื่ออ่านคําอธิบาย

สกรีนช็อตแสดงตําแหน่งที่จะวางเมาส์เหนือเพื่อดูคุณสมบัติของขั้นตอน

โน้ต

เมื่อต้องการเรียนรู้เพิ่มเติมเกี่ยวกับขั้นตอนที่ใช้ ให้ไปที่ โดยใช้รายการ ขั้นตอนที่ใช้

ก่อนที่คุณจะเพิ่มคอลัมน์ใหม่ ปิดใช้งานมุมมองไดอะแกรมเพื่อใช้เฉพาะการแสดงตัวอย่างข้อมูล

เพิ่มคอลัมน์ใหม่

คุณสามารถเพิ่มคอลัมน์ใหม่ที่คํานวณจากคอลัมน์ที่มีอยู่ได้ ด้วยข้อมูลสําหรับลูกค้าและซัพพลายเออร์ในตารางเดียว ตอนนี้คุณสามารถคํานวณอัตราส่วนลูกค้าต่อซัพพลายเออร์สําหรับแต่ละประเทศ/ภูมิภาคได้ เลือกขั้นตอนสุดท้ายของคิวรีการวิเคราะห์ประเทศ/ภูมิภาค จากนั้นเลือกทั้งคอลัมน์ลูกค้าและซัพพลายเออร์ ในแท็บ เพิ่มคอลัมน์ ใน ribbon และภายในกลุ่ม จากหมายเลข ให้เลือก มาตรฐาน แล้ว หาร (จํานวนเต็ม) จากรายการดรอปดาวน์

ภาพหน้าจอของพื้นที่ทํางาน Power Query โดยเน้นไฟล์ เพิ่มคอลัมน์ และ มาตรฐาน เลือกและ แบ่ง (จํานวนเต็ม) ตัวเลือกเน้น

การเปลี่ยนแปลงนี้จะสร้างคอลัมน์ใหม่ที่เรียกว่า การหารจํานวนเต็ม ที่คุณสามารถเปลี่ยนชื่อเป็น อัตราส่วน ได้ การเปลี่ยนแปลงนี้เป็นขั้นตอนสุดท้ายของคิวรีของคุณ และให้อัตราส่วนลูกค้าต่อซัพพลายเออร์สําหรับประเทศ/ภูมิภาคที่ข้อมูลมีลูกค้าและซัพพลายเออร์

การสร้างโพรไฟล์ข้อมูล

การทําโปรไฟล์ข้อมูลเป็นคุณลักษณะ Power Query ที่ช่วยให้คุณเข้าใจข้อมูลของคุณได้ดียิ่งขึ้น ด้วยการเปิดใช้งานคุณลักษณะการสร้างโพรไฟล์ข้อมูล คุณจะได้รับคําติชมเกี่ยวกับข้อมูลภายในเขตข้อมูลคิวรีของคุณ เช่น การกระจายค่า คุณภาพของคอลัมน์ และอื่นๆ

ใช้คุณลักษณะนี้ตลอดการพัฒนาคิวรีของคุณ คุณสามารถเปิดและปิดใช้งานคุณลักษณะนี้ได้ตามความสะดวกของคุณ รูปภาพต่อไปนี้แสดงเครื่องมือการสร้างโพรไฟล์ข้อมูลทั้งหมดที่เปิดใช้งานสําหรับคิวรี การวิเคราะห์ประเทศ/ภูมิภาค ของคุณ

สกรีนช็อตของข้อมูลการทําโพรไฟล์ข้อมูลพร้อมรายละเอียดสําหรับคอลัมน์ อัตราส่วน ที่ด้านล่าง

โน้ต

เมื่อต้องการเรียนรู้เพิ่มเติมเกี่ยวกับ การทําโปรไฟล์ข้อมูล ให้ไปที่ การใช้เครื่องมือการสร้างโพรไฟล์ข้อมูล

ตัวแก้ไขขั้นสูง

ถ้าคุณต้องการสังเกตโค้ดที่ตัวแก้ไข Power Query กําลังสร้างขึ้นในแต่ละขั้นตอน หรือต้องการสร้างโค้ดการจัดรูปร่างของคุณเอง คุณสามารถใช้ตัวแก้ไขขั้นสูงได้ เมื่อต้องการเปิด advanced editor ให้เลือกแท็บ View บน Ribbon แล้วเลือก เครื่องมือแก้ไขขั้นสูง หน้าต่างจะปรากฏขึ้น โดยแสดงรหัสคิวรีที่มีอยู่

สกรีนช็อตของตัวแก้ไขขั้นสูง ซึ่งประกอบด้วยโค้ดที่ไม่มีข้อผิดพลาดทางไวยากรณ์

คุณสามารถแก้ไขรหัสได้โดยตรงในหน้าต่าง เครื่องมือแก้ไขขั้นสูง ตัวแก้ไขจะระบุว่าโค้ดของคุณไม่มีข้อผิดพลาดทางไวยากรณ์ เมื่อต้องการปิดหน้าต่าง ให้เลือกปุ่ม เสร็จสิ้น หรือ ยกเลิก

เข้าถึงวิธีใช้ Power Query

มีวิธีใช้หลายระดับที่สามารถเข้าถึงได้ในแอป Microsoft ที่ใช้ Power Query ในส่วนนี้จะอธิบายระดับความช่วยเหลือเหล่านี้

วิธีใช้ Power Query ใน Excel

มีสองวิธีในการเข้าถึงข้อมูลวิธีใช้ Power Query ที่ใช้กับ Power Query ใน Excel โดยเฉพาะ วิธีหนึ่งในการเข้าถึงเอกสารประกอบ Excel Power Query ออนไลน์คือการเลือก File>Help>Help ในตัวแก้ไข Power Query

เมื่อต้องการเข้าถึงข้อมูลวิธีใช้ Power Query แบบอินไลน์ใน Excel ให้เลือกแท็บ วิธีใช้ บน Ribbon Excel แล้วใส่ Power Query ในกล่องข้อความค้นหา

วิธีใช้ Power Query ใน Power BI Desktop

มีแท็บ Help ในตัวแก้ไข Power Query ที่ทํางานบนเดสก์ท็อป Power BI แต่ในขณะนี้ตัวเลือกทั้งหมดจะไปที่ตําแหน่งที่ให้ข้อมูล Power BI คุณยังสามารถเข้าถึงข้อมูล Power BI Help เดียวกันนี้ในตัวแก้ไข Power Query ใน Power BI Desktop โดยเลือก File>Help แล้วเลือกตัวเลือกวิธีใช้อย่างใดอย่างหนึ่ง

Power Query ช่วยในการ บริการของ Power BI Power Apps ข้อมูลเชิงลึกของลูกค้า Dynamics 365 และ Azure Data Factory

แท็บ Power Query วิธีใช้ ใน บริการของ Power BI, Power Apps Dynamics 365 Customer Insights และ Azure Data Factory มีลิงก์ไปยังแหล่งข้อมูลที่สําคัญเกี่ยวกับ Power Query

สกรีนช็อตของแท็บวิธีใช้พร้อมเอกสารประกอบ Power Query พร้อมตัวเลือกวิธีใช้ ชุมชน และข้อเสนอแนะทั้งหมดที่แสดงอยู่

ตัวเลือกในแท็บวิธีใช้มีลิงก์ไปยัง:

  • Power Query เอกสารประกอบ: ลิงก์ไปยังเอกสารประกอบของ Power Query
  • แป้นพิมพ์ลัด: ลิงก์ไปยังบทความแป้นพิมพ์ลัดในเอกสารประกอบของ Power Query
  • Support: ลิงก์ไปยังเว็บไซต์สนับสนุนของผลิตภัณฑ์ Microsoft ที่ Power Query กําลังใช้งานอยู่
  • Power Query เว็บไซต์: ลิงก์ไปยังเว็บไซต์ Power Query
  • Power Query blog: ลิงก์ไปยังบล็อก Power Query
  • Power Query community: ลิงก์ไปยังชุมชน Power Query
  • ส่งไอเดีย: ลิงก์ไปยังเว็บไซต์ไอเดียของผลิตภัณฑ์ Microsoft ที่ Power Query กําลังใช้งานอยู่
  • ส่งคําติชม: เปิดหน้าต่างใน Power Query หน้าต่างขอให้คุณให้คะแนนประสบการณ์ของคุณกับ Power Query และให้ข้อมูลเพิ่มเติมที่คุณต้องการให้

โน้ต

ปัจจุบัน Azure Analysis Services ไม่มีลิงก์วิธีใช้ Power Query แบบอินไลน์ อย่างไรก็ตาม คุณสามารถรับความช่วยเหลือสําหรับฟังก์ชัน Power Query M ได้ ข้อมูลเพิ่มเติมอยู่ในส่วนถัดไป

วิธีใช้สําหรับฟังก์ชัน Power Query M

นอกเหนือจากฟังก์ชันวิธีใช้ Power Query ที่แสดงในส่วนก่อนหน้านี้แล้ว คุณยังสามารถรับความช่วยเหลือสําหรับฟังก์ชัน M แต่ละฟังก์ชันได้จากภายในตัวแก้ไข Power Query ขั้นตอนแตกต่างกันเล็กน้อยขึ้นอยู่กับเวอร์ชันที่คุณใช้: Power Query Desktop (รวมอยู่ในแอปเช่น Power BI Desktop) หรือ Power Query Online (รวมอยู่ในบริการเช่น บริการของ Power BI และ กระแสข้อมูล) ขั้นตอนต่อไปนี้อธิบายวิธีการรับความช่วยเหลือแบบอินไลน์นี้

  1. เมื่อตัวแก้ไข Power Query เปิดอยู่ ให้เลือกปุ่มขั้นตอนการแทรก ( )
  2. ในแถบสูตร ใส่ชื่อของฟังก์ชันที่คุณต้องการตรวจสอบ
    1. ถ้าคุณกําลังใช้ Power Query Desktop ให้ใส่เครื่องหมายเท่ากับ ช่องว่าง และชื่อของฟังก์ชัน
    2. ถ้าคุณกําลังใช้ Power Query Online ให้ป้อนชื่อของฟังก์ชัน
  3. เลือกคุณสมบัติของฟังก์ชัน
    1. ถ้าคุณกําลังใช้ Power Query Desktop ในบานหน้าต่าง Query Settings ภายใต้ Properties ให้เลือก All properties
    2. ถ้าคุณกําลังใช้ Power Query Online ในบานหน้าต่าง การตั้งค่าแบบสอบถาม ให้เลือก คุณสมบัติ

ขั้นตอนเหล่านี้จะเปิดข้อมูลวิธีใช้แบบอินไลน์สําหรับฟังก์ชันที่คุณเลือก และช่วยให้คุณสามารถใส่คุณสมบัติแต่ละรายการที่ใช้โดยฟังก์ชันได้

สกรีนช็อตของคําอธิบายฟังก์ชัน Date.AddDays M และไวยากรณ์ พร้อมกับจุดเข้าใช้งานสําหรับพารามิเตอร์แต่ละตัวของฟังก์ชัน

สรุป

ในบทความนี้ คุณได้สร้างชุดของคิวรีที่มี Power Query ที่มีการวิเคราะห์อัตราส่วนอัตราส่วนลูกค้าต่อผู้จัดหาสินค้าในระดับประเทศ/ภูมิภาคสําหรับบริษัท Northwind

คุณได้เรียนรู้ส่วนประกอบของส่วนติดต่อผู้ใช้ Power Query วิธีสร้างคิวรีใหม่ภายในตัวแก้ไขคิวรี คิวรีอ้างอิง คิวรีผสาน ทําความเข้าใจส่วนขั้นตอนที่ใช้ และเพิ่มคอลัมน์ใหม่ คุณยังได้เรียนรู้วิธีการใช้เครื่องมือการสร้างโพรไฟล์ข้อมูลเพื่อทําความเข้าใจข้อมูลของคุณให้ดียิ่งขึ้น

Power Query เป็นเครื่องมือที่มีประสิทธิภาพที่ใช้ในการเชื่อมต่อกับแหล่งข้อมูลต่างๆ มากมาย และแปลงข้อมูลให้เป็นรูปร่างที่คุณต้องการ สถานการณ์สมมติที่ระบุไว้ในบทความนี้เป็นตัวอย่างที่แสดงให้คุณเห็นว่าคุณสามารถใช้ Power Query เพื่อแปลงข้อมูลดิบให้เป็นข้อมูลเชิงลึกทางธุรกิจที่สําคัญที่นําไปใช้ได้จริงได้อย่างไร