Abfrageübersicht in Power BI Desktop

Mit Power BI Desktop stellen Sie eine Verbindung zur Welt der Daten her, erstellen überzeugende und fundierte Berichte und teilen Ihre Ergebnisse mit anderen Personen, die dann auf Ihrer Arbeit aufbauen und so ihr Business Intelligence-Potenzial erweitern können.

Power BI Desktop-Ansichten

Power BI Desktop verfügt über drei Ansichten:

  • Ansicht Bericht – Hier verwenden Sie von Ihnen erstellte Abfragen, um ansprechende Visualisierungen zu erstellen. Sie können diese wie gewünscht anordnen und mehrere Seiten verwenden, die Sie für andere Benutzer freigeben können.
  • Tabellenansicht – Sehen Sie die Daten in Ihrem Bericht im Datenmodellformat, in dem Sie Kennzahlen hinzufügen, neue Spalten erstellen und Beziehungen verwalten können.
  • Ansicht Modell – Hier können Sie eine grafische Darstellung der Beziehungen abrufen, die in Ihrem Datenmodell eingerichtet wurden, und diese je nach Bedarf verwalten oder ändern.

Sie können auf diese Ansichten zugreifen, indem Sie auf eins der drei Symbole auf der linken Seite von Power BI Desktop klicken. In der folgenden Abbildung ist die Berichtsansicht ausgewählt. Dies wird durch den gelben Streifen neben dem Symbol signalisiert.

Screenshot von Power BI Desktop, wenn die Ansicht „Bericht“ ausgewählt ist

Im Lieferumfang von Power BI Desktop ist auch der Power Query-Editor enthalten. Verwenden Sie den Power Query-Editor, um eine Verbindung zu einer oder mehreren Datenquellen herzustellen, die Daten gemäß Ihren Anforderungen zu strukturieren und zu transformieren und anschließend das Modell in Power BI Desktop zu laden.

Dieser Artikel bietet nur eine Übersicht über die Arbeit mit Daten im Power Query-Editor, aber es gibt noch viele weitere Artikel zu diesem Thema. Am Ende dieses Artikels finden Sie Links zu detaillierten Anleitungen zu unterstützten Datentypen. Außerdem finden Sie Anleitungen zum Herstellen einer Verbindung mit Daten, zum Strukturieren von Daten, zum Erstellen von Beziehungen und zu den ersten Schritten.

Zuerst wollen wir uns aber mit dem Power Query-Editor vertraut machen.

Power Query-Editor

Power BI Desktop bietet zwei Power Query-Editor Oberflächen:

  • Neue Power Query Erfahrung (Vorschau): Ein neu gestalteter Editor mit optimierter Navigation, verbesserter Barrierefreiheit und einer konsistenten Power Query Erfahrung in Power BI Desktop, Webmodellierung und anderen Fabric Produkten.
  • Legacyoberfläche: Das originale Power Query-Editor-Fenster.

In beiden Umgebungen verwenden Sie Power Query-Editor, um eine Verbindung mit einer oder mehreren Datenquellen herzustellen, die Daten so zu gestalten, dass sie Ihren Anforderungen entsprechen, und laden Sie das Ergebnis dann in Power BI Desktop. Wählen Sie die Registerkarte aus, die zu der von Ihnen verwendeten Benutzeroberfläche passt.

Informationen zu bekannten Einschränkungen, Problemumgehungen und einem Ort zum Teilen von Feedback finden Sie unter "Neue Power Query bekannte Einschränkungen und Problemumgehungen".

Note

Die neue Power Query-Benutzeroberfläche ist in der Vorschau.

Voraussetzungen

Power BI Desktop mit aktivierter Vorschaufunktion für die neue Power Query Oberfläche.

So aktivieren Sie die neue Power Query-Benutzeroberfläche:

  1. Starten Sie Power BI Desktop.
  2. Wechseln Sie zu Datei>Optionen und Einstellungen>Optionen.
  3. Wählen Sie Preview-Features aus, und aktivieren Sie dann das Kontrollkästchen Neue Power Query Erfahrung.
  4. Wählen Sie OK aus.

Dieselbe Vorschaufunktion ermöglicht sowohl die neue Funktion „Daten abrufen“ als auch den neuen Power Query-Editor. Um zum Legacy-Editor zurückzukehren, deaktivieren Sie das Kontrollkästchen. Sie müssen Power BI Desktop nicht neu starten. Weitere Informationen zur neuen Benutzeroberfläche "Daten abrufen" finden Sie unter "Daten abrufen" in Power BI Desktop.

Öffnen von Power Query-Editor

Um Power Query-Editor zu öffnen, wählen Sie "Daten transformieren" auf der Registerkarte "Start" von Power BI Desktop aus.

Ohne vorhandene Datenverbindungen erscheint der Power Query-Editor als leerer Bereich, bereit für die Eingabe von Daten. Nachdem eine Abfrage geladen wurde, stellt der Editor fünf unterschiedliche Komponenten dar. Die Zahlen in der folgenden Tabelle entsprechen den nummerierten Beschriftungen im Screenshot.

Screenshot des neuen Power Query-Editors in Power BI Desktop, in dem jede Komponente umrandet und nummeriert ist.

# Bestandteil Description
1 Menüband Die Menübandnavigation, die mehrere Registerkarten bietet, um Transformationen hinzuzufügen, Optionen für Ihre Abfrage auszuwählen und auf verschiedene Schaltflächen im Menüband zuzugreifen, um verschiedene Aufgaben auszuführen.
2 Bereich "Abfragen" Eine Ansicht aller verfügbaren Abfragen.
3 Aktuelle Ansicht Ihre Hauptarbeitsansicht, die standardmäßig eine Vorschau der Daten für Ihre Abfrage anzeigt. Sie können die Diagrammansicht auch zusammen mit der Datenvorschau aktivieren. Sie können zwischen der Schemaansicht und der Datenvorschau wechseln, während Sie die Diagrammansicht beibehalten.
4 Abfrageeinstellungen Eine Ansicht der aktuell ausgewählten Abfrage mit relevanten Informationen, z. B. Abfragename, Abfrageschritte und verschiedene Indikatoren.
5 Statusleiste Eine Leiste mit wichtigen Informationen zu Ihrer Abfrage, z. B. Ausführungszeit, Gesamtspalten und Zeilen sowie Verarbeitungsstatus. Diese Leiste enthält auch Schaltflächen zum Ändern der aktuellen Ansicht.

Jede dieser Komponenten wird in den folgenden Abschnitten beschrieben. Eine ausführliche Einführung in die Power Query-Benutzeroberfläche finden Sie unter Mithilfe von Power Query Daten transformieren.

Das Menüband

Das Menüband ist die Komponente, in der Sie die meisten Transformationen und Aktionen finden, die Sie in Power Query-Editor ausführen können. Befehle werden auf den Registerkarten "Start", "Transformieren", " Spalte hinzufügen", "Ansicht", "Extras" und " Hilfe " gruppiert. Jede Registerkarte enthält bestimmte Schaltflächen und Optionen, die Ihnen einfachen Zugriff auf die transformationen und Aktionen bieten, die Sie möglicherweise benötigen.

Die Registerkarte " Start " enthält die allgemeinen Abfrageaufgaben, einschließlich der Befehle " Daten abrufen ", mit denen Sie eine Verbindung mit Daten herstellen und den Abfrageerstellungsprozess beginnen. Weitere Informationen zu den verfügbaren Datenquellen finden Sie unter Datenquellen in Power BI Desktop. Weitere Informationen zur Verwendung von Konnektoren finden Sie unter Übersicht zum Abrufen von Daten.

Die Registerkarte "Transformieren " bietet Zugriff auf allgemeine Datentransformationsaufgaben, z. B. das Hinzufügen oder Entfernen von Spalten, das Ändern von Datentypen und das Teilen von Spalten. Auf der Registerkarte " Spalte hinzufügen " werden weitere Aufgaben bereitgestellt, die dem Hinzufügen einer Spalte, dem Formatieren von Spaltendaten und dem Hinzufügen von benutzerdefinierten Spalten zugeordnet sind. Die Registerkarte "Ansicht" steuert, welche Bereiche und Ansichten angezeigt werden, und öffnet die Erweiterter Editor.

Die Power Query Schnittstelle ist reaktionsfähig und passt sich an ihre Bildschirmauflösung an. Wenn Sie eine kompakte Version des Menübands verwenden möchten, wählen Sie die Schaltfläche "Reduzieren" in der unteren rechten Ecke des Menübands aus. Um zurück zum Standardmenüband zu wechseln, wählen Sie das Erweiterungssymbol in derselben Ecke aus.

Viele der im Menüband verfügbaren Aufgaben sind auch verfügbar, indem Sie in der aktuellen Ansicht mit der rechten Maustaste auf eine Spalte oder andere Daten klicken. Transformationen können häufig von mehr als einem Ort aus erreicht werden, sodass Sie die gewünschte Erfahrung verwenden können.

Weitere Informationen zum Transformieren von Daten sowie Beispiele hierzu finden Sie unter Tutorial: Strukturieren und Kombinieren von Daten in Power BI Desktop.

Der Bereich "Abfragen"

Im Bereich "Abfragen " werden alle verfügbaren Abfragen angezeigt. Wenn Sie eine Abfrage auswählen, werden die zugehörigen Daten in der aktuellen Ansicht angezeigt, in der Sie die Daten so gestalten und transformieren können, dass sie Ihren Anforderungen entsprechen.

Wählen Sie das Symbol in der oberen rechten Ecke des Bereichs "Abfragen " aus, um den Bereich zu reduzieren, und wählen Sie es erneut aus, um den Bereich zu erweitern. Mit ähnlichen Symbolen auf der gesamten Benutzeroberfläche können Sie andere Ansichten und Abschnitte reduzieren oder erweitern, sodass Sie sich auf die Ansicht konzentrieren können, die für Sie am wichtigsten ist.

Weitere Informationen finden Sie im Bereich "Abfragen".

Aktuelle Ansicht

Die aktuelle Ansicht ist Ihre Hauptarbeitsansicht. Standardmäßig wird die Datenvorschau für die ausgewählte Abfrage angezeigt. In diesem Bereich erledigen Sie einen Großteil der Abfragearbeit. Wählen Sie eine Spaltenüberschrift aus, oder klicken Sie mit der rechten Maustaste darauf, um die für diese Spalte verfügbaren Transformationen anzuzeigen. Viele dieser Elemente sind identisch mit den Schaltflächen auf den Registerkarten des Menübands.

Wenn Sie eine Transformation auswählen, wendet die Abfrage den Schritt auf die Daten an. Außerdem wird der Schritt als Teil der Abfrage selbst gespeichert. Im Bereich "Abfrageeinstellungen " werden die Schritte in sequenzieller Reihenfolge aufgezeichnet, wie weiter unten in diesem Artikel beschrieben.

Sie können die Datenprofilerstellungstools auch aktivieren, um Ihre Daten besser zu verstehen, einschließlich Wertverteilung und Spaltenqualität. Aktivieren und deaktivieren Sie diese Tools auf der Registerkarte "Ansicht " ganz bequem. Weitere Informationen finden Sie unter Verwenden der Datenprofilerstellungstools.

Wechseln zwischen Ansichten

Neben dem Reduzieren von Bereichen und Abschnitten können Sie auch wechseln, welche Ansichten angezeigt werden. Wechseln Sie im Menüband zur Registerkarte "Ansicht ", in der Sie die Gruppen "Vorschau" und "Layout " finden, die steuern, wie die Benutzeroberfläche aussieht.

Screenshot der Registerkarte

Die rechte Seite der Statusleiste enthält auch Symbole für die Diagramm-, Daten- und Schemaansichten. Verwenden Sie diese Symbole, um zwischen Ansichten zu wechseln oder die Ansicht Ihrer Wahl zu aktivieren und zu deaktivieren.

Probieren Sie diese Optionen aus, um die Ansicht und das Layout zu finden, mit denen Sie am besten arbeiten können.

Schemaansicht

Die Schemaansicht bietet eine schnelle und einfache Möglichkeit, nur mit den Komponenten des Schemas für Ihre Tabelle zu interagieren, z. B. spaltennamen und Datentypen. Verwenden Sie die Schemaansicht, wenn Sie schemabezogene Aktionen ausführen möchten, z. B. Das Entfernen von Spalten, das Umbenennen von Spalten, das Ändern von Spaltendatentypen, das Neuanordnen von Spalten oder das Duplizieren von Spalten.

Screenshot der Schemaansicht in der neuen Power Query-Editor mit den Spalten

Wenn die Schemaansicht aktiv ist, wird die Registerkarte " Schematools " im Menüband mit den Aktionen angezeigt, die für Spalten gelten.

Weitere Informationen finden Sie unter Verwenden der Schemaansicht.

Diagrammansicht

Mithilfe der Diagrammansicht können Sie visualisieren, wie Ihre Abfrage strukturiert ist und wie sie mit anderen Abfragen in Ihrem Projekt interagieren kann. Jeder Schritt in Ihrer Abfrage verfügt über ein eigenes Symbol, um die verwendete Transformation zu erkennen, und Zeilen verbinden die Schritte, um Abhängigkeiten zu veranschaulichen.

Wenn sowohl die Datenvorschau als auch die Diagrammansicht aktiviert sind, wird die Diagrammansicht über der Datenvorschau angezeigt. Wenn die Diagrammansicht aktiviert ist, wählen Sie das Pluszeichen aus, um nach einer neuen Transformation zu suchen, die Sie Ihrer Abfrage hinzufügen möchten.

Screenshot der Diagrammansicht oberhalb der Datenvorschau im neuen Power Query-Editor.

Weitere Informationen finden Sie in der Diagrammansicht.

Der Bereich "Abfrageeinstellungen"

Im Bereich "Abfrageeinstellungen " werden Informationen zur aktuell ausgewählten Abfrage angezeigt, z. B. der Abfragename, die zugehörigen Schritte und verschiedene Indikatoren. Jede auf Ihre Abfrage angewendete Transformation wird als Schritt im Abschnitt "Angewendete Schritte " gespeichert.

Wenn Sie überprüfen müssen, wie Ihre Abfrage von Schritt zu Schritt transformiert wird, wählen Sie einen Schritt aus, um eine Vorschau anzuzeigen, wie Ihre Abfrage an diesem bestimmten Punkt aufgelöst wird.

Sie sollten wissen, dass die zugrunde liegenden Daten nicht geändert werden. Stattdessen ändert und strukturiert der Power Query-Editor seine Ansicht der Daten.

Sie können Schritte umbenennen, Schritte löschen oder die Schritte nach Bedarf neu anordnen. Klicken Sie dazu mit der rechten Maustaste auf den Schritt im Abschnitt "Angewendete Schritte ", und wählen Sie aus dem daraufhin angezeigten Menü aus. Wählen Sie "Eigenschaften" aus, um den Namen eines Schritts zu ändern, oder fügen Sie ihr eine Beschreibung hinzu. Alle Abfrageschritte werden in der Reihenfolge ausgeführt, in der sie angezeigt werden.

Weitere Informationen finden Sie unter Verwenden der Liste "Angewendete Schritte".

Die status-Leiste

Die Statusleiste wird unten im Editor angezeigt und zeigt wichtige Informationen zu Ihrer Abfrage an, z. B. Ausführungszeit, Gesamtspalten und Zeilen sowie Verarbeitungsstatus. Die rechte Seite der Statusleiste enthält auch Symbole, mit denen Sie die aktuelle Ansicht ändern können.

Screenshot der Statusleiste im neuen Power Query-Editor, mit Verarbeitungsstatus, Spalten- und Zeilenanzahl und den Ansichtssymbolen.

Die Bearbeitungsleiste

In der Formelleiste wird der Ausdruck in der Power Query M-Formelsprache für den ausgewählten Schritt angezeigt. Sie können den Ausdruck direkt in der Bearbeitungsleiste bearbeiten, um einen einzelnen Schritt anzupassen, oder die Erweiterter Editor verwenden, um mit dem vollständigen Abfrageskript zu arbeiten.

Hilfe erhalten

Die Registerkarte "Hilfe" in Power Query-Editor enthält Links zu Power BI Informationen. Sie können die gleichen Hilfeoptionen erreichen, indem Sie "Dateihilfe"> auswählen.

Erweiterter Editor

Mit dem Erweiterten Editor können Sie den Code abrufen, den der Power Query-Editor bei jedem Schritt erstellt. Außerdem können Sie ihren eigenen Code in der Formelsprache „Power Query M“ erstellen. Zum Starten des Erweiterten Editors wählen Sie zunächst Ansicht im Menüband und dann Erweiterter Editoraus. Es wird ein Fenster mit dem Code angezeigt, der für die ausgewählte Abfrage generiert wurde.
Screenshot von Power BI Desktop mit dem Dialogfeld „Erweiterter Editor“

Im Fenster Erweiterter Editor können Sie den Code direkt bearbeiten. Zum Schließen des Fensters wählen Sie die Schaltfläche Fertig oder Abbrechen aus.

Die Erweiterter Editor ist sowohl in der neuen als auch in der Legacyumgebung verfügbar. Der vorherige Screenshot zeigt die frühere Benutzeroberfläche. Einige Erweiterter Editor Steuerelemente und Anzeigeoptionen unterscheiden sich in der neuen Oberfläche. Weitere Informationen finden Sie unter Bekannte Einschränkungen und Problemumgehungen für die neue Power Query-Benutzeroberfläche.

Speichern der Arbeit

Wenn Sie mit Ihrer Abfrage zufrieden sind, klicken Sie im Dateimenü des Power Query-Editors auf Close & Apply (Schließen und anwenden). Mit dieser Aktion werden die Änderungen angewendet und der Editor geschlossen.
Screenshot von Power BI Desktop mit der Option zum Schließen und Anwenden auf der Registerkarte „Datei“

Sobald Fortschritte gemacht werden, stellt Power BI Desktop ein Dialogfeld bereit, um den Status anzuzeigen.
Screenshot von Power BI Desktop mit dem Dialogfeld zur Bestätigung der übernommenen Abfrageänderungen

Wenn Sie fertig sind, kann Power BI Desktop Ihre Arbeit in Form einer PBIX-Datei speichern.

Klicken Sie zum Speichern Ihrer Arbeit wie in der folgenden Abbildung gezeigt auf Datei>Speichern (oder Datei>Speichern unter). Screenshot von Power BI Desktop mit der Registerkarte „Datei“ im „Power Query-Editor“. Die Optionen „Speichern“ und „Speichern unter“ sind hervorgehoben.

Mit Power BI Desktop können Sie viele Aufgaben ausführen. Weitere Informationen zu den Funktionen und Möglichkeiten finden Sie in den folgenden Ressourcen: