Site feedback

YitzhakKhabinsky-0887 avatar image
1 Vote"
YitzhakKhabinsky-0887 suggested TracyMyles commented

Access Denied You don't have permission

You really need to fix this issue.
It is a software related Q&A., that doesn't allow to provide an answer by using source code.
In my case via T-SQL.

Here is the post that I tried to answer:

Access Denied
You don't have permission to access ""; on this server.
Reference #18.d5f0f748.1599105499.39230fff

I tried both ways: directly embedding T-SQL as well as tried to attach *.txt file with the same T-SQL.

· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@YitzhakKhabinsky-0887 - The content considered as malicious and blocked by our Web application firewall rules. We are currently working on optimizing the rules to reduce false positive. The Reference #18.d5f0f748.1599105499.39230fff you have shared is expired. Could you please retry and share the reference number to help us with further investigation.

0 Votes 0 ·

Hi @Nandha2277,

I figured it out what was giving false positive in my T-SQL.

While handing XML, I used CDATA section in the XQuery portion of the code.
That CDATA section is not passing your rules.

Please make CDATA legit, because it is a normal statement while dealing with XML, XQuery, XSLT, etc.

0 Votes 0 ·

Thanks @YitzhakKhabinsky-0887 , we will investigate further on this.

0 Votes 0 ·

@YitzhakKhabinsky-0887 , thank you for the feedback. We are reviewing it and we will be updating this item once we finish the review.

0 Votes 0 ·

No Solutions

Your Opinion Counts

Share your feedback, or help out by voting for other people's feedback.