Notitie
Voor toegang tot deze pagina is autorisatie vereist. U kunt proberen u aan te melden of mappen te wijzigen.
Voor toegang tot deze pagina is autorisatie vereist. U kunt proberen om mappen te wijzigen.
Met Power BI Desktop kunt u verbinding maken met de wereld van gegevens, aantrekkelijke en fundamentele rapporten maken en uw inspanningen delen met anderen, die vervolgens kunnen bouwen op uw werk en hun business intelligence-inspanningen kunnen uitbreiden.
Power BI Desktop-weergaven
Power BI Desktop heeft drie weergaven:
- Rapportweergave : u kunt query's gebruiken die u maakt om aantrekkelijke visualisaties te maken, gerangschikt zoals u ze wilt weergeven en met meerdere pagina's die u met anderen kunt delen.
- Tabelweergave : bekijk de gegevens in uw rapport in gegevensmodelindeling, waar u metingen kunt toevoegen, nieuwe kolommen kunt maken en relaties kunt beheren.
- Modelweergave : haal een grafische weergave op van de relaties die in uw gegevensmodel tot stand zijn gebracht en beheer of wijzig deze indien nodig.
Open deze weergaven door een van de drie pictogrammen aan de linkerkant van Power BI Desktop te selecteren. In de volgende afbeelding wordt de rapportweergave geselecteerd, aangegeven door de gele band naast het pictogram.
Power BI Desktop wordt ook geleverd met Power Query-editor. Gebruik Power Query-editor om verbinding te maken met een of meer gegevensbronnen, de gegevens vorm te geven en te transformeren om aan uw behoeften te voldoen en dat model vervolgens in Power BI Desktop te laden.
Dit artikel bevat een overzicht van het werken met gegevens in de Power Query-editor, maar er is meer te leren. Aan het einde van dit artikel vindt u koppelingen naar gedetailleerde richtlijnen over ondersteunde gegevenstypen. U vindt ook richtlijnen voor het maken van verbinding met gegevens, het vormgeven van gegevens, het maken van relaties en het aan de slag gaan.
Maar laten we eerst kennis maken met Power Query-editor.
Power Query-editor
Power BI Desktop biedt twee Power Query-editor ervaringen:
- Nieuwe Power Query-ervaring (preview): een opnieuw ontworpen editor met gestroomlijnde navigatie, verbeterde toegankelijkheid en een consistente Power Query ervaring in Power BI Desktop, webmodellering en andere Fabric producten.
- Klassieke versie: Het oorspronkelijke venster van de Power Query-editor.
In beide ervaringen gebruikt u Power Query-editor om verbinding te maken met een of meer gegevensbronnen, de gegevens vorm te geven en te transformeren om aan uw behoeften te voldoen en het resultaat vervolgens in Power BI Desktop te laden. Selecteer het tabblad dat overeenkomt met de ervaring die u gebruikt.
Zie voor bekende beperkingen, tijdelijke oplossingen en waar u feedback kunt delen bekende beperkingen en tijdelijke oplossingen voor de nieuwe Power Query-ervaring.
Note
De nieuwe Power Query-ervaring is in previewversie.
Prerequisites
Power BI Desktop met de Nieuwe Power Query-ervaring preview-functie ingeschakeld.
De nieuwe Power Query-ervaring inschakelen:
- Start Power BI Desktop.
- Ga naar Bestand>Opties en instellingen>Opties.
- Selecteer Previewfuncties en schakel vervolgens het selectievakje Nieuwe Power Query-ervaring in.
- Kies OK.
Dezelfde preview-functie maakt zowel de nieuwe ervaring Gegevens ophalen als de nieuwe Power Query-editor mogelijk. Als u wilt terugkeren naar de verouderde editor, schakelt u het selectievakje uit. U hoeft Power BI Desktop niet opnieuw op te starten. Zie Gegevens ophalen in Power BI Desktop voor meer informatie over de nieuwe ervaring Gegevens ophalen.
Open Power Query-editor
Als u Power Query-editor wilt openen, selecteert u Gegevens transformeren op het tabblad Start van Power BI Desktop.
Zonder gegevensverbindingen wordt Power Query-editor weergegeven als een leeg deelvenster, klaar voor gegevens. Nadat een query is geladen, worden in de editor vijf afzonderlijke onderdelen weergegeven. De nummers in de volgende tabel komen overeen met de genummerde aanduidingen in de schermafbeelding.
| # | Onderdeel | Beschrijving |
|---|---|---|
| 1 | Ribbon | De lintnavigatie, met meerdere tabbladen om transformaties toe te voegen, opties voor uw query te selecteren en verschillende knoppen op het lint te gebruiken voor het uitvoeren van verschillende taken. |
| 2 | Deelvenster Query's | Een weergave van al uw beschikbare query's. |
| 3 | Huidige weergave | Uw belangrijkste werkweergave, die standaard een voorbeeld van de gegevens voor uw query weergeeft. U kunt ook de diagramweergave inschakelen, samen met de voorbeeldweergave van de gegevens. U kunt schakelen tussen de schemaweergave en de voorbeeldweergave van de gegevens terwijl u de diagramweergave behoudt. |
| 4 | Query-instellingen | Een weergave van de momenteel geselecteerde query met relevante informatie, zoals querynaam, querystappen en verschillende indicatoren. |
| 5 | Statusbalk | Een balk met belangrijke informatie over uw query, zoals uitvoeringstijd, totale kolommen en rijen en verwerkingsstatus. Deze balk bevat ook knoppen om uw huidige weergave te wijzigen. |
Elk van deze onderdelen wordt beschreven in de volgende secties. Zie Power Query gebruiken om gegevens te transformeren voor een volledig overzicht van de Power Query gebruikersinterface.
Het lint
Het lint is het onderdeel waarin u de meeste transformaties en acties vindt die u in Power Query-editor kunt uitvoeren. Opdrachten zijn gegroepeerd op de tabbladen Start, Transformeren, Toevoegen, Weergave, Hulpmiddelen en Help . Elk tabblad biedt specifieke knoppen en opties waarmee u eenvoudig toegang hebt tot de transformaties en acties die u mogelijk nodig hebt.
Het tabblad Start bevat de algemene querytaken, waaronder de opdrachten Gegevens ophalen die u gebruikt om verbinding te maken met gegevens en het proces voor het bouwen van query's te starten. Zie Gegevensbronnen in Power BI Desktop voor meer informatie over de beschikbare gegevensbronnen. Zie Overzicht van gegevens ophalen voor meer informatie over het gebruik van connectors.
Het tabblad Transformeren biedt toegang tot algemene taken voor gegevenstransformatie, zoals het toevoegen of verwijderen van kolommen, het wijzigen van gegevenstypen en het splitsen van kolommen. Het tabblad Kolom toevoegen biedt meer taken die zijn gekoppeld aan het toevoegen van een kolom, het opmaken van kolomgegevens en het toevoegen van aangepaste kolommen. Het tabblad Weergave bepaalt welke deelvensters en weergaven worden weergegeven en opent de Geavanceerde editor.
De Power Query-interface reageert en past zich aan uw schermresolutie aan. Als u een compacte versie van het lint wilt, selecteert u de knop Samenvouwen in de rechterbenedenhoek van het lint. Als u wilt teruggaan naar het standaardlint, selecteert u het uitvouwpictogram in dezelfde hoek.
Veel van de taken die beschikbaar zijn op het lint, zijn ook beschikbaar door in de huidige weergave met de rechtermuisknop op een kolom of andere gegevens te klikken. Transformaties kunnen vaak worden bereikt vanaf meer dan één plek, zodat u de gewenste ervaring kunt gebruiken.
Zie Zelfstudie: Gegevens vormgeven en combineren in Power BI Desktop voor meer informatie over het transformeren van gegevens, inclusief voorbeelden.
Het deelvenster Query's
In het deelvenster Query's worden al uw beschikbare query's weergegeven. Wanneer u een query selecteert, worden de bijbehorende gegevens weergegeven in de huidige weergave, waar u de gegevens kunt vormgeven en transformeren om aan uw behoeften te voldoen.
Selecteer het pictogram in de rechterbovenhoek van het deelvenster Query's om het deelvenster samen te vouwen en selecteer het opnieuw om het deelvenster uit te vouwen. Met vergelijkbare pictogrammen in de interface kunt u andere weergaven en secties samenvouwen of uitvouwen, zodat u zich kunt richten op de weergave die het belangrijkst voor u is.
Zie het deelvenster Query's voor meer informatie.
De huidige weergave
De huidige weergave is de belangrijkste werkweergave. Standaard wordt het voorbeeld van de gegevens voor de geselecteerde query weergegeven. U voert op dit gebied veel van de querytaken uit. Selecteer een kolomkop of klik er met de rechtermuisknop op om de transformaties te bekijken die beschikbaar zijn voor die kolom. Veel van deze items zijn dezelfde als de knoppen op de tabbladen van het lint.
Wanneer u een transformatie selecteert, past de query de stap toe op de gegevens. De stap wordt ook opgeslagen als onderdeel van de query zelf. In het deelvenster Query-instellingen worden de stappen in opeenvolgende volgorde vastgelegd, zoals verderop in dit artikel wordt beschreven.
U kunt de hulpprogramma's voor gegevensprofilering ook inschakelen om meer inzicht te krijgen in uw gegevens, inclusief waardedistributie en kolomkwaliteit. Schakel deze hulpmiddelen op het tabblad Beeld op uw gemak in en uit. Zie De hulpprogramma's voor gegevensprofilering gebruiken voor meer informatie.
Schakelen tussen weergaven
Naast het samenvouwen van deelvensters en secties, kunt u ook wisselen welke weergaven worden getoond. Ga naar het tabblad Weergave op het lint, waar u de groepen Voorbeeld en Indeling vindt die bepalen hoe de interface eruitziet.
De rechterkant van de statusbalk bevat ook pictogrammen voor de diagram-, gegevens- en schemaweergaven. Gebruik deze pictogrammen om te schakelen tussen weergaven of om de weergave van uw keuze in en uit te schakelen.
Probeer deze opties om de weergave en indeling te vinden waarmee u het prettigst kunt werken.
Schemaweergave
De schemaweergave biedt een snelle en eenvoudige manier om alleen te communiceren met de onderdelen van het schema voor uw tabel, zoals de kolomnamen en gegevenstypen. Gebruik de schemaweergave als u schemagerelateerde acties wilt uitvoeren, zoals het verwijderen van kolommen, het wijzigen van de naam van kolommen, het wijzigen van kolomgegevenstypen, het opnieuw ordenen van kolommen of het dupliceren van kolommen.
Wanneer de schemaweergave actief is, wordt het tabblad Hulpmiddelen voor schema weergegeven op het lint met de acties die van toepassing zijn op kolommen.
Zie Schemaweergave gebruiken voor meer informatie.
Diagramweergave
Met de diagramweergave kunt u visualiseren hoe uw query is gestructureerd en hoe deze kan communiceren met andere query's in uw project. Elke stap in uw query heeft een uniek pictogram om u te helpen bij het herkennen van de transformatie die is gebruikt en lijnen verbinden de stappen om afhankelijkheden te illustreren.
Wanneer zowel de gegevensvoorvertoning als de diagramweergave zijn ingeschakeld, verschijnt de diagramweergave boven de gegevensvoorvertoning. Als de diagramweergave is ingeschakeld, selecteert u het plusteken om te zoeken naar een nieuwe transformatie die u aan uw query wilt toevoegen.
Zie de diagramweergave voor meer informatie.
Het deelvenster Query-instellingen
In het deelvenster Queryinstellingen ziet u informatie over de geselecteerde query, zoals de naam van de query, de stappen en verschillende indicatoren. Elke transformatie die op uw query wordt toegepast, wordt opgeslagen als een stap in de sectie Toegepaste stappen .
Als u wilt controleren hoe uw query wordt getransformeerd van stap tot stap, selecteert u een stap om een voorbeeld te bekijken van hoe uw query op dat specifieke punt wordt omgezet.
Het is belangrijk om te weten dat de onderliggende gegevens niet worden gewijzigd. In plaats daarvan past Power Query-editor zijn weergave van de gegevens aan en vormt het naar wens.
U kunt de naam van de stappen wijzigen, stappen verwijderen of de volgorde van de stappen naar wens wijzigen. Hiervoor klikt u met de rechtermuisknop op de stap in de sectie Toegepaste stappen en kiest u in het menu dat wordt weergegeven. Selecteer Eigenschappen om de naam van een stap te wijzigen of voeg er een beschrijving aan toe. Alle querystappen worden uitgevoerd in de volgorde waarin ze worden weergegeven.
Zie De lijst Toegepaste stappen gebruiken voor meer informatie.
De statusbalk
De statusbalk wordt onder aan de editor weergegeven en bevat belangrijke informatie over uw query, zoals uitvoeringstijd, totale kolommen en rijen en verwerkingsstatus. De rechterkant van de statusbalk bevat ook pictogrammen die u kunt gebruiken om de huidige weergave te wijzigen.
De formulebalk
De formulebalk toont de expressie Power Query M-formuletaal voor de geselecteerde stap. U kunt de expressie rechtstreeks in de formulebalk bewerken om één stap aan te passen of de Geavanceerde editor gebruiken om met het volledige queryscript te werken.
Hulp krijgen
Het tabblad Help in Power Query-editor bevat koppelingen naar Power BI informatie. U kunt dezelfde Help-opties bereiken door De Help voor>bestanden te selecteren.
Geavanceerde editor
Met de Geavanceerde editor kunt u de code zien die Power Query-editor bij elke stap maakt. U kunt ook uw eigen code maken in de Power Query M-formuletaal. Als u de geavanceerde editor wilt starten, selecteert u Weergave op het lint en selecteert u vervolgens Geavanceerde editor. Er wordt een venster weergegeven met de code die is gegenereerd voor de geselecteerde query.
U kunt de code rechtstreeks bewerken in het venster Geavanceerde editor. Als u het venster wilt sluiten, selecteert u de knop Gereed of Annuleren .
De Geavanceerde editor is beschikbaar in zowel de nieuwe als de verouderde ervaring. In de voorgaande schermopname ziet u de verouderde ervaring. Sommige Geavanceerde editor besturingselementen en weergaveopties verschillen in de nieuwe ervaring. Zie Nieuwe Power Query ervaring met bekende beperkingen en tijdelijke oplossingen voor meer informatie.
Uw werk opslaan
Wanneer de query naar wens is, selecteert u Sluiten en toepassen in het Bestand-menu van de Power Query-editor. Met deze actie worden de wijzigingen toegepast en wordt de editor gesloten.
Naarmate de voortgang wordt gemaakt, biedt Power BI Desktop een dialoogvenster om de status ervan weer te geven.
Wanneer u klaar bent, kan Power BI Desktop uw werk opslaan in de vorm van een PBIX-bestand .
Om uw werk op te slaan, selecteert u File>Opslaan (of Bestand>Opslaan als), zoals weergegeven in de volgende afbeelding.
Gerelateerde inhoud
Er zijn allerlei dingen die u kunt doen met Power BI Desktop. Bekijk de volgende bronnen voor meer informatie over de mogelijkheden:
- Wat is Power BI?
- Gegevens transformeren met Power Query
- Nieuwe Power Query ervaring met bekende beperkingen en tijdelijke oplossingen
- Gegevensbronnen in Power BI Desktop
- Verbinding maken met gegevensbronnen in Power BI Desktop
- Zelfstudie: Gegevens vormgeven en combineren met Power BI Desktop
- Algemene querytaken uitvoeren in Power BI Desktop