本文提供有关在 Microsoft Dataverse 中使用 服务器端同步时电子邮件同步 问题的故障排除信息。
常见原因
当电子邮件无法同步到 Dataverse 时,这通常是由于以下原因之一:
- 由于 Dataverse 中的自定义(插件或工作流)错误,处理电子邮件时发生失败。
- 没有已知的 Dataverse 用户或电子邮件队列收件人根据其 传入电子邮件筛选方法配置自动接受电子邮件。
- 拥有接收邮箱或队列记录的 Dataverse 用户没有许可证或足够的权限来同步电子邮件。 详细了解 电子邮件同步所需的特权。
- 收到的电子邮件不在目标邮箱的根 收件箱 中。 电子邮件必须保留在根 收件箱 中,直到跟踪它们。 在文件夹之间移动电子邮件可能会导致服务器端同步省略它们。
- 邮箱未在远程电子邮件系统(Microsoft Exchange 或 Google Gmail)中正确配置,或者邮箱与远程电子邮件系统之间存在连接问题。 可以在邮箱警报墙上找到配置和连接错误。
使用“服务器端同步项级别监视”仪表板进行故障排除
可以使用 服务器端同步项目级监视 仪表板来了解电子邮件、约会、联系人和任务未同步的原因。
若要在服务器端同步项级别监视仪表板中获取故障排除信息,请执行以下作:
在 Microsoft Dataverse 中,转到 “电子邮件配置 ”区域,然后选择 服务器端同步项目级别监视 导航链接。
备注
拥有邮箱的用户或具有现 成的系统管理员 安全角色的用户可以看到仪表板故障。
“ 同步错误 ”列包含有关项未同步的原因的信息。 选择链接会将你定向到有关错误的文章(如果有)。 例如:
使用邮箱警报进行故障排除
查看目标 Dataverse 收件人邮箱中的邮箱警报,以识别和解决同步问题和处理错误。
获取信息:
在 Power Platform 管理中心,选择一个环境。
选择设置>电子邮件>邮箱。
打开受影响的邮箱记录,然后在左侧导航栏的“通用”下,选择“警报”。
例如,以下警报消息指示由于“1 测试”自定义工作流中的错误而无法处理电子邮件。
启动同步工作流“1 测试”,id:<ID> 输入UpdateStep1_step:
同步工作流“1 测试”已终止,出现错误“实体”联系人“ID = <ID> 不存在”
仔细检查错误表明,工作流正在尝试设置系统中不再存在的联系人,从而导致电子邮件创建失败。
不会自动跟踪特定电子邮件
如果任何已解析的(已知)用户或电子邮件队列收件人根据其传入电子邮件筛选方法配置接受它们,则收件箱文件夹中的电子邮件会自动通过服务器端同步到 Dataverse 中。 有关详细信息,请参阅 设置影响客户参与应用与 Outlook 或 Exchange 之间的跟踪和同步的个人选项。
若要缩小电子邮件可能不会自动跟踪的原因,请检查以下每一项:
对于有问题的电子邮件,请确保电子邮件位于 目标 Dataverse 邮箱的收件箱 文件夹中。 无法处理收件箱文件夹外部的电子邮件,即使以后将电子邮件移回收件箱。
- 如果要重新处理已移回 收件箱 文件夹的电子邮件,可以在 Dataverse 邮箱记录上重置处理日期(
ProcessEmailsReceivedAfter
)。 此作允许服务器端同步发现和处理电子邮件。 此最佳做法页的 “注释”部分概述了详细信息。 - 如果要自动跟踪从 Outlook 发送的电子邮件答复(在 “已发送邮件 ”文件夹中),请参阅 Outlook 答复不会自动同步。
- 如果要跟踪已移动到子文件夹的电子邮件,则需要启用 基于文件夹的跟踪。
- 如果要重新处理已移回 收件箱 文件夹的电子邮件,可以在 Dataverse 邮箱记录上重置处理日期(
检查收件人:和抄送:中的收件人电子邮件地址,并确保其中至少有一个与 Dataverse 邮箱相关联,该邮箱经过测试和启用服务器端同步,并配置为根据其关联的传入电子邮件筛选方法自动跟踪电子邮件。 如果电子邮件发送到通讯组或具有密件抄送收件人,请参阅下面的主题以确保正确配置了底线 Dataverse 邮箱。
确保 Exchange 或 Gmail 中的收件人电子邮件地址与 Dataverse 用户或队列邮箱的相应电子邮件地址匹配。
不会自动跟踪发送到通讯组和密件抄送收件人的电子邮件
Dataverse 会将电子邮件中的收件人电子邮件地址解析为已知的 Dataverse 用户或队列记录。 如果收件人电子邮件地址包括通讯组或密件抄送收件人,Dataverse 无法将这些收件人解析为已知的 Dataverse 用户或队列。
解决方案
若要自动跟踪发送到通讯组或密件抄送收件人的电子邮件,请设置接收电子邮件以接受 所有电子邮件的 Dataverse 用户或队列邮箱的下划线。 有关详细信息,请参阅 设置影响客户参与应用与 Outlook 或 Exchange 之间的跟踪和同步的个人选项。
在 Exchange 中分配了“不可交付”类别的电子邮件
原因
当服务器端同步处理电子邮件但无法在 Dataverse 中创建电子邮件活动记录时,会将“不可交付”类别分配给电子邮件。 此问题通常是由于处理电子邮件时出现自定义插件、工作流失败或特权问题。 拥有接收邮箱或队列的用户没有足够的 权限来同步电子邮件记录时,通常会发生特权 问题。
解决方案
若要解决此问题,请查看 电子邮件同步 所需的权限,并确保设置了所需的权限。
可以通过检查 服务器端同步项目级别监视仪表板来查看有关失败电子邮件的信息。
Outlook 答复不会自动同步
确保为 Outlook 答复正确配置了同步设置。 管理员可以配置 OrgDBOrgSettings 的 AutoTrackSentFolderItems 值。 此作将使服务器端同步能够处理 Exchange 中“已发送邮件”文件夹中的电子邮件,并通过遵循“设置个人选项”中的电子邮件接受选项,自动跟踪答复电子邮件Microsoft Dynamics 365。
重要
- 默认情况下禁用自动跟踪已发送邮件,必须在 OrgDBOrgSettings 中配置 AutoTrackSentFolderItems 值来启用它。
- 仅Microsoft Exchange 邮箱支持对已发送邮件启用跟踪。
有关详细信息,请参阅 使用服务器端同步自动跟踪已发送的文件夹项。