Vytváření sestav Power BI pomocí nástrojů pro usnadnění přístupu

Pro autory, kteří při vytváření sestav používají nástroje pro usnadnění přístupu, nabízí Power BI spoustu integrovaných funkcí, které jim pomáhají.

Press the Alt key to see KeyTips

Tento článek popisuje množství typů nástrojů pro usnadnění přístupu, které jsou dostupné autorům sestav v Power BI Desktopu.

Navigace na úrovni aplikace

Při navigaci v Power BI Desktopu můžete stisknutím kláves Ctrl+F6 přesouvat fokus po hlavních oblastech aplikace. Fokus se v hlavní oblasti Power BI Desktopu posouvá v následujícím pořadí:

  1. Objekty na plátně
  2. Karty stránek
  3. Podokna (každé zvlášť, zleva doprava přes všechna otevřená)
  4. Navigátor zobrazení
  5. Zápatí
  6. Přihlásit se
  7. Žlutý panel s upozorněním / chybou / aktualizacemi

Mezi nejčastější postupy patří použití klávesy Enter k výběru nebo vstupu do nějaké oblasti a následné použití klávesy Esc k jejímu opuštění.

Navigace na pásu karet

Při stisknutí klávesy Alt se nad každým příkazem v aktuálním zobrazení pásu karet ukážou čtverečky označované jako klávesové zkratky. Pak můžete stisknout písmeno zobrazené v klávesové zkratce, která se nachází nad příkazem, který chcete použít.

Například na následujícím obrázku byly stisknutím klávesy Alt zobrazeny klávesové zkratky, které obsahují písmena pro dostupné příkazy. Stisknutím klávesy M by se pak otevřela karta Modelování na pásu karet.

Press the Alt key to see KeyTips

V závislosti na tom, jaké písmeno stisknete, se mohou zobrazit další klávesové zkratky. Pokud je například aktivní karta Domů a stisknete klávesu W, zobrazí se karta Zobrazení spolu s klávesovými zkratkami pro skupiny na kartě Zobrazení na pásu karet. Můžete pokračovat stisknutím písmen zobrazených v klávesových zkratkách, dokud nestisknete písmeno konkrétního příkazu, který chcete použít. Pokud chcete přejít na předchozí sadu klávesových zkratek, stiskněte klávesu Esc. Pokud chcete akci, kterou provádíte, zrušit a skrýt klávesové zkratky, stiskněte klávesu Alt .

Navigace v podokně vizuálů

Pokud chcete přejít do podokna Vizualizace, nejprve zajistěte, aby byl fokus na tomto podokně – opakovaně stiskněte klávesy Ctrl+F6, dokud se do tohoto podokna nedostanete. Když uživatel prochází podokno Vizualizace, přesune se fokus nejprve na záhlaví. Počínaje shora je pořadí ovládacích prvků následující, jak znázorňuje následující obrázek:

  1. Název záhlaví
  2. Šipka pro rozbalení/sbalení
  3. Ikona prvního vizuálu

Tab order for panes

Když se dostanete k vizuálům, můžete pomocí šipkových kláves přejít na konkrétní vizuál a stisknutím klávesy Enter ho vybrat. Pokud používáte čtečku obrazovky, zavolá se, pokud jste vytvořili nový graf a řekne vám, o který typ jde, nebo vám řekne, že jste graf určitého typu změnili na jiný typ grafu.

Po oddílu vizuálů v tomto podokně se následně fokus přesune na pivoty podokna, jak ukazuje následující obrázek.

Pane pivots

Když je fokus na pivotech podokna, při stisknutí tabulátoru se přesune jen na ikonu vybraného podokna. K přepnutí do jiných podoken použijte šipkové klávesy.

Zdroj polí

Když je fokus na pivotech podokna, jak bylo popsáno v předchozí části, posunete se opětovným stisknutím tabulátoru na zdroj polí.

Ve zdroji polí se fokus postupně přesouvá na:

  1. Název každého z nich (první)
  2. Následuje dané pole v každé studně (další)
  3. Tlačítko rozevíracího seznamu pro otevření nabídky polí (potom)
  4. Pak tlačítko pro odebrání (poslední)

Toto přesouvání fokusu znázorňuje následující obrázek.

Field well focus progression

Čtečka obrazovky bude předčítat název a popis zdroje. U každého pole ve zdroji předčítá čtečka obrazovky název pole a jeho popis. Pokud je zdroj prázdný, měl by se fokus přesunout do celého prázdného zdroje. Čtečka obrazovky by měla předčítat název zdroje, popis a to, zda je prázdný.

Když je otevřená nabídka pole, můžete ji procházet klávesami Tab nebo Shift+Tab, případně šipkami nahoru / dolů. Čtečka obrazovky bude předčítat názvy možností.

Pokud chcete přesunout některé pole z jednoho kontejneru ve zdroji polí do jiného, můžete použít klávesnici a následně možnost Přesunout v nabídce zdroje polí, jak je znázorněno na následujícím obrázku.

Move a field using the menu

Podokno formátování

V podokně formátování se fokus přesouvá shora dolů podle pořadí karet. Fokus přejde na název karty a následně na přepínač zapnuto/vypnuto, pokud existuje. Když je fokus na názvu karty, předčítá čtečka obrazovky název této karty a to, zda je karta rozbalená nebo sbalená. Stisknutím klávesy Enter můžete kartu sbalit nebo rozbalit. Klávesu Enter lze použít také k přepnutí přepínače do polohy Zapnuto nebo Vypnuto.

Focus progression on the Formatting pane

Pokud je otevřená nějaká karta, můžete klávesou Tab procházet ovládací prvky na této kartě a následně přejít na další kartu. U ovládacích prvků na kartě předčítá čtečka obrazovky název, aktuální hodnotu a typ ovládacího prvku.

Focus progression for an open card

Navigace v seznamu Pole

Stisknutím klávesy Tab můžete procházet seznam Pole. Pokud jsou tabulky sbaleny, přesouvá se fokus podobně jako v podokně formátování v následujícím pořadí:

  1. Záhlaví seznamu Pole
  2. Panel hledání
  3. Názvy jednotlivých tabulek

Focus progression for Fields list

Stisknutím kláves Alt+Shift+9 rozbalíte všechny tabulky ve zdroji Pole. Stisknutím kláves Alt+Shift+1 všechny tabulky sbalíte. Pokud chcete rozbalit jednu tabulku, stiskněte klávesu se šipkou vpravo. Pokud chcete sbalit jednu tabulku, stiskněte klávesu se šipkou vlevo. Pokud je některá tabulka rozbalená, pak se při stisknutí tabulátoru a navigaci v seznamu polí procházejí zobrazená pole, podobně jako v podokně formátování. Čtečka obrazovky předčítá, zda je tabulka rozbalená nebo sbalená.

Focus progression for Fields list with expanded tables

Pole můžete zaškrtnout tak, že na ně přejdete a stisknete klávesu Enter. Čtečka obrazovky předčítá pole, na kterém je fokus, a to, jestli je nebo není zaškrtnuté.

Uživatelé, kteří používají myš, zpravidla přesouvají pole na plátno nebo do kontejnerů relevantních filtrů. Pokud chcete použít klávesnici, můžete pole přidat do kontejneru filtru tak, že stisknutím kláves Shift+F10 přejdete na místní nabídku pole, pomocí šipkových kláves přejdete na Přidat do filtrů a potom stisknete klávesu Enter u typu filtru, do kterého chcete toto pole přidat.

Add a field to a filter bucket

Navigace v podokně výběru

V podokně Výběr se fokus přesouvá takto:

  1. Název záhlaví
  2. Tlačítko Konec
  3. Přepínač pořadí vrstev nebo karet
  4. Tlačítko pro přesun o vrstvu nahoru
  5. Tlačítko pro přesun o vrstvu dolů
  6. Tlačítko pro zobrazení
  7. Tlačítko pro skrytí
  8. Objekty

Selection pane focus progression

Stisknutím tabulátoru můžete procházet jednotlivé prvky a stisknutím klávesy Enter vybrat ten, o který máte zájem.

Když se dostanete k přepínači pořadí vrstev nebo karet, můžete pomocí šipkových kláves přepnout mezi pořadím vrstev a pořadím karet.

Když se dostanete k objektům v podokně Výběr, aktivujete stisknutím klávesy F6 podokno Výběr. Po aktivaci podokna Výběr můžete pomocí kláves se šipkami nahoru a dolů přejít k různým objektům v podokně Výběr. Jakmile přejdete na objekt vašeho zájmu, můžete provést několik různých akcí:

  • Stisknutím kláves Ctrl+Shift+S objekt skryjete nebo zobrazíte.
  • Stisknutím kláves Ctrl+Shift+F přesunete objekt o vrstvu nahoru.
  • Stisknutím kláves Ctrl+Shift+B přesunete objekt o vrstvu dolů.
  • Stisknutím kláves Ctrl+Space vyberete více objektů.

Dialogy v Power BI Desktopu

Všechny dialogy v Power BI Desktopu jsou přístupné prostřednictvím klávesnice a fungují s čtečkami obrazovky.

Mezi dialogy v Power BI Desktopu patří:

  • Dialog Rychlé míry
  • Dialogové okno datových pruhů podmíněného & formátování
  • Dialogové okno Průzkumníka QA&
  • Dialog Začínáme
  • Nabídka Soubor a dialog O produktu
  • Panel upozornění
  • Dialog obnovení souboru
  • Dialog se zamračenými smajlíky

Podpora vysokého kontrastu

Pokud ve Windows používáte režimy vysokého kontrastu, aplikují se tato nastavení a vybrané palety také na sestavy Power BI Desktopu.

High contrast settings in Windows

Power BI Desktop automaticky zjišťuje, který motiv s vysokým kontrastem se používá ve Windows, a tato nastavení aplikuje na sestavy. Barvy s vysokým kontrastem v sestavě zůstanou i po publikování ve službě Power BI nebo jinde.

High contrast windows settings

Další kroky

Sada článků o usnadnění přístupu v Power BI: