SCOM DB Migration - Reporting issue

Kam Wai Chan 211 Reputation points
2020-10-21T12:34:22.493+00:00

Hi,

We recently migrated the SCOM SQL into separated SQL instance. We did following the steps restore the DB and updated the servername under the operationDB and oeprationDWDB. Also updated the SSRS connection string, for some reason few report will ask to enter user credential to access the data source. Please let us know what did we missing during the migration?

34057-image.png

Thank you!

Operations Manager
Operations Manager
A family of System Center products that provide infrastructure monitoring, help ensure the predictable performance and availability of vital applications, and offer comprehensive monitoring for datacenters and cloud, both private and public.
1,395 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Leon Laude 85,566 Reputation points
    2020-10-21T12:40:15.633+00:00

    Hi @Kam Wai Chan ,

    Can you please tell is if you've followed all the official guides below?

    How to move the Operational database
    https://learn.microsoft.com/en-us/system-center/scom/manage-move-opsdb?view=sc-om-2019

    How to move the Reporting data warehouse database
    https://learn.microsoft.com/en-us/system-center/scom/manage-move-omdwdb?view=sc-om-2019

    Where is your SCOM Reporting feature & SQL Server Reporting Services installed?

    It might be that your datasource (Data Warehouse Main) is configured to require credentials in the SQL Server Reporting Services, you can change this by following the steps I mentioned over THIS thread.

    ----------

    (If the reply was helpful please don't forget to upvote or accept as answer, thank you)

    Best regards,
    Leon

    0 comments No comments

  2. Kam Wai Chan 211 Reputation points
    2020-10-21T13:08:54.92+00:00

    Hi @Leon Laude ,

    Yes, we did following those two URL to move the operationDB and reportDB.

    We did uninstall the SCOM report service from the SCOM management (with old SQL instance installed) server and install into the new SQL server. we did update the credentials section "Credentials are not required". It seem like it cannot inherit to all report. Only few of them require user credential.

    Is there have anyway we can re-apply it for all report?

    Thank you!