Getting Error while adding attribute for an entity in Master data services

sembu prasad pamidimarri 1 Reputation point

Getting the Error shown in the screenshot while adding an attribute for an entity in MDS. It's not showing error description. Please help us how to troubleshoot this error. ![75888-image.png][1] [1]: /api/attachments/75888-image.png?platform=QnA

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
9,802 questions
0 comments No comments
{count} votes

5 answers

Sort by: Most helpful
  1. Nandan Hegde 22,721 Reputation points

    Hey @sembu prasad pamidimarri ,
    It seems that there are some business rules created for that entity and one of the business rule might be getting violated or the other reason might be the name and display names are mismatch for the 3rd row
    You can refer this link to backtrack:

    0 comments No comments

  2. sembu prasad pamidimarri 1 Reputation point

    no business rules were created. it's a simple entity created for testing purpose.

    0 comments No comments

  3. CathyJi-MSFT 20,976 Reputation points Microsoft Vendor

    Hi @sembu prasad pamidimarri ,

    I could not see the screenshot that you offered. It seems they did not upload successfully. Could you please share us the screenshot about your issue again?

    Which type of attribute that you want to add, suggest you read the MS document Attributes (Master Data Services) to check if you missing something when you adding the attribute.

    If the response is helpful, please click "Accept Answer" and upvote it, thank you.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  4. sembu prasad pamidimarri 1 Reputation point

    @Nandan Hegde , @CathyJi-MSFT : Thank you for your response on this issue.

    We are able to create entity but unable to add or edit the existing attribute within an entity. Also, we are able to publish the data from excel. I have 'Admin' access on that Model.

    In the mds-Error1 screenshot, we are trying to add attribute, it takes 2-3 minutes and then gives the error in mds-Error2 screenshot.

    When we try to open that entity or tried to create new entity in Excel , we are getting divide by zero error in mds-Error3 screen shot.

    Interestingly, we can see that attribute[which is showing error in mds-error2 screenshot ] in the metadata table "select * from mdm.tblAttribute" but unable to see MDS site.

    We have tried IISReset also. Still no luck on adding or editing attribute for an entity in MDS.




  5. Wikström Magnus RG 1 Reputation point

    We had the same issue in our test database. I could create the entity, but got an error when adding an additional attribute.
    Also, the Code and Name attributes didn't show in the attribute list while administrating attributes.
    I connected to the SQL server and ran the ”Master Data Service Configuration Manager” tool as an administrator. When I connected to the database the tool indicated that the database needed a repair.
    I I executed the "Repair Database" action which succeeded and this cleared up the problem for us. The Code and Name attributes reappeared and I can now add attributes again.

    0 comments No comments