Azure Enterprise Apps Missing grant admin permissions blank

MarsVsWorld 21 Reputation points
2020-06-16T21:02:28.923+00:00

10197-boxperms.jpgIt seems that my enterprise apps when i go to add an app like "box" there should be some permissions already listed so i can "grant admin concent for" our domain. However after i add the app it lists no permissions. All i get is No admin consented permissions found for the application. I have tried it for other apps with the same result.
Steps i take is azure portal, Enterprise apps, + new application, select an application like box or github, once added i go to the permissions section and see nothing i can grant. What am i missing? What is wrong? how can i fix? Maybe what do you see when you add box or github or other apps?

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
20,529 questions
0 comments No comments
{count} votes

Accepted answer
  1. soumi-MSFT 11,761 Reputation points Microsoft Employee
    2020-06-18T06:54:37.813+00:00

    @MarsVsWorld-5599, Thank you for reaching out. Let me get you some details on how the application structure looks like in Azure AD. When you register an application (be it a gallery application), it creates two entries in AAD. One is called the Application Object, that can be found under App Registration section and a corresponding Service Principal Object for this same application under the Enterprise Applications section.

    Now all the permissions that you would want to add or remove are present under the Application Object under the App Registration. Under Enterprise Application sections that permissions that you see, are the permissions for which the consent has already been provided, which includes both the Admin and Delegated Permissions. Hence, if its a fresh application integration that you have done for your organization and no user has yet accessed the application and hence no consent has been provided for this application, so there wont be any consented permissions visible under the Permissions blade of Enterprise Application.

    So in case you want to add some permission you would need to add the permission under the application registration's Api Permissions blade.

    Hope this helps.

    Do let us know if this helps and if there are any more queries around this, please do let us know so that we can help you further. Also, please do not forget to accept the response as Answer; if the above response helped in answering your query.


0 additional answers

Sort by: Most helpful